1 apt (0.5.4.9) unstable; urgency=low
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
96 -- Adam Heath <doogie@debian.org> Sun, 02 Feb 2003 02:54:45 -0600
98 apt (0.5.4) unstable; urgency=low
100 * M68k config.guess patch. Closes: #88913
101 * Bi-yearly test on OpenBSD and Solaris
102 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
103 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
105 * Various cosmetic code updates. Closes: #89066, #89066, #89152
106 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
108 * More patches from Alfredo for Vendors and more SHA-1 stuff
109 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
110 similar situations. Closes: #56708, #59432
111 * no_proxy and ftp. Closes: #89671
112 * Philippe Batailler's man page patches.
113 * Fix for display bug. Closes: #92033, #93652, #98468
114 * Use more than 16bits for the dep ID. Some people ran out..
115 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
116 #106911, #107395, #108968
117 * Reordered some things to make dante and FTP happier. Closes: #92757
118 * James R. Van Zandt's guide.sgml updates. Closes: #90027
119 * apt-ftparchive copes with no uncompressed package files + contents.
120 * French man pages from philippe batailler - well sort of. They
122 * run-parts. Closes: #94286
123 * 'apt-cache policy' preferences debug tool.
124 * Whatever. Closes: #89762
125 * libstdc++ and HURD. Closes: #92025
126 * More apt-utils verbage. Closes: #86954
127 * Fliped comparision operator. Closes: #94618
128 * Used the right copyright file. Closes: #65691
129 * Randolph's G++3 patches.
130 * Fixed no_proxy tokanizing. Closes: #100046
131 * Strip Config-Version when copying status to available. Closes: #97520
132 * Segfault with missing source files. Closes: #100325
133 * EINTR check. Closes: #102293
134 * Various changes to the locking metholodgy for --print-uris.
136 * Lame LD_LIBRARY_PATH thing. Closes: #98928
137 * apt-cache search searchs provide names too now. Closes: #98695
138 * Checksum and long lines problem. Closes: #106591
139 * .aptignr and empty files are just a warning. Closes: #97364
141 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
143 apt (0.5.3) unstable; urgency=low
145 * JoeyH's dpkg::preconfig not working. Closes: #88675
146 * Fixed apt override disparity
147 * Alfredo's SHA-1 and related patches
149 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
151 apt (0.5.2) unstable; urgency=low
153 * Fixed mention of /usr/doc in the long description
154 * JoeyH's downgrade bug -- don't use 0.5.1
155 * Doc bug. Closes: #88538
156 * Fault in building release strings. Closes: #88533
158 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
160 apt (0.5.1) unstable; urgency=low
162 * Fixed #82894 again, or should be and.
163 * Process the option string right. Closes: #86921
164 * Don't eat the last command for pipes. Closes: #86923
165 * Ignore .* for configuration directory processing. Closes: #86923
166 * Alfredo's no_proxy patch
167 * Documentation fixes. Closes: #87091
168 * JoeyH's double slash bug. Closes: #87266
169 * Unintitialized buffer and apt-ftparchive contents generation.
171 * Build-deps on virtual packages. Closes: #87639
172 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
173 libstdc++ version info in the library soname and in the package
174 provides. Closes: #87426
175 * Updated soname version to 0.3.2
176 * apt-extracttemplates moved from debconf into apt-utils
177 * s390 archtable entry. Closes: #88232
179 * Some instances where the status file can source a package in a
180 non-sensical way. Closes: #87390
181 * Work better if there are duplicate sources.list entries.
182 * Fixed the resetting of Dir with "dir {};". Closes: #87323
184 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
186 apt (0.5.0) unstable; urgency=low
188 * Fixed an obscure bug with missing final double new lines in
190 * Changed the apt-cdrom index copy routine to use the new section
192 * Added a package file sorter, apt-sortpkgs
193 * Parse obsolete Optional dependencies.
194 * Added Ben's rsh method. Closes: #57794
195 * Added IPv6 FTP support and better DNS rotation support.
196 * Include the server IP in error messages when using a DNS rotation.
198 * Made most of the byte counters into doubles to prevent 32bit overflow.
200 * HTTP Authorization. Closes: #61158
201 * Ability to parse and return source index build depends from Randolph.
202 * new 'apt-get build-dep' command from Randolph. Closes: #63982
203 * Added apt-ftparchive the all dancing all singing FTP archive
205 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
207 * Removed useless internal cruft including the xstatus file.
208 * Fixed config parser bugs. Closes: #67848, #71108
209 * Brain Damanged apt-get config options changed, does not change the command
210 line interface, except to allow --enable-* to undo a configuration
213 No-Download -> Download
214 No-Upgrade -> Upgrade
215 * Made this fix configable (DSelect::CheckDir) and default to disabled:
216 * No remove prompt if the archives dir has not changed. Closes: #55709
217 Because it is stupid in the case where no files were downloaded due to
218 a resumed-aborted install, or a full cache! Closes: #65952
219 * Obscure divide by zero problem. Closes: #64394
220 * Update sizetable for mips. Closes: #62288
221 * Fixed a bug with passive FTP connections
222 * Has sizetable entry for sparc64. Closes: #64869
223 * Escape special characters in the ::Label section of the cdroms.lst
224 * Created apt-utils and python-apt packages
225 * Due to the new policy engine, the available file may contain entries
226 from the status file. These are generated if the package is not obsolete
227 but the policy engine prohibits using the version from the package files.
228 They can be identified by the lack of a Filename field.
229 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
230 #36223, #33468, #22551
231 * Fixed deb-src line for non-us. Closes: #71501, #71601
232 * Fixes for G++ 2.96, s/friend/friend class/
233 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
234 * Confirmed fix for missing new line problem. Closes: #69386
235 * Fixed up dhelp files. Closes: #71312
236 * Added some notes about dselect and offline usage. Closes: #66473, #38316
237 * Lock files on read only file systems are ignored w/ warning.
239 * apt-get update foo now gives an error! Closes: #42891
240 * Added test for shlibs on hurd. Closes: #71499
241 * Clarified apt-cache document. Closes: #71934
242 * DocBook SGML man pages and some improvements in the text..
243 * sigwinch thing. Closes: #72382
244 * Caching can be turned off by setting the cache file names blank.
245 * Ignores arches it does not know about when autocleaning. Closes: #72862
246 * New function in apt-config to return dirs, files, bools and integers.
247 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
248 complex cases involving OR groups and provides.
249 68754 describes confusing messages which are the result of this..
250 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
251 * Speeling mistake and return code for the 'wicked' resolver error
252 Closes: #72621, #75226, #77464
253 * Solved unable to upgrade libc6 from potato to woody due to 3 package
254 libc6 dependency loop problem.
255 * Leading sources.list spaces. Closes: #76010
256 * Removed a possible infinite loop while processing installations.
257 * Man page updates. Closes: #75411, #75560, #64292, #78469
258 * ReduceSourceList bug. Closes: #76027
259 * --only-source option. Closes: #76320
260 * Typos. Closes: #77812, #77999
261 * Different status messages. Closes: #76652, #78353
262 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
263 * OS detection an support for the new pseduo standard of os-arch for the
264 Architecture string. Also uses regexing.. Closes: #39227, #72349
265 * Various i18n stuff. Note that this still needs some i18n wizard
266 to do the last gettextization right. Closes: #62386
267 * Fixed a problem with some odd http servers/proxies that did not return
268 the content size in the header. Closes: #79878, #44379
269 * Little acquire bugs. Closes: #77029, #55820
270 * _POSIX_THREADS may not be defined to anything, just defined..
272 * Spelling of Ignore-Hold correctly. Closes: #78042
273 * Unlock the dpkg db if in download only mode. Closes: #84851
274 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
275 * Patch from BenC. Closes: #80810
276 * Single output of some names in lists. Closes: #80498, #43286
277 * Nice message for people who can't read syserror output. Closes: #84734
278 * OR search function. Closes: #82894
279 * User's guide updates. Closes: #82469
280 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
281 * Various CD bugs, again thanks to Greenbush
282 Closes: #80946, #76547, #71810, #70049, #69482
283 * Using potato debhelper. Closes: #57977
284 * I cannot self-terminate. Closes: #74928
286 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
288 apt (0.3.19) frozen unstable; urgency=low
290 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
292 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
293 * Fixed hardcoded path. Closes: #59743
294 * Fixed Jay's relative path bug
295 * Allowed source only CDs. Closes: #58952
296 * Space check is supressed if --print-uris is given. Closes: #58965
297 * Clarified the documenation examples for non-us. Closes: #58646
298 * Typo in the package description. Closes: #60230
299 * Man Page typo. Closes: #60347
300 * Typo in Algorithms.cc. Closes: #63577
301 * Evil dotty function in apt-cache for generating dependency graphs
302 with the as-yet-unpackaged GraphVis.
303 * Appears to have been fixed in Janurary.. Closes: #57981
304 * New config.guess/sub for the new archs. Closes: #60874
305 * Fixed error reporting for certain kinds of resolution failures.
307 * Made autoclean respect 'q' settings. Closes: #63023
308 * Fixed up the example sources.list. Closes: #63676
309 * Added DPkg::FlushSTDIN to control the flushing of stdin before
310 forking dpkg. Closes: #63991
312 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
314 apt (0.3.18) frozen unstable; urgency=low
316 * Changes in the postinst script. Closes: #56855, #57237
317 * Fixed bashism. Closes: #57216, #57335
318 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
320 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
322 apt (0.3.17) unstable; urgency=low
324 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
325 * Fixed the configuration parser to not blow up if ; is in the config
327 * Applied visual patch to dselect install script . Closes #55214
328 * Included the configure-index example
330 * Library soname has increased
331 * Fixed default sources.list to have correct URLs for potato when it
333 * Added a message about erasing sources.list to dselect setup script
335 * No remove prompt if the archives dir has not changed. Closes: #55709
336 * Fixed inclusion of 2nd sample config file. Closes: #55374
337 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
340 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
342 apt (0.3.16) unstable; urgency=low
344 * Made --no-download work. Closes: #52993
345 * Now compiles on OpenBSD, Solaris and HP-UX
346 * Clarify segfault errors
347 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
348 * Fix for Joel's discovery of glibc removal behavoir.
349 * Fix for Ben Collins file: uri from slink upgrade.
350 * Fixed resume code in FTP. Closes: #54323
351 * Take more precautions to prevent the corruption Joey Hess saw.
352 * Fixed --no-list-cleanup
353 * RFC 2732 URI parsing ([] for hostnames).
354 * Typo in apt-cache man page. Closes: #54949
356 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
358 apt (0.3.15) unstable; urgency=low
360 * Added DSelect::WaitAfterDownload Closes: #49549
361 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
362 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
363 * Made -s and clean not do anything. Closes: #50238
364 * Problem with Protected packages and the new OR code.
365 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
366 * Remove doesn't require a package to be installable. Closes: #51175
367 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
369 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
371 apt (0.3.14) unstable; urgency=low
373 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
374 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
375 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
376 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
377 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
378 Closes: #45034, #45695, #46537
379 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
380 * Added APT::Clean-Installed option. Closes: #45973
381 * Moves the free space check to after the calculated size is printed.
382 Closes: #46639, #47498
383 * mipsel arch Closes: #47614
384 * Beautified URI printing to not include passwords Closes: #46857
385 * Fixed little problem with --no-download Closes: #47557
386 * Tweaked Dselect 'update' script to re-gen the avail file even in the
387 event of a failure Closes: #47112
388 * Retries for source archives too Closes: #47529
389 * Unmounts CDROMs iff it mounted them Closes: #45299
390 * Checks for the partial directories before doing downloads Closes: #47392
391 * no_proxy environment variable (http only!) Closes: #43476
392 * apt-cache showsrc Closes: #45799
393 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
394 * Regexs for install. Closes: #35304, #38835
395 * Dependency reports now show OR group relations
396 * Re-Install feature. Cloes: #46961, #37393, #38919
397 * Locks archive directory on clean (woops)
398 * Remove is not 'sticky'. Closes: #48392
399 * Slightly more accurate 'can not find package' message. Closes: #48311
400 * --trivial-only and --no-remove. Closes: #48518
401 * Increased the cache size. Closes: #47648
402 * Comment woopsie. Closes: #48789
403 * Removes existing links when linking sources. Closes: #48775
404 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
405 * Clearer usage message about 'source' Closes: #48858
406 * Immediate configure internal error Closes: #49062, #48884
408 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
410 apt (0.3.13) unstable; urgency=low
412 * Fix timestamp miss in FTP. Closes: #44363
413 * Fix sorting of Kept packages. Closes: #44377
414 * Fix Segfault for dselect-upgrade. Closes: #44436
415 * Fix handling of '/' for the dist name. Closes #43830
416 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
417 * Add commented-out deb-src URI to default sources.list file.
419 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
421 apt (0.3.12) unstable; urgency=low
423 * Fix for typo in the dhelp index. Closes: #40377
424 * Multiple media swap support
425 * Purge support. Closes: #33291, #40694
426 * Better handling of - remove notation. Closes: #41024
427 * Purge support. Closes: #33291, #40694
428 * Error code on failed update. Closes: #41053
429 * apt-cdrom adds entries for source directories. Closes: #41231
430 * Sorts the output of any list. Closes: #41107
431 * Fixes the looping problem. Closes: #41784, #42414, #44022
432 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
433 * More checks to keep the display sane. Particularly when fail-over is
434 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
435 * PThread lockup problem on certain sparc/m68k. Closes: #40628
436 * apt-cdrom understands .gz Package files too. Closes: #42779
437 * Spelling error in dselect method description. Closes: #43251
438 * Added security to the default source list. Closes: #43356
440 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
442 apt (0.3.11) unstable; urgency=low
444 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
445 * Fix for properly upgrading the system from perl 5.004 to 5.005
447 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
449 apt (0.3.9) unstable; urgency=low
451 * Spelling error in cachefile.cc. Closes: #39885
452 * Trailing slash in dselect install if you try to use the
453 default config file. Closes: #40011
454 * Simulate works for autoclean. Closes: #39141
455 * Fixed spelling errors. Closes: #39673
456 * Changed url parsing a bit. Closes: #40070, #40069
457 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
459 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
461 apt (0.3.7) unstable; urgency=low
463 * Fixed missing text in the apt-get(8) page. Closes: #37596
464 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
465 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
466 * Fixed handling of the -q option with not-entirely integer arguments
468 * Man page typo Closes: #37762
469 * Fixed parsing of the Source: line. Closes: #37679
470 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
471 * Added a check for an empty cache directory. Closes: #37963
472 * Return a failure code if -d is given and packages fail to download.
474 * Arranged for an ftp proxy specifing an http server to work. See the
475 important note in the sources.list man page.
476 * Accounted for resumed files in the cps calculation. Closes: #36787
477 * Deal with duplicate same version different packages. Closes: #30237
478 * Added --no-download. Closes: #38095
479 * Order of apt-cdrom dist detection. Closes: #38139
480 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
482 * Suggests dpkg-dev for apt-get source. Closes: #38158
483 * Fixed typo in apt-get help. Closes: #38712
484 * Improved the error message in the case of broken held package. Closes: #38777
485 * Fixed handling of MD5 failures
486 * Documented list notation Closes: #39008
487 * Change the 'b' to 'B'. Closes: #39007
489 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
491 apt (0.3.6) unstable; urgency=low
493 * Note that 0.3.5 never made it out the door..
494 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
495 * Made APT print numbers in decimal. Closes: #35617, #37319
496 * Buffer munching fix for FTP. Closes: #35868
497 * Typo in sample config file. Closes: #35907
498 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
499 * Changed installed size counter to only count unpacked packages.
501 * apt-get source support. Closes: #23934, #27190
502 * Renames .debs that fail MD5 checking, provides automatic corruption
503 recovery. Closes: #35931
504 * Fixed autoconf verison. Closes: #37305
505 * Random Segfaulting. Closes: #37312, #37530
506 * Fixed apt-cache man page. Closes: #36904
507 * Added a newline to apt-cache showpkg. Closes: #36903
509 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
511 apt (0.3.4) unstable; urgency=low
513 * Release for Ben while he is out of town.
514 * Checked the size of partial files. Closes: #33705
515 * apt-get should not print progress on non-tty. Closes: #34944
516 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
517 * Applied cdrom patches from Torsten. Closes: #35140, #35141
518 * smbmounted cdrom fix. Closes: #35470
519 * Changed ie to eg. Closes: #35196
521 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
523 apt (0.3.3) unstable; urgency=low
525 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
527 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
529 apt (0.3.2) unstable; urgency=low
531 * Major release into unstable of v3
532 * These bugs have been fixed, explanations are in the bug system, read
533 the man pages as well..
534 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
535 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
536 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
537 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
538 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
539 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
540 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
541 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
543 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
545 apt (0.3.1) experimental; urgency=low
547 * Minor release of cvs version.
548 * Added virtual package libapt-pkgx.x
550 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
552 apt (0.3.0) experimental; urgency=low
554 * New experimental version.
556 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
558 apt (0.1.9) frozen unstable; urgency=low
560 * Return to the wacky numbering for when we build 0.1.8 for hamm
561 * Important bug related to APT on the Alpha fixed
562 * apt-get dist-upgrade problems fixed
563 * tiny patch for http method to fix an endless loop
564 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
565 libtool and add proper shared lib dependancies
566 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
567 in case an old libpkg is installed while building APT to prevent
568 spurious dependancies
570 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
572 apt (0.1.7) unstable; urgency=low
574 * New build with libstdc++2.9.
575 * Various fixes; read the Changelog.
577 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
579 apt (0.1.6) unstable; urgency=low
581 * Various fixes in the FTP method for error checking. Fixes: #26188.
582 * Spelling corrections in dselect method. Fixes: #25884
583 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
584 * No more bo releases: we're using a normal numbering system now.
586 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
588 apt (0.1.5) unstable; urgency=low
590 * Changed sources.list to point to 'unstable' by default, as
591 'frozen' no longer exists!
593 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
595 apt (0.1.3) unstable; urgency=low
597 * New upstreamish version.
598 * ftp method rewritten in C. Removes dependancies on all perl/perl
599 related modules. This fixes many of the ftp method bugs.
601 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
603 apt (0.1.1) unstable; urgency=low
605 * Release for unstable.
607 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
609 apt (0.1) unstable; urgency=low
611 * Kludge to fix problem in libnet-perl with illegal anonymous
613 * Moved to unstable; apt is in a useable state now.
614 * Fixed version numbering. From now on, numbering will be:
615 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
616 0.1.1 (release for unstable). Thanks, Manoj.
618 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
620 apt (0.0.17-1) experimental; urgency=low
622 * Fixed problem with libc6 version compare
623 * Scott's away for a while, so I'll be packaging apt for the time
626 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
628 apt (0.0.16-1) experimental; urgency=low
630 * Modifications to make apt-get more friendly when backgrounded.
631 * Updated documentation.
632 * Updates to graphic widgets
634 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
636 apt (0.0.15-0.2bo) experimental; urgency=low
639 * Bob Hilliards crash
641 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
643 apt (0.0.15-0.1bo) experimental; urgency=low
648 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
650 apt (0.0.15) experimental; urgency=low
652 * Clean up source tarball (no user-visible changes)
654 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
656 apt (0.0.14) experimental; urgency=low
658 * Updates in ordering code to make sure certain upgrades work correctly.
659 * Made dselect/setup understand ftp as well as http
661 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
663 apt (0.0.13-bo1) experimental; urgency=low
667 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
669 apt (0.0.13) experimental; urgency=low
671 * Remove hardcoded egcc from debian/rules (#21575)
672 * Fixes for ordering logic when system has a number of unpacked
673 but unconfigured packages installed.
674 * Spelling fix in dselect install method (#22556)
676 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
678 apt (0.0.12) experimental; urgency=low
680 * Fixed problems with package cache corruption.
681 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
683 * Interface and documentation improvements.
685 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
687 apt (0.0.11) experimental; urgency=low
689 * Change dependancies to pre-depends since breaking your packaging tools
690 in the middle of an installation isn't very good.
691 * Bug fixes to ftp method and general apt-get code
693 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
695 apt (0.0.10) experimental; urgency=low
697 * Run "dpkg --configure -a" after an aborted dselect install
698 * Fixed problem with install looping
699 * Support for authenticating proxys: (note this isn't terribly secure)
700 http_proxy="http://user:pass@firewall:port/"
701 * Substitute $ARCH in sources.list
702 * Fixes in the resumption code for ftp
704 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
706 apt (0.0.9) experimental; urgency=low
709 * Various other less visible bug fixes.
710 * Fixed problem with segfault when apt-get invoked in a non-existant
711 directory (Bug #21863)
712 * Bumped policy to 2.4.1
714 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
716 apt (0.0.8) experimental; urgency=low
718 * Fixed generated available file (Bug #21836)
719 * Added download ETA (Bug #21774).
720 * Fixed hardcoded ARCH (Bug #21751).
721 * Fixed check on http_proxy (Bug #21795).
722 * Added download speed indicator.
724 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
726 apt (0.0.7) experimental; urgency=low
728 * Remove libdeity and apt from package for now, since only apt-get and
729 apt-cache are actually useful right now.
730 * Clean up handling of package installation errors.
731 * Added timeout to http transfers (#21269)
732 * Updated setup for dselect/apt method.
734 * Long options (added in 0.0.6)
736 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
738 apt (0.0.6) experimental; urgency=low
741 * Revamped download status display.
742 * Call apt-get clean after successful install in dselect.
743 * Added "apt-get clean" which deletes package files from /var/cache/apt
745 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
747 apt (0.0.5) experimental; urgency=low
749 * Ignore signals while dpkg is running so we don't leave dpkg running in
750 the background (#20804)
751 * Check Packages as well as Packages.gz for file URIs (#20784)
752 * Spelling cleanup (#20800)
753 * Added -m option to permit upgrade to go on in the case of a bad mirror.
754 This option may result in incomplete upgrades when used with -f.
756 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
758 apt (0.0.4) experimental; urgency=low
761 * Various documentation updates and cleanup.
762 * Added '-f' option to apt-get attempt to fix broken dependancies.
764 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
766 apt (0.0.3) experimental; urgency=low
768 * Added a shlibs.local file to prevent apt from depending on itself.
769 * Updates to how apt-get handles bad states in installed packages.
770 * Updated rules to make sure build works from a freshly checked out source
771 archive. Building from CVS needs libtool/automake/autoconf, builds from
772 the distributed source package should have no such dependancy.
774 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
776 apt (0.0.2) unstable; urgency=low
778 * Updates to apt-get and http binding for dselect method (apt).
779 * Updating version number from 0.0.1, which was released only on IRC.
781 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
783 apt (0.0.1) unstable; urgency=low
787 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500