2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
17 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
18 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
22 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
24 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
28 -include build
/environment.mak
30 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
31 export CXXFLAGS
= -O0
-g
-Wall
33 export CXXFLAGS
= -O2
-g
-Wall
39 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
40 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p')
41 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
42 APT_CVSTAG
=$(shell echo
"$(APT_DEBVER)" | sed
-e
's/^/v/' -e
's/\./_/g')
44 # Determine the build directory to use
47 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
49 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
-m
) $(BASE
)/build
51 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
52 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
53 override BLD
:= $(BUILDX
)
55 ifeq ($(words $(BLD
)),0)
56 override BLD
:= .
/build
59 # Rebuild configure.in to have the correct version from the change log
60 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
63 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$ && mv
$@.
$$$$ $@
68 # APT Programs in apt-utils
69 APT_UTILS
=ftparchive sortpkgs extracttemplates
71 # Uncomment this to turn on verbose mode.
74 # Find the libapt-pkg major version for use in other control files
75 export LIBAPTPKG_MAJOR
:=$(shell egrep
'^MAJOR=' apt-pkg
/makefile |cut
-d
'=' -f
2)
76 export LIBAPTINST_MAJOR
:=$(shell egrep
'^MAJOR=' apt-inst
/makefile |cut
-d
'=' -f
2)
78 # Determine which package we should provide in the control files
79 LIBAPTPKG_PROVIDE
=libapt-pkg
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTPKG_MAJOR
)
80 LIBAPTINST_PROVIDE
=libapt-inst
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTINST_MAJOR
)
82 debian
/shlibs.local
: apt-pkg
/makefile
83 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
84 # one for the rest of the packages. This ensures that each package gets
85 # the right overrides..
86 rm -rf
$@
$@.apt
$@.apt-utils
87 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
89 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
90 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
92 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
93 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
95 build
: build
/build-stamp
96 build-doc
: build
/build-doc-stamp
98 # Note that this is unconditionally done first as part of loading environment.mak
99 # The true is needed to force make to reload environment.mak after running
100 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
101 build
/environment.mak
: build
/configure-stamp
104 configure
: configure.in
105 build
/configure-stamp
: configure
108 cp COPYING debian
/copyright
109 cd build
&& ..
/configure
$(confflags
)
112 build
/build-stamp
: build
/configure-stamp
113 # Add here commands to compile the package.
117 build
/build-doc-stamp
: build
/configure-stamp
118 # Add here commands to compile the package.
130 # Add here commands to clean up after the build process.
131 dh_clean debian
/copyright debian
/shlibs.local debian
/shlibs.local.apt debian
/shlibs.local.apt-utils
133 binary-indep
: apt-doc libapt-pkg-doc
134 # Build architecture-independent files here.
135 libapt-pkg-doc
: build-doc debian
/shlibs.local
141 # libapt-pkg-doc install
143 dh_installdocs
-p
$@
$(BLD
)/docs
/cache
* $(BLD
)/docs
/design
* $(BLD
)/docs
/dpkg-tech
* \
144 $(BLD
)/docs
/files
* $(BLD
)/docs
/method
* \
145 doc
/libapt-pkg2_to_3.txt doc
/style.txt
146 dh_installexamples
-p
$@
147 # dh_installmenu -p$@
148 # dh_installinit -p$@
149 # dh_installcron -p$@
152 # dh_undocumented -p$@
153 dh_installchangelogs
-p
$@
157 # dh_suidregister -p$@
159 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
171 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text
$(BLD
)/docs
/guide
*.html \
172 $(BLD
)/docs
/offline.text
$(BLD
)/docs
/offline.html
173 dh_installchangelogs
-p
$@
183 # Build architecture-dependent files here.
185 binary-arch
: apt libapt-pkg-dev apt-utils
186 apt
: build debian
/shlibs.local
190 dh_installdirs
-p
$@
/usr
/share
/bug
/$@
194 cp
$(BLD
)/bin
/apt-
* debian
/apt
/usr
/bin
/
196 # Remove the bits that are in apt-utils
197 rm $(addprefix debian
/apt
/usr
/bin
/apt-
,$(APT_UTILS
))
199 # install the shared libs
200 find
$(BLD
)/bin
/ -type f
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/apt
/usr
/lib
/ \
;
201 find
$(BLD
)/bin
/ -type l
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/apt
/usr
/lib
/ \
;
203 cp
$(BLD
)/bin
/methods
/* debian
/apt
/usr
/lib
/apt
/methods
/
205 cp
$(BLD
)/scripts
/dselect
/* debian
/apt
/usr
/lib
/dpkg
/methods
/apt
/
206 cp
-r
$(BLD
)/locale debian
/apt
/usr
/share
/
208 cp debian
/bugscript debian
/apt
/usr
/share
/bug
/apt
/script
210 # head -n 500 ChangeLog > debian/ChangeLog
212 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
216 dh_installchangelogs
-p
$@
220 dh_makeshlibs
-p
$@
-m
$(LIBAPTPKG_MAJOR
) -V
'$(LIBAPTPKG_PROVIDE)'
222 dh_shlibdeps
-p
$@
-l
`pwd`/debian
/apt
/usr
/lib
-- -Ldebian
/shlibs.local.apt
223 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
227 libapt-pkg-dev
: build debian
/shlibs.local
233 # libapt-pkg-dev install
235 cp
-a
$(BLD
)/bin
/libapt-pkg
*.so debian
/libapt-pkg-dev
/usr
/lib
/
236 cp
-a
$(BLD
)/bin
/libapt-inst
*.so debian
/libapt-pkg-dev
/usr
/lib
/
237 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
238 cp
$(BLD
)/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
241 # dh_installmenu -p$@
242 # dh_installinit -p$@
243 # dh_installcron -p$@
246 dh_installchangelogs
-p
$@
250 # dh_suidregister -p$@
252 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
) -Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
256 apt-utils
: build debian
/shlibs.local
262 # install the shared libs
263 find
$(BLD
)/bin
/ -type f
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
264 find
$(BLD
)/bin
/ -type l
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
266 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
269 # Install the man pages..
272 dh_installchangelogs
-p
$@
276 dh_makeshlibs
-m
$(LIBAPTINST_MAJOR
) -V
'$(LIBAPTINST_PROVIDE)' -p
$@
278 dh_shlibdeps
-p
$@
-l
`pwd`/debian
/apt
/usr
/lib
:`pwd`/debian
/$@
/usr
/lib
-- -Ldebian
/shlibs.local.apt-utils
279 dh_gencontrol
-p
$@
-u
-Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
284 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
291 # Update from CVS and then configure for build
292 super-l33ch
: l33ch Makefile.in
297 l33ch-stamp
: super-l33ch
301 -find
-name Makefile.in
-print0 | xargs
-0r
rm -f
302 find
-name ChangeLog | xargs
rm -f
305 binary
: binary-indep binary-arch
306 .PHONY
: build
clean binary-indep binary-arch binary debian
/shlibs.local
309 # Done by the uploader.
311 #edit debian/changelog
312 # configure.in has the version automatically updated now.
314 # debian/rules cvs-build
316 CVS_BUILDDIR
=apt-
$(APT_DEBVER
)
317 CVS_ROOT
=$(shell cat CVS
/Root
)
318 CVS_MODULE
=$(shell cat CVS
/Repository
)
320 rm -rf debian
/cvs-build
321 mkdir
-p debian
/cvs-build
322 (cd debian
/cvs-build
;cvs
-d
$(CVS_ROOT
) export -r
$(APT_CVSTAG
) -d apt-
$(APT_DEBVER
) $(CVS_MODULE
))
323 $(MAKE
) -C debian
/cvs-build
/$(CVS_BUILDDIR
) startup doc
324 (cd debian
/cvs-build
/$(CVS_BUILDDIR
);$(DEB_BUILD_PROG
))
327 -mkdir
-p ..
/upload-
$(APT_DEBVER
)
328 cp
`find debian/cvs-build -maxdepth 1 -type f` ..
/upload-
$(APT_DEBVER
)