]> git.saurik.com Git - apt.git/blob - debian/rules
- pt update from Miguel Figueiredo <elmig@debianpt.org>...
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
22 confflags += --build $(DEB_HOST_GNU_TYPE)
23 else
24 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
25 endif
26
27 # See below
28 -include build/environment.mak
29
30 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
31 export CXXFLAGS = -O0 -g -Wall
32 else
33 export CXXFLAGS = -O2 -g -Wall
34 endif
35
36 # Default rule
37 build:
38
39 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
40 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
41 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
42 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
43
44 # Determine the build directory to use
45 BASE=.
46 ifdef BUILD
47 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
48 else
49 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
50 endif
51 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
52 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
53 override BLD := $(BUILDX)
54
55 ifeq ($(words $(BLD)),0)
56 override BLD := ./build
57 endif
58
59 # Rebuild configure.in to have the correct version from the change log
60 ifneq ($(APT_DEBVER),$(APT_CONFVER))
61 .PHONY: configure.in
62 configure.in:
63 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
64 else
65 configure.in:
66 endif
67
68 # APT Programs in apt-utils
69 APT_UTILS=ftparchive sortpkgs extracttemplates
70
71 # Uncomment this to turn on verbose mode.
72 #export DH_VERBOSE=1
73
74 # Find the libapt-pkg major version for use in other control files
75 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
76 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
77
78 # Determine which package we should provide in the control files
79 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
80 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
81
82 debian/shlibs.local: apt-pkg/makefile
83 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
84 # one for the rest of the packages. This ensures that each package gets
85 # the right overrides..
86 rm -rf $@ $@.apt $@.apt-utils
87 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
88
89 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
90 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
91
92 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
93 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
94
95 build: build/build-stamp
96 build-doc: build/build-doc-stamp
97
98 # Note that this is unconditionally done first as part of loading environment.mak
99 # The true is needed to force make to reload environment.mak after running
100 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
101 build/environment.mak: build/configure-stamp
102 @true
103
104 configure: configure.in
105 build/configure-stamp: configure
106 dh_testdir
107 -mkdir build
108 cp COPYING debian/copyright
109 cd build && ../configure $(confflags)
110 touch $@
111
112 build/build-stamp: build/configure-stamp
113 # Add here commands to compile the package.
114 $(MAKE) binary
115 touch $@
116
117 build/build-doc-stamp: build/configure-stamp
118 # Add here commands to compile the package.
119 $(MAKE) doc
120 touch $@
121
122 clean:
123 dh_testdir
124 # dh_testroot
125 -$(MAKE) clean
126 -$(MAKE) distclean
127
128 rm -rf build
129
130 # Add here commands to clean up after the build process.
131 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
132
133 binary-indep: apt-doc libapt-pkg-doc
134 # Build architecture-independent files here.
135 libapt-pkg-doc: build-doc debian/shlibs.local
136 dh_testdir -p$@
137 dh_testroot -p$@
138 dh_clean -p$@ -k
139 dh_installdirs -p$@
140 #
141 # libapt-pkg-doc install
142 #
143 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
144 $(BLD)/docs/files* $(BLD)/docs/method* \
145 doc/libapt-pkg2_to_3.txt doc/style.txt
146 dh_installexamples -p$@
147 # dh_installmenu -p$@
148 # dh_installinit -p$@
149 # dh_installcron -p$@
150 # dh_installman -p$@
151
152 # dh_undocumented -p$@
153 dh_installchangelogs -p$@
154 dh_strip -p$@
155 dh_compress -p$@
156 dh_fixperms -p$@
157 # dh_suidregister -p$@
158 dh_installdeb -p$@
159 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
160 dh_md5sums -p$@
161 dh_builddeb -p$@
162
163 apt-doc: build-doc
164 dh_testdir -p$@
165 dh_testroot -p$@
166 dh_clean -p$@ -k
167 #
168 # apt-doc install
169 #
170 # Copy the guides
171 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
172 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
173 dh_installchangelogs -p$@
174 dh_compress -p$@
175 dh_fixperms -p$@
176 dh_installdeb -p$@
177 dh_gencontrol -p$@
178 dh_md5sums -p$@
179 dh_builddeb -p$@
180
181
182
183 # Build architecture-dependent files here.
184
185 binary-arch: apt libapt-pkg-dev apt-utils
186 apt: build debian/shlibs.local
187 dh_testdir -p$@
188 dh_testroot -p$@
189 dh_clean -p$@ -k
190 dh_installdirs -p$@ /usr/share/bug/$@
191 #
192 # apt install
193 #
194 cp $(BLD)/bin/apt-* debian/apt/usr/bin/
195
196 # Remove the bits that are in apt-utils
197 rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
198
199 # install the shared libs
200 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
201 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
202
203 cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
204
205 cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
206 cp -r $(BLD)/locale debian/apt/usr/share/
207
208 cp debian/bugscript debian/apt/usr/share/bug/apt/script
209
210 # head -n 500 ChangeLog > debian/ChangeLog
211
212 dh_installexamples -p$@ $(BLD)/docs/examples/*
213 dh_installman -p$@
214
215 dh_installdocs -p$@
216 dh_installchangelogs -p$@
217 dh_strip -p$@
218 dh_compress -p$@
219 dh_fixperms -p$@
220 dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
221 dh_installdeb -p$@
222 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
223 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
224 dh_md5sums -p$@
225 dh_builddeb -p$@
226
227 libapt-pkg-dev: build debian/shlibs.local
228 dh_testdir -p$@
229 dh_testroot -p$@
230 dh_clean -p$@ -k
231 dh_installdirs -p$@
232 #
233 # libapt-pkg-dev install
234 #
235 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
236 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
237 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
238 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
239
240 dh_installdocs -p$@
241 # dh_installmenu -p$@
242 # dh_installinit -p$@
243 # dh_installcron -p$@
244 # dh_installman -p$@
245
246 dh_installchangelogs -p$@
247 dh_strip -p$@
248 dh_compress -p$@
249 dh_fixperms -p$@
250 # dh_suidregister -p$@
251 dh_installdeb -p$@
252 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
253 dh_md5sums -p$@
254 dh_builddeb -p$@
255
256 apt-utils: build debian/shlibs.local
257 dh_testdir -p$@
258 dh_testroot -p$@
259 dh_clean -p$@ -k
260 dh_installdirs -p$@
261
262 # install the shared libs
263 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
264 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
265
266 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
267 dh_installdocs -p$@
268
269 # Install the man pages..
270 dh_installman -p$@
271
272 dh_installchangelogs -p$@
273 dh_strip -p$@
274 dh_compress -p$@
275 dh_fixperms -p$@
276 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
277 dh_installdeb -p$@
278 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
279 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
280 dh_md5sums -p$@
281 dh_builddeb -p$@
282
283 source diff:
284 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
285
286 # Update from CVS
287 l33ch: really-clean
288 cvs update
289 buildlib/mkChangeLog
290
291 # Update from CVS and then configure for build
292 super-l33ch: l33ch Makefile.in
293
294 configure:
295 $(MAKE) configure
296
297 l33ch-stamp: super-l33ch
298 touch $@
299
300 really-clean: clean
301 -find -name Makefile.in -print0 | xargs -0r rm -f
302 find -name ChangeLog | xargs rm -f
303 rm -f l33ch-stamp
304
305 binary: binary-indep binary-arch
306 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
307
308
309 # Done by the uploader.
310 #cvs update..
311 #edit debian/changelog
312 # configure.in has the version automatically updated now.
313 # edit configure.in
314 # debian/rules cvs-build
315
316 CVS_BUILDDIR=apt-$(APT_DEBVER)
317 CVS_ROOT=$(shell cat CVS/Root)
318 CVS_MODULE=$(shell cat CVS/Repository)
319 cvs-build:
320 rm -rf debian/cvs-build
321 mkdir -p debian/cvs-build
322 (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
323 $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
324 (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
325
326 cvs-mkul:
327 -mkdir -p ../upload-$(APT_DEBVER)
328 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)