]> git.saurik.com Git - apt.git/blob - debian/rules
Packaging tweaks
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.2 1999/01/27 05:30:16 jgg Exp $
6
7
8 # Uncomment this to turn on verbose mode.
9 #export DH_VERBOSE=1
10
11 build: build-stamp
12 build-stamp: configure
13 dh_testdir
14 mkdir build
15 cd build; ../configure
16 cd ..
17 # cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
18 # cd build && make all-hdr
19 # cd build && make -s
20
21 # Add here commands to compile the package.
22 make
23 touch build-stamp
24
25 clean:
26 dh_testdir
27 # dh_testroot
28 rm -f build-stamp
29 rm -rf build
30
31 # Add here commands to clean up after the build process.
32 -$(MAKE) clean
33 -$(MAKE) distclean
34 dh_clean
35
36 # Build architecture-independent files here.
37 binary-indep: build libapt-pkg-doc
38 # We have nothing to do by default.
39
40 # Build architecture-dependent files here.
41 binary-arch: build apt libapt-pkg-dev
42
43 apt: build
44 # dh_testversion -papt
45 dh_testdir -papt
46 dh_testroot -papt
47 dh_clean -papt -k
48 dh_installdirs -papt usr/bin usr/lib/apt/methods usr/lib/dpkg/methods/apt etc/apt usr/doc/apt var/cache/apt/archives/partial var/state/apt/lists/partial
49
50 cp build/bin/apt-* debian/tmp/usr/bin/
51
52 # install the shared libs
53 find build/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
54 find build/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
55
56 cp build/bin/methods/* debian/tmp/usr/lib/apt/methods/
57
58 cp build/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
59 # cp debian/sources.list debian/tmp/etc/apt/
60
61 cp build/docs/guide.text debian/tmp/usr/doc/apt/users-guide.txt
62 mkdir debian/tmp/usr/doc/apt/users-guide.html/
63 cp -a build/docs/guide.html/* debian/tmp/usr/doc/apt/users-guide.html/
64
65 # head -n 500 ChangeLog > debian/ChangeLog
66
67 dh_installdocs -papt
68 dh_installexamples -papt build/docs/examples/*
69 # dh_installmenu -papt
70 # dh_installinit -papt
71 # dh_installcron -papt
72 dh_installmanpages -papt
73
74 # dh_undocumented -papt
75 dh_installchangelogs -papt
76 dh_strip -papt
77 dh_compress -papt
78 dh_fixperms -papt
79 dh_suidregister -papt
80 dh_installdeb -papt
81 LD_LIBRARY_PATH=debian/tmp/usr/lib dh_shlibdeps -papt
82 dh_gencontrol -papt
83 dh_makeshlibs -papt
84 dh_md5sums -papt
85 dh_builddeb -papt
86
87 libapt-pkg-dev: build
88 dh_testdir -plibapt-pkg-dev
89 dh_testroot -plibapt-pkg-dev
90 dh_clean -plibapt-pkg-dev -k
91 dh_installdirs -plibapt-pkg-dev usr/lib usr/include/apt-pkg
92
93 ln -s libapt-pkg.so.2.0 debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
94
95 cp build/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
96
97 dh_installdocs -plibapt-pkg-dev
98 dh_installchangelogs -plibapt-pkg-dev
99 dh_strip -plibapt-pkg-dev
100 dh_compress -plibapt-pkg-dev
101 dh_fixperms -plibapt-pkg-dev
102 dh_installdeb -plibapt-pkg-dev
103 dh_shlibdeps -plibapt-pkg-dev
104 dh_gencontrol -plibapt-pkg-dev
105 dh_md5sums -plibapt-pkg-dev
106 dh_builddeb -plibapt-pkg-dev
107
108 libapt-pkg-doc: build
109 dh_testdir -plibapt-pkg-doc
110 dh_testroot -plibapt-pkg-doc
111 dh_clean -plibapt-pkg-doc -k
112 dh_installdirs -plibapt-pkg-doc usr/doc/apt
113
114 cp -a build/docs/cache* build/docs/design* build/docs/dpkg-tech* \
115 build/docs/files* build/docs/method* debian/libapt-pkg-doc/usr/doc/apt/
116
117 dh_installdocs -plibapt-pkg-doc
118 dh_installchangelogs -plibapt-pkg-doc
119 dh_strip -plibapt-pkg-doc
120 dh_compress -plibapt-pkg-doc
121 dh_fixperms -plibapt-pkg-doc
122 dh_installdeb -plibapt-pkg-doc
123 dh_shlibdeps -plibapt-pkg-doc
124 dh_gencontrol -plibapt-pkg-doc
125 dh_md5sums -plibapt-pkg-doc
126 dh_builddeb -plibapt-pkg-doc
127
128 source diff:
129 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
130
131 # Update from CVS
132 l33ch: really-clean
133 cvs update
134 utils/mkChangeLog
135
136 # Update from CVS and then configure for build
137 super-l33ch: l33ch Makefile.in
138
139 configure:
140 make startup
141
142 l33ch-stamp: super-l33ch
143 touch l33ch-stamp
144
145 really-clean: clean
146 -find -name Makefile.in -print0 | xargs -0r rm -f
147 find -name ChangeLog | xargs rm -f
148 rm -f l33ch-stamp
149
150 binary: binary-indep binary-arch
151 .PHONY: build clean binary-indep binary-arch binary