1 apt (0.5.6) unstable; urgency=low
3 * Adam Heath <doogie@debian.org>
4 - Fix segfault when handling /etc/apt/preferences. Closes: #192409.
5 * Matt Zimmerman <mdz@debian.org>
6 - Clean up some string handling, patch from Peter Lundkvist
7 <p.lundkvist@telia.com> (Closes: #192225)
8 - Don't fall off the end of the buffer when comparing versions.
9 Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
10 - Minor fixes to apt-ftparchive(1) (Closes: #118156)
11 - Fix typo in apt-ftparchive help text (Closes: #119072)
12 - Update config.guess, config.sub to latest versions
13 - Modify the description for apt-utils to reflect the fact that it is not
14 (any longer) infrequently used (Closes: #138045)
15 - Make setup script for dselect method more explicit about
16 overwriting sources.list (Closes: #151727)
17 - Fix typo in apt-cache(8) (Closes: #161243)
18 - Remove duplicate 'showpkg' from synopsis on apt-cache(8)
20 - Document in apt-get(8) the meaning of the '*' in ShowList, which is that
21 the package is being purged (Closes: #182369)
25 apt (0.5.5.1) unstable; urgency=low
27 * Move the target of the example docs from doc to binary. Closes:
29 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
30 backing out change that incorretly attempted to handle Package sections
31 larger than 32k. Closes: #192373
32 * Fix never-ending loop with apt-get install -V. Closes: #192355.
34 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
36 apt (0.5.5) unstable; urgency=low
38 * New deb version compare function, that has no integer limits, and
39 supports pre-versions using ~. Code ported from dpkg.
40 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
41 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
42 * "apt-get --arch-only build-dep" to install only architecture-
43 dependent build dependencies. Bump minor shared lib number to reflect
44 small change in BuildDepend API.
45 * APT::Build-Essential configuration option (defaults to "build-essential")
46 so that "apt-get build-dep" will ensure build essential packages are
47 installed prior to installing other build-dependencies. Closes: #148879
48 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
49 * /usr/doc reference in postinst. Closes: #126189
50 * Doc updates. Closes: #120689
51 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
53 * Print special message for EAI_AGAIN. Closes: #131397
54 * libapt-pkg-dev needs to bring in the apt-inst library if linking
55 is to work. Closes: #133943
56 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
57 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
58 #139994, #142955, #151654, #151834, #147611, #154268, #173971
59 * Fix possibility for tag file parsing to fail in some unlikely situations.
61 * Use std C++ names for some header files. Closes: #128741
62 * Do not check for free space if --no-download. Closes: #117856
63 * Actually implement or group handling for 'upgrade'. Closes: #133950
64 * "Internal Error, Couldn't configure pre-depend" is not actually an
65 internal error, it is a packaging error and now it says so, and
66 pinpoints the problem dependency. Closes: #155621
67 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
68 * Use usr/share/doc for dhelp. Closes: #115701
69 * --print-uris works with 'update'. Closes: #57070
70 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
72 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
74 * Allow an uninstalled package to be marked for removal on an install
75 line (meaning not to automatically install it), also fix some dodgy
76 handling of protected packages. Closes: #92287, #116011
77 * Fix errant prefix matching in version selection. Closes: #105968
78 * Ensure that all files needed to run APT as a user are readable and
79 ignore roots umask for these files. Closes: #108801
80 * Support larger config spaces. Closes: #111914
81 * 'apt-get update' no longer does 'Building Dependency Tree'.
82 * When matching regexs allways print a message. Change regex activation
83 charset. Closes: #147817
84 * Don't die if lines in sources.list are too long. Closes: #146846
85 * Show file name on apt-extracttemplate error messges. Closes: #151835
86 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
87 * Some highly unlikely memory faults. Closes: #155842
88 * C++ stuff for G++3.2. Closes: #162617, #165515,
89 * apt-config dumps sends to stdout not stderr now. Closes: #146294
90 * Fix segfault in FindAny when /i is used, and there is no default.
92 * Add s390x to archtable. Closese: #160992.
93 * Update config.sub/config.guess in cvs, and add support to debian/rules
94 to update them from /usr/share/misc if they exist. Closes: #155014
95 * Remove 'Sorry' from messages. Closes: #148824.
96 * Change wording of 'additional disk space usage' message. Closes:
98 * apt-extracttemplates now prepends the package name when extracting
99 files. Closes: #132776
100 * Add -n synonym for --names-only for apt-cache. Closes: #130689
101 * Display both current version and new version in apt-get -s. Closes:
103 * Add an options and timeout config item to ssh/rsh. Closes: #90654
104 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
105 * Change verbose logging output of apt-ftparchive to go to stderr,
106 instead of stdout. Also, errors that occur no longer go to stdout,
107 but stderr. Closes: #161592
108 * Test for timegm in configure. Closes: #165516.
109 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
110 support compliation on platforms where st_mtime is a macro. Closes:
112 * Check the currently mounted cdrom, to see if it's the one we are
113 interested in. Closes: #154602
114 * Refer to reportbug instead of bug in the man pages. Closes: #173745
115 * Link apt-inst to apt-pkg. Closes: #175055
116 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
118 * Fix > 300 col screen segfault. Closes: #176052
119 * Rebuild with gcc-3.2. Closes: #177752, #178008.
120 * Fix build-dep handling of | dependencies.
121 Closes: #98640, #145997, #158896, #172901
122 * Double default value of APT::Cache-Limit, until such time as it
123 can be made more dynamic. Closes: #178623.
124 * Report uris with '.gz' when there are errors. Closes: #178435.
125 * When installing build-deps, make sure the new version will
126 satisfy build requirements. Closes: #178121
127 * Split offline and guide documentation into apt-doc. This was done so
128 that binary-arch builds do not require documention deps. Note, that
129 apt-doc is not installed on upgrades.
130 * Use doc-base, instead of dhelp directly. Closes: #110389
131 * Change http message 'Waiting for file' to 'Waiting for headers'.
133 * Remove trailing lines on package lists in apt-get. Closes: #178736.
134 * Fix origin pins for file:// uris. Closes: #189014.
135 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
137 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
139 * Fix some typos in the apt-get manual. Closes: #163932.
140 * Apply patch from bug, to change frozen to testing, and then do it
141 everywhere else. Closes: #165085.
142 * Update es.po. Closes: #183111.
143 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
145 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
146 * Add option to apt-get to show versions of packages being
148 * Be quiet in apt.post{inst,rm}. Closes: #70685.
149 * apt-get now prints out suggested and recommended packages. Closes:
151 * Insert some newlines in the cdrom change media message. Closes:
153 * Add a rdepends command to apt-cache. Closes: #159864.
154 * When building the dpkg command line, allow for 8192 chars to be used,
155 instead of only 1024.
156 * APT::Immediate-Configure had inverted semantics(false meant it was
157 enabled). Closes: #173619.
158 * Fix status file parser so that if a record is larger than 32k, the
159 buffer size will be doubled, and the read attempted again. Closes:
162 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
164 apt (0.5.4) unstable; urgency=low
166 * M68k config.guess patch. Closes: #88913
167 * Bi-yearly test on OpenBSD and Solaris
168 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
169 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
171 * Various cosmetic code updates. Closes: #89066, #89066, #89152
172 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
174 * More patches from Alfredo for Vendors and more SHA-1 stuff
175 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
176 similar situations. Closes: #56708, #59432
177 * no_proxy and ftp. Closes: #89671
178 * Philippe Batailler's man page patches.
179 * Fix for display bug. Closes: #92033, #93652, #98468
180 * Use more than 16bits for the dep ID. Some people ran out..
181 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
182 #106911, #107395, #108968
183 * Reordered some things to make dante and FTP happier. Closes: #92757
184 * James R. Van Zandt's guide.sgml updates. Closes: #90027
185 * apt-ftparchive copes with no uncompressed package files + contents.
186 * French man pages from philippe batailler - well sort of. They
188 * run-parts. Closes: #94286
189 * 'apt-cache policy' preferences debug tool.
190 * Whatever. Closes: #89762
191 * libstdc++ and HURD. Closes: #92025
192 * More apt-utils verbage. Closes: #86954
193 * Fliped comparision operator. Closes: #94618
194 * Used the right copyright file. Closes: #65691
195 * Randolph's G++3 patches.
196 * Fixed no_proxy tokanizing. Closes: #100046
197 * Strip Config-Version when copying status to available. Closes: #97520
198 * Segfault with missing source files. Closes: #100325
199 * EINTR check. Closes: #102293
200 * Various changes to the locking metholodgy for --print-uris.
202 * Lame LD_LIBRARY_PATH thing. Closes: #98928
203 * apt-cache search searchs provide names too now. Closes: #98695
204 * Checksum and long lines problem. Closes: #106591
205 * .aptignr and empty files are just a warning. Closes: #97364
207 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
209 apt (0.5.3) unstable; urgency=low
211 * JoeyH's dpkg::preconfig not working. Closes: #88675
212 * Fixed apt override disparity
213 * Alfredo's SHA-1 and related patches
215 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
217 apt (0.5.2) unstable; urgency=low
219 * Fixed mention of /usr/doc in the long description
220 * JoeyH's downgrade bug -- don't use 0.5.1
221 * Doc bug. Closes: #88538
222 * Fault in building release strings. Closes: #88533
224 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
226 apt (0.5.1) unstable; urgency=low
228 * Fixed #82894 again, or should be and.
229 * Process the option string right. Closes: #86921
230 * Don't eat the last command for pipes. Closes: #86923
231 * Ignore .* for configuration directory processing. Closes: #86923
232 * Alfredo's no_proxy patch
233 * Documentation fixes. Closes: #87091
234 * JoeyH's double slash bug. Closes: #87266
235 * Unintitialized buffer and apt-ftparchive contents generation.
237 * Build-deps on virtual packages. Closes: #87639
238 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
239 libstdc++ version info in the library soname and in the package
240 provides. Closes: #87426
241 * Updated soname version to 0.3.2
242 * apt-extracttemplates moved from debconf into apt-utils
243 * s390 archtable entry. Closes: #88232
245 * Some instances where the status file can source a package in a
246 non-sensical way. Closes: #87390
247 * Work better if there are duplicate sources.list entries.
248 * Fixed the resetting of Dir with "dir {};". Closes: #87323
250 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
252 apt (0.5.0) unstable; urgency=low
254 * Fixed an obscure bug with missing final double new lines in
256 * Changed the apt-cdrom index copy routine to use the new section
258 * Added a package file sorter, apt-sortpkgs
259 * Parse obsolete Optional dependencies.
260 * Added Ben's rsh method. Closes: #57794
261 * Added IPv6 FTP support and better DNS rotation support.
262 * Include the server IP in error messages when using a DNS rotation.
264 * Made most of the byte counters into doubles to prevent 32bit overflow.
266 * HTTP Authorization. Closes: #61158
267 * Ability to parse and return source index build depends from Randolph.
268 * new 'apt-get build-dep' command from Randolph. Closes: #63982
269 * Added apt-ftparchive the all dancing all singing FTP archive
271 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
273 * Removed useless internal cruft including the xstatus file.
274 * Fixed config parser bugs. Closes: #67848, #71108
275 * Brain Damanged apt-get config options changed, does not change the command
276 line interface, except to allow --enable-* to undo a configuration
279 No-Download -> Download
280 No-Upgrade -> Upgrade
281 * Made this fix configable (DSelect::CheckDir) and default to disabled:
282 * No remove prompt if the archives dir has not changed. Closes: #55709
283 Because it is stupid in the case where no files were downloaded due to
284 a resumed-aborted install, or a full cache! Closes: #65952
285 * Obscure divide by zero problem. Closes: #64394
286 * Update sizetable for mips. Closes: #62288
287 * Fixed a bug with passive FTP connections
288 * Has sizetable entry for sparc64. Closes: #64869
289 * Escape special characters in the ::Label section of the cdroms.lst
290 * Created apt-utils and python-apt packages
291 * Due to the new policy engine, the available file may contain entries
292 from the status file. These are generated if the package is not obsolete
293 but the policy engine prohibits using the version from the package files.
294 They can be identified by the lack of a Filename field.
295 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
296 #36223, #33468, #22551
297 * Fixed deb-src line for non-us. Closes: #71501, #71601
298 * Fixes for G++ 2.96, s/friend/friend class/
299 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
300 * Confirmed fix for missing new line problem. Closes: #69386
301 * Fixed up dhelp files. Closes: #71312
302 * Added some notes about dselect and offline usage. Closes: #66473, #38316
303 * Lock files on read only file systems are ignored w/ warning.
305 * apt-get update foo now gives an error! Closes: #42891
306 * Added test for shlibs on hurd. Closes: #71499
307 * Clarified apt-cache document. Closes: #71934
308 * DocBook SGML man pages and some improvements in the text..
309 * sigwinch thing. Closes: #72382
310 * Caching can be turned off by setting the cache file names blank.
311 * Ignores arches it does not know about when autocleaning. Closes: #72862
312 * New function in apt-config to return dirs, files, bools and integers.
313 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
314 complex cases involving OR groups and provides.
315 68754 describes confusing messages which are the result of this..
316 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
317 * Speeling mistake and return code for the 'wicked' resolver error
318 Closes: #72621, #75226, #77464
319 * Solved unable to upgrade libc6 from potato to woody due to 3 package
320 libc6 dependency loop problem.
321 * Leading sources.list spaces. Closes: #76010
322 * Removed a possible infinite loop while processing installations.
323 * Man page updates. Closes: #75411, #75560, #64292, #78469
324 * ReduceSourceList bug. Closes: #76027
325 * --only-source option. Closes: #76320
326 * Typos. Closes: #77812, #77999
327 * Different status messages. Closes: #76652, #78353
328 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
329 * OS detection an support for the new pseduo standard of os-arch for the
330 Architecture string. Also uses regexing.. Closes: #39227, #72349
331 * Various i18n stuff. Note that this still needs some i18n wizard
332 to do the last gettextization right. Closes: #62386
333 * Fixed a problem with some odd http servers/proxies that did not return
334 the content size in the header. Closes: #79878, #44379
335 * Little acquire bugs. Closes: #77029, #55820
336 * _POSIX_THREADS may not be defined to anything, just defined..
338 * Spelling of Ignore-Hold correctly. Closes: #78042
339 * Unlock the dpkg db if in download only mode. Closes: #84851
340 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
341 * Patch from BenC. Closes: #80810
342 * Single output of some names in lists. Closes: #80498, #43286
343 * Nice message for people who can't read syserror output. Closes: #84734
344 * OR search function. Closes: #82894
345 * User's guide updates. Closes: #82469
346 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
347 * Various CD bugs, again thanks to Greenbush
348 Closes: #80946, #76547, #71810, #70049, #69482
349 * Using potato debhelper. Closes: #57977
350 * I cannot self-terminate. Closes: #74928
352 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
354 apt (0.3.19) frozen unstable; urgency=low
356 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
358 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
359 * Fixed hardcoded path. Closes: #59743
360 * Fixed Jay's relative path bug
361 * Allowed source only CDs. Closes: #58952
362 * Space check is supressed if --print-uris is given. Closes: #58965
363 * Clarified the documenation examples for non-us. Closes: #58646
364 * Typo in the package description. Closes: #60230
365 * Man Page typo. Closes: #60347
366 * Typo in Algorithms.cc. Closes: #63577
367 * Evil dotty function in apt-cache for generating dependency graphs
368 with the as-yet-unpackaged GraphVis.
369 * Appears to have been fixed in Janurary.. Closes: #57981
370 * New config.guess/sub for the new archs. Closes: #60874
371 * Fixed error reporting for certain kinds of resolution failures.
373 * Made autoclean respect 'q' settings. Closes: #63023
374 * Fixed up the example sources.list. Closes: #63676
375 * Added DPkg::FlushSTDIN to control the flushing of stdin before
376 forking dpkg. Closes: #63991
378 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
380 apt (0.3.18) frozen unstable; urgency=low
382 * Changes in the postinst script. Closes: #56855, #57237
383 * Fixed bashism. Closes: #57216, #57335
384 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
386 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
388 apt (0.3.17) unstable; urgency=low
390 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
391 * Fixed the configuration parser to not blow up if ; is in the config
393 * Applied visual patch to dselect install script . Closes #55214
394 * Included the configure-index example
396 * Library soname has increased
397 * Fixed default sources.list to have correct URLs for potato when it
399 * Added a message about erasing sources.list to dselect setup script
401 * No remove prompt if the archives dir has not changed. Closes: #55709
402 * Fixed inclusion of 2nd sample config file. Closes: #55374
403 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
406 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
408 apt (0.3.16) unstable; urgency=low
410 * Made --no-download work. Closes: #52993
411 * Now compiles on OpenBSD, Solaris and HP-UX
412 * Clarify segfault errors
413 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
414 * Fix for Joel's discovery of glibc removal behavoir.
415 * Fix for Ben Collins file: uri from slink upgrade.
416 * Fixed resume code in FTP. Closes: #54323
417 * Take more precautions to prevent the corruption Joey Hess saw.
418 * Fixed --no-list-cleanup
419 * RFC 2732 URI parsing ([] for hostnames).
420 * Typo in apt-cache man page. Closes: #54949
422 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
424 apt (0.3.15) unstable; urgency=low
426 * Added DSelect::WaitAfterDownload Closes: #49549
427 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
428 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
429 * Made -s and clean not do anything. Closes: #50238
430 * Problem with Protected packages and the new OR code.
431 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
432 * Remove doesn't require a package to be installable. Closes: #51175
433 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
435 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
437 apt (0.3.14) unstable; urgency=low
439 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
440 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
441 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
442 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
443 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
444 Closes: #45034, #45695, #46537
445 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
446 * Added APT::Clean-Installed option. Closes: #45973
447 * Moves the free space check to after the calculated size is printed.
448 Closes: #46639, #47498
449 * mipsel arch Closes: #47614
450 * Beautified URI printing to not include passwords Closes: #46857
451 * Fixed little problem with --no-download Closes: #47557
452 * Tweaked Dselect 'update' script to re-gen the avail file even in the
453 event of a failure Closes: #47112
454 * Retries for source archives too Closes: #47529
455 * Unmounts CDROMs iff it mounted them Closes: #45299
456 * Checks for the partial directories before doing downloads Closes: #47392
457 * no_proxy environment variable (http only!) Closes: #43476
458 * apt-cache showsrc Closes: #45799
459 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
460 * Regexs for install. Closes: #35304, #38835
461 * Dependency reports now show OR group relations
462 * Re-Install feature. Cloes: #46961, #37393, #38919
463 * Locks archive directory on clean (woops)
464 * Remove is not 'sticky'. Closes: #48392
465 * Slightly more accurate 'can not find package' message. Closes: #48311
466 * --trivial-only and --no-remove. Closes: #48518
467 * Increased the cache size. Closes: #47648
468 * Comment woopsie. Closes: #48789
469 * Removes existing links when linking sources. Closes: #48775
470 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
471 * Clearer usage message about 'source' Closes: #48858
472 * Immediate configure internal error Closes: #49062, #48884
474 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
476 apt (0.3.13) unstable; urgency=low
478 * Fix timestamp miss in FTP. Closes: #44363
479 * Fix sorting of Kept packages. Closes: #44377
480 * Fix Segfault for dselect-upgrade. Closes: #44436
481 * Fix handling of '/' for the dist name. Closes #43830
482 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
483 * Add commented-out deb-src URI to default sources.list file.
485 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
487 apt (0.3.12) unstable; urgency=low
489 * Fix for typo in the dhelp index. Closes: #40377
490 * Multiple media swap support
491 * Purge support. Closes: #33291, #40694
492 * Better handling of - remove notation. Closes: #41024
493 * Purge support. Closes: #33291, #40694
494 * Error code on failed update. Closes: #41053
495 * apt-cdrom adds entries for source directories. Closes: #41231
496 * Sorts the output of any list. Closes: #41107
497 * Fixes the looping problem. Closes: #41784, #42414, #44022
498 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
499 * More checks to keep the display sane. Particularly when fail-over is
500 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
501 * PThread lockup problem on certain sparc/m68k. Closes: #40628
502 * apt-cdrom understands .gz Package files too. Closes: #42779
503 * Spelling error in dselect method description. Closes: #43251
504 * Added security to the default source list. Closes: #43356
506 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
508 apt (0.3.11) unstable; urgency=low
510 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
511 * Fix for properly upgrading the system from perl 5.004 to 5.005
513 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
515 apt (0.3.9) unstable; urgency=low
517 * Spelling error in cachefile.cc. Closes: #39885
518 * Trailing slash in dselect install if you try to use the
519 default config file. Closes: #40011
520 * Simulate works for autoclean. Closes: #39141
521 * Fixed spelling errors. Closes: #39673
522 * Changed url parsing a bit. Closes: #40070, #40069
523 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
525 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
527 apt (0.3.7) unstable; urgency=low
529 * Fixed missing text in the apt-get(8) page. Closes: #37596
530 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
531 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
532 * Fixed handling of the -q option with not-entirely integer arguments
534 * Man page typo Closes: #37762
535 * Fixed parsing of the Source: line. Closes: #37679
536 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
537 * Added a check for an empty cache directory. Closes: #37963
538 * Return a failure code if -d is given and packages fail to download.
540 * Arranged for an ftp proxy specifing an http server to work. See the
541 important note in the sources.list man page.
542 * Accounted for resumed files in the cps calculation. Closes: #36787
543 * Deal with duplicate same version different packages. Closes: #30237
544 * Added --no-download. Closes: #38095
545 * Order of apt-cdrom dist detection. Closes: #38139
546 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
548 * Suggests dpkg-dev for apt-get source. Closes: #38158
549 * Fixed typo in apt-get help. Closes: #38712
550 * Improved the error message in the case of broken held package. Closes: #38777
551 * Fixed handling of MD5 failures
552 * Documented list notation Closes: #39008
553 * Change the 'b' to 'B'. Closes: #39007
555 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
557 apt (0.3.6) unstable; urgency=low
559 * Note that 0.3.5 never made it out the door..
560 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
561 * Made APT print numbers in decimal. Closes: #35617, #37319
562 * Buffer munching fix for FTP. Closes: #35868
563 * Typo in sample config file. Closes: #35907
564 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
565 * Changed installed size counter to only count unpacked packages.
567 * apt-get source support. Closes: #23934, #27190
568 * Renames .debs that fail MD5 checking, provides automatic corruption
569 recovery. Closes: #35931
570 * Fixed autoconf verison. Closes: #37305
571 * Random Segfaulting. Closes: #37312, #37530
572 * Fixed apt-cache man page. Closes: #36904
573 * Added a newline to apt-cache showpkg. Closes: #36903
575 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
577 apt (0.3.4) unstable; urgency=low
579 * Release for Ben while he is out of town.
580 * Checked the size of partial files. Closes: #33705
581 * apt-get should not print progress on non-tty. Closes: #34944
582 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
583 * Applied cdrom patches from Torsten. Closes: #35140, #35141
584 * smbmounted cdrom fix. Closes: #35470
585 * Changed ie to eg. Closes: #35196
587 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
589 apt (0.3.3) unstable; urgency=low
591 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
593 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
595 apt (0.3.2) unstable; urgency=low
597 * Major release into unstable of v3
598 * These bugs have been fixed, explanations are in the bug system, read
599 the man pages as well..
600 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
601 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
602 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
603 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
604 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
605 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
606 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
607 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
609 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
611 apt (0.3.1) experimental; urgency=low
613 * Minor release of cvs version.
614 * Added virtual package libapt-pkgx.x
616 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
618 apt (0.3.0) experimental; urgency=low
620 * New experimental version.
622 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
624 apt (0.1.9) frozen unstable; urgency=low
626 * Return to the wacky numbering for when we build 0.1.8 for hamm
627 * Important bug related to APT on the Alpha fixed
628 * apt-get dist-upgrade problems fixed
629 * tiny patch for http method to fix an endless loop
630 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
631 libtool and add proper shared lib dependancies
632 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
633 in case an old libpkg is installed while building APT to prevent
634 spurious dependancies
636 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
638 apt (0.1.7) unstable; urgency=low
640 * New build with libstdc++2.9.
641 * Various fixes; read the Changelog.
643 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
645 apt (0.1.6) unstable; urgency=low
647 * Various fixes in the FTP method for error checking. Fixes: #26188.
648 * Spelling corrections in dselect method. Fixes: #25884
649 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
650 * No more bo releases: we're using a normal numbering system now.
652 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
654 apt (0.1.5) unstable; urgency=low
656 * Changed sources.list to point to 'unstable' by default, as
657 'frozen' no longer exists!
659 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
661 apt (0.1.3) unstable; urgency=low
663 * New upstreamish version.
664 * ftp method rewritten in C. Removes dependancies on all perl/perl
665 related modules. This fixes many of the ftp method bugs.
667 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
669 apt (0.1.1) unstable; urgency=low
671 * Release for unstable.
673 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
675 apt (0.1) unstable; urgency=low
677 * Kludge to fix problem in libnet-perl with illegal anonymous
679 * Moved to unstable; apt is in a useable state now.
680 * Fixed version numbering. From now on, numbering will be:
681 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
682 0.1.1 (release for unstable). Thanks, Manoj.
684 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
686 apt (0.0.17-1) experimental; urgency=low
688 * Fixed problem with libc6 version compare
689 * Scott's away for a while, so I'll be packaging apt for the time
692 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
694 apt (0.0.16-1) experimental; urgency=low
696 * Modifications to make apt-get more friendly when backgrounded.
697 * Updated documentation.
698 * Updates to graphic widgets
700 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
702 apt (0.0.15-0.2bo) experimental; urgency=low
705 * Bob Hilliards crash
707 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
709 apt (0.0.15-0.1bo) experimental; urgency=low
714 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
716 apt (0.0.15) experimental; urgency=low
718 * Clean up source tarball (no user-visible changes)
720 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
722 apt (0.0.14) experimental; urgency=low
724 * Updates in ordering code to make sure certain upgrades work correctly.
725 * Made dselect/setup understand ftp as well as http
727 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
729 apt (0.0.13-bo1) experimental; urgency=low
733 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
735 apt (0.0.13) experimental; urgency=low
737 * Remove hardcoded egcc from debian/rules (#21575)
738 * Fixes for ordering logic when system has a number of unpacked
739 but unconfigured packages installed.
740 * Spelling fix in dselect install method (#22556)
742 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
744 apt (0.0.12) experimental; urgency=low
746 * Fixed problems with package cache corruption.
747 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
749 * Interface and documentation improvements.
751 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
753 apt (0.0.11) experimental; urgency=low
755 * Change dependancies to pre-depends since breaking your packaging tools
756 in the middle of an installation isn't very good.
757 * Bug fixes to ftp method and general apt-get code
759 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
761 apt (0.0.10) experimental; urgency=low
763 * Run "dpkg --configure -a" after an aborted dselect install
764 * Fixed problem with install looping
765 * Support for authenticating proxys: (note this isn't terribly secure)
766 http_proxy="http://user:pass@firewall:port/"
767 * Substitute $ARCH in sources.list
768 * Fixes in the resumption code for ftp
770 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
772 apt (0.0.9) experimental; urgency=low
775 * Various other less visible bug fixes.
776 * Fixed problem with segfault when apt-get invoked in a non-existant
777 directory (Bug #21863)
778 * Bumped policy to 2.4.1
780 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
782 apt (0.0.8) experimental; urgency=low
784 * Fixed generated available file (Bug #21836)
785 * Added download ETA (Bug #21774).
786 * Fixed hardcoded ARCH (Bug #21751).
787 * Fixed check on http_proxy (Bug #21795).
788 * Added download speed indicator.
790 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
792 apt (0.0.7) experimental; urgency=low
794 * Remove libdeity and apt from package for now, since only apt-get and
795 apt-cache are actually useful right now.
796 * Clean up handling of package installation errors.
797 * Added timeout to http transfers (#21269)
798 * Updated setup for dselect/apt method.
800 * Long options (added in 0.0.6)
802 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
804 apt (0.0.6) experimental; urgency=low
807 * Revamped download status display.
808 * Call apt-get clean after successful install in dselect.
809 * Added "apt-get clean" which deletes package files from /var/cache/apt
811 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
813 apt (0.0.5) experimental; urgency=low
815 * Ignore signals while dpkg is running so we don't leave dpkg running in
816 the background (#20804)
817 * Check Packages as well as Packages.gz for file URIs (#20784)
818 * Spelling cleanup (#20800)
819 * Added -m option to permit upgrade to go on in the case of a bad mirror.
820 This option may result in incomplete upgrades when used with -f.
822 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
824 apt (0.0.4) experimental; urgency=low
827 * Various documentation updates and cleanup.
828 * Added '-f' option to apt-get attempt to fix broken dependancies.
830 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
832 apt (0.0.3) experimental; urgency=low
834 * Added a shlibs.local file to prevent apt from depending on itself.
835 * Updates to how apt-get handles bad states in installed packages.
836 * Updated rules to make sure build works from a freshly checked out source
837 archive. Building from CVS needs libtool/automake/autoconf, builds from
838 the distributed source package should have no such dependancy.
840 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
842 apt (0.0.2) unstable; urgency=low
844 * Updates to apt-get and http binding for dselect method (apt).
845 * Updating version number from 0.0.1, which was released only on IRC.
847 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
849 apt (0.0.1) unstable; urgency=low
853 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500