]> git.saurik.com Git - apt.git/blob - debian/rules
merged lp:~donkult/apt/sid
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
76
77 # do not fail as we are just experimenting with symbol files for now
78 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
79
80 build: build/build-stamp
81 build-doc: build/build-doc-stamp
82
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build/environment.mak: build/configure-stamp
87 @true
88
89 configure: configure.in
90 build/configure-stamp: configure
91 dh_testdir
92 -mkdir build
93 cp COPYING debian/copyright
94 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
95 touch $@
96
97 build/build-stamp: build/configure-stamp
98 # Add here commands to compile the package.
99 $(MAKE) binary
100 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
101 $(MAKE) test
102 else
103 @echo "Tests DISABLED"
104 endif
105 touch $@
106
107 build/build-doc-stamp: build/configure-stamp
108 # Add here commands to compile the package.
109 $(MAKE) doc
110 touch $@
111
112 clean:
113 dh_testdir
114
115 [ ! -f Makefile ] || $(MAKE) clean distclean
116 rm -rf build
117
118 binary-indep: apt-doc libapt-pkg-doc
119 # Build architecture-independent files here.
120 libapt-pkg-doc: build-doc
121 dh_testdir -p$@
122 dh_testroot -p$@
123 dh_prep -p$@
124 dh_installdirs -p$@
125 #
126 # libapt-pkg-doc install
127 #
128 dh_installdocs -p$@ $(BLD)/docs/design* \
129 $(BLD)/docs/dpkg-tech* \
130 $(BLD)/docs/files* \
131 $(BLD)/docs/method* \
132 doc/libapt-pkg2_to_3.txt \
133 doc/style.txt \
134 $(BLD)/doc/doxygen/html
135 dh_installexamples -p$@
136
137 dh_installchangelogs -p$@
138 dh_strip -p$@
139 dh_compress -p$@
140 dh_fixperms -p$@
141 dh_installdeb -p$@
142 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
143 dh_md5sums -p$@
144 dh_builddeb -p$@
145
146 apt-doc: build-doc
147 dh_testdir -p$@
148 dh_testroot -p$@
149 dh_prep -p$@
150 #
151 # apt-doc install
152 #
153 # Copy the guides
154 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
155 $(BLD)/docs/guide*.html \
156 $(BLD)/docs/offline*.text \
157 $(BLD)/docs/offline*.html
158 dh_installchangelogs -p$@
159 dh_compress -p$@
160 dh_fixperms -p$@
161 dh_installdeb -p$@
162 dh_gencontrol -p$@
163 dh_md5sums -p$@
164 dh_builddeb -p$@
165
166
167
168 # Build architecture-dependent files here.
169
170 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
171 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
172 apt: build build-doc
173 dh_testdir -p$@
174 dh_testroot -p$@
175 dh_prep -p$@
176 dh_installdirs -p$@
177 #
178 # apt install
179 #
180 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
181
182 # make rosetta happy and remove pot files in po/ (but leave stuff
183 # in po/domains/* untouched) and cp *.po into each domain dir
184 rm -f build/po/*.pot
185 rm -f po/*.pot
186
187 dh_install -p$@ --sourcedir=$(BLD)
188
189 # Remove the bits that are in apt-utils
190 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
191
192 # https has its own package
193 rm debian/$@/usr/lib/apt/methods/https
194
195 # move the mirror failure script in place
196 #mv debian/$@/usr/bin/apt-report-mirror-failure \
197 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
198
199 dh_bugfiles -p$@
200 dh_lintian -p$@
201 dh_installexamples -p$@ $(BLD)/docs/examples/*
202 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
203 dh_installcron -p$@
204 dh_installdocs -p$@
205 dh_installchangelogs -p$@
206 dh_installlogrotate -p$@
207 dh_strip -p$@
208 dh_compress -p$@
209 dh_fixperms -p$@
210 dh_makeshlibs -p$@
211 dh_installdeb -p$@
212 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
213 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
214 dh_md5sums -p$@
215 dh_builddeb -p$@
216
217 libapt-pkg-dev: build
218 dh_testdir -p$@
219 dh_testroot -p$@
220 dh_prep -p$@
221 dh_installdirs -p$@
222 #
223 # libapt-pkg-dev install
224 #
225 dh_install -p$@ --sourcedir=$(BLD)
226 dh_installdocs -p$@
227 dh_installchangelogs -p$@
228 dh_strip -p$@
229 dh_compress -p$@
230 dh_fixperms -p$@
231 dh_installdeb -p$@
232 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
233 dh_md5sums -p$@
234 dh_builddeb -p$@
235
236 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
237 apt-utils: build
238 dh_testdir -p$@
239 dh_testroot -p$@
240 dh_prep -p$@
241 dh_installdirs -p$@
242
243 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
244
245 dh_install -p$@ --sourcedir=$(BLD)
246 dh_installdocs -p$@
247 dh_installexamples -p$@
248
249 # Install the man pages..
250 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
251
252 dh_installchangelogs -p$@
253 dh_strip -p$@
254 dh_compress -p$@
255 dh_fixperms -p$@
256 dh_makeshlibs -p$@
257 dh_installdeb -p$@
258 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
259 dh_gencontrol -p$@ -- -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
260 dh_md5sums -p$@
261 dh_builddeb -p$@
262
263 apt-transport-https: build libapt-pkg-dev
264 dh_testdir -p$@
265 dh_testroot -p$@
266 dh_prep -p$@
267 dh_installdirs -p$@
268
269 dh_install -p$@ --sourcedir=$(BLD)
270 dh_installdocs -p$@ debian/apt-transport-https.README
271 dh_installexamples -p$@
272
273 # Install the man pages..
274 dh_installman -p$@
275
276 dh_installchangelogs -p$@
277 dh_strip -p$@
278 dh_compress -p$@
279 dh_fixperms -p$@
280 dh_installdeb -p$@
281 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
282 dh_gencontrol -p$@
283 dh_md5sums -p$@
284 dh_builddeb -p$@
285
286 configure:
287 $(MAKE) configure
288
289 really-clean: clean
290 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
291 find -name ChangeLog | xargs rm -f
292 rm -f l33ch-stamp
293
294 binary: binary-indep binary-arch
295 .PHONY: build clean binary-indep binary-arch binary