]> git.saurik.com Git - apt.git/blob - debian/rules
Move the guide and offline docs to a separate package. ...
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.46 2003/02/12 07:39:45 doogie Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DH_COMPAT=2
18
19 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
20 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
21
22 # FOR AUTOCONF 2.52 AND NEWER ONLY
23 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
24 confflags += --build $(DEB_HOST_GNU_TYPE)
25 else
26 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
27 endif
28
29 # See below
30 -include build/environment.mak
31
32 # Default rule
33 build:
34
35 DEB_BUILD_PROG:=debuild -us -uc
36 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
37 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
38
39 # Determine the build directory to use
40 BASE=.
41 ifdef BUILD
42 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
43 else
44 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
45 endif
46 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
47 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
48 override BLD := $(BUILDX)
49
50 ifeq ($(words $(BLD)),0)
51 override BLD := ./build
52 endif
53
54 # Rebuild configure.in to have the correct version from the change log
55 ifneq ($(APT_DEBVER),$(APT_CONFVER))
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
59 else
60 configure.in:
61 endif
62
63 # APT Programs in apt-utils
64 APT_UTILS=ftparchive sortpkgs extracttemplates
65
66 # Uncomment this to turn on verbose mode.
67 #export DH_VERBOSE=1
68
69 # Find the libapt-pkg major version for use in other control files
70 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
71 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
76
77 debian/shlibs.local: apt-pkg/makefile
78 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
79 # one for the rest of the packages. This ensures that each package gets
80 # the right overrides..
81 rm -rf $@ $@.apt $@.apt-utils
82 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
83
84 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
85 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
86
87 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
88 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
89
90 build: build/build-stamp
91 build-doc: build/build-doc-stamp
92
93 # Note that this is unconditionally done first as part of loading environment.mak
94 # The true is needed to force make to reload environment.mak after running
95 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
96 build/environment.mak: build/configure-stamp
97 @true
98
99 configure: configure.in
100 build/configure-stamp: configure
101 dh_testdir
102 -mkdir build
103 cp COPYING debian/copyright
104 ifneq ($(wildcard /usr/share/misc/config.sub),)
105 cp -a /usr/share/misc/config.sub buildlib/config.sub
106 echo Updating buildlib/config.sub
107 endif
108 ifneq ($(wildcard /usr/share/misc/config.guess),)
109 cp -a /usr/share/misc/config.guess buildlib/config.guess
110 echo Updating buildlib/config.guess
111 endif
112 cd build && ../configure $(confflags)
113 touch $@
114
115 build/build-stamp: build/configure-stamp
116 # Add here commands to compile the package.
117 $(MAKE) binary
118 touch $@
119
120 build/build-doc-stamp: build/configure-stamp
121 # Add here commands to compile the package.
122 $(MAKE) doc
123 touch $@
124
125 clean:
126 dh_testdir
127 # dh_testroot
128 -$(MAKE) clean
129 -$(MAKE) distclean
130
131 rm -rf build
132
133 # Add here commands to clean up after the build process.
134 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
135
136 binary-indep: apt-doc libapt-pkg-doc
137 # Build architecture-independent files here.
138 libapt-pkg-doc: build-doc debian/shlibs.local
139 dh_testdir -p$@
140 dh_testroot -p$@
141 dh_clean -p$@ -k
142 dh_installdirs -p$@
143 #
144 # libapt-pkg-doc install
145 #
146 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
147 $(BLD)/docs/files* $(BLD)/docs/method* \
148 doc/libapt-pkg2_to_3.txt doc/style.txt
149
150 -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
151 -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
152
153 dh_installexamples -p$@
154 # dh_installmenu -p$@
155 # dh_installinit -p$@
156 # dh_installcron -p$@
157 # dh_installmanpages -p$@
158
159 # dh_undocumented -p$@
160 dh_installchangelogs -p$@
161 dh_strip -p$@
162 dh_compress -p$@
163 dh_fixperms -p$@
164 # dh_suidregister -p$@
165 dh_installdeb -p$@
166 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
167 dh_md5sums -p$@
168 dh_builddeb -p$@
169
170 apt-doc: build-doc
171 dh_testdir -p$@
172 dh_testroot -p$@
173 dh_clean -p$@ -k
174 #
175 # apt-doc install
176 #
177 # Copy the guides
178 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
179 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
180
181 # One or the other..
182 -cp -a debian/apt-doc.dhelp debian/apt/usr/doc/apt-doc/.dhelp
183 -cp -a debian/apt-doc.dhelp debian/apt/usr/share/doc/apt-doc/.dhelp
184
185 dh_installchangelogs -p$@
186 dh_compress -p$@
187 dh_fixperms -p$@
188 dh_installdeb -p$@
189 dh_gencontrol -p$@
190 dh_md5sums -p$@
191 dh_builddeb -p$@
192
193
194
195 # Build architecture-dependent files here.
196
197 binary-arch: apt libapt-pkg-dev apt-utils
198 apt: build debian/shlibs.local
199 dh_testdir -p$@
200 dh_testroot -p$@
201 dh_clean -p$@ -k
202 dh_installdirs -p$@ /usr/share
203 #
204 # apt install
205 #
206 cp $(BLD)/bin/apt-* debian/apt/usr/bin/
207
208 # Remove the bits that are in apt-utils
209 rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
210
211 # install the shared libs
212 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
213 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
214
215 cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
216
217 cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
218 cp -r $(BLD)/locale debian/apt/usr/share/
219
220 # Copy the guides
221 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
222 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
223
224 # One or the other..
225 -cp -a debian/dhelp debian/apt/usr/doc/apt/.dhelp
226 -cp -a debian/dhelp debian/apt/usr/share/doc/apt/.dhelp
227
228 # head -n 500 ChangeLog > debian/ChangeLog
229
230 dh_installexamples -p$@ $(BLD)/docs/examples/*
231 dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
232
233 dh_installchangelogs -p$@
234 dh_strip -p$@
235 dh_compress -p$@
236 dh_fixperms -p$@
237 dh_installdeb -p$@
238 dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
239 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
240 dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
241 dh_md5sums -p$@
242 dh_builddeb -p$@
243
244 libapt-pkg-dev: build debian/shlibs.local
245 dh_testdir -p$@
246 dh_testroot -p$@
247 dh_clean -p$@ -k
248 dh_installdirs -p$@
249 #
250 # libapt-pkg-dev install
251 #
252 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
253 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
254 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
255 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
256
257 dh_installdocs -p$@
258 # dh_installmenu -p$@
259 # dh_installinit -p$@
260 # dh_installcron -p$@
261 # dh_installmanpages -p$@
262
263 dh_installchangelogs -p$@
264 dh_strip -p$@
265 dh_compress -p$@
266 dh_fixperms -p$@
267 # dh_suidregister -p$@
268 dh_installdeb -p$@
269 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
270 dh_md5sums -p$@
271 dh_builddeb -p$@
272
273 apt-utils: build debian/shlibs.local
274 dh_testdir -p$@
275 dh_testroot -p$@
276 dh_clean -p$@ -k
277 dh_installdirs -p$@
278
279 # install the shared libs
280 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
281 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
282
283 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
284 dh_installdocs -p$@
285
286 # Install the man pages..
287 mkdir -p debian/$@/usr/share/man/man1
288 -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
289
290 dh_installchangelogs -p$@
291 dh_strip -p$@
292 dh_compress -p$@
293 dh_fixperms -p$@
294 dh_installdeb -p$@
295 LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
296 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
297 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
298 dh_md5sums -p$@
299 dh_builddeb -p$@
300
301 source diff:
302 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
303
304 # Update from CVS
305 l33ch: really-clean
306 cvs update
307 buildlib/mkChangeLog
308
309 # Update from CVS and then configure for build
310 super-l33ch: l33ch Makefile.in
311
312 configure:
313 $(MAKE) configure
314
315 l33ch-stamp: super-l33ch
316 touch $@
317
318 really-clean: clean
319 -find -name Makefile.in -print0 | xargs -0r rm -f
320 find -name ChangeLog | xargs rm -f
321 rm -f l33ch-stamp
322
323 binary: binary-indep binary-arch
324 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
325
326
327 # Done by the uploader.
328 #cvs update..
329 #edit debian/changelog
330 # configure.in has the version automatically updated now.
331 # edit configure.in
332 # debian/rules cvs-build
333
334 cvs-build:
335 rm -rf debian/cvs-build
336 cvs update
337 $(MAKE) startup
338 $(MAKE) doc
339 tar c --exclude CVS --exclude cvs-build . |\
340 (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
341 (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
342
343 cvs-mkul:
344 -mkdir -p ../upload-$(APT_DEBVER)
345 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)