2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
6 # build in verbose mode by default to make it easy to diangose issues
9 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
10 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
11 export DEB_HOST_MULTIARCH ?
= $(shell dpkg-architecture
-qDEB_HOST_MULTIARCH
)
13 # FOR AUTOCONF 2.52 AND NEWER ONLY
14 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
15 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
17 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
21 -include build
/environment.mak
23 ifneq (,$(shell which dpkg-buildflags
))
24 # make does not export to $(shell) so we need to workaround
25 # (http://savannah.gnu.org/bugs/?10593)
26 dpkg_buildflags
= DEB_BUILD_MAINT_OPTIONS
=hardening
=+all dpkg-buildflags
27 export CXXFLAGS
= $(shell $(dpkg_buildflags
) --get CXXFLAGS
)
28 export LDFLAGS
= $(shell $(dpkg_buildflags
) --get LDFLAGS
)
29 export CPPFLAGS
= $(shell $(dpkg_buildflags
) --get CPPFLAGS
)
31 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
32 export CXXFLAGS
= -O0
-g
-Wall
34 export CXXFLAGS
= -O2
-g
-Wall
42 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
44 # Determine the build directory to use
47 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
49 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
51 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
52 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
53 override BLD
:= $(BUILDX
)
55 ifeq ($(words $(BLD
)),0)
56 override BLD
:= .
/build
59 # APT Programs in apt-utils
60 APT_UTILS
=ftparchive sortpkgs extracttemplates
62 # Uncomment this to turn on verbose mode.
65 # Find the libapt-pkg major version for use in other control files
66 include buildlib
/libversion.mak
68 # Determine which library package names to use
69 LIBAPT_PKG
=libapt-pkg
$(LIBAPTPKG_MAJOR
)
70 LIBAPT_INST
=libapt-inst
$(LIBAPTINST_MAJOR
)
72 # do not fail as we are just experimenting with symbol files for now
73 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
75 build-binary
: build
/build-binary-stamp
76 build-docbook
: build
/build-docbook-stamp
77 build-manpages
: build
/build-manpages-stamp
79 # Note that this is unconditionally done first as part of loading environment.mak
80 # The true is needed to force make to reload environment.mak after running
81 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
82 build
/environment.mak
: build
/configure-stamp
85 configure
: configure.ac
86 build
/configure-stamp
: configure buildlib
/config.sub buildlib
/config.guess
89 cp COPYING debian
/copyright
90 cd build
&& CXXFLAGS
="$(CXXFLAGS)" LDFLAGS
="$(LDFLAGS)" CPPFLAGS
="$(CPPFLAGS)" ..
/configure
$(confflags
)
93 build
/build-binary-stamp
: build
/configure-stamp
94 # Add here commands to compile the package.
96 # compat symlink for the locale split
97 mkdir
-p build
/usr
/share
98 cd build
/usr
/share
&& ln
-f
-s ..
/..
/locale .
99 # compile and run tests
100 ifeq (,$(findstring nocheck
, $(DEB_BUILD_OPTIONS
)))
103 @echo
"Tests DISABLED"
107 build
/build-docbook-stamp
: build
/configure-stamp
108 # Add here commands to compile the package.
112 build
/build-manpages-stamp
: build
/configure-stamp
113 # Add here commands to compile the package.
121 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
123 rm -f debian
/$(LIBAPT_PKG
).
install debian
/$(LIBAPT_INST
).
install \
124 debian
/libapt-pkg-dev.
install debian
/apt.
install
125 test ! -L buildlib
/config.guess ||
rm -f buildlib
/config.guess
126 test ! -L buildlib
/config.sub ||
rm -f buildlib
/config.sub
128 debian
/%.
install: debian
/%.
install.in
129 sed
's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
131 # Build architecture-independent files here.
132 libapt-pkg-doc
: build-docbook
138 # libapt-pkg-doc install
140 rm -f
$(BLD
)/doc
/doxygen
/html
/*.map
$(BLD
)/doc
/doxygen
/html
/*.md5
141 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
142 $(BLD
)/docs
/dpkg-tech
* \
144 $(BLD
)/docs
/method
* \
145 doc
/libapt-pkg2_to_3.txt \
147 $(BLD
)/doc
/doxygen
/html
148 dh_installexamples
-p
$@
150 dh_installchangelogs
-p
$@
152 dh_compress
-p
$@
-X.xhtml
159 apt-doc
: build-docbook
167 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
168 $(BLD
)/docs
/guide
*.html \
169 $(BLD
)/docs
/offline
*.text \
170 $(BLD
)/docs
/offline
*.html
171 dh_installchangelogs
-p
$@
181 # Build architecture-dependent files here.
183 apt_MANPAGES
= apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
184 apt
: build-binary build-manpages debian
/apt.
install
192 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
193 cp debian
/apt.auto-removal.sh debian
/$@
/etc
/kernel
/postinst.d
/apt-auto-removal
194 chmod
755 debian
/$@
/etc
/kernel
/postinst.d
/apt-auto-removal
195 # install vendor specific apt confs
196 find
-L vendor
/current
-name
'apt.conf-*' | while read conf
; do cp
"$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
198 # make rosetta happy and remove pot files in po/ (but leave stuff
199 # in po/domains/* untouched) and cp *.po into each domain dir
203 dh_install
-p
$@
--sourcedir
=$(BLD
)
205 # Remove the bits that are in apt-utils
206 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
) dump-solver internal-solver
)
208 # https has its own package
209 rm debian
/$@
/usr
/lib
/apt
/methods
/https
211 # move the mirror failure script in place
212 #mv debian/$@/usr/bin/apt-report-mirror-failure \
213 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
215 # move the apt-helper in place
216 mv debian
/$@
/usr
/bin
/apt-helper debian
/$@
/usr
/lib
/apt
/apt-helper
220 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
221 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/en
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
224 dh_installchangelogs
-p
$@
225 dh_installlogrotate
-p
$@
232 dh_gencontrol
-p
$@
-- -Vapt
:keyring
="$(shell ./vendor/getinfo keyring-package)"
236 libapt-pkg-dev
: build-binary debian
/libapt-pkg-dev.
install
242 # libapt-pkg-dev install
244 dh_install
-p
$@
--sourcedir
=$(BLD
)
246 dh_installchangelogs
-p
$@
251 dh_gencontrol
-p
$@
-- -Vlibapt-pkg-name
=$(LIBAPT_PKG
) -Vlibapt-inst-name
=$(LIBAPT_INST
)
255 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
256 apt-utils
: build-binary build-manpages
262 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
263 cp
$(BLD
)/bin
/apt-dump-solver debian
/$@
/usr
/lib
/apt
/solvers
/dump
264 cp
$(BLD
)/bin
/apt-internal-solver debian
/$@
/usr
/lib
/apt
/solvers
/apt
266 dh_install
-p
$@
--sourcedir
=$(BLD
)
269 dh_installexamples
-p
$@
271 # Install the man pages..
272 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/en
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
274 dh_installchangelogs
-p
$@
285 $(LIBAPT_PKG
): build-binary debian
/$(LIBAPT_PKG
).
install
291 dh_install
-p
$@
--sourcedir
=$(BLD
)
293 dh_installchangelogs
-p
$@
304 $(LIBAPT_INST
): build-binary debian
/$(LIBAPT_INST
).
install
310 dh_install
-p
$@
--sourcedir
=$(BLD
)
312 dh_installchangelogs
-p
$@
323 apt-transport-https
: build-binary libapt-pkg-dev
329 dh_install
-p
$@
--sourcedir
=$(BLD
)
330 dh_installdocs
-p
$@ debian
/apt-transport-https.README
331 dh_installexamples
-p
$@
333 # Install the man pages..
336 dh_installchangelogs
-p
$@
346 buildlib
/config.guess buildlib
/config.sub
:
352 # translate targets to targets required by debian-policy
353 binary-arch
: $(LIBAPT_PKG
) $(LIBAPT_INST
) apt libapt-pkg-dev apt-utils apt-transport-https
354 binary-indep
: apt-doc libapt-pkg-doc
355 binary
: binary-indep binary-arch
356 build-arch
: build-binary
357 build-indep
: build-manpages build-docbook
358 build
: build-indep build-arch
360 .PHONY
: build
clean binary-indep binary-arch binary