]> git.saurik.com Git - apt.git/blob - debian/rules
reenable automatic parallel build of APT
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
9
10 # FOR AUTOCONF 2.52 AND NEWER ONLY
11 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
12 confflags += --build $(DEB_HOST_GNU_TYPE)
13 else
14 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
15 endif
16
17 # See below
18 -include build/environment.mak
19
20 ifneq (,$(shell which dpkg-buildflags))
21 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
22 export LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
23 export CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
24 else
25 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26 export CXXFLAGS = -O0 -g -Wall
27 else
28 export CXXFLAGS = -O2 -g -Wall
29 endif
30 endif
31
32 # Default rule
33 build:
34
35 PKG=apt
36 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # APT Programs in apt-utils
54 APT_UTILS=ftparchive sortpkgs extracttemplates
55
56 # Uncomment this to turn on verbose mode.
57 #export DH_VERBOSE=1
58
59 # Find the libapt-pkg major version for use in other control files
60 include buildlib/libversion.mak
61
62 # Determine which library package names to use
63 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
64 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
65
66 # do not fail as we are just experimenting with symbol files for now
67 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
68
69 build-binary: build/build-binary-stamp
70 build-debiandoc: build/build-debiandoc-stamp
71 build-manpages: build/build-manpages-stamp
72
73 # Note that this is unconditionally done first as part of loading environment.mak
74 # The true is needed to force make to reload environment.mak after running
75 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
76 build/environment.mak: build/configure-stamp
77 @true
78
79 configure: configure.ac
80 build/configure-stamp: configure
81 dh_testdir
82 -mkdir build
83 cp COPYING debian/copyright
84 cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
85 touch $@
86
87 build/build-binary-stamp: build/configure-stamp
88 # Add here commands to compile the package.
89 $(MAKE) binary
90 # compat symlink for the locale split
91 mkdir -p build/usr/share
92 cd build/usr/share && ln -f -s ../../locale .
93 # compile and run tests
94 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
95 $(MAKE) test
96 else
97 @echo "Tests DISABLED"
98 endif
99 touch $@
100
101 build/build-debiandoc-stamp: build/configure-stamp
102 # Add here commands to compile the package.
103 $(MAKE) debiandoc
104 touch $@
105
106 build/build-manpages-stamp: build/configure-stamp
107 # Add here commands to compile the package.
108 $(MAKE) manpages
109 touch $@
110
111 clean:
112 dh_testdir
113 dh_clean
114
115 [ ! -f Makefile ] || $(MAKE) clean distclean
116 rm -rf build
117 rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
118 debian/libapt-pkg-dev.install
119
120 debian/%.install: debian/%.install.in
121 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
122
123 # Build architecture-independent files here.
124 libapt-pkg-doc: build-debiandoc
125 dh_testdir -p$@
126 dh_testroot -p$@
127 dh_prep -p$@
128 dh_installdirs -p$@
129 #
130 # libapt-pkg-doc install
131 #
132 dh_installdocs -p$@ $(BLD)/docs/design* \
133 $(BLD)/docs/dpkg-tech* \
134 $(BLD)/docs/files* \
135 $(BLD)/docs/method* \
136 doc/libapt-pkg2_to_3.txt \
137 doc/style.txt \
138 $(BLD)/doc/doxygen/html
139 dh_installexamples -p$@
140
141 dh_installchangelogs -p$@
142 dh_strip -p$@
143 dh_compress -p$@
144 dh_fixperms -p$@
145 dh_installdeb -p$@
146 dh_gencontrol -p$@
147 dh_md5sums -p$@
148 dh_builddeb -p$@
149
150 apt-doc: build-debiandoc
151 dh_testdir -p$@
152 dh_testroot -p$@
153 dh_prep -p$@
154 #
155 # apt-doc install
156 #
157 # Copy the guides
158 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
159 $(BLD)/docs/guide*.html \
160 $(BLD)/docs/offline*.text \
161 $(BLD)/docs/offline*.html
162 dh_installchangelogs -p$@
163 dh_compress -p$@
164 dh_fixperms -p$@
165 dh_installdeb -p$@
166 dh_gencontrol -p$@
167 dh_md5sums -p$@
168 dh_builddeb -p$@
169
170
171
172 # Build architecture-dependent files here.
173
174 apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
175 apt: build-binary build-manpages
176 dh_testdir -p$@
177 dh_testroot -p$@
178 dh_prep -p$@
179 dh_installdirs -p$@
180 #
181 # apt install
182 #
183 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
184 cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
185 chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
186
187 # make rosetta happy and remove pot files in po/ (but leave stuff
188 # in po/domains/* untouched) and cp *.po into each domain dir
189 rm -f build/po/*.pot
190 rm -f po/*.pot
191
192 dh_install -p$@ --sourcedir=$(BLD)
193
194 # Remove the bits that are in apt-utils
195 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
196
197 # https has its own package
198 rm debian/$@/usr/lib/apt/methods/https
199
200 # move the mirror failure script in place
201 #mv debian/$@/usr/bin/apt-report-mirror-failure \
202 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
203
204 dh_bugfiles -p$@
205 dh_lintian -p$@
206 dh_installexamples -p$@ $(BLD)/docs/examples/*
207 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
208 dh_installcron -p$@
209 dh_installdocs -p$@
210 dh_installchangelogs -p$@
211 dh_installlogrotate -p$@
212 dh_strip -p$@
213 dh_compress -p$@
214 dh_fixperms -p$@
215 dh_installdeb -p$@
216 dh_shlibdeps -p$@
217 dh_gencontrol -p$@
218 dh_md5sums -p$@
219 dh_builddeb -p$@
220
221 libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
222 dh_testdir -p$@
223 dh_testroot -p$@
224 dh_prep -p$@
225 dh_installdirs -p$@
226 #
227 # libapt-pkg-dev install
228 #
229 dh_install -p$@ --sourcedir=$(BLD)
230 dh_installdocs -p$@
231 dh_installchangelogs -p$@
232 dh_strip -p$@
233 dh_compress -p$@
234 dh_fixperms -p$@
235 dh_installdeb -p$@
236 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
237 dh_md5sums -p$@
238 dh_builddeb -p$@
239
240 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
241 apt-utils: build-binary build-manpages
242 dh_testdir -p$@
243 dh_testroot -p$@
244 dh_prep -p$@
245 dh_installdirs -p$@
246
247 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
248 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
249 cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
250
251 dh_install -p$@ --sourcedir=$(BLD)
252 dh_link -p$@
253 dh_installdocs -p$@
254 dh_installexamples -p$@
255
256 # Install the man pages..
257 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
258
259 dh_installchangelogs -p$@
260 dh_strip -p$@
261 dh_compress -p$@
262 dh_fixperms -p$@
263 dh_makeshlibs -p$@
264 dh_installdeb -p$@
265 dh_shlibdeps -p$@
266 dh_gencontrol -p$@
267 dh_md5sums -p$@
268 dh_builddeb -p$@
269
270 $(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
271 dh_testdir -p$@
272 dh_testroot -p$@
273 dh_prep -p$@
274 dh_installdirs -p$@
275
276 dh_install -p$@ --sourcedir=$(BLD)
277 dh_installdocs -p$@
278 dh_installchangelogs -p$@
279 dh_strip -p$@
280 dh_compress -p$@
281 dh_fixperms -p$@
282 dh_makeshlibs -p$@
283 dh_installdeb -p$@
284 dh_shlibdeps -p$@
285 dh_gencontrol -p$@
286 dh_md5sums -p$@
287 dh_builddeb -p$@
288
289 $(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
290 dh_testdir -p$@
291 dh_testroot -p$@
292 dh_prep -p$@
293 dh_installdirs -p$@
294
295 dh_install -p$@ --sourcedir=$(BLD)
296 dh_installdocs -p$@
297 dh_installchangelogs -p$@
298 dh_strip -p$@
299 dh_compress -p$@
300 dh_fixperms -p$@
301 dh_makeshlibs -p$@
302 dh_installdeb -p$@
303 dh_shlibdeps -p$@
304 dh_gencontrol -p$@
305 dh_md5sums -p$@
306 dh_builddeb -p$@
307
308 apt-transport-https: build-binary libapt-pkg-dev
309 dh_testdir -p$@
310 dh_testroot -p$@
311 dh_prep -p$@
312 dh_installdirs -p$@
313
314 dh_install -p$@ --sourcedir=$(BLD)
315 dh_installdocs -p$@ debian/apt-transport-https.README
316 dh_installexamples -p$@
317
318 # Install the man pages..
319 dh_installman -p$@
320
321 dh_installchangelogs -p$@
322 dh_strip -p$@
323 dh_compress -p$@
324 dh_fixperms -p$@
325 dh_installdeb -p$@
326 dh_shlibdeps -p$@
327 dh_gencontrol -p$@
328 dh_md5sums -p$@
329 dh_builddeb -p$@
330
331 configure:
332 $(MAKE) configure
333
334 # translate targets to targets required by debian-policy
335 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
336 binary-indep: apt-doc libapt-pkg-doc
337 binary: binary-indep binary-arch
338 build-arch: build-binary
339 build-indep: build-manpages build-debiandoc
340 build: build-indep build-arch
341
342 .PHONY: build clean binary-indep binary-arch binary