]> git.saurik.com Git - apt.git/blob - debian/changelog
Fix api breakage caused when attempting to support bloc...
[apt.git] / debian / changelog
1 apt (0.5.5.1) unstable; urgency=low
2
3 * Move the target of the example docs from doc to binary. Closes:
4 #192331
5 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
6 backing out change that incorretly attempted to handle Package sections
7 larger than 32k. Closes: #192373
8
9 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 11:53:49 -0500
10
11 apt (0.5.5) unstable; urgency=low
12
13 * New deb version compare function, that has no integer limits, and
14 supports pre-versions using ~. Code ported from dpkg.
15 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
16 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
17 * "apt-get --arch-only build-dep" to install only architecture-
18 dependent build dependencies. Bump minor shared lib number to reflect
19 small change in BuildDepend API.
20 * APT::Build-Essential configuration option (defaults to "build-essential")
21 so that "apt-get build-dep" will ensure build essential packages are
22 installed prior to installing other build-dependencies. Closes: #148879
23 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
24 * /usr/doc reference in postinst. Closes: #126189
25 * Doc updates. Closes: #120689
26 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
27 #131062, #136749
28 * Print special message for EAI_AGAIN. Closes: #131397
29 * libapt-pkg-dev needs to bring in the apt-inst library if linking
30 is to work. Closes: #133943
31 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
32 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
33 #139994, #142955, #151654, #151834, #147611, #154268, #173971
34 * Fix possibility for tag file parsing to fail in some unlikely situations.
35 Closes: #139328
36 * Use std C++ names for some header files. Closes: #128741
37 * Do not check for free space if --no-download. Closes: #117856
38 * Actually implement or group handling for 'upgrade'. Closes: #133950
39 * "Internal Error, Couldn't configure pre-depend" is not actually an
40 internal error, it is a packaging error and now it says so, and
41 pinpoints the problem dependency. Closes: #155621
42 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
43 * Use usr/share/doc for dhelp. Closes: #115701
44 * --print-uris works with 'update'. Closes: #57070
45 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
46 command line.
47 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
48 #142298
49 * Allow an uninstalled package to be marked for removal on an install
50 line (meaning not to automatically install it), also fix some dodgy
51 handling of protected packages. Closes: #92287, #116011
52 * Fix errant prefix matching in version selection. Closes: #105968
53 * Ensure that all files needed to run APT as a user are readable and
54 ignore roots umask for these files. Closes: #108801
55 * Support larger config spaces. Closes: #111914
56 * 'apt-get update' no longer does 'Building Dependency Tree'.
57 * When matching regexs allways print a message. Change regex activation
58 charset. Closes: #147817
59 * Don't die if lines in sources.list are too long. Closes: #146846
60 * Show file name on apt-extracttemplate error messges. Closes: #151835
61 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
62 * Some highly unlikely memory faults. Closes: #155842
63 * C++ stuff for G++3.2. Closes: #162617, #165515,
64 * apt-config dumps sends to stdout not stderr now. Closes: #146294
65 * Fix segfault in FindAny when /i is used, and there is no default.
66 Closes: #165891
67 * Add s390x to archtable. Closese: #160992.
68 * Update config.sub/config.guess in cvs, and add support to debian/rules
69 to update them from /usr/share/misc if they exist. Closes: #155014
70 * Remove 'Sorry' from messages. Closes: #148824.
71 * Change wording of 'additional disk space usage' message. Closes:
72 #135021.
73 * apt-extracttemplates now prepends the package name when extracting
74 files. Closes: #132776
75 * Add -n synonym for --names-only for apt-cache. Closes: #130689
76 * Display both current version and new version in apt-get -s. Closes:
77 #92358
78 * Add an options and timeout config item to ssh/rsh. Closes: #90654
79 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
80 * Change verbose logging output of apt-ftparchive to go to stderr,
81 instead of stdout. Also, errors that occur no longer go to stdout,
82 but stderr. Closes: #161592
83 * Test for timegm in configure. Closes: #165516.
84 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
85 support compliation on platforms where st_mtime is a macro. Closes:
86 #165518
87 * Check the currently mounted cdrom, to see if it's the one we are
88 interested in. Closes: #154602
89 * Refer to reportbug instead of bug in the man pages. Closes: #173745
90 * Link apt-inst to apt-pkg. Closes: #175055
91 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
92 and others.
93 * Fix > 300 col screen segfault. Closes: #176052
94 * Rebuild with gcc-3.2. Closes: #177752, #178008.
95 * Fix build-dep handling of | dependencies.
96 Closes: #98640, #145997, #158896, #172901
97 * Double default value of APT::Cache-Limit, until such time as it
98 can be made more dynamic. Closes: #178623.
99 * Report uris with '.gz' when there are errors. Closes: #178435.
100 * When installing build-deps, make sure the new version will
101 satisfy build requirements. Closes: #178121
102 * Split offline and guide documentation into apt-doc. This was done so
103 that binary-arch builds do not require documention deps. Note, that
104 apt-doc is not installed on upgrades.
105 * Use doc-base, instead of dhelp directly. Closes: #110389
106 * Change http message 'Waiting for file' to 'Waiting for headers'.
107 Closes: #178537
108 * Remove trailing lines on package lists in apt-get. Closes: #178736.
109 * Fix origin pins for file:// uris. Closes: #189014.
110 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
111 #155194
112 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
113 Closes: #153734.
114 * Fix some typos in the apt-get manual. Closes: #163932.
115 * Apply patch from bug, to change frozen to testing, and then do it
116 everywhere else. Closes: #165085.
117 * Update es.po. Closes: #183111.
118 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
119 Closes: #183904.
120 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
121 * Add option to apt-get to show versions of packages being
122 upgraded/installed.
123 * Be quiet in apt.post{inst,rm}. Closes: #70685.
124 * apt-get now prints out suggested and recommended packages. Closes:
125 #54982.
126 * Insert some newlines in the cdrom change media message. Closes:
127 #154601.
128 * Add a rdepends command to apt-cache. Closes: #159864.
129 * When building the dpkg command line, allow for 8192 chars to be used,
130 instead of only 1024.
131 * APT::Immediate-Configure had inverted semantics(false meant it was
132 enabled). Closes: #173619.
133 * Fix status file parser so that if a record is larger than 32k, the
134 buffer size will be doubled, and the read attempted again. Closes:
135 #174945.
136
137 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
138
139 apt (0.5.4) unstable; urgency=low
140
141 * M68k config.guess patch. Closes: #88913
142 * Bi-yearly test on OpenBSD and Solaris
143 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
144 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
145 #105606, #105377
146 * Various cosmetic code updates. Closes: #89066, #89066, #89152
147 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
148 update).
149 * More patches from Alfredo for Vendors and more SHA-1 stuff
150 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
151 similar situations. Closes: #56708, #59432
152 * no_proxy and ftp. Closes: #89671
153 * Philippe Batailler's man page patches.
154 * Fix for display bug. Closes: #92033, #93652, #98468
155 * Use more than 16bits for the dep ID. Some people ran out..
156 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
157 #106911, #107395, #108968
158 * Reordered some things to make dante and FTP happier. Closes: #92757
159 * James R. Van Zandt's guide.sgml updates. Closes: #90027
160 * apt-ftparchive copes with no uncompressed package files + contents.
161 * French man pages from philippe batailler - well sort of. They
162 don't build yet..
163 * run-parts. Closes: #94286
164 * 'apt-cache policy' preferences debug tool.
165 * Whatever. Closes: #89762
166 * libstdc++ and HURD. Closes: #92025
167 * More apt-utils verbage. Closes: #86954
168 * Fliped comparision operator. Closes: #94618
169 * Used the right copyright file. Closes: #65691
170 * Randolph's G++3 patches.
171 * Fixed no_proxy tokanizing. Closes: #100046
172 * Strip Config-Version when copying status to available. Closes: #97520
173 * Segfault with missing source files. Closes: #100325
174 * EINTR check. Closes: #102293
175 * Various changes to the locking metholodgy for --print-uris.
176 Closes: #100590
177 * Lame LD_LIBRARY_PATH thing. Closes: #98928
178 * apt-cache search searchs provide names too now. Closes: #98695
179 * Checksum and long lines problem. Closes: #106591
180 * .aptignr and empty files are just a warning. Closes: #97364
181
182 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
183
184 apt (0.5.3) unstable; urgency=low
185
186 * JoeyH's dpkg::preconfig not working. Closes: #88675
187 * Fixed apt override disparity
188 * Alfredo's SHA-1 and related patches
189
190 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
191
192 apt (0.5.2) unstable; urgency=low
193
194 * Fixed mention of /usr/doc in the long description
195 * JoeyH's downgrade bug -- don't use 0.5.1
196 * Doc bug. Closes: #88538
197 * Fault in building release strings. Closes: #88533
198
199 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
200
201 apt (0.5.1) unstable; urgency=low
202
203 * Fixed #82894 again, or should be and.
204 * Process the option string right. Closes: #86921
205 * Don't eat the last command for pipes. Closes: #86923
206 * Ignore .* for configuration directory processing. Closes: #86923
207 * Alfredo's no_proxy patch
208 * Documentation fixes. Closes: #87091
209 * JoeyH's double slash bug. Closes: #87266
210 * Unintitialized buffer and apt-ftparchive contents generation.
211 Closes: #87612
212 * Build-deps on virtual packages. Closes: #87639
213 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
214 libstdc++ version info in the library soname and in the package
215 provides. Closes: #87426
216 * Updated soname version to 0.3.2
217 * apt-extracttemplates moved from debconf into apt-utils
218 * s390 archtable entry. Closes: #88232
219 * Dan's segfault
220 * Some instances where the status file can source a package in a
221 non-sensical way. Closes: #87390
222 * Work better if there are duplicate sources.list entries.
223 * Fixed the resetting of Dir with "dir {};". Closes: #87323
224
225 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
226
227 apt (0.5.0) unstable; urgency=low
228
229 * Fixed an obscure bug with missing final double new lines in
230 package files
231 * Changed the apt-cdrom index copy routine to use the new section
232 rewriter
233 * Added a package file sorter, apt-sortpkgs
234 * Parse obsolete Optional dependencies.
235 * Added Ben's rsh method. Closes: #57794
236 * Added IPv6 FTP support and better DNS rotation support.
237 * Include the server IP in error messages when using a DNS rotation.
238 Closes: #64895
239 * Made most of the byte counters into doubles to prevent 32bit overflow.
240 Closes: #65349
241 * HTTP Authorization. Closes: #61158
242 * Ability to parse and return source index build depends from Randolph.
243 * new 'apt-get build-dep' command from Randolph. Closes: #63982
244 * Added apt-ftparchive the all dancing all singing FTP archive
245 maintinance program
246 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
247 in apt-get.
248 * Removed useless internal cruft including the xstatus file.
249 * Fixed config parser bugs. Closes: #67848, #71108
250 * Brain Damanged apt-get config options changed, does not change the command
251 line interface, except to allow --enable-* to undo a configuration
252 option:
253 No-Remove -> Remove
254 No-Download -> Download
255 No-Upgrade -> Upgrade
256 * Made this fix configable (DSelect::CheckDir) and default to disabled:
257 * No remove prompt if the archives dir has not changed. Closes: #55709
258 Because it is stupid in the case where no files were downloaded due to
259 a resumed-aborted install, or a full cache! Closes: #65952
260 * Obscure divide by zero problem. Closes: #64394
261 * Update sizetable for mips. Closes: #62288
262 * Fixed a bug with passive FTP connections
263 * Has sizetable entry for sparc64. Closes: #64869
264 * Escape special characters in the ::Label section of the cdroms.lst
265 * Created apt-utils and python-apt packages
266 * Due to the new policy engine, the available file may contain entries
267 from the status file. These are generated if the package is not obsolete
268 but the policy engine prohibits using the version from the package files.
269 They can be identified by the lack of a Filename field.
270 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
271 #36223, #33468, #22551
272 * Fixed deb-src line for non-us. Closes: #71501, #71601
273 * Fixes for G++ 2.96, s/friend/friend class/
274 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
275 * Confirmed fix for missing new line problem. Closes: #69386
276 * Fixed up dhelp files. Closes: #71312
277 * Added some notes about dselect and offline usage. Closes: #66473, #38316
278 * Lock files on read only file systems are ignored w/ warning.
279 Closes: #61701
280 * apt-get update foo now gives an error! Closes: #42891
281 * Added test for shlibs on hurd. Closes: #71499
282 * Clarified apt-cache document. Closes: #71934
283 * DocBook SGML man pages and some improvements in the text..
284 * sigwinch thing. Closes: #72382
285 * Caching can be turned off by setting the cache file names blank.
286 * Ignores arches it does not know about when autocleaning. Closes: #72862
287 * New function in apt-config to return dirs, files, bools and integers.
288 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
289 complex cases involving OR groups and provides.
290 68754 describes confusing messages which are the result of this..
291 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
292 * Speeling mistake and return code for the 'wicked' resolver error
293 Closes: #72621, #75226, #77464
294 * Solved unable to upgrade libc6 from potato to woody due to 3 package
295 libc6 dependency loop problem.
296 * Leading sources.list spaces. Closes: #76010
297 * Removed a possible infinite loop while processing installations.
298 * Man page updates. Closes: #75411, #75560, #64292, #78469
299 * ReduceSourceList bug. Closes: #76027
300 * --only-source option. Closes: #76320
301 * Typos. Closes: #77812, #77999
302 * Different status messages. Closes: #76652, #78353
303 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
304 * OS detection an support for the new pseduo standard of os-arch for the
305 Architecture string. Also uses regexing.. Closes: #39227, #72349
306 * Various i18n stuff. Note that this still needs some i18n wizard
307 to do the last gettextization right. Closes: #62386
308 * Fixed a problem with some odd http servers/proxies that did not return
309 the content size in the header. Closes: #79878, #44379
310 * Little acquire bugs. Closes: #77029, #55820
311 * _POSIX_THREADS may not be defined to anything, just defined..
312 Closes: #78996
313 * Spelling of Ignore-Hold correctly. Closes: #78042
314 * Unlock the dpkg db if in download only mode. Closes: #84851
315 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
316 * Patch from BenC. Closes: #80810
317 * Single output of some names in lists. Closes: #80498, #43286
318 * Nice message for people who can't read syserror output. Closes: #84734
319 * OR search function. Closes: #82894
320 * User's guide updates. Closes: #82469
321 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
322 * Various CD bugs, again thanks to Greenbush
323 Closes: #80946, #76547, #71810, #70049, #69482
324 * Using potato debhelper. Closes: #57977
325 * I cannot self-terminate. Closes: #74928
326
327 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
328
329 apt (0.3.19) frozen unstable; urgency=low
330
331 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
332 Paul Wade.
333 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
334 * Fixed hardcoded path. Closes: #59743
335 * Fixed Jay's relative path bug
336 * Allowed source only CDs. Closes: #58952
337 * Space check is supressed if --print-uris is given. Closes: #58965
338 * Clarified the documenation examples for non-us. Closes: #58646
339 * Typo in the package description. Closes: #60230
340 * Man Page typo. Closes: #60347
341 * Typo in Algorithms.cc. Closes: #63577
342 * Evil dotty function in apt-cache for generating dependency graphs
343 with the as-yet-unpackaged GraphVis.
344 * Appears to have been fixed in Janurary.. Closes: #57981
345 * New config.guess/sub for the new archs. Closes: #60874
346 * Fixed error reporting for certain kinds of resolution failures.
347 Closes: #61327
348 * Made autoclean respect 'q' settings. Closes: #63023
349 * Fixed up the example sources.list. Closes: #63676
350 * Added DPkg::FlushSTDIN to control the flushing of stdin before
351 forking dpkg. Closes: #63991
352
353 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
354
355 apt (0.3.18) frozen unstable; urgency=low
356
357 * Changes in the postinst script. Closes: #56855, #57237
358 * Fixed bashism. Closes: #57216, #57335
359 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
360
361 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
362
363 apt (0.3.17) unstable; urgency=low
364
365 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
366 * Fixed the configuration parser to not blow up if ; is in the config
367 string
368 * Applied visual patch to dselect install script . Closes #55214
369 * Included the configure-index example
370 * Minimal CD swaps
371 * Library soname has increased
372 * Fixed default sources.list to have correct URLs for potato when it
373 becomes stable
374 * Added a message about erasing sources.list to dselect setup script
375 Closes: #55755
376 * No remove prompt if the archives dir has not changed. Closes: #55709
377 * Fixed inclusion of 2nd sample config file. Closes: #55374
378 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
379 Closes: #55991
380
381 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
382
383 apt (0.3.16) unstable; urgency=low
384
385 * Made --no-download work. Closes: #52993
386 * Now compiles on OpenBSD, Solaris and HP-UX
387 * Clarify segfault errors
388 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
389 * Fix for Joel's discovery of glibc removal behavoir.
390 * Fix for Ben Collins file: uri from slink upgrade.
391 * Fixed resume code in FTP. Closes: #54323
392 * Take more precautions to prevent the corruption Joey Hess saw.
393 * Fixed --no-list-cleanup
394 * RFC 2732 URI parsing ([] for hostnames).
395 * Typo in apt-cache man page. Closes: #54949
396
397 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
398
399 apt (0.3.15) unstable; urgency=low
400
401 * Added DSelect::WaitAfterDownload Closes: #49549
402 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
403 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
404 * Made -s and clean not do anything. Closes: #50238
405 * Problem with Protected packages and the new OR code.
406 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
407 * Remove doesn't require a package to be installable. Closes: #51175
408 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
409
410 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
411
412 apt (0.3.14) unstable; urgency=low
413
414 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
415 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
416 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
417 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
418 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
419 Closes: #45034, #45695, #46537
420 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
421 * Added APT::Clean-Installed option. Closes: #45973
422 * Moves the free space check to after the calculated size is printed.
423 Closes: #46639, #47498
424 * mipsel arch Closes: #47614
425 * Beautified URI printing to not include passwords Closes: #46857
426 * Fixed little problem with --no-download Closes: #47557
427 * Tweaked Dselect 'update' script to re-gen the avail file even in the
428 event of a failure Closes: #47112
429 * Retries for source archives too Closes: #47529
430 * Unmounts CDROMs iff it mounted them Closes: #45299
431 * Checks for the partial directories before doing downloads Closes: #47392
432 * no_proxy environment variable (http only!) Closes: #43476
433 * apt-cache showsrc Closes: #45799
434 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
435 * Regexs for install. Closes: #35304, #38835
436 * Dependency reports now show OR group relations
437 * Re-Install feature. Cloes: #46961, #37393, #38919
438 * Locks archive directory on clean (woops)
439 * Remove is not 'sticky'. Closes: #48392
440 * Slightly more accurate 'can not find package' message. Closes: #48311
441 * --trivial-only and --no-remove. Closes: #48518
442 * Increased the cache size. Closes: #47648
443 * Comment woopsie. Closes: #48789
444 * Removes existing links when linking sources. Closes: #48775
445 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
446 * Clearer usage message about 'source' Closes: #48858
447 * Immediate configure internal error Closes: #49062, #48884
448
449 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
450
451 apt (0.3.13) unstable; urgency=low
452
453 * Fix timestamp miss in FTP. Closes: #44363
454 * Fix sorting of Kept packages. Closes: #44377
455 * Fix Segfault for dselect-upgrade. Closes: #44436
456 * Fix handling of '/' for the dist name. Closes #43830
457 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
458 * Add commented-out deb-src URI to default sources.list file.
459
460 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
461
462 apt (0.3.12) unstable; urgency=low
463
464 * Fix for typo in the dhelp index. Closes: #40377
465 * Multiple media swap support
466 * Purge support. Closes: #33291, #40694
467 * Better handling of - remove notation. Closes: #41024
468 * Purge support. Closes: #33291, #40694
469 * Error code on failed update. Closes: #41053
470 * apt-cdrom adds entries for source directories. Closes: #41231
471 * Sorts the output of any list. Closes: #41107
472 * Fixes the looping problem. Closes: #41784, #42414, #44022
473 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
474 * More checks to keep the display sane. Particularly when fail-over is
475 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
476 * PThread lockup problem on certain sparc/m68k. Closes: #40628
477 * apt-cdrom understands .gz Package files too. Closes: #42779
478 * Spelling error in dselect method description. Closes: #43251
479 * Added security to the default source list. Closes: #43356
480
481 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
482
483 apt (0.3.11) unstable; urgency=low
484
485 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
486 * Fix for properly upgrading the system from perl 5.004 to 5.005
487
488 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
489
490 apt (0.3.9) unstable; urgency=low
491
492 * Spelling error in cachefile.cc. Closes: #39885
493 * Trailing slash in dselect install if you try to use the
494 default config file. Closes: #40011
495 * Simulate works for autoclean. Closes: #39141
496 * Fixed spelling errors. Closes: #39673
497 * Changed url parsing a bit. Closes: #40070, #40069
498 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
499
500 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
501
502 apt (0.3.7) unstable; urgency=low
503
504 * Fixed missing text in the apt-get(8) page. Closes: #37596
505 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
506 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
507 * Fixed handling of the -q option with not-entirely integer arguments
508 Closes: #37499
509 * Man page typo Closes: #37762
510 * Fixed parsing of the Source: line. Closes: #37679
511 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
512 * Added a check for an empty cache directory. Closes: #37963
513 * Return a failure code if -d is given and packages fail to download.
514 Closes: #38127
515 * Arranged for an ftp proxy specifing an http server to work. See the
516 important note in the sources.list man page.
517 * Accounted for resumed files in the cps calculation. Closes: #36787
518 * Deal with duplicate same version different packages. Closes: #30237
519 * Added --no-download. Closes: #38095
520 * Order of apt-cdrom dist detection. Closes: #38139
521 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
522 * IPv6 http support
523 * Suggests dpkg-dev for apt-get source. Closes: #38158
524 * Fixed typo in apt-get help. Closes: #38712
525 * Improved the error message in the case of broken held package. Closes: #38777
526 * Fixed handling of MD5 failures
527 * Documented list notation Closes: #39008
528 * Change the 'b' to 'B'. Closes: #39007
529
530 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
531
532 apt (0.3.6) unstable; urgency=low
533
534 * Note that 0.3.5 never made it out the door..
535 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
536 * Made APT print numbers in decimal. Closes: #35617, #37319
537 * Buffer munching fix for FTP. Closes: #35868
538 * Typo in sample config file. Closes: #35907
539 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
540 * Changed installed size counter to only count unpacked packages.
541 Closes: #36201
542 * apt-get source support. Closes: #23934, #27190
543 * Renames .debs that fail MD5 checking, provides automatic corruption
544 recovery. Closes: #35931
545 * Fixed autoconf verison. Closes: #37305
546 * Random Segfaulting. Closes: #37312, #37530
547 * Fixed apt-cache man page. Closes: #36904
548 * Added a newline to apt-cache showpkg. Closes: #36903
549
550 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
551
552 apt (0.3.4) unstable; urgency=low
553
554 * Release for Ben while he is out of town.
555 * Checked the size of partial files. Closes: #33705
556 * apt-get should not print progress on non-tty. Closes: #34944
557 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
558 * Applied cdrom patches from Torsten. Closes: #35140, #35141
559 * smbmounted cdrom fix. Closes: #35470
560 * Changed ie to eg. Closes: #35196
561
562 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
563
564 apt (0.3.3) unstable; urgency=low
565
566 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
567
568 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
569
570 apt (0.3.2) unstable; urgency=low
571
572 * Major release into unstable of v3
573 * These bugs have been fixed, explanations are in the bug system, read
574 the man pages as well..
575 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
576 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
577 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
578 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
579 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
580 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
581 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
582 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
583
584 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
585
586 apt (0.3.1) experimental; urgency=low
587
588 * Minor release of cvs version.
589 * Added virtual package libapt-pkgx.x
590
591 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
592
593 apt (0.3.0) experimental; urgency=low
594
595 * New experimental version.
596
597 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
598
599 apt (0.1.9) frozen unstable; urgency=low
600
601 * Return to the wacky numbering for when we build 0.1.8 for hamm
602 * Important bug related to APT on the Alpha fixed
603 * apt-get dist-upgrade problems fixed
604 * tiny patch for http method to fix an endless loop
605 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
606 libtool and add proper shared lib dependancies
607 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
608 in case an old libpkg is installed while building APT to prevent
609 spurious dependancies
610
611 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
612
613 apt (0.1.7) unstable; urgency=low
614
615 * New build with libstdc++2.9.
616 * Various fixes; read the Changelog.
617
618 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
619
620 apt (0.1.6) unstable; urgency=low
621
622 * Various fixes in the FTP method for error checking. Fixes: #26188.
623 * Spelling corrections in dselect method. Fixes: #25884
624 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
625 * No more bo releases: we're using a normal numbering system now.
626
627 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
628
629 apt (0.1.5) unstable; urgency=low
630
631 * Changed sources.list to point to 'unstable' by default, as
632 'frozen' no longer exists!
633
634 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
635
636 apt (0.1.3) unstable; urgency=low
637
638 * New upstreamish version.
639 * ftp method rewritten in C. Removes dependancies on all perl/perl
640 related modules. This fixes many of the ftp method bugs.
641
642 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
643
644 apt (0.1.1) unstable; urgency=low
645
646 * Release for unstable.
647
648 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
649
650 apt (0.1) unstable; urgency=low
651
652 * Kludge to fix problem in libnet-perl with illegal anonymous
653 FTP passwords.
654 * Moved to unstable; apt is in a useable state now.
655 * Fixed version numbering. From now on, numbering will be:
656 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
657 0.1.1 (release for unstable). Thanks, Manoj.
658
659 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
660
661 apt (0.0.17-1) experimental; urgency=low
662
663 * Fixed problem with libc6 version compare
664 * Scott's away for a while, so I'll be packaging apt for the time
665 being.
666
667 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
668
669 apt (0.0.16-1) experimental; urgency=low
670
671 * Modifications to make apt-get more friendly when backgrounded.
672 * Updated documentation.
673 * Updates to graphic widgets
674
675 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
676
677 apt (0.0.15-0.2bo) experimental; urgency=low
678
679 * Bo compilation
680 * Bob Hilliards crash
681
682 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
683
684 apt (0.0.15-0.1bo) experimental; urgency=low
685
686 * Bo compilation
687 * libstdc++272 patch
688
689 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
690
691 apt (0.0.15) experimental; urgency=low
692
693 * Clean up source tarball (no user-visible changes)
694
695 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
696
697 apt (0.0.14) experimental; urgency=low
698
699 * Updates in ordering code to make sure certain upgrades work correctly.
700 * Made dselect/setup understand ftp as well as http
701
702 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
703
704 apt (0.0.13-bo1) experimental; urgency=low
705
706 * Bo compilation
707
708 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
709
710 apt (0.0.13) experimental; urgency=low
711
712 * Remove hardcoded egcc from debian/rules (#21575)
713 * Fixes for ordering logic when system has a number of unpacked
714 but unconfigured packages installed.
715 * Spelling fix in dselect install method (#22556)
716
717 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
718
719 apt (0.0.12) experimental; urgency=low
720
721 * Fixed problems with package cache corruption.
722 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
723 earlier versions.
724 * Interface and documentation improvements.
725
726 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
727
728 apt (0.0.11) experimental; urgency=low
729
730 * Change dependancies to pre-depends since breaking your packaging tools
731 in the middle of an installation isn't very good.
732 * Bug fixes to ftp method and general apt-get code
733
734 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
735
736 apt (0.0.10) experimental; urgency=low
737
738 * Run "dpkg --configure -a" after an aborted dselect install
739 * Fixed problem with install looping
740 * Support for authenticating proxys: (note this isn't terribly secure)
741 http_proxy="http://user:pass@firewall:port/"
742 * Substitute $ARCH in sources.list
743 * Fixes in the resumption code for ftp
744
745 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
746
747 apt (0.0.9) experimental; urgency=low
748
749 * Added ftp support.
750 * Various other less visible bug fixes.
751 * Fixed problem with segfault when apt-get invoked in a non-existant
752 directory (Bug #21863)
753 * Bumped policy to 2.4.1
754
755 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
756
757 apt (0.0.8) experimental; urgency=low
758
759 * Fixed generated available file (Bug #21836)
760 * Added download ETA (Bug #21774).
761 * Fixed hardcoded ARCH (Bug #21751).
762 * Fixed check on http_proxy (Bug #21795).
763 * Added download speed indicator.
764
765 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
766
767 apt (0.0.7) experimental; urgency=low
768
769 * Remove libdeity and apt from package for now, since only apt-get and
770 apt-cache are actually useful right now.
771 * Clean up handling of package installation errors.
772 * Added timeout to http transfers (#21269)
773 * Updated setup for dselect/apt method.
774 * Updated man pages
775 * Long options (added in 0.0.6)
776
777 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
778
779 apt (0.0.6) experimental; urgency=low
780
781 * Spelling changes.
782 * Revamped download status display.
783 * Call apt-get clean after successful install in dselect.
784 * Added "apt-get clean" which deletes package files from /var/cache/apt
785
786 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
787
788 apt (0.0.5) experimental; urgency=low
789
790 * Ignore signals while dpkg is running so we don't leave dpkg running in
791 the background (#20804)
792 * Check Packages as well as Packages.gz for file URIs (#20784)
793 * Spelling cleanup (#20800)
794 * Added -m option to permit upgrade to go on in the case of a bad mirror.
795 This option may result in incomplete upgrades when used with -f.
796
797 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
798
799 apt (0.0.4) experimental; urgency=low
800
801 * New usage guide.
802 * Various documentation updates and cleanup.
803 * Added '-f' option to apt-get attempt to fix broken dependancies.
804
805 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
806
807 apt (0.0.3) experimental; urgency=low
808
809 * Added a shlibs.local file to prevent apt from depending on itself.
810 * Updates to how apt-get handles bad states in installed packages.
811 * Updated rules to make sure build works from a freshly checked out source
812 archive. Building from CVS needs libtool/automake/autoconf, builds from
813 the distributed source package should have no such dependancy.
814
815 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
816
817 apt (0.0.2) unstable; urgency=low
818
819 * Updates to apt-get and http binding for dselect method (apt).
820 * Updating version number from 0.0.1, which was released only on IRC.
821
822 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
823
824 apt (0.0.1) unstable; urgency=low
825
826 * Initial Release.
827
828 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
829