2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
6 # build in verbose mode by default to make it easy to diangose issues
9 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
10 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
11 export DEB_HOST_MULTIARCH ?
= $(shell dpkg-architecture
-qDEB_HOST_MULTIARCH
)
12 export PARALLEL
= $(or
$(patsubst parallel
=%,%,$(filter parallel
=%,$(DEB_BUILD_OPTIONS
))),1)
14 # FOR AUTOCONF 2.52 AND NEWER ONLY
15 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
16 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
18 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
21 # Set the number of procs to be run in parallel from the options.
22 confflags
+= --with-procs
=$(PARALLEL
)
25 -include build
/environment.mak
27 ifneq (,$(shell which dpkg-buildflags
))
28 # make does not export to $(shell) so we need to workaround
29 # (http://savannah.gnu.org/bugs/?10593)
30 dpkg_buildflags
= DEB_BUILD_MAINT_OPTIONS
=hardening
=+all dpkg-buildflags
31 export CXXFLAGS
= $(shell $(dpkg_buildflags
) --get CXXFLAGS
)
32 export LDFLAGS
= $(shell $(dpkg_buildflags
) --get LDFLAGS
)
33 export CPPFLAGS
= $(shell $(dpkg_buildflags
) --get CPPFLAGS
)
35 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
36 export CXXFLAGS
= -O0
-g
-Wall
38 export CXXFLAGS
= -O2
-g
-Wall
46 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
48 # Determine the build directory to use
51 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
53 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
55 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
56 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
57 override BLD
:= $(BUILDX
)
59 ifeq ($(words $(BLD
)),0)
60 override BLD
:= .
/build
63 # When building without <nocheck>, the header is available and thus the test is
64 # successful. When building with <nocheck>, the header is missing, but we still
65 # pretend it to be available, because configure would fail otherwise.
66 export ac_cv_header_gtest_gtest_h
=yes
68 # APT Programs in apt-utils
69 APT_UTILS
=ftparchive sortpkgs extracttemplates
71 # Uncomment this to turn on verbose mode.
74 # Find the libapt-pkg major version for use in other control files
75 include buildlib
/libversion.mak
77 # Determine which library package names to use
78 LIBAPT_PKG
=libapt-pkg
$(LIBAPTPKG_MAJOR
)
79 LIBAPT_INST
=libapt-inst
$(LIBAPTINST_MAJOR
)
81 # do not fail as we are just experimenting with symbol files for now
82 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
84 build-binary
: build
/build-binary-stamp
85 build-docbook
: build
/build-docbook-stamp
86 build-manpages
: build
/build-manpages-stamp
88 # Note that this is unconditionally done first as part of loading environment.mak
89 # The true is needed to force make to reload environment.mak after running
90 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
91 build
/environment.mak
: build
/configure-stamp
94 configure
: configure.ac
95 build
/configure-stamp
: configure buildlib
/config.sub buildlib
/config.guess
98 cp COPYING debian
/copyright
99 cd build
&& CXXFLAGS
="$(CXXFLAGS)" LDFLAGS
="$(LDFLAGS)" CPPFLAGS
="$(CPPFLAGS)" ..
/configure
$(confflags
)
102 build
/build-binary-stamp
: build
/configure-stamp
103 # Add here commands to compile the package.
105 # compat symlink for the locale split
106 mkdir
-p build
/usr
/share
107 cd build
/usr
/share
&& ln
-f
-s ..
/..
/locale .
108 # compile and run tests
109 ifeq (,$(findstring nocheck
, $(DEB_BUILD_OPTIONS
)))
112 @echo
"Tests DISABLED"
116 build
/build-docbook-stamp
: build
/configure-stamp
117 # Add here commands to compile the package.
121 build
/build-manpages-stamp
: build
/configure-stamp
122 # Add here commands to compile the package.
130 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
132 rm -f debian
/$(LIBAPT_PKG
).
install debian
/$(LIBAPT_INST
).
install \
133 debian
/libapt-pkg-dev.
install debian
/apt.
install
134 test ! -L buildlib
/config.guess ||
rm -f buildlib
/config.guess
135 test ! -L buildlib
/config.sub ||
rm -f buildlib
/config.sub
137 debian
/%.
install: debian
/%.
install.in
138 sed
's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
140 # Build architecture-independent files here.
141 libapt-pkg-doc
: build-docbook
147 # libapt-pkg-doc install
149 rm -f
$(BLD
)/doc
/doxygen
/html
/*.map
$(BLD
)/doc
/doxygen
/html
/*.md5
150 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
151 $(BLD
)/docs
/dpkg-tech
* \
153 $(BLD
)/docs
/method
* \
154 doc
/libapt-pkg2_to_3.txt \
156 $(BLD
)/doc
/doxygen
/html
157 dh_installexamples
-p
$@
159 dh_installchangelogs
-p
$@
161 dh_compress
-p
$@
-X.xhtml
168 apt-doc
: build-docbook
176 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
177 $(BLD
)/docs
/guide
*.html \
178 $(BLD
)/docs
/offline
*.text \
179 $(BLD
)/docs
/offline
*.html
180 dh_installchangelogs
-p
$@
190 # Build architecture-dependent files here.
192 apt_MANPAGES
= apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
193 apt
: build-binary build-manpages debian
/apt.
install
201 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
202 cp debian
/apt.auto-removal.sh debian
/$@
/etc
/kernel
/postinst.d
/apt-auto-removal
203 chmod
755 debian
/$@
/etc
/kernel
/postinst.d
/apt-auto-removal
204 # install vendor specific apt confs
205 find
-L vendor
/current
-name
'apt.conf-*' | while read conf
; do cp
"$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
207 # make rosetta happy and remove pot files in po/ (but leave stuff
208 # in po/domains/* untouched) and cp *.po into each domain dir
212 dh_install
-p
$@
--sourcedir
=$(BLD
)
214 # Remove the bits that are in apt-utils
215 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
) dump-solver internal-solver
)
217 # https has its own package
218 rm debian
/$@
/usr
/lib
/apt
/methods
/https
220 # move the mirror failure script in place
221 #mv debian/$@/usr/bin/apt-report-mirror-failure \
222 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
224 # move the apt-helper in place
225 mv debian
/$@
/usr
/bin
/apt-helper debian
/$@
/usr
/lib
/apt
/apt-helper
229 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
230 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/en
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
233 dh_installchangelogs
-p
$@
234 dh_installlogrotate
-p
$@
241 dh_gencontrol
-p
$@
-- -Vapt
:keyring
="$(shell ./vendor/getinfo keyring-package)"
245 libapt-pkg-dev
: build-binary debian
/libapt-pkg-dev.
install
251 # libapt-pkg-dev install
253 dh_install
-p
$@
--sourcedir
=$(BLD
)
255 dh_installchangelogs
-p
$@
260 dh_gencontrol
-p
$@
-- -Vlibapt-pkg-name
=$(LIBAPT_PKG
) -Vlibapt-inst-name
=$(LIBAPT_INST
)
264 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
265 apt-utils
: build-binary build-manpages
271 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
272 cp
$(BLD
)/bin
/apt-dump-solver debian
/$@
/usr
/lib
/apt
/solvers
/dump
273 cp
$(BLD
)/bin
/apt-internal-solver debian
/$@
/usr
/lib
/apt
/solvers
/apt
275 dh_install
-p
$@
--sourcedir
=$(BLD
)
278 dh_installexamples
-p
$@
280 # Install the man pages..
281 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/en
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
283 dh_installchangelogs
-p
$@
294 $(LIBAPT_PKG
): build-binary debian
/$(LIBAPT_PKG
).
install
300 dh_install
-p
$@
--sourcedir
=$(BLD
)
302 dh_installchangelogs
-p
$@
313 $(LIBAPT_INST
): build-binary debian
/$(LIBAPT_INST
).
install
319 dh_install
-p
$@
--sourcedir
=$(BLD
)
321 dh_installchangelogs
-p
$@
332 apt-transport-https
: build-binary libapt-pkg-dev
338 dh_install
-p
$@
--sourcedir
=$(BLD
)
339 dh_installdocs
-p
$@ debian
/apt-transport-https.README
340 dh_installexamples
-p
$@
342 # Install the man pages..
345 dh_installchangelogs
-p
$@
355 buildlib
/config.guess buildlib
/config.sub
:
361 # translate targets to targets required by debian-policy
362 binary-arch
: $(LIBAPT_PKG
) $(LIBAPT_INST
) apt libapt-pkg-dev apt-utils apt-transport-https
363 binary-indep
: apt-doc libapt-pkg-doc
364 binary
: binary-indep binary-arch
365 build-arch
: build-binary
366 build-indep
: build-manpages build-docbook
367 build
: build-indep build-arch
369 .PHONY
: build
clean binary-indep binary-arch binary