]> git.saurik.com Git - apt.git/blob - debian/rules
enforce LFS for partial files in https range requests
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 # build in verbose mode by default to make it easy to diangose issues
7 export NOISY=1
8
9 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
10 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
11 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
12
13 # FOR AUTOCONF 2.52 AND NEWER ONLY
14 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
15 confflags += --build $(DEB_HOST_GNU_TYPE)
16 else
17 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
18 endif
19
20 # See below
21 -include build/environment.mak
22
23 ifneq (,$(shell which dpkg-buildflags))
24 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
25 export LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
26 export CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
27 else
28 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
29 export CXXFLAGS = -O0 -g -Wall
30 else
31 export CXXFLAGS = -O2 -g -Wall
32 endif
33 endif
34
35 # Default rule
36 build:
37
38 PKG=apt
39 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
40
41 # Determine the build directory to use
42 BASE=.
43 ifdef BUILD
44 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
45 else
46 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
47 endif
48 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
49 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
50 override BLD := $(BUILDX)
51
52 ifeq ($(words $(BLD)),0)
53 override BLD := ./build
54 endif
55
56 # APT Programs in apt-utils
57 APT_UTILS=ftparchive sortpkgs extracttemplates
58
59 # get distro
60 APT_VENDOR_CONF := $(shell lsb_release -i -s)
61
62 # Uncomment this to turn on verbose mode.
63 #export DH_VERBOSE=1
64
65 # Find the libapt-pkg major version for use in other control files
66 include buildlib/libversion.mak
67
68 # Determine which library package names to use
69 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
70 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
71
72 # do not fail as we are just experimenting with symbol files for now
73 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
74
75 build-binary: build/build-binary-stamp
76 build-debiandoc: build/build-debiandoc-stamp
77 build-manpages: build/build-manpages-stamp
78
79 # Note that this is unconditionally done first as part of loading environment.mak
80 # The true is needed to force make to reload environment.mak after running
81 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
82 build/environment.mak: build/configure-stamp
83 @true
84
85 configure: configure.ac
86 build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
87 dh_testdir
88 -mkdir build
89 cp COPYING debian/copyright
90 cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
91 touch $@
92
93 build/build-binary-stamp: build/configure-stamp
94 # Add here commands to compile the package.
95 $(MAKE) binary
96 # compat symlink for the locale split
97 mkdir -p build/usr/share
98 cd build/usr/share && ln -f -s ../../locale .
99 # compile and run tests
100 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
101 $(MAKE) test
102 else
103 @echo "Tests DISABLED"
104 endif
105 touch $@
106
107 build/build-debiandoc-stamp: build/configure-stamp
108 # Add here commands to compile the package.
109 $(MAKE) debiandoc
110 touch $@
111
112 build/build-manpages-stamp: build/configure-stamp
113 # Add here commands to compile the package.
114 $(MAKE) manpages
115 touch $@
116
117 clean:
118 dh_testdir
119 dh_clean
120
121 [ ! -f Makefile ] || $(MAKE) clean distclean
122 rm -rf build
123 rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
124 debian/libapt-pkg-dev.install debian/apt.install
125 test ! -L buildlib/config.guess || rm -f buildlib/config.guess
126 test ! -L buildlib/config.sub || rm -f buildlib/config.sub
127
128 debian/%.install: debian/%.install.in
129 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
130
131 # Build architecture-independent files here.
132 libapt-pkg-doc: build-debiandoc
133 dh_testdir -p$@
134 dh_testroot -p$@
135 dh_prep -p$@
136 dh_installdirs -p$@
137 #
138 # libapt-pkg-doc install
139 #
140 rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
141 dh_installdocs -p$@ $(BLD)/docs/design* \
142 $(BLD)/docs/dpkg-tech* \
143 $(BLD)/docs/files* \
144 $(BLD)/docs/method* \
145 doc/libapt-pkg2_to_3.txt \
146 doc/style.txt \
147 $(BLD)/doc/doxygen/html
148 dh_installexamples -p$@
149
150 dh_installchangelogs -p$@
151 dh_strip -p$@
152 dh_compress -p$@ -X.xhtml
153 dh_fixperms -p$@
154 dh_installdeb -p$@
155 dh_gencontrol -p$@
156 dh_md5sums -p$@
157 dh_builddeb -p$@
158
159 apt-doc: build-debiandoc
160 dh_testdir -p$@
161 dh_testroot -p$@
162 dh_prep -p$@
163 #
164 # apt-doc install
165 #
166 # Copy the guides
167 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
168 $(BLD)/docs/guide*.html \
169 $(BLD)/docs/offline*.text \
170 $(BLD)/docs/offline*.html
171 dh_installchangelogs -p$@
172 dh_compress -p$@
173 dh_fixperms -p$@
174 dh_installdeb -p$@
175 dh_gencontrol -p$@
176 dh_md5sums -p$@
177 dh_builddeb -p$@
178
179
180
181 # Build architecture-dependent files here.
182
183 apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
184 apt: build-binary build-manpages debian/apt.install
185 dh_testdir -p$@
186 dh_testroot -p$@
187 dh_prep -p$@
188 dh_installdirs -p$@
189 #
190 # apt install
191 #
192 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
193 cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
194 chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
195 # install bash completion
196 cp share/bash-completions/* debian/$@/usr/share/bash-completion/completions/
197 # install distro specific apt conf
198 if [ -e debian/apt.conf.${APT_VENDOR_CONF} ]; then \
199 cp debian/apt.conf.${APT_VENDOR_CONF} debian/$@/etc/apt/apt.conf.d/01-vendor-${APT_VENDOR_CONF}; \
200 fi
201
202 # make rosetta happy and remove pot files in po/ (but leave stuff
203 # in po/domains/* untouched) and cp *.po into each domain dir
204 rm -f build/po/*.pot
205 rm -f po/*.pot
206
207 dh_install -p$@ --sourcedir=$(BLD)
208
209 # Remove the bits that are in apt-utils
210 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
211
212 # https has its own package
213 rm debian/$@/usr/lib/apt/methods/https
214
215 # move the mirror failure script in place
216 #mv debian/$@/usr/bin/apt-report-mirror-failure \
217 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
218
219 # move the apt-helper in place
220 mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
221
222 dh_bugfiles -p$@
223 dh_lintian -p$@
224 dh_installexamples -p$@ $(BLD)/docs/examples/*
225 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
226 dh_installcron -p$@
227 dh_installdocs -p$@
228 dh_installchangelogs -p$@
229 dh_installlogrotate -p$@
230 dh_strip -p$@
231 dh_compress -p$@
232 dh_fixperms -p$@
233 dh_makeshlibs -p$@
234 dh_installdeb -p$@
235 dh_shlibdeps -p$@
236 dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
237 dh_md5sums -p$@
238 dh_builddeb -p$@
239
240 libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
241 dh_testdir -p$@
242 dh_testroot -p$@
243 dh_prep -p$@
244 dh_installdirs -p$@
245 #
246 # libapt-pkg-dev install
247 #
248 dh_install -p$@ --sourcedir=$(BLD)
249 dh_installdocs -p$@
250 dh_installchangelogs -p$@
251 dh_strip -p$@
252 dh_compress -p$@
253 dh_fixperms -p$@
254 dh_installdeb -p$@
255 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
256 dh_md5sums -p$@
257 dh_builddeb -p$@
258
259 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
260 apt-utils: build-binary build-manpages
261 dh_testdir -p$@
262 dh_testroot -p$@
263 dh_prep -p$@
264 dh_installdirs -p$@
265
266 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
267 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
268 cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
269
270 dh_install -p$@ --sourcedir=$(BLD)
271 dh_link -p$@
272 dh_installdocs -p$@
273 dh_installexamples -p$@
274
275 # Install the man pages..
276 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
277
278 dh_installchangelogs -p$@
279 dh_strip -p$@
280 dh_compress -p$@
281 dh_fixperms -p$@
282 dh_makeshlibs -p$@
283 dh_installdeb -p$@
284 dh_shlibdeps -p$@
285 dh_gencontrol -p$@
286 dh_md5sums -p$@
287 dh_builddeb -p$@
288
289 $(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
290 dh_testdir -p$@
291 dh_testroot -p$@
292 dh_prep -p$@
293 dh_installdirs -p$@
294
295 dh_install -p$@ --sourcedir=$(BLD)
296 dh_installdocs -p$@
297 dh_installchangelogs -p$@
298 dh_strip -p$@
299 dh_compress -p$@
300 dh_fixperms -p$@
301 dh_makeshlibs -p$@
302 dh_installdeb -p$@
303 dh_shlibdeps -p$@
304 dh_gencontrol -p$@
305 dh_md5sums -p$@
306 dh_builddeb -p$@
307
308 $(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
309 dh_testdir -p$@
310 dh_testroot -p$@
311 dh_prep -p$@
312 dh_installdirs -p$@
313
314 dh_install -p$@ --sourcedir=$(BLD)
315 dh_installdocs -p$@
316 dh_installchangelogs -p$@
317 dh_strip -p$@
318 dh_compress -p$@
319 dh_fixperms -p$@
320 dh_makeshlibs -p$@
321 dh_installdeb -p$@
322 dh_shlibdeps -p$@
323 dh_gencontrol -p$@
324 dh_md5sums -p$@
325 dh_builddeb -p$@
326
327 apt-transport-https: build-binary libapt-pkg-dev
328 dh_testdir -p$@
329 dh_testroot -p$@
330 dh_prep -p$@
331 dh_installdirs -p$@
332
333 dh_install -p$@ --sourcedir=$(BLD)
334 dh_installdocs -p$@ debian/apt-transport-https.README
335 dh_installexamples -p$@
336
337 # Install the man pages..
338 dh_installman -p$@
339
340 dh_installchangelogs -p$@
341 dh_strip -p$@
342 dh_compress -p$@
343 dh_fixperms -p$@
344 dh_installdeb -p$@
345 dh_shlibdeps -p$@
346 dh_gencontrol -p$@
347 dh_md5sums -p$@
348 dh_builddeb -p$@
349
350 buildlib/config.guess buildlib/config.sub:
351 $(MAKE) "$@"
352
353 configure:
354 $(MAKE) configure
355
356 # translate targets to targets required by debian-policy
357 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
358 binary-indep: apt-doc libapt-pkg-doc
359 binary: binary-indep binary-arch
360 build-arch: build-binary
361 build-indep: build-manpages build-debiandoc
362 build: build-indep build-arch
363
364 .PHONY: build clean binary-indep binary-arch binary