1 apt (0.5.6) unstable; urgency=low
3 * Adam Heath <doogie@debian.org>
4 - Fix segfault when handling /etc/apt/preferences. Closes: #192409.
5 * Matt Zimmerman <mdz@debian.org>
6 - Clean up some string handling, patch from Peter Lundkvist
7 <p.lundkvist@telia.com> (Closes: #192225)
8 - Don't fall off the end of the buffer when comparing versions.
9 Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
10 - Minor fixes to apt-ftparchive(1) (Closes: #118156)
11 - Fix typo in apt-ftparchive help text (Closes: #119072)
12 - Update config.guess, config.sub to latest versions
13 - Modify the description for apt-utils to reflect the fact that it is not
14 (any longer) infrequently used (Closes: #138045)
15 - Make setup script for dselect method more explicit about
16 overwriting sources.list (Closes: #151727)
17 - Fix typo in apt-cache(8) (Closes: #161243)
21 apt (0.5.5.1) unstable; urgency=low
23 * Move the target of the example docs from doc to binary. Closes:
25 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
26 backing out change that incorretly attempted to handle Package sections
27 larger than 32k. Closes: #192373
28 * Fix never-ending loop with apt-get install -V. Closes: #192355.
30 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
32 apt (0.5.5) unstable; urgency=low
34 * New deb version compare function, that has no integer limits, and
35 supports pre-versions using ~. Code ported from dpkg.
36 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
37 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
38 * "apt-get --arch-only build-dep" to install only architecture-
39 dependent build dependencies. Bump minor shared lib number to reflect
40 small change in BuildDepend API.
41 * APT::Build-Essential configuration option (defaults to "build-essential")
42 so that "apt-get build-dep" will ensure build essential packages are
43 installed prior to installing other build-dependencies. Closes: #148879
44 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
45 * /usr/doc reference in postinst. Closes: #126189
46 * Doc updates. Closes: #120689
47 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
49 * Print special message for EAI_AGAIN. Closes: #131397
50 * libapt-pkg-dev needs to bring in the apt-inst library if linking
51 is to work. Closes: #133943
52 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
53 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
54 #139994, #142955, #151654, #151834, #147611, #154268, #173971
55 * Fix possibility for tag file parsing to fail in some unlikely situations.
57 * Use std C++ names for some header files. Closes: #128741
58 * Do not check for free space if --no-download. Closes: #117856
59 * Actually implement or group handling for 'upgrade'. Closes: #133950
60 * "Internal Error, Couldn't configure pre-depend" is not actually an
61 internal error, it is a packaging error and now it says so, and
62 pinpoints the problem dependency. Closes: #155621
63 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
64 * Use usr/share/doc for dhelp. Closes: #115701
65 * --print-uris works with 'update'. Closes: #57070
66 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
68 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
70 * Allow an uninstalled package to be marked for removal on an install
71 line (meaning not to automatically install it), also fix some dodgy
72 handling of protected packages. Closes: #92287, #116011
73 * Fix errant prefix matching in version selection. Closes: #105968
74 * Ensure that all files needed to run APT as a user are readable and
75 ignore roots umask for these files. Closes: #108801
76 * Support larger config spaces. Closes: #111914
77 * 'apt-get update' no longer does 'Building Dependency Tree'.
78 * When matching regexs allways print a message. Change regex activation
79 charset. Closes: #147817
80 * Don't die if lines in sources.list are too long. Closes: #146846
81 * Show file name on apt-extracttemplate error messges. Closes: #151835
82 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
83 * Some highly unlikely memory faults. Closes: #155842
84 * C++ stuff for G++3.2. Closes: #162617, #165515,
85 * apt-config dumps sends to stdout not stderr now. Closes: #146294
86 * Fix segfault in FindAny when /i is used, and there is no default.
88 * Add s390x to archtable. Closese: #160992.
89 * Update config.sub/config.guess in cvs, and add support to debian/rules
90 to update them from /usr/share/misc if they exist. Closes: #155014
91 * Remove 'Sorry' from messages. Closes: #148824.
92 * Change wording of 'additional disk space usage' message. Closes:
94 * apt-extracttemplates now prepends the package name when extracting
95 files. Closes: #132776
96 * Add -n synonym for --names-only for apt-cache. Closes: #130689
97 * Display both current version and new version in apt-get -s. Closes:
99 * Add an options and timeout config item to ssh/rsh. Closes: #90654
100 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
101 * Change verbose logging output of apt-ftparchive to go to stderr,
102 instead of stdout. Also, errors that occur no longer go to stdout,
103 but stderr. Closes: #161592
104 * Test for timegm in configure. Closes: #165516.
105 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
106 support compliation on platforms where st_mtime is a macro. Closes:
108 * Check the currently mounted cdrom, to see if it's the one we are
109 interested in. Closes: #154602
110 * Refer to reportbug instead of bug in the man pages. Closes: #173745
111 * Link apt-inst to apt-pkg. Closes: #175055
112 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
114 * Fix > 300 col screen segfault. Closes: #176052
115 * Rebuild with gcc-3.2. Closes: #177752, #178008.
116 * Fix build-dep handling of | dependencies.
117 Closes: #98640, #145997, #158896, #172901
118 * Double default value of APT::Cache-Limit, until such time as it
119 can be made more dynamic. Closes: #178623.
120 * Report uris with '.gz' when there are errors. Closes: #178435.
121 * When installing build-deps, make sure the new version will
122 satisfy build requirements. Closes: #178121
123 * Split offline and guide documentation into apt-doc. This was done so
124 that binary-arch builds do not require documention deps. Note, that
125 apt-doc is not installed on upgrades.
126 * Use doc-base, instead of dhelp directly. Closes: #110389
127 * Change http message 'Waiting for file' to 'Waiting for headers'.
129 * Remove trailing lines on package lists in apt-get. Closes: #178736.
130 * Fix origin pins for file:// uris. Closes: #189014.
131 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
133 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
135 * Fix some typos in the apt-get manual. Closes: #163932.
136 * Apply patch from bug, to change frozen to testing, and then do it
137 everywhere else. Closes: #165085.
138 * Update es.po. Closes: #183111.
139 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
141 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
142 * Add option to apt-get to show versions of packages being
144 * Be quiet in apt.post{inst,rm}. Closes: #70685.
145 * apt-get now prints out suggested and recommended packages. Closes:
147 * Insert some newlines in the cdrom change media message. Closes:
149 * Add a rdepends command to apt-cache. Closes: #159864.
150 * When building the dpkg command line, allow for 8192 chars to be used,
151 instead of only 1024.
152 * APT::Immediate-Configure had inverted semantics(false meant it was
153 enabled). Closes: #173619.
154 * Fix status file parser so that if a record is larger than 32k, the
155 buffer size will be doubled, and the read attempted again. Closes:
158 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
160 apt (0.5.4) unstable; urgency=low
162 * M68k config.guess patch. Closes: #88913
163 * Bi-yearly test on OpenBSD and Solaris
164 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
165 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
167 * Various cosmetic code updates. Closes: #89066, #89066, #89152
168 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
170 * More patches from Alfredo for Vendors and more SHA-1 stuff
171 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
172 similar situations. Closes: #56708, #59432
173 * no_proxy and ftp. Closes: #89671
174 * Philippe Batailler's man page patches.
175 * Fix for display bug. Closes: #92033, #93652, #98468
176 * Use more than 16bits for the dep ID. Some people ran out..
177 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
178 #106911, #107395, #108968
179 * Reordered some things to make dante and FTP happier. Closes: #92757
180 * James R. Van Zandt's guide.sgml updates. Closes: #90027
181 * apt-ftparchive copes with no uncompressed package files + contents.
182 * French man pages from philippe batailler - well sort of. They
184 * run-parts. Closes: #94286
185 * 'apt-cache policy' preferences debug tool.
186 * Whatever. Closes: #89762
187 * libstdc++ and HURD. Closes: #92025
188 * More apt-utils verbage. Closes: #86954
189 * Fliped comparision operator. Closes: #94618
190 * Used the right copyright file. Closes: #65691
191 * Randolph's G++3 patches.
192 * Fixed no_proxy tokanizing. Closes: #100046
193 * Strip Config-Version when copying status to available. Closes: #97520
194 * Segfault with missing source files. Closes: #100325
195 * EINTR check. Closes: #102293
196 * Various changes to the locking metholodgy for --print-uris.
198 * Lame LD_LIBRARY_PATH thing. Closes: #98928
199 * apt-cache search searchs provide names too now. Closes: #98695
200 * Checksum and long lines problem. Closes: #106591
201 * .aptignr and empty files are just a warning. Closes: #97364
203 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
205 apt (0.5.3) unstable; urgency=low
207 * JoeyH's dpkg::preconfig not working. Closes: #88675
208 * Fixed apt override disparity
209 * Alfredo's SHA-1 and related patches
211 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
213 apt (0.5.2) unstable; urgency=low
215 * Fixed mention of /usr/doc in the long description
216 * JoeyH's downgrade bug -- don't use 0.5.1
217 * Doc bug. Closes: #88538
218 * Fault in building release strings. Closes: #88533
220 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
222 apt (0.5.1) unstable; urgency=low
224 * Fixed #82894 again, or should be and.
225 * Process the option string right. Closes: #86921
226 * Don't eat the last command for pipes. Closes: #86923
227 * Ignore .* for configuration directory processing. Closes: #86923
228 * Alfredo's no_proxy patch
229 * Documentation fixes. Closes: #87091
230 * JoeyH's double slash bug. Closes: #87266
231 * Unintitialized buffer and apt-ftparchive contents generation.
233 * Build-deps on virtual packages. Closes: #87639
234 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
235 libstdc++ version info in the library soname and in the package
236 provides. Closes: #87426
237 * Updated soname version to 0.3.2
238 * apt-extracttemplates moved from debconf into apt-utils
239 * s390 archtable entry. Closes: #88232
241 * Some instances where the status file can source a package in a
242 non-sensical way. Closes: #87390
243 * Work better if there are duplicate sources.list entries.
244 * Fixed the resetting of Dir with "dir {};". Closes: #87323
246 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
248 apt (0.5.0) unstable; urgency=low
250 * Fixed an obscure bug with missing final double new lines in
252 * Changed the apt-cdrom index copy routine to use the new section
254 * Added a package file sorter, apt-sortpkgs
255 * Parse obsolete Optional dependencies.
256 * Added Ben's rsh method. Closes: #57794
257 * Added IPv6 FTP support and better DNS rotation support.
258 * Include the server IP in error messages when using a DNS rotation.
260 * Made most of the byte counters into doubles to prevent 32bit overflow.
262 * HTTP Authorization. Closes: #61158
263 * Ability to parse and return source index build depends from Randolph.
264 * new 'apt-get build-dep' command from Randolph. Closes: #63982
265 * Added apt-ftparchive the all dancing all singing FTP archive
267 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
269 * Removed useless internal cruft including the xstatus file.
270 * Fixed config parser bugs. Closes: #67848, #71108
271 * Brain Damanged apt-get config options changed, does not change the command
272 line interface, except to allow --enable-* to undo a configuration
275 No-Download -> Download
276 No-Upgrade -> Upgrade
277 * Made this fix configable (DSelect::CheckDir) and default to disabled:
278 * No remove prompt if the archives dir has not changed. Closes: #55709
279 Because it is stupid in the case where no files were downloaded due to
280 a resumed-aborted install, or a full cache! Closes: #65952
281 * Obscure divide by zero problem. Closes: #64394
282 * Update sizetable for mips. Closes: #62288
283 * Fixed a bug with passive FTP connections
284 * Has sizetable entry for sparc64. Closes: #64869
285 * Escape special characters in the ::Label section of the cdroms.lst
286 * Created apt-utils and python-apt packages
287 * Due to the new policy engine, the available file may contain entries
288 from the status file. These are generated if the package is not obsolete
289 but the policy engine prohibits using the version from the package files.
290 They can be identified by the lack of a Filename field.
291 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
292 #36223, #33468, #22551
293 * Fixed deb-src line for non-us. Closes: #71501, #71601
294 * Fixes for G++ 2.96, s/friend/friend class/
295 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
296 * Confirmed fix for missing new line problem. Closes: #69386
297 * Fixed up dhelp files. Closes: #71312
298 * Added some notes about dselect and offline usage. Closes: #66473, #38316
299 * Lock files on read only file systems are ignored w/ warning.
301 * apt-get update foo now gives an error! Closes: #42891
302 * Added test for shlibs on hurd. Closes: #71499
303 * Clarified apt-cache document. Closes: #71934
304 * DocBook SGML man pages and some improvements in the text..
305 * sigwinch thing. Closes: #72382
306 * Caching can be turned off by setting the cache file names blank.
307 * Ignores arches it does not know about when autocleaning. Closes: #72862
308 * New function in apt-config to return dirs, files, bools and integers.
309 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
310 complex cases involving OR groups and provides.
311 68754 describes confusing messages which are the result of this..
312 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
313 * Speeling mistake and return code for the 'wicked' resolver error
314 Closes: #72621, #75226, #77464
315 * Solved unable to upgrade libc6 from potato to woody due to 3 package
316 libc6 dependency loop problem.
317 * Leading sources.list spaces. Closes: #76010
318 * Removed a possible infinite loop while processing installations.
319 * Man page updates. Closes: #75411, #75560, #64292, #78469
320 * ReduceSourceList bug. Closes: #76027
321 * --only-source option. Closes: #76320
322 * Typos. Closes: #77812, #77999
323 * Different status messages. Closes: #76652, #78353
324 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
325 * OS detection an support for the new pseduo standard of os-arch for the
326 Architecture string. Also uses regexing.. Closes: #39227, #72349
327 * Various i18n stuff. Note that this still needs some i18n wizard
328 to do the last gettextization right. Closes: #62386
329 * Fixed a problem with some odd http servers/proxies that did not return
330 the content size in the header. Closes: #79878, #44379
331 * Little acquire bugs. Closes: #77029, #55820
332 * _POSIX_THREADS may not be defined to anything, just defined..
334 * Spelling of Ignore-Hold correctly. Closes: #78042
335 * Unlock the dpkg db if in download only mode. Closes: #84851
336 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
337 * Patch from BenC. Closes: #80810
338 * Single output of some names in lists. Closes: #80498, #43286
339 * Nice message for people who can't read syserror output. Closes: #84734
340 * OR search function. Closes: #82894
341 * User's guide updates. Closes: #82469
342 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
343 * Various CD bugs, again thanks to Greenbush
344 Closes: #80946, #76547, #71810, #70049, #69482
345 * Using potato debhelper. Closes: #57977
346 * I cannot self-terminate. Closes: #74928
348 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
350 apt (0.3.19) frozen unstable; urgency=low
352 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
354 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
355 * Fixed hardcoded path. Closes: #59743
356 * Fixed Jay's relative path bug
357 * Allowed source only CDs. Closes: #58952
358 * Space check is supressed if --print-uris is given. Closes: #58965
359 * Clarified the documenation examples for non-us. Closes: #58646
360 * Typo in the package description. Closes: #60230
361 * Man Page typo. Closes: #60347
362 * Typo in Algorithms.cc. Closes: #63577
363 * Evil dotty function in apt-cache for generating dependency graphs
364 with the as-yet-unpackaged GraphVis.
365 * Appears to have been fixed in Janurary.. Closes: #57981
366 * New config.guess/sub for the new archs. Closes: #60874
367 * Fixed error reporting for certain kinds of resolution failures.
369 * Made autoclean respect 'q' settings. Closes: #63023
370 * Fixed up the example sources.list. Closes: #63676
371 * Added DPkg::FlushSTDIN to control the flushing of stdin before
372 forking dpkg. Closes: #63991
374 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
376 apt (0.3.18) frozen unstable; urgency=low
378 * Changes in the postinst script. Closes: #56855, #57237
379 * Fixed bashism. Closes: #57216, #57335
380 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
382 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
384 apt (0.3.17) unstable; urgency=low
386 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
387 * Fixed the configuration parser to not blow up if ; is in the config
389 * Applied visual patch to dselect install script . Closes #55214
390 * Included the configure-index example
392 * Library soname has increased
393 * Fixed default sources.list to have correct URLs for potato when it
395 * Added a message about erasing sources.list to dselect setup script
397 * No remove prompt if the archives dir has not changed. Closes: #55709
398 * Fixed inclusion of 2nd sample config file. Closes: #55374
399 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
402 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
404 apt (0.3.16) unstable; urgency=low
406 * Made --no-download work. Closes: #52993
407 * Now compiles on OpenBSD, Solaris and HP-UX
408 * Clarify segfault errors
409 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
410 * Fix for Joel's discovery of glibc removal behavoir.
411 * Fix for Ben Collins file: uri from slink upgrade.
412 * Fixed resume code in FTP. Closes: #54323
413 * Take more precautions to prevent the corruption Joey Hess saw.
414 * Fixed --no-list-cleanup
415 * RFC 2732 URI parsing ([] for hostnames).
416 * Typo in apt-cache man page. Closes: #54949
418 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
420 apt (0.3.15) unstable; urgency=low
422 * Added DSelect::WaitAfterDownload Closes: #49549
423 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
424 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
425 * Made -s and clean not do anything. Closes: #50238
426 * Problem with Protected packages and the new OR code.
427 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
428 * Remove doesn't require a package to be installable. Closes: #51175
429 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
431 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
433 apt (0.3.14) unstable; urgency=low
435 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
436 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
437 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
438 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
439 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
440 Closes: #45034, #45695, #46537
441 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
442 * Added APT::Clean-Installed option. Closes: #45973
443 * Moves the free space check to after the calculated size is printed.
444 Closes: #46639, #47498
445 * mipsel arch Closes: #47614
446 * Beautified URI printing to not include passwords Closes: #46857
447 * Fixed little problem with --no-download Closes: #47557
448 * Tweaked Dselect 'update' script to re-gen the avail file even in the
449 event of a failure Closes: #47112
450 * Retries for source archives too Closes: #47529
451 * Unmounts CDROMs iff it mounted them Closes: #45299
452 * Checks for the partial directories before doing downloads Closes: #47392
453 * no_proxy environment variable (http only!) Closes: #43476
454 * apt-cache showsrc Closes: #45799
455 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
456 * Regexs for install. Closes: #35304, #38835
457 * Dependency reports now show OR group relations
458 * Re-Install feature. Cloes: #46961, #37393, #38919
459 * Locks archive directory on clean (woops)
460 * Remove is not 'sticky'. Closes: #48392
461 * Slightly more accurate 'can not find package' message. Closes: #48311
462 * --trivial-only and --no-remove. Closes: #48518
463 * Increased the cache size. Closes: #47648
464 * Comment woopsie. Closes: #48789
465 * Removes existing links when linking sources. Closes: #48775
466 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
467 * Clearer usage message about 'source' Closes: #48858
468 * Immediate configure internal error Closes: #49062, #48884
470 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
472 apt (0.3.13) unstable; urgency=low
474 * Fix timestamp miss in FTP. Closes: #44363
475 * Fix sorting of Kept packages. Closes: #44377
476 * Fix Segfault for dselect-upgrade. Closes: #44436
477 * Fix handling of '/' for the dist name. Closes #43830
478 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
479 * Add commented-out deb-src URI to default sources.list file.
481 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
483 apt (0.3.12) unstable; urgency=low
485 * Fix for typo in the dhelp index. Closes: #40377
486 * Multiple media swap support
487 * Purge support. Closes: #33291, #40694
488 * Better handling of - remove notation. Closes: #41024
489 * Purge support. Closes: #33291, #40694
490 * Error code on failed update. Closes: #41053
491 * apt-cdrom adds entries for source directories. Closes: #41231
492 * Sorts the output of any list. Closes: #41107
493 * Fixes the looping problem. Closes: #41784, #42414, #44022
494 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
495 * More checks to keep the display sane. Particularly when fail-over is
496 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
497 * PThread lockup problem on certain sparc/m68k. Closes: #40628
498 * apt-cdrom understands .gz Package files too. Closes: #42779
499 * Spelling error in dselect method description. Closes: #43251
500 * Added security to the default source list. Closes: #43356
502 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
504 apt (0.3.11) unstable; urgency=low
506 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
507 * Fix for properly upgrading the system from perl 5.004 to 5.005
509 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
511 apt (0.3.9) unstable; urgency=low
513 * Spelling error in cachefile.cc. Closes: #39885
514 * Trailing slash in dselect install if you try to use the
515 default config file. Closes: #40011
516 * Simulate works for autoclean. Closes: #39141
517 * Fixed spelling errors. Closes: #39673
518 * Changed url parsing a bit. Closes: #40070, #40069
519 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
521 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
523 apt (0.3.7) unstable; urgency=low
525 * Fixed missing text in the apt-get(8) page. Closes: #37596
526 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
527 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
528 * Fixed handling of the -q option with not-entirely integer arguments
530 * Man page typo Closes: #37762
531 * Fixed parsing of the Source: line. Closes: #37679
532 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
533 * Added a check for an empty cache directory. Closes: #37963
534 * Return a failure code if -d is given and packages fail to download.
536 * Arranged for an ftp proxy specifing an http server to work. See the
537 important note in the sources.list man page.
538 * Accounted for resumed files in the cps calculation. Closes: #36787
539 * Deal with duplicate same version different packages. Closes: #30237
540 * Added --no-download. Closes: #38095
541 * Order of apt-cdrom dist detection. Closes: #38139
542 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
544 * Suggests dpkg-dev for apt-get source. Closes: #38158
545 * Fixed typo in apt-get help. Closes: #38712
546 * Improved the error message in the case of broken held package. Closes: #38777
547 * Fixed handling of MD5 failures
548 * Documented list notation Closes: #39008
549 * Change the 'b' to 'B'. Closes: #39007
551 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
553 apt (0.3.6) unstable; urgency=low
555 * Note that 0.3.5 never made it out the door..
556 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
557 * Made APT print numbers in decimal. Closes: #35617, #37319
558 * Buffer munching fix for FTP. Closes: #35868
559 * Typo in sample config file. Closes: #35907
560 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
561 * Changed installed size counter to only count unpacked packages.
563 * apt-get source support. Closes: #23934, #27190
564 * Renames .debs that fail MD5 checking, provides automatic corruption
565 recovery. Closes: #35931
566 * Fixed autoconf verison. Closes: #37305
567 * Random Segfaulting. Closes: #37312, #37530
568 * Fixed apt-cache man page. Closes: #36904
569 * Added a newline to apt-cache showpkg. Closes: #36903
571 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
573 apt (0.3.4) unstable; urgency=low
575 * Release for Ben while he is out of town.
576 * Checked the size of partial files. Closes: #33705
577 * apt-get should not print progress on non-tty. Closes: #34944
578 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
579 * Applied cdrom patches from Torsten. Closes: #35140, #35141
580 * smbmounted cdrom fix. Closes: #35470
581 * Changed ie to eg. Closes: #35196
583 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
585 apt (0.3.3) unstable; urgency=low
587 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
589 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
591 apt (0.3.2) unstable; urgency=low
593 * Major release into unstable of v3
594 * These bugs have been fixed, explanations are in the bug system, read
595 the man pages as well..
596 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
597 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
598 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
599 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
600 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
601 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
602 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
603 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
605 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
607 apt (0.3.1) experimental; urgency=low
609 * Minor release of cvs version.
610 * Added virtual package libapt-pkgx.x
612 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
614 apt (0.3.0) experimental; urgency=low
616 * New experimental version.
618 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
620 apt (0.1.9) frozen unstable; urgency=low
622 * Return to the wacky numbering for when we build 0.1.8 for hamm
623 * Important bug related to APT on the Alpha fixed
624 * apt-get dist-upgrade problems fixed
625 * tiny patch for http method to fix an endless loop
626 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
627 libtool and add proper shared lib dependancies
628 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
629 in case an old libpkg is installed while building APT to prevent
630 spurious dependancies
632 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
634 apt (0.1.7) unstable; urgency=low
636 * New build with libstdc++2.9.
637 * Various fixes; read the Changelog.
639 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
641 apt (0.1.6) unstable; urgency=low
643 * Various fixes in the FTP method for error checking. Fixes: #26188.
644 * Spelling corrections in dselect method. Fixes: #25884
645 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
646 * No more bo releases: we're using a normal numbering system now.
648 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
650 apt (0.1.5) unstable; urgency=low
652 * Changed sources.list to point to 'unstable' by default, as
653 'frozen' no longer exists!
655 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
657 apt (0.1.3) unstable; urgency=low
659 * New upstreamish version.
660 * ftp method rewritten in C. Removes dependancies on all perl/perl
661 related modules. This fixes many of the ftp method bugs.
663 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
665 apt (0.1.1) unstable; urgency=low
667 * Release for unstable.
669 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
671 apt (0.1) unstable; urgency=low
673 * Kludge to fix problem in libnet-perl with illegal anonymous
675 * Moved to unstable; apt is in a useable state now.
676 * Fixed version numbering. From now on, numbering will be:
677 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
678 0.1.1 (release for unstable). Thanks, Manoj.
680 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
682 apt (0.0.17-1) experimental; urgency=low
684 * Fixed problem with libc6 version compare
685 * Scott's away for a while, so I'll be packaging apt for the time
688 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
690 apt (0.0.16-1) experimental; urgency=low
692 * Modifications to make apt-get more friendly when backgrounded.
693 * Updated documentation.
694 * Updates to graphic widgets
696 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
698 apt (0.0.15-0.2bo) experimental; urgency=low
701 * Bob Hilliards crash
703 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
705 apt (0.0.15-0.1bo) experimental; urgency=low
710 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
712 apt (0.0.15) experimental; urgency=low
714 * Clean up source tarball (no user-visible changes)
716 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
718 apt (0.0.14) experimental; urgency=low
720 * Updates in ordering code to make sure certain upgrades work correctly.
721 * Made dselect/setup understand ftp as well as http
723 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
725 apt (0.0.13-bo1) experimental; urgency=low
729 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
731 apt (0.0.13) experimental; urgency=low
733 * Remove hardcoded egcc from debian/rules (#21575)
734 * Fixes for ordering logic when system has a number of unpacked
735 but unconfigured packages installed.
736 * Spelling fix in dselect install method (#22556)
738 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
740 apt (0.0.12) experimental; urgency=low
742 * Fixed problems with package cache corruption.
743 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
745 * Interface and documentation improvements.
747 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
749 apt (0.0.11) experimental; urgency=low
751 * Change dependancies to pre-depends since breaking your packaging tools
752 in the middle of an installation isn't very good.
753 * Bug fixes to ftp method and general apt-get code
755 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
757 apt (0.0.10) experimental; urgency=low
759 * Run "dpkg --configure -a" after an aborted dselect install
760 * Fixed problem with install looping
761 * Support for authenticating proxys: (note this isn't terribly secure)
762 http_proxy="http://user:pass@firewall:port/"
763 * Substitute $ARCH in sources.list
764 * Fixes in the resumption code for ftp
766 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
768 apt (0.0.9) experimental; urgency=low
771 * Various other less visible bug fixes.
772 * Fixed problem with segfault when apt-get invoked in a non-existant
773 directory (Bug #21863)
774 * Bumped policy to 2.4.1
776 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
778 apt (0.0.8) experimental; urgency=low
780 * Fixed generated available file (Bug #21836)
781 * Added download ETA (Bug #21774).
782 * Fixed hardcoded ARCH (Bug #21751).
783 * Fixed check on http_proxy (Bug #21795).
784 * Added download speed indicator.
786 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
788 apt (0.0.7) experimental; urgency=low
790 * Remove libdeity and apt from package for now, since only apt-get and
791 apt-cache are actually useful right now.
792 * Clean up handling of package installation errors.
793 * Added timeout to http transfers (#21269)
794 * Updated setup for dselect/apt method.
796 * Long options (added in 0.0.6)
798 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
800 apt (0.0.6) experimental; urgency=low
803 * Revamped download status display.
804 * Call apt-get clean after successful install in dselect.
805 * Added "apt-get clean" which deletes package files from /var/cache/apt
807 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
809 apt (0.0.5) experimental; urgency=low
811 * Ignore signals while dpkg is running so we don't leave dpkg running in
812 the background (#20804)
813 * Check Packages as well as Packages.gz for file URIs (#20784)
814 * Spelling cleanup (#20800)
815 * Added -m option to permit upgrade to go on in the case of a bad mirror.
816 This option may result in incomplete upgrades when used with -f.
818 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
820 apt (0.0.4) experimental; urgency=low
823 * Various documentation updates and cleanup.
824 * Added '-f' option to apt-get attempt to fix broken dependancies.
826 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
828 apt (0.0.3) experimental; urgency=low
830 * Added a shlibs.local file to prevent apt from depending on itself.
831 * Updates to how apt-get handles bad states in installed packages.
832 * Updated rules to make sure build works from a freshly checked out source
833 archive. Building from CVS needs libtool/automake/autoconf, builds from
834 the distributed source package should have no such dependancy.
836 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
838 apt (0.0.2) unstable; urgency=low
840 * Updates to apt-get and http binding for dselect method (apt).
841 * Updating version number from 0.0.1, which was released only on IRC.
843 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
845 apt (0.0.1) unstable; urgency=low
849 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500