%if %{unicode}
--enable-unicode \
%else
- --with-odbc \
+ --disable-unicode \
%endif
- --with-opengl
$MAKE
cd contrib/src
%if %{unicode}
--enable-unicode \
%else
- --with-odbc \
+ --disable-unicode \
%endif
--with-opengl
$MAKE
wx/archive.h
wx/arrimpl.cpp
wx/arrstr.h
+wx/atomic.h
+wx/base64.h
wx/beforestd.h
wx/buffer.h
wx/build.h
wx/chartype.h
wx/chkconf.h
wx/clntdata.h
+wx/cmdargs.h
wx/cmdline.h
wx/confbase.h
wx/config.h
wx/convauto.h
wx/containr.h
wx/cpp.h
+wx/crt.h
wx/datetime.h
wx/datstrm.h
wx/dde.h
wx/ioswrap.h
wx/ipc.h
wx/ipcbase.h
-wx/isql.h
-wx/isqlext.h
wx/link.h
wx/list.h
wx/listimpl.cpp
wx/wx.h
wx/wxchar.h
wx/wxcrt.h
+wx/wxcrtbase.h
wx/wxcrtvararg.h
wx/wxprec.h
wx/xti.h
wx/xtistrm.h
wx/zipstrm.h
wx/zstream.h
+wx/private/fdiodispatcher.h
+wx/private/selectdispatcher.h
wx/unix/app.h
wx/unix/apptbase.h
wx/unix/apptrait.h
+wx/unix/chkconf.h
wx/unix/execute.h
wx/unix/evtloop.h
wx/unix/mimetype.h
wx/unix/gsockunx.h
wx/xml/xml.h
wx/xtixml.h
-wx/db.h
-wx/dbkeyg.h
-wx/dbtable.h
EOF
# --- wxBase headers list ends here ---
for f in `cat wxbase-headers-list` ; do
%doc COPYING.LIB *.txt
%{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
%{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
-%if !%{unicode}
- %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
-%endif
%{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
%{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
%{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
%defattr(-,root,root)
%{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
%{_libdir}/libwx_%{portname}*_core-%{ver2}.so
-%if !%{unicode}
- %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
-%endif
%{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
%{_libdir}/libwx_%{portname}*_html-%{ver2}.so
%{_libdir}/libwx_%{portname}*_media-%{ver2}.so