--enable-sound \
--with-sdl \
--enable-display \
+ --enable-geometry \
+ --enable-graphics_ctx \
--with-libjpeg=sys \
--with-libpng=sys \
--with-libtiff=sys \
package_gtk_py_lib := python-wxgtk$(release)$(unicode_suffix)
package_gtk_py_ver = python-wxversion
package_gtk_py_tools = python-wxtools
+package_gtk_py_addons = python-wxaddons
package_headers := wx$(release)-headers
package_i18n := wx$(release)-i18n
# The packages listed here are common to all wx versions, and may be provided
# by another source package if more than one is in the release simultaneously.
-common_packages := $(package_common) $(package_gtk_py_ver) $(package_gtk_py_tools)
+common_packages := $(package_common) $(package_gtk_py_ver) $(package_gtk_py_tools) $(package_gtk_py_addons)
package_gtk_dbg_py := python-wxgtk$(release)$(unicode_suffix)-dbg
rm debian/$(package_gtk_py_lib)/$(pydir)/wxversion.py
endif
+
+
install-gtk-py-tools: DH_OPTIONS=-p$(package_gtk_py_tools)
install-gtk-py-tools: install-gtk-py-ver
dh_testdir
rm -r debian/$(package_gtk_py_lib)/usr/bin
-install-gtk-py: install-gtk-py-tools
+install-gtk-py-addons: DH_OPTIONS=-p$(package_gtk_py_addons)
+install-gtk-py-addons: install-gtk-py-tools
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ifndef DEBIAN_WX_DEFAULT_VERSION
+
+ dh_movefiles --sourcedir=debian/$(package_gtk_py_lib) $(pydir)/wxaddons
+else
+ rm -r debian/$(package_gtk_py_lib)/$(pydir)/wxaddons
+endif
+
+
+install-gtk-py: install-gtk-py-addons
install-common: DH_OPTIONS=-p$(package_common)
fi
dh_installdeb
- dh_shlibdeps -ldebian/$(package_gtk_lib)/usr/lib:debian/$(package_gtk_dbg)/usr/lib
+ dh_shlibdeps -ldebian/$(package_wxbase_lib)/usr/lib:debian/$(package_wxbase_dbg)/usr/lib:debian/$(package_gtk_lib)/usr/lib:debian/$(package_gtk_dbg)/usr/lib
dh_gencontrol
dh_md5sums
dh_builddeb