]> git.saurik.com Git - wxWidgets.git/blobdiff - debian/rules
non-PCH build fix (according to Tinderbox).
[wxWidgets.git] / debian / rules
index ec2c69e35235d04f86051437348cd5df9ff1f883..200fbb98769b2e4b01b2c6e48a117f0aaeac614e 100755 (executable)
@@ -67,12 +67,23 @@ release   := $(shell dpkg-parsechangelog | sed -n 's/^Source: wxwidgets//p' | se
 soversion := 0
 sorelease := $(release:%-$(DEBIAN_WXFLAVOUR)=%)-$(soversion)$(addprefix -,$(DEBIAN_WXFLAVOUR))
 
+# In some places we use the full version number, including the micro version,
+# for the development releases (which can be incompatible for the same major
+# and minor version) but just the major.minor for the stable releases (which
+# are supposed to be compatible), this variable contains the appropriate value
+ifeq ($(shell echo `echo $(release) | sed 's/.\+\.\(.\+\)/\1/'`%2 | bc),1)
+    # development release
+    compatible_release := $(release).$(soversion)
+else
+    compatible_release := $(release)
+endif
+
 # Base value for alternative priorities.
 alt_prio  := $(subst .,,$(release))
 
 pytoolkit := gtk2
 pydir     := usr/lib/$(python_ver)/site-packages
-wxpydir   := $(pydir)/wx-$(release)-$(pytoolkit)
+wxpydir   := $(pydir)/wx-$(compatible_release)-$(pytoolkit)
 
 cross_host  := i586-mingw32msvc
 cross_build := $(shell ./config.guess)
@@ -86,7 +97,6 @@ COMMON_CONFIGURE_OPTIONS = \
     --prefix=/usr \
     --cache-file=$(config_cache) \
     --with-flavour=$(DEBIAN_WXFLAVOUR) \
-    --enable-debug \
     --with-zlib=sys \
     --disable-reserved_virtual \
 
@@ -100,6 +110,8 @@ GTK_CONFIGURE_OPTIONS = $(COMMON_CONFIGURE_OPTIONS) \
     --enable-sound \
     --with-sdl \
     --enable-display \
+    --enable-geometry \
+    --enable-graphics_ctx \
     --with-libjpeg=sys \
     --with-libpng=sys \
     --with-libtiff=sys \
@@ -114,7 +126,7 @@ ifeq ($(WX_UNICODE),1)
     COMMON_CONFIGURE_OPTIONS += --enable-unicode
     PY_WX_CONFIG_OPTIONS += --unicode
     PY_UNICODE="UNICODE=1"
-    wxpydir := $(pydir)/wx-$(release)-$(pytoolkit)-unicode
+    wxpydir := $(pydir)/wx-$(compatible_release)-$(pytoolkit)-unicode
 
     # for compatibility with the existing 2.6 packages, we don't use "u" in
     # the Unicode (default) package names
@@ -143,9 +155,10 @@ package_gtk_dbg         := libwxgtk$(release)$(unicode_suffix)-dbg
 
 
 
-package_gtk_py_lib      := python-wxgtk$(release)
+package_gtk_py_lib      := python-wxgtk$(release)$(unicode_suffix)
 package_gtk_py_ver       = python-wxversion
 package_gtk_py_tools     = python-wxtools
+package_gtk_py_addons    = python-wxaddons
 
 package_headers         := wx$(release)-headers
 package_i18n            := wx$(release)-i18n
@@ -155,15 +168,15 @@ package_common           = wx-common
 
 # The packages listed here are common to all wx versions, and may be provided
 # by another source package if more than one is in the release simultaneously.
-common_packages        := $(package_common) $(package_gtk_py_ver) $(package_gtk_py_tools)
+common_packages        := $(package_common) $(package_gtk_py_ver) $(package_gtk_py_tools) $(package_gtk_py_addons)
 
 
-package_gtk_dbg_py      := python-wxgtk$(release)-dbg
+package_gtk_dbg_py      := python-wxgtk$(release)$(unicode_suffix)-dbg
 
 
 
-package_msw_dev         := libwxmsw$(release)-dev
-package_msw_dbg         := libwxmsw$(release)-dbg
+package_msw_dev         := libwxmsw$(release)$(unicode_suffix)-dev
+package_msw_dbg         := libwxmsw$(release)$(unicode_suffix)-dbg
 package_headers_msw     := wx$(release)-headers-msw
 
 # The packages listed here will not be built by default.
@@ -720,6 +733,8 @@ else
        rm debian/$(package_gtk_py_lib)/$(pydir)/wxversion.py
 endif
 
+
+
 install-gtk-py-tools: DH_OPTIONS=-p$(package_gtk_py_tools)
 install-gtk-py-tools: install-gtk-py-ver
        dh_testdir
@@ -758,7 +773,20 @@ endif
 
        rm -r debian/$(package_gtk_py_lib)/usr/bin
 
-install-gtk-py: install-gtk-py-tools
+install-gtk-py-addons: DH_OPTIONS=-p$(package_gtk_py_addons)
+install-gtk-py-addons: install-gtk-py-tools
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+ifndef DEBIAN_WX_DEFAULT_VERSION
+
+       dh_movefiles --sourcedir=debian/$(package_gtk_py_lib) $(pydir)/wxaddons
+else
+       rm -r debian/$(package_gtk_py_lib)/$(pydir)/wxaddons
+endif
+
+
+install-gtk-py: install-gtk-py-addons
 
 
 install-common: DH_OPTIONS=-p$(package_common)
@@ -767,10 +795,13 @@ install-common: install-gtk-shared-stamp
        dh_testroot
        dh_clean -k
 
-       dh_install $(objdir_gtk_install)/share/aclocal  usr/share
+       dh_install $(objdir_gtk_install)/share/bakefile/presets usr/share/bakefile
+       dh_install $(objdir_gtk_install)/share/bakefile/presets/wx*.bkl usr/share/bakefile/presets
+
+       dh_install $(objdir_gtk_install)/share/aclocal usr/share
        dh_installman debian/wx-config.1
 
-       dh_install $(objdir_gtk_shared)/utils/wxrc/wxrc usr/bin
+       dh_install $(objdir_gtk_shared)/utils/wxrc/wxrc usr/bin
        dh_installman debian/wxrc-tools.1
        dh_link usr/share/man/man1/wxrc-tools.1 usr/share/man/man1/wxrc.1
 
@@ -930,7 +961,7 @@ binary-common:
        fi
 
        dh_installdeb
-       dh_shlibdeps -ldebian/$(package_gtk_lib)/usr/lib:debian/$(package_gtk_dbg)/usr/lib
+       dh_shlibdeps -ldebian/$(package_wxbase_lib)/usr/lib:debian/$(package_wxbase_dbg)/usr/lib:debian/$(package_gtk_lib)/usr/lib:debian/$(package_gtk_dbg)/usr/lib
        dh_gencontrol
        dh_md5sums
        dh_builddeb
@@ -978,17 +1009,21 @@ binary-dbg-py: control-files-stamp install-gtk-dbg-py
 # Debian policy.  Do not distribute packages built with these rules, they
 # are currently useful for rapid in-house testing by developers only.
 
+DH_OPTIONS_GTK := -p$(package_wxbase_lib) -p$(package_gtk_lib) -p$(package_headers)
+
 # libwxgtk shared lib package
-binary-gtk: control-files-stamp install-gtk-lib install-headers
-       $(MAKE) -f debian/rules DH_OPTIONS="-p$(package_gtk_lib) -p$(package_headers)" binary-common
+binary-gtk: control-files-stamp install-gtk-lib install-wxbase-lib install-headers
+       $(MAKE) -f debian/rules DH_OPTIONS="$(DH_OPTIONS_GTK)" binary-common
 
-binary-gtk-dev: control-files-stamp install-gtk-dev install-headers
+binary-gtk-dev: control-files-stamp install-gtk-dev install-wxbase-dev install-headers
        $(MAKE) -f debian/rules \
-         DH_OPTIONS="-p$(package_gtk_lib) -p$(package_gtk_dev) -p$(package_headers)" \
-         binary-common
+           DH_OPTIONS="-p$(package_wxbase_dev) -p$(package_gtk_dev) $(DH_OPTIONS_GTK)" \
+           binary-common
 
-binary-gtk-dbg: control-files-stamp install-gtk-dbg install-headers
-       $(MAKE) -f debian/rules DH_OPTIONS="-p$(package_gtk_dbg) -p$(package_headers)" binary-common
+binary-gtk-dbg: control-files-stamp install-gtk-dbg install-wxbase-dbg install-headers
+       $(MAKE) -f debian/rules \
+           DH_OPTIONS="-p$(package_wxbase_dbg) -p$(package_gtk_dbg) -p$(package_headers)" \
+           binary-common
 
 
 # docs package