update spec files version
[wxWidgets.git] / wxBase.spec
1 %define pref /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild command line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %if %{unicode}
12 %define name wx-base-unicode
13 %define wxconfig base-unicode-release-%{ver2}
14 %define wxconfiglink wxbaseu-%{ver2}-config
15 %else
16 %define name wx-base
17 %define wxconfig base-ansi-release-%{ver2}
18 %define wxconfiglink wxbase-%{ver2}-config
19 %endif
20
21 Summary: wxBase library - non-GUI support classes of wxWidgets toolkit
22 Name: %{name}
23 Version: %{ver}
24 Release: %{rel}
25 License: wxWindows Licence
26 Group: Development/Libraries
27 Source: wxBase-%{ver}.tar.bz2
28 URL: http://www.wxwidgets.org
29 Packager: Vadim Zeitlin <vadim@wxwindows.org>
30 Prefix: %{pref}
31 BuildRoot: %{_tmppath}/%{name}-root
32 Provides: wxBase
33
34 %description
35 wxBase is a collection of C++ classes providing basic data structures (strings,
36 lists, arrays), powerful wxDateTime class for date manipulations, portable
37 wrappers around many OS-specific functions allowing to build the same program
38 under all supported folders, wxThread class for writing multithreaded programs
39 using either Win32 or POSIX threads and much more. wxBase currently supports
40 the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
41 ...) and BeOS.
42
43 %package devel
44 Summary: wxBase headers needed for developping with wxBase
45 Group: Development/Libraries
46 Requires: %{name} = %{ver}
47 Provides: wxBase-devel
48
49 %description devel
50 Header files for wxBase. You need them to develop programs using wxBase.
51
52 %package static
53 Summary: wxBase static libraries
54 Group: Development/Libraries
55 Requires: %{name}-devel = %{ver}
56
57 %description static
58 Static libraries for wxBase. You need them if you want to link statically against wxBase.
59
60 %prep
61 %setup -q -n wxBase-%{ver}
62
63 %build
64 if [ "$SMP" != "" ]; then
65 export MAKE="make -j$SMP"
66 else
67 export MAKE="make"
68 fi
69
70 mkdir obj-shared
71 cd obj-shared
72 ../configure --prefix=%{pref} --disable-gui \
73 %if %{unicode}
74 --enable-unicode
75 %else
76 --with-odbc
77 %endif
78 $MAKE
79 cd ..
80
81 mkdir obj-static
82 cd obj-static
83 ../configure --prefix=%{pref} --disable-gui --disable-shared \
84 %if %{unicode}
85 --enable-unicode
86 %else
87 --with-odbc
88 %endif
89 $MAKE
90 cd ..
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 (cd obj-static ; make prefix=$RPM_BUILD_ROOT%{pref} install)
95 (cd obj-shared ; make prefix=$RPM_BUILD_ROOT%{pref} install)
96
97 %find_lang wxstd
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 /sbin/ldconfig
104
105 %postun
106 /sbin/ldconfig
107
108 %post devel
109 # link wx-config when you install RPM.
110 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
111 # link wx-config with explicit name.
112 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
113 /sbin/ldconfig
114
115 %postun devel
116 /sbin/ldconfig
117
118 %preun devel
119 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
120 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
121 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
122 if test "x$SUM1" = "x$SUM2" ; then
123 rm -f %{_bindir}/wx-config
124 fi
125 fi
126 rm -f %{_bindir}/%{wxconfiglink}
127
128 %files -f wxstd.lang
129 %defattr (-,root,root)
130 %doc COPYING.LIB *.txt
131 %{_libdir}/libwx_base*-%{ver2}.so.*
132
133 %files devel
134 %defattr (-,root,root)
135 %dir %{_includedir}/wx-%{ver2}
136 %{_includedir}/wx-%{ver2}/*
137 %{_libdir}/libwx_base*-%{ver2}.so
138 %dir %{_libdir}/wx
139 %{_libdir}/wx/*
140 %{_datadir}/aclocal/*.m4
141
142 %files static
143 %defattr (-,root,root)
144 %{_libdir}/lib*.a