1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
4 # Note that this is NOT a relocatable package
10 Summary: The Motif
/Lesstif port of the wxWindows library
14 Copyright: wxWindows Licence
16 Source: wxMOTIF
-%{ver}.tar.bz2
17 URL: http
://www.wxwindows.org
18 Packager: Robert Fendt
<rfendt@myokay.net
>
19 BuildRoot: /tmp
/wxmotif_root
21 # all packages providing an implementation of wxWindows library (regardless of
22 # the toolkit used) should provide the (virtual) wxwin package, this makes it
23 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
27 wxWindows is a free C
++ library
for cross
-platform GUI development.
28 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
29 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
32 Summary: The Motif
/Lesstif port of the wxWindows library
34 Requires: wxMotif
= %{ver}
37 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
40 Summary: The Motif
/Lesstif port of the wxWindows library
, OpenGL add
-on.
42 Requires: wxMotif
= %{ver}
45 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
48 Summary: wxMotif static libraries
49 Group: Development
/Libraries
52 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
56 %setup -n wxMOTIF
-%{ver}
59 if [ "$SMP"
!= ""
]; then
60 export MAKE
="
make -j$SMP"
65 (cd locale
; make allmo
)
69 ..
/configure
--prefix
=%{pref} --enable-soname
--with
-odbc
--with
-opengl
--with
-motif
75 ..
/configure
--prefix
=%{pref} --disable
-shared
--with
-odbc
--with
-opengl
--with
-motif
80 rm -rf $RPM_BUILD_ROOT
81 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
82 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
87 rm -rf $RPM_BUILD_ROOT
102 # Install wx-config if there isn't any
103 if test ! -f
%{_bindir}/wx
-config
; then
104 ln
-sf wxmotif
-%{ver2}-config %{_bindir}/wx
-config
108 # Remove wx-config if it points to this package
109 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
110 SUM1
=`md5sum
%{_bindir}/wxmotif-%{ver2}-config | cut
-c
0-32`
111 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
112 if test "x$SUM1"
= "x$SUM2"
; then
113 rm -f
%{_bindir}/wx
-config
119 %defattr (-,root
,root
)
120 %doc COPYING.LIB
*.txt
123 %{_libdir}/libwx_motif-%{ver2}*.so.
*
126 %defattr (-,root
,root
)
127 %{_libdir}/libwx_motif-%{ver2}*.so
128 %dir %{_includedir}/wx
132 %{_bindir}/wxmotif-%{ver2}-config
133 %{_datadir}/aclocal
/*.m4
136 %defattr(-,root
,root
)
137 %{_libdir}/libwx_motif_gl
*
140 %defattr (-,root
,root
)