6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
13 %define name wx
-%{portname}-unicode
14 %define wxbasename wx
-base
-unicode
16 %define name wx
-%{portname}
17 %define wxbasename wx
-base
21 %define wxconfigname wx
%{portname}univu-%{ver2}-config
23 %define wxconfigname wx
%{portname}univ-%{ver2}-config
26 Summary: The X11 port of the wxWindows library
30 License: wxWindows Licence
32 Source: wxX11
-%{ver}.tar.bz2
33 URL: http
://www.wxwindows.org
34 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
36 BuildRoot: /var
/tmp
/%{name}-root
38 # all packages providing an implementation of wxWindows library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
43 # in addition, we should provide libwx_gtk as automatic generator only notices
44 # libwx_gtk-%{ver}-%{rel}
45 Provides: libwx_x11.so
46 Provides: libwx_x11
-%{ver2}.so
49 Requires: %{wxbasename} = %{ver}
52 wxWindows is a free C
++ library
for cross
-platform GUI development.
53 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
54 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
57 Summary: The X11 port of the wxWindows library
59 Requires: %{name} = %{ver}
60 Requires: %{wxbasename}-devel = %{ver}
63 Header files
for wxX11
, the X11 port of the wxWindows library.
66 Summary: The X11 port of the wxWindows library
, OpenGL add
-on.
68 Requires: %{name} = %{ver}
71 OpenGL add
-on library
for wxX11
, the X11 port of the wxWindows library.
74 Summary: wxX11 static libraries
75 Group: Development
/Libraries
78 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
81 Summary: Contrib libraries
for wxX11.
83 Requires: %{name} = %{ver}
86 Contributed libraries
for wxX11.
88 %package contrib
-devel
89 Summary: Contrib libraries
for wxX11.
91 Requires: %{name}-contrib = %{ver}
92 Requires: %{name}-devel = %{ver}
94 %description contrib
-devel
95 Header files
for contributed libraries
for wxX11.
98 %setup -q
-n wxX11
-%{ver}
101 if [ "$SMP"
!= ""
]; then
102 export MAKE
="
make -j$SMP"
109 ..
/configure
--prefix
=%{pref} --with
-x11 \
123 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
134 rm -rf $RPM_BUILD_ROOT
135 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
136 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
138 # Remove headers that are part of wx-base-devel:
140 # --- wxBase headers list begins here ---
141 cat
<<EOF
>wxbase
-headers
-list
263 wx
/protocol
/protocol.h
276 # --- wxBase headers list ends here ---
277 for f
in `cat wxbase
-headers
-list`
; do
278 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx
-*/$f
281 # list of all core headers:
282 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
285 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
286 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
288 # remove wxBase files so that RPM doesn't complain about unpackaged files:
289 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
290 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
291 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
294 rm -rf $RPM_BUILD_ROOT
310 %defattr(-,root
,root
)
311 %doc COPYING.LIB
*.txt
312 %{_libdir}/libwx_%{portname}*_core
*.so.
*
313 %{_libdir}/libwx_%{portname}*_html
*.so.
*
314 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
316 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
319 %files devel
-f core
-headers.files
320 %defattr(-,root
,root
)
321 %{_libdir}/libwx_%{portname}*_core
*.so
322 %{_libdir}/libwx_%{portname}*_html
*.so
323 %{_libdir}/libwx_%{portname}*_adv
*.so
325 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
327 %{_libdir}/libwx_%{portname}*_gl
*.so
330 %{_bindir}/%{wxconfigname}
333 %defattr(-,root
,root
)
334 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
337 %defattr (-,root
,root
)
338 %{_libdir}/libwx_%{portname}*.a
341 %defattr(-,root
,root
)
342 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
343 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
344 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
345 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
346 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
347 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
348 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
349 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
350 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
351 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
354 %defattr(-,root
,root
)
356 %dir %{_includedir}/wx
-*/wx
/animate
357 %{_includedir}/wx
-*/wx
/animate
/*
358 %{_libdir}/libwx_%{portname}*_animate
*.so
360 %dir %{_includedir}/wx
-*/wx
/deprecated
361 %{_includedir}/wx
-*/wx
/deprecated
/*
362 %{_libdir}/libwx_%{portname}*_deprecated
*.so
364 %dir %{_includedir}/wx
-*/wx
/fl
365 %{_includedir}/wx
-*/wx
/fl
/*
366 %{_libdir}/libwx_%{portname}*_fl
*.so
368 %dir %{_includedir}/wx
-*/wx
/gizmos
369 %{_includedir}/wx
-*/wx
/gizmos
/*
370 %{_libdir}/libwx_%{portname}*_gizmos
*.so
372 %dir %{_includedir}/wx
-*/wx
/mmedia
373 %{_includedir}/wx
-*/wx
/mmedia
/*
374 %{_libdir}/libwx_%{portname}*_mmedia
*.so
376 %dir %{_includedir}/wx
-*/wx
/ogl
377 %{_includedir}/wx
-*/wx
/ogl
/*
378 %{_libdir}/libwx_%{portname}*_ogl
*.so
380 %dir %{_includedir}/wx
-*/wx
/plot
381 %{_includedir}/wx
-*/wx
/plot
/*
382 %{_libdir}/libwx_%{portname}*_plot
*.so
384 %dir %{_includedir}/wx
-*/wx
/stc
385 %{_includedir}/wx
-*/wx
/stc
/*
386 %{_libdir}/libwx_%{portname}*_stc
*.so
388 %dir %{_includedir}/wx
-*/wx
/svg
389 %{_includedir}/wx
-*/wx
/svg
/*
390 %{_libdir}/libwx_%{portname}*_svg
*.so
392 %dir %{_includedir}/wx
-*/wx
/xrc
393 %{_includedir}/wx
-*/wx
/xrc
/*
394 %{_libdir}/libwx_%{portname}*_xrc
*.so