regenerated after adding platinfo.{h|cpp}
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers.files
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/beforestd.h
145 wx/buffer.h
146 wx/build.h
147 wx/chkconf.h
148 wx/clntdata.h
149 wx/cmdline.h
150 wx/confbase.h
151 wx/config.h
152 wx/convauto.h
153 wx/containr.h
154 wx/datetime.h
155 wx/datstrm.h
156 wx/dde.h
157 wx/debug.h
158 wx/defs.h
159 wx/dir.h
160 wx/dlimpexp.h
161 wx/dynarray.h
162 wx/dynlib.h
163 wx/dynload.h
164 wx/encconv.h
165 wx/event.h
166 wx/except.h
167 wx/features.h
168 wx/ffile.h
169 wx/file.h
170 wx/fileconf.h
171 wx/filefn.h
172 wx/filename.h
173 wx/filesys.h
174 wx/fontenc.h
175 wx/fontmap.h
176 wx/fs_mem.h
177 wx/fs_zip.h
178 wx/hash.h
179 wx/hashmap.h
180 wx/hashset.h
181 wx/html/forcelnk.h
182 wx/iconloc.h
183 wx/init.h
184 wx/intl.h
185 wx/iosfwrap.h
186 wx/ioswrap.h
187 wx/ipc.h
188 wx/ipcbase.h
189 wx/isql.h
190 wx/isqlext.h
191 wx/link.h
192 wx/list.h
193 wx/listimpl.cpp
194 wx/log.h
195 wx/longlong.h
196 wx/math.h
197 wx/memconf.h
198 wx/memory.h
199 wx/memtext.h
200 wx/mimetype.h
201 wx/module.h
202 wx/msgout.h
203 wx/mstream.h
204 wx/object.h
205 wx/platform.h
206 wx/platinfo.h
207 wx/power.h
208 wx/process.h
209 wx/ptr_scpd.h
210 wx/recguard.h
211 wx/regex.h
212 wx/scopeguard.h
213 wx/snglinst.h
214 wx/sstream.h
215 wx/stack.h
216 wx/stackwalk.h
217 wx/stdpaths.h
218 wx/stockitem.h
219 wx/stopwatch.h
220 wx/strconv.h
221 wx/stream.h
222 wx/string.h
223 wx/sysopt.h
224 wx/textbuf.h
225 wx/textfile.h
226 wx/thread.h
227 wx/thrimpl.cpp
228 wx/timer.h
229 wx/tokenzr.h
230 wx/txtstrm.h
231 wx/types.h
232 wx/uri.h
233 wx/utils.h
234 wx/variant.h
235 wx/vector.h
236 wx/version.h
237 wx/volume.h
238 wx/wfstream.h
239 wx/wx.h
240 wx/wxchar.h
241 wx/wxprec.h
242 wx/xti.h
243 wx/xtistrm.h
244 wx/zipstrm.h
245 wx/zstream.h
246 wx/unix/apptbase.h
247 wx/unix/apptrait.h
248 wx/unix/execute.h
249 wx/unix/mimetype.h
250 wx/unix/pipe.h
251 wx/unix/private.h
252 wx/unix/stackwalk.h
253 wx/unix/stdpaths.h
254 wx/fs_inet.h
255 wx/gsocket.h
256 wx/protocol/file.h
257 wx/protocol/ftp.h
258 wx/protocol/http.h
259 wx/protocol/protocol.h
260 wx/sckaddr.h
261 wx/sckipc.h
262 wx/sckstrm.h
263 wx/socket.h
264 wx/url.h
265 wx/unix/gsockunx.h
266 wx/xml/xml.h
267 wx/xtixml.h
268 wx/db.h
269 wx/dbkeyg.h
270 wx/dbtable.h
271 EOF
272 # --- wxBase headers list ends here ---
273 for f in `cat wxbase-headers-list` ; do
274 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
275 done
276
277 # list of all core headers:
278 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
279
280 # contrib stuff:
281 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
282 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
283
284 # remove wxBase files so that RPM doesn't complain about unpackaged files:
285 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
286 %if %{unicode}
287 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
288 %endif
289 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
290 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
291
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 %post
296 /sbin/ldconfig
297
298 %postun
299 /sbin/ldconfig
300
301 %post devel
302 # link wx-config when you install RPM.
303 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
304 # link wx-config with explicit name.
305 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
306 /sbin/ldconfig
307
308 %postun devel
309 /sbin/ldconfig
310
311 %preun devel
312 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
313 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
314 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
315 if test "x$SUM1" = "x$SUM2" ; then
316 rm -f %{_bindir}/wx-config
317 fi
318 fi
319 rm -f %{_bindir}/%{wxconfiglink}
320
321 %post gl
322 /sbin/ldconfig
323
324 %postun gl
325 /sbin/ldconfig
326
327 %post contrib
328 /sbin/ldconfig
329
330 %postun contrib
331 /sbin/ldconfig
332
333 %post contrib-devel
334 /sbin/ldconfig
335
336 %postun contrib-devel
337 /sbin/ldconfig
338
339 %files
340 %defattr(-,root,root)
341 %doc COPYING.LIB *.txt
342 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
343 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
344 %if !%{unicode}
345 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
346 %endif
347 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
348 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
349 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
350 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
351
352
353 %files devel -f core-headers.files
354 %defattr(-,root,root)
355 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
356 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
357 %if !%{unicode}
358 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
359 %endif
360 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
361 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
362 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
363 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
364 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
365 %dir %{_libdir}/wx
366 %{_libdir}/wx/*
367 %{_bindir}/wxrc*
368
369 %files gl
370 %defattr(-,root,root)
371 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
372
373 %files static
374 %defattr (-,root,root)
375 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
376
377 %files contrib
378 %defattr(-,root,root)
379 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
380 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
381 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
382 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
383 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
384 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
385 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
386 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
387 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
388
389 %files contrib-devel
390 %defattr(-,root,root)
391 %dir %{_includedir}/wx-%{ver2}/wx/animate
392 %{_includedir}/wx-%{ver2}/wx/animate/*
393 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
394
395 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
396 %{_includedir}/wx-%{ver2}/wx/deprecated/*
397 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
398
399 %dir %{_includedir}/wx-%{ver2}/wx/fl
400 %{_includedir}/wx-%{ver2}/wx/fl/*
401 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
402
403 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
404 %{_includedir}/wx-%{ver2}/wx/gizmos/*
405 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
406
407 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
408 %{_includedir}/wx-%{ver2}/wx/mmedia/*
409 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
410
411 %dir %{_includedir}/wx-%{ver2}/wx/ogl
412 %{_includedir}/wx-%{ver2}/wx/ogl/*
413 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
414
415 %dir %{_includedir}/wx-%{ver2}/wx/plot
416 %{_includedir}/wx-%{ver2}/wx/plot/*
417 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
418
419 %dir %{_includedir}/wx-%{ver2}/wx/stc
420 %{_includedir}/wx-%{ver2}/wx/stc/*
421 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
422
423 %dir %{_includedir}/wx-%{ver2}/wx/svg
424 %{_includedir}/wx-%{ver2}/wx/svg/*
425 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so