regenerated after adding platinfo.{h|cpp}
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 --with-odbc \
171 %endif
172 --with-opengl
173 $MAKE
174
175 cd contrib/src
176 $MAKE
177 cd ../../..
178
179 mkdir obj-static
180 cd obj-static
181 ../configure --prefix=%{_prefix} \
182 %if ! %{gtk2}
183 --with-gtk=1 \
184 %else
185 --with-gtk=2 \
186 %endif
187 --disable-shared \
188 %if %{unicode}
189 --enable-unicode \
190 %else
191 --disable-unicode \
192 --with-odbc \
193 %endif
194 --with-opengl
195 $MAKE
196
197 cd contrib/src
198 $MAKE
199 cd ../../..
200
201 make -C locale allmo
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208 # --- wxBase headers list begins here ---
209 cat <<EOF >wxbase-headers.files
210 wx/afterstd.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chkconf.h
220 wx/clntdata.h
221 wx/cmdline.h
222 wx/confbase.h
223 wx/config.h
224 wx/convauto.h
225 wx/containr.h
226 wx/datetime.h
227 wx/datstrm.h
228 wx/dde.h
229 wx/debug.h
230 wx/defs.h
231 wx/dir.h
232 wx/dlimpexp.h
233 wx/dynarray.h
234 wx/dynlib.h
235 wx/dynload.h
236 wx/encconv.h
237 wx/event.h
238 wx/except.h
239 wx/features.h
240 wx/ffile.h
241 wx/file.h
242 wx/fileconf.h
243 wx/filefn.h
244 wx/filename.h
245 wx/filesys.h
246 wx/fontenc.h
247 wx/fontmap.h
248 wx/fs_mem.h
249 wx/fs_zip.h
250 wx/hash.h
251 wx/hashmap.h
252 wx/hashset.h
253 wx/html/forcelnk.h
254 wx/iconloc.h
255 wx/init.h
256 wx/intl.h
257 wx/iosfwrap.h
258 wx/ioswrap.h
259 wx/ipc.h
260 wx/ipcbase.h
261 wx/isql.h
262 wx/isqlext.h
263 wx/link.h
264 wx/list.h
265 wx/listimpl.cpp
266 wx/log.h
267 wx/longlong.h
268 wx/math.h
269 wx/memconf.h
270 wx/memory.h
271 wx/memtext.h
272 wx/mimetype.h
273 wx/module.h
274 wx/msgout.h
275 wx/mstream.h
276 wx/object.h
277 wx/platform.h
278 wx/platinfo.h
279 wx/power.h
280 wx/process.h
281 wx/ptr_scpd.h
282 wx/recguard.h
283 wx/regex.h
284 wx/scopeguard.h
285 wx/snglinst.h
286 wx/sstream.h
287 wx/stack.h
288 wx/stackwalk.h
289 wx/stdpaths.h
290 wx/stockitem.h
291 wx/stopwatch.h
292 wx/strconv.h
293 wx/stream.h
294 wx/string.h
295 wx/sysopt.h
296 wx/textbuf.h
297 wx/textfile.h
298 wx/thread.h
299 wx/thrimpl.cpp
300 wx/timer.h
301 wx/tokenzr.h
302 wx/txtstrm.h
303 wx/types.h
304 wx/uri.h
305 wx/utils.h
306 wx/variant.h
307 wx/vector.h
308 wx/version.h
309 wx/volume.h
310 wx/wfstream.h
311 wx/wx.h
312 wx/wxchar.h
313 wx/wxprec.h
314 wx/xti.h
315 wx/xtistrm.h
316 wx/zipstrm.h
317 wx/zstream.h
318 wx/unix/apptbase.h
319 wx/unix/apptrait.h
320 wx/unix/execute.h
321 wx/unix/mimetype.h
322 wx/unix/pipe.h
323 wx/unix/private.h
324 wx/unix/stackwalk.h
325 wx/unix/stdpaths.h
326 wx/fs_inet.h
327 wx/gsocket.h
328 wx/protocol/file.h
329 wx/protocol/ftp.h
330 wx/protocol/http.h
331 wx/protocol/protocol.h
332 wx/sckaddr.h
333 wx/sckipc.h
334 wx/sckstrm.h
335 wx/socket.h
336 wx/url.h
337 wx/unix/gsockunx.h
338 wx/xml/xml.h
339 wx/xtixml.h
340 wx/db.h
341 wx/dbkeyg.h
342 wx/dbtable.h
343 EOF
344 # --- wxBase headers list ends here ---
345 cat <<EOF >wxbase-headers.paths
346 %{_includedir}/wx-%{ver2}/wx/afterstd.h
347 %{_includedir}/wx-%{ver2}/wx/app.h
348 %{_includedir}/wx-%{ver2}/wx/apptrait.h
349 %{_includedir}/wx-%{ver2}/wx/archive.h
350 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
351 %{_includedir}/wx-%{ver2}/wx/arrstr.h
352 %{_includedir}/wx-%{ver2}/wx/beforestd.h
353 %{_includedir}/wx-%{ver2}/wx/buffer.h
354 %{_includedir}/wx-%{ver2}/wx/build.h
355 %{_includedir}/wx-%{ver2}/wx/chkconf.h
356 %{_includedir}/wx-%{ver2}/wx/clntdata.h
357 %{_includedir}/wx-%{ver2}/wx/cmdline.h
358 %{_includedir}/wx-%{ver2}/wx/confbase.h
359 %{_includedir}/wx-%{ver2}/wx/config.h
360 %{_includedir}/wx-%{ver2}/wx/containr.h
361 %{_includedir}/wx-%{ver2}/wx/convauto.h
362 %{_includedir}/wx-%{ver2}/wx/datetime.h
363 %{_includedir}/wx-%{ver2}/wx/datstrm.h
364 %{_includedir}/wx-%{ver2}/wx/dde.h
365 %{_includedir}/wx-%{ver2}/wx/debug.h
366 %{_includedir}/wx-%{ver2}/wx/defs.h
367 %{_includedir}/wx-%{ver2}/wx/dir.h
368 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
369 %{_includedir}/wx-%{ver2}/wx/dynarray.h
370 %{_includedir}/wx-%{ver2}/wx/dynlib.h
371 %{_includedir}/wx-%{ver2}/wx/dynload.h
372 %{_includedir}/wx-%{ver2}/wx/encconv.h
373 %{_includedir}/wx-%{ver2}/wx/event.h
374 %{_includedir}/wx-%{ver2}/wx/except.h
375 %{_includedir}/wx-%{ver2}/wx/features.h
376 %{_includedir}/wx-%{ver2}/wx/ffile.h
377 %{_includedir}/wx-%{ver2}/wx/file.h
378 %{_includedir}/wx-%{ver2}/wx/fileconf.h
379 %{_includedir}/wx-%{ver2}/wx/filefn.h
380 %{_includedir}/wx-%{ver2}/wx/filename.h
381 %{_includedir}/wx-%{ver2}/wx/filesys.h
382 %{_includedir}/wx-%{ver2}/wx/fontenc.h
383 %{_includedir}/wx-%{ver2}/wx/fontmap.h
384 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
385 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
386 %{_includedir}/wx-%{ver2}/wx/hash.h
387 %{_includedir}/wx-%{ver2}/wx/hashmap.h
388 %{_includedir}/wx-%{ver2}/wx/hashset.h
389 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
390 %{_includedir}/wx-%{ver2}/wx/iconloc.h
391 %{_includedir}/wx-%{ver2}/wx/init.h
392 %{_includedir}/wx-%{ver2}/wx/intl.h
393 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
394 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
395 %{_includedir}/wx-%{ver2}/wx/ipc.h
396 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
397 %{_includedir}/wx-%{ver2}/wx/isql.h
398 %{_includedir}/wx-%{ver2}/wx/isqlext.h
399 %{_includedir}/wx-%{ver2}/wx/link.h
400 %{_includedir}/wx-%{ver2}/wx/list.h
401 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
402 %{_includedir}/wx-%{ver2}/wx/log.h
403 %{_includedir}/wx-%{ver2}/wx/longlong.h
404 %{_includedir}/wx-%{ver2}/wx/math.h
405 %{_includedir}/wx-%{ver2}/wx/memconf.h
406 %{_includedir}/wx-%{ver2}/wx/memory.h
407 %{_includedir}/wx-%{ver2}/wx/memtext.h
408 %{_includedir}/wx-%{ver2}/wx/mimetype.h
409 %{_includedir}/wx-%{ver2}/wx/module.h
410 %{_includedir}/wx-%{ver2}/wx/msgout.h
411 %{_includedir}/wx-%{ver2}/wx/mstream.h
412 %{_includedir}/wx-%{ver2}/wx/object.h
413 %{_includedir}/wx-%{ver2}/wx/platform.h
414 %{_includedir}/wx-%{ver2}/wx/power.h
415 %{_includedir}/wx-%{ver2}/wx/process.h
416 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
417 %{_includedir}/wx-%{ver2}/wx/recguard.h
418 %{_includedir}/wx-%{ver2}/wx/regex.h
419 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
420 %{_includedir}/wx-%{ver2}/wx/snglinst.h
421 %{_includedir}/wx-%{ver2}/wx/sstream.h
422 %{_includedir}/wx-%{ver2}/wx/stack.h
423 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
424 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
425 %{_includedir}/wx-%{ver2}/wx/stockitem.h
426 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
427 %{_includedir}/wx-%{ver2}/wx/strconv.h
428 %{_includedir}/wx-%{ver2}/wx/stream.h
429 %{_includedir}/wx-%{ver2}/wx/string.h
430 %{_includedir}/wx-%{ver2}/wx/sysopt.h
431 %{_includedir}/wx-%{ver2}/wx/textbuf.h
432 %{_includedir}/wx-%{ver2}/wx/textfile.h
433 %{_includedir}/wx-%{ver2}/wx/thread.h
434 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
435 %{_includedir}/wx-%{ver2}/wx/timer.h
436 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
437 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
438 %{_includedir}/wx-%{ver2}/wx/types.h
439 %{_includedir}/wx-%{ver2}/wx/uri.h
440 %{_includedir}/wx-%{ver2}/wx/utils.h
441 %{_includedir}/wx-%{ver2}/wx/variant.h
442 %{_includedir}/wx-%{ver2}/wx/vector.h
443 %{_includedir}/wx-%{ver2}/wx/version.h
444 %{_includedir}/wx-%{ver2}/wx/volume.h
445 %{_includedir}/wx-%{ver2}/wx/wfstream.h
446 %{_includedir}/wx-%{ver2}/wx/wx.h
447 %{_includedir}/wx-%{ver2}/wx/wxchar.h
448 %{_includedir}/wx-%{ver2}/wx/wxprec.h
449 %{_includedir}/wx-%{ver2}/wx/xti.h
450 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
451 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
452 %{_includedir}/wx-%{ver2}/wx/zstream.h
453 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
454 %{_includedir}/wx-%{ver2}/wx/gsocket.h
455 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
456 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
457 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
458 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
459 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
460 %{_includedir}/wx-%{ver2}/wx/sckipc.h
461 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
462 %{_includedir}/wx-%{ver2}/wx/socket.h
463 %{_includedir}/wx-%{ver2}/wx/url.h
464 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
465 %{_includedir}/wx-%{ver2}/wx/xtixml.h
466 %{_includedir}/wx-%{ver2}/wx/db.h
467 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
468 %{_includedir}/wx-%{ver2}/wx/dbtable.h
469 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
470 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
471 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
472 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
473 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
474 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
475 %{_includedir}/wx-%{ver2}/wx/unix/private.h
476 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
477 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
478 EOF
479 # --- wxBase headers list ends here ---
480
481 # temporarily remove base headers
482 mkdir $RPM_BUILD_ROOT/_save_dir
483 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
484 for f in `cat wxbase-headers.files` ; do
485 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
486 done
487 # list of all core headers:
488 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
489 # move base headers (actually all headers) back again
490 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
491 rm -rf $RPM_BUILD_ROOT/_save_dir
492
493 # contrib stuff:
494 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
495 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
496
497 # utils:
498 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
499
500 # wx-config link is created during package installation, remove it for now
501 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
502
503 %clean
504 rm -rf $RPM_BUILD_ROOT
505
506 %post
507 /sbin/ldconfig
508
509 %postun
510 /sbin/ldconfig
511
512 %post devel
513 # link wx-config when you install RPM.
514 %if %{unicode}
515 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
516 %endif
517 # link wx-config with explicit name.
518 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
519 /sbin/ldconfig
520
521 %postun devel
522 /sbin/ldconfig
523
524 %preun devel
525 %if %{unicode}
526 rm -f %{_bindir}/wx-config
527 %endif
528 rm -f %{_bindir}/%{wxconfiglink}
529
530 %post -n %{wxbasename}
531 /sbin/ldconfig
532
533 %postun -n %{wxbasename}
534 /sbin/ldconfig
535
536 %post -n %{wxbasename}-devel
537 # link wx-config with explicit name.
538 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
539 /sbin/ldconfig
540
541 %postun -n %{wxbasename}-devel
542 /sbin/ldconfig
543
544 %preun -n %{wxbasename}-devel
545 rm -f %{_bindir}/%{wxbaseconfiglink}
546
547 %post gl
548 /sbin/ldconfig
549
550 %postun gl
551 /sbin/ldconfig
552
553 %post contrib
554 /sbin/ldconfig
555
556 %postun contrib
557 /sbin/ldconfig
558
559 %post contrib-devel
560 /sbin/ldconfig
561
562 %postun contrib-devel
563 /sbin/ldconfig
564
565 %files
566 %defattr(-,root,root)
567 %doc COPYING.LIB *.txt
568 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
569 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
570 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
571 %if !%{unicode}
572 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
573 %endif
574 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
575 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
576 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
577 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
578 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
579
580 %files -n wx-i18n
581 %defattr(-,root,root)
582 %{_datadir}/locale/*/LC_MESSAGES/*.mo
583
584 %files devel -f core-headers.files
585 %defattr(-,root,root)
586 # shared libs
587 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
588 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
589 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
590 %if !%{unicode}
591 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
592 %endif
593 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
594 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
595 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
596 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
599 # static libs
600 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
601 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
602 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
603 %if !%{unicode}
604 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
605 %endif
606 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
607 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
608 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
609 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
610 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
611 %dir %{_libdir}/wx
612 %{_libdir}/wx/config/%{wxconfig}
613 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
614 %{_libdir}/wx/config/%{wxconfigstatic}
615 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
616 %{_bindir}/wxrc*
617
618 %files -n %{wxbasename}
619 %defattr(-,root,root)
620 %{_libdir}/libwx_base*-%{ver2}.so.*
621
622 %files -n %{wxbasename}-devel -f wxbase-headers.paths
623 %defattr (-,root,root)
624 %dir %{_includedir}/wx-%{ver2}
625 %{_libdir}/libwx_base*-%{ver2}.so
626 %{_libdir}/libwx_base*-%{ver2}.a
627 %if %{unicode}
628 %{_libdir}/libwxregexu-%{ver2}.a
629 %endif
630 %dir %{_libdir}/wx
631 %{_datadir}/aclocal/*.m4
632 %{_datadir}/bakefile/presets/*
633
634 %files gl
635 %defattr(-,root,root)
636 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
637
638 %files contrib
639 %defattr(-,root,root)
640 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
641 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
642 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
643 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
644 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
645 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
646 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
647 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
648 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
649 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
650
651 # static libs
652 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
653 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
654 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
655 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
656 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
657 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
658 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
659 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
660 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
661 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
662
663 %files contrib-devel
664 %defattr(-,root,root)
665 %dir %{_includedir}/wx-%{ver2}/wx/animate
666 %{_includedir}/wx-%{ver2}/wx/animate/*
667 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
668
669 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
670 %{_includedir}/wx-%{ver2}/wx/deprecated/*
671 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
672
673 %dir %{_includedir}/wx-%{ver2}/wx/fl
674 %{_includedir}/wx-%{ver2}/wx/fl/*
675 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
676
677 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
678 %{_includedir}/wx-%{ver2}/wx/gizmos/*
679 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
680 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
681
682 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
683 %{_includedir}/wx-%{ver2}/wx/mmedia/*
684 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
685
686 %dir %{_includedir}/wx-%{ver2}/wx/ogl
687 %{_includedir}/wx-%{ver2}/wx/ogl/*
688 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
689
690 %dir %{_includedir}/wx-%{ver2}/wx/plot
691 %{_includedir}/wx-%{ver2}/wx/plot/*
692 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
693
694 %dir %{_includedir}/wx-%{ver2}/wx/stc
695 %{_includedir}/wx-%{ver2}/wx/stc/*
696 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
697
698 %dir %{_includedir}/wx-%{ver2}/wx/svg
699 %{_includedir}/wx-%{ver2}/wx/svg/*
700 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so