6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
24 %define name wx
-%{portname}-unicode
25 %define wxbasename wx
-base
-unicode
27 %define name wx
-%{portname}
28 %define wxbasename wx
-base
32 %define wxconfigname
%{portname}-unicode-release-%{ver2}
33 %define wxconfiglinkname wx
%{portname}u-%{ver2}-config
35 %define wxconfigname
%{portname}-ansi-release-%{ver2}
36 %define wxconfiglinkname wx
%{portname}-%{ver2}-config
40 Summary: The GTK
+ %{gtkver} port of the wxWindows library
43 License: wxWindows Licence
45 Source: wxGTK
-%{ver}.tar.bz2
46 URL: http
://www.wxwindows.org
47 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
49 BuildRoot: /var
/tmp
/%{name}-root
51 # all packages providing an implementation of wxWindows library (regardless of
52 # the toolkit used) should provide the (virtual) wxwin package, this makes it
53 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
57 # in addition, we should provide libwx_gtk as automatic generator only notices
58 # libwx_gtk-%{ver}-%{rel}
59 Provides: libwx_gtk.so
60 Provides: libwx_gtk
-%{ver2}.so
62 Requires: %{wxbasename} = %{ver}
65 wxWindows is a free C
++ library
for cross
-platform GUI development.
66 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
67 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
70 Summary: The GTK
+ %{gtkver} port of the wxWindows library
72 Requires: %{name} = %{ver}
73 Requires: %{wxbasename}-devel = %{ver}
77 Header files
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
80 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, OpenGL add
-on.
82 Requires: %{name} = %{ver}
85 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
88 Summary: wxGTK static libraries
89 Group: Development
/Libraries
90 Requires: %{wxbasename}-static
93 Static libraries
for wxGTK. You need them
if you want to link statically against wxGTK.
96 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, contributed libraries.
98 Requires: %{name} = %{ver}
101 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
103 %package contrib
-devel
104 Summary: The GTK
+ %{gtkver} port of the wxWindows library
106 Requires: %{name}-contrib = %{ver}
107 Requires: %{name}-devel = %{ver}
109 %description contrib
-devel
110 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
113 %setup -q
-n wxGTK
-%{ver}
116 if [ "$SMP"
!= ""
]; then
117 export MAKE
="
make -j$SMP"
124 ..
/configure
--prefix
=%{pref} \
141 ..
/configure
--prefix
=%{pref} --disable
-shared \
155 rm -rf $RPM_BUILD_ROOT
156 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
157 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
159 # Remove headers that are part of wx-base-devel:
161 # --- wxBase headers list begins here ---
162 cat
<<EOF
>wxbase
-headers
-list
284 wx
/protocol
/protocol.h
297 # --- wxBase headers list ends here ---
298 for f
in `cat wxbase
-headers
-list`
; do
299 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx
-*/$f
302 # list of all core headers:
303 find $RPM_BUILD_ROOT
/usr
/include
/wx
-* -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
306 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
307 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
309 # remove wxBase files so that RPM doesn't complain about unpackaged files:
310 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
311 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwxregexu-%{ver2}.a
312 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
313 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
316 rm -rf $RPM_BUILD_ROOT
331 # link wx-config when you install RPM.
332 ln
-sf
%{_libdir}/wx/config/%{wxconfigname} %{_bindir}/wx
-config
333 # link wx-config with explicit name.
334 ln
-sf
%{_libdir}/wx/config/%{wxconfigname} %{_bindir}/%{wxconfiglinkname}
337 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
338 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfigname} | cut
-c
0-32`
339 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
340 if test "x$SUM1"
= "x$SUM2"
; then
341 rm -f
%{_bindir}/wx
-config
345 rm -f
%{_bindir}/%{wxconfiglinkname}
348 %defattr(-,root
,root
)
349 %doc COPYING.LIB
*.txt
350 %{_libdir}/libwx_%{portname}*_core
*.so.
*
351 %{_libdir}/libwx_%{portname}*_html
*.so.
*
352 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
353 %{_libdir}/libwx_%{portname}*_media
*.so.
*
355 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
358 %files devel
-f core
-headers.files
359 %defattr(-,root
,root
)
360 %{_libdir}/libwx_%{portname}*_core
*.so
361 %{_libdir}/libwx_%{portname}*_html
*.so
362 %{_libdir}/libwx_%{portname}*_adv
*.so
363 %{_libdir}/libwx_%{portname}*_media
*.so
365 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
367 %{_libdir}/libwx_%{portname}*_gl
*.so
372 %defattr(-,root
,root
)
373 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
376 %defattr (-,root
,root
)
377 %{_libdir}/libwx_gtk
*.a
380 %defattr(-,root
,root
)
381 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
382 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
383 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
384 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
385 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
386 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
387 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
388 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
389 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
390 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
393 %defattr(-,root
,root
)
395 %dir %{_includedir}/wx
-*/wx
/animate
396 %{_includedir}/wx
-*/wx
/animate
/*
397 %{_libdir}/libwx_%{portname}*_animate
*.so
399 %dir %{_includedir}/wx
-*/wx
/deprecated
400 %{_includedir}/wx
-*/wx
/deprecated
/*
401 %{_libdir}/libwx_%{portname}*_deprecated
*.so
403 %dir %{_includedir}/wx
-*/wx
/fl
404 %{_includedir}/wx
-*/wx
/fl
/*
405 %{_libdir}/libwx_%{portname}*_fl
*.so
407 %dir %{_includedir}/wx
-*/wx
/gizmos
408 %{_includedir}/wx
-*/wx
/gizmos
/*
409 %{_libdir}/libwx_%{portname}*_gizmos
*.so
411 %dir %{_includedir}/wx
-*/wx
/mmedia
412 %{_includedir}/wx
-*/wx
/mmedia
/*
413 %{_libdir}/libwx_%{portname}*_mmedia
*.so
415 %dir %{_includedir}/wx
-*/wx
/ogl
416 %{_includedir}/wx
-*/wx
/ogl
/*
417 %{_libdir}/libwx_%{portname}*_ogl
*.so
419 %dir %{_includedir}/wx
-*/wx
/plot
420 %{_includedir}/wx
-*/wx
/plot
/*
421 %{_libdir}/libwx_%{portname}*_plot
*.so
423 %dir %{_includedir}/wx
-*/wx
/stc
424 %{_includedir}/wx
-*/wx
/stc
/*
425 %{_libdir}/libwx_%{portname}*_stc
*.so
427 %dir %{_includedir}/wx
-*/wx
/svg
428 %{_includedir}/wx
-*/wx
/svg
/*
429 %{_libdir}/libwx_%{portname}*_svg
*.so
431 %dir %{_includedir}/wx
-*/wx
/xrc
432 %{_includedir}/wx
-*/wx
/xrc
/*
433 %{_libdir}/libwx_%{portname}*_xrc
*.so