5 Summary: Cross platform GUI toolkit
for use with the Python language.
9 Copyright: wxWindows
License
10 Group: Development
/Languages
/Python
11 Source: wxPython
-%{ver}.tar.gz
12 Packager: Robin Dunn
<robin@alldunn.com
>
13 URL:http
://alldunn.com
/wxPython
/index.html
14 Vendor: Total Control Software
15 Requires: python
>= 1.5.2
16 ##BuildRoot: /tmp/wxPython-build
17 ##Prefix: /usr/lib/python1.5/site-packages
22 wxPython is a GUI toolkit
for Python that is a wrapper around the
23 wxWindows C
++ GUI library. wxPython provides a large variety of
24 window types and controls
, all imlemented with a native look and
25 feel
(and runtime speed
) on the platforms it is supported on.
29 Summary: Cross platform GUI toolkit
for use with the Python language
, OpenGL addon.
30 Group: Development
/Languages
/Python
34 OpenGL add on
for wxPython.
36 #----------------------------------------------------------------------
46 python ..
/distrib
/build.py
-b WXPSRCDIR
=$PWD USE_SONAME
=1
48 python ..
/..
/distrib
/build.py
-b WXPSRCDIR
=..
/..
/src USE_SONAME
=1
50 python ..
/..
/distrib
/build.py
-b WXPSRCDIR
=..
/..
/src USE_SONAME
=1
51 if [ -z $NOGLCANVAS
]; then
53 python ..
/..
/distrib
/build.py
-b WXPSRCDIR
=..
/..
/src USE_SONAME
=1
56 #----------------------------------------------------------------------
62 python ..
/distrib
/build.py
-i
64 python ..
/..
/distrib
/build.py
-i
66 python ..
/..
/distrib
/build.py
-i
67 if [ -z $NOGLCANVAS
]; then
69 python ..
/..
/distrib
/build.py
-i
72 #----------------------------------------------------------------------
80 #----------------------------------------------------------------------
83 %doc BUILD.txt CHANGES.txt README.txt gpl.txt lgpl.txt licence.txt licendoc.txt preamble.txt
84 %{pref}/lib
/libwxPyHelpers
*
85 %{pref}/lib
/python1.5
/site
-packages
/wxPython
/*.py
86 %{pref}/lib
/python1.5
/site
-packages
/wxPython
/*.py?
87 %{pref}/lib
/python1.5
/site
-packages
/wxPython
/lib
88 %{pref}/lib
/python1.5
/site
-packages
/wxPython
/demo
89 %{pref}/lib
/python1.5
/site
-packages
/wxPython
/wxcmodule.so
90 %{pref}/lib
/python1.5
/site
-packages
/wxPython
/oglcmodule.so
91 %{pref}/lib
/python1.5
/site
-packages
/wxPython
/stc_cmodule.so
94 %{pref}/lib
/python1.5
/site
-packages
/wxPython
/glcanvascmodule.so