i18n files are installed as part of wxBase (and should be ideally part of separate...
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.bz2
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 BuildRequires: gtk+-2.0-devel
68 %else
69 BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package -n wx-i18n
86 Summary: The translations for the wxWidgets library.
87 Group: X11/Libraries
88
89 %description -n wx-i18n
90 The translations files for the wxWidgets library.
91
92 %package devel
93 Summary: The GTK+ %{gtkver} port of the wxWidgets library
94 Group: X11/Libraries
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
97 Provides: wxGTK-devel
98
99 %description devel
100 The GTK+ %{gtkver} port of the wxWidgets library, header files.
101
102 %package gl
103 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
104 Group: X11/Libraries
105 Requires: %{name} = %{ver}
106 Provides: wxGTK-gl
107
108 %description gl
109 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
110
111 %package -n %{wxbasename}
112 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
113 Group: Development/Libraries
114 Provides: wxBase
115
116 %description -n %{wxbasename}
117 wxBase is a collection of C++ classes providing basic data structures (strings,
118 lists, arrays), portable wrappers around many OS-specific funstions (file
119 operations, time/date manipulations, threads, processes, sockets, shared
120 library loading) as well as other utility classes (streams, archive and
121 compression). wxBase currently supports Win32, most Unix variants (Linux,
122 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
123
124 %package -n %{wxbasename}-devel
125 Summary: wxBase library, header files.
126 Group: Development/Libraries
127 Provides: wxBase-devel
128
129 %description -n %{wxbasename}-devel
130 wxBase library - non-GUI support classes of the wxWidgets toolkit,
131 header files.
132
133 %package contrib
134 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
135 Group: X11/Libraries
136 Requires: %{name} = %{ver}
137
138 %description contrib
139 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
140
141 %package contrib-devel
142 Summary: The GTK+ %{gtkver} port of the wxWidgets library
143 Group: X11/Libraries
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
146
147 %description contrib-devel
148 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
149
150 %prep
151 %setup -q -n wxGTK-%{ver}
152
153 %build
154 if [ "$SMP" != "" ]; then
155 export MAKE="make -j$SMP"
156 else
157 export MAKE="make"
158 fi
159
160 mkdir obj-shared-no-gui
161 cd obj-shared-no-gui
162 ../configure --prefix=%{_prefix} \
163 --disable-gui \
164 %if %{unicode}
165 --enable-unicode
166 %else
167 --disable-unicode
168 %endif
169 $MAKE
170 cd ..
171
172 mkdir obj-shared
173 cd obj-shared
174 ../configure --prefix=%{_prefix} \
175 %if ! %{gtk2}
176 --with-gtk=1 \
177 %else
178 --with-gtk=2 \
179 %endif
180 %if %{unicode}
181 --enable-unicode \
182 %else
183 --disable-unicode \
184 --with-odbc \
185 %endif
186 --with-opengl
187 $MAKE
188
189 cd contrib/src
190 $MAKE
191 cd ../../..
192
193 mkdir obj-static-no-gui
194 cd obj-static-no-gui
195 ../configure --prefix=%{_prefix} \
196 --disable-gui \
197 --disable-shared \
198 %if %{unicode}
199 --enable-unicode
200 %else
201 --disable-unicode
202 %endif
203 $MAKE
204 cd ..
205
206 mkdir obj-static
207 cd obj-static
208 ../configure --prefix=%{_prefix} \
209 %if ! %{gtk2}
210 --with-gtk=1 \
211 %else
212 --with-gtk=2 \
213 %endif
214 --disable-shared \
215 %if %{unicode}
216 --enable-unicode \
217 %else
218 --disable-unicode \
219 --with-odbc \
220 %endif
221 --with-opengl
222 $MAKE
223
224 cd contrib/src
225 $MAKE
226 cd ../../..
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230 (cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
231 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
232 (cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
233 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
234
235 # --- wxBase headers list begins here ---
236 cat <<EOF >wxbase-headers.files
237 wx/afterstd.h
238 wx/app.h
239 wx/apptrait.h
240 wx/archive.h
241 wx/arrimpl.cpp
242 wx/arrstr.h
243 wx/beforestd.h
244 wx/buffer.h
245 wx/build.h
246 wx/chkconf.h
247 wx/clntdata.h
248 wx/cmdline.h
249 wx/confbase.h
250 wx/config.h
251 wx/convauto.h
252 wx/containr.h
253 wx/datetime.h
254 wx/datstrm.h
255 wx/dde.h
256 wx/debug.h
257 wx/defs.h
258 wx/dir.h
259 wx/dlimpexp.h
260 wx/dynarray.h
261 wx/dynlib.h
262 wx/dynload.h
263 wx/encconv.h
264 wx/event.h
265 wx/except.h
266 wx/features.h
267 wx/ffile.h
268 wx/file.h
269 wx/fileconf.h
270 wx/filefn.h
271 wx/filename.h
272 wx/filesys.h
273 wx/fontenc.h
274 wx/fontmap.h
275 wx/fs_mem.h
276 wx/fs_zip.h
277 wx/hash.h
278 wx/hashmap.h
279 wx/hashset.h
280 wx/html/forcelnk.h
281 wx/iconloc.h
282 wx/init.h
283 wx/intl.h
284 wx/iosfwrap.h
285 wx/ioswrap.h
286 wx/ipc.h
287 wx/ipcbase.h
288 wx/isql.h
289 wx/isqlext.h
290 wx/link.h
291 wx/list.h
292 wx/listimpl.cpp
293 wx/log.h
294 wx/longlong.h
295 wx/math.h
296 wx/memconf.h
297 wx/memory.h
298 wx/memtext.h
299 wx/mimetype.h
300 wx/module.h
301 wx/msgout.h
302 wx/mstream.h
303 wx/object.h
304 wx/platform.h
305 wx/power.h
306 wx/process.h
307 wx/ptr_scpd.h
308 wx/recguard.h
309 wx/regex.h
310 wx/scopeguard.h
311 wx/snglinst.h
312 wx/sstream.h
313 wx/stack.h
314 wx/stackwalk.h
315 wx/stdpaths.h
316 wx/stockitem.h
317 wx/stopwatch.h
318 wx/strconv.h
319 wx/stream.h
320 wx/string.h
321 wx/sysopt.h
322 wx/textbuf.h
323 wx/textfile.h
324 wx/thread.h
325 wx/thrimpl.cpp
326 wx/timer.h
327 wx/tokenzr.h
328 wx/txtstrm.h
329 wx/types.h
330 wx/uri.h
331 wx/utils.h
332 wx/variant.h
333 wx/vector.h
334 wx/version.h
335 wx/volume.h
336 wx/wfstream.h
337 wx/wx.h
338 wx/wxchar.h
339 wx/wxprec.h
340 wx/xti.h
341 wx/xtistrm.h
342 wx/zipstrm.h
343 wx/zstream.h
344 wx/unix/apptbase.h
345 wx/unix/apptrait.h
346 wx/unix/execute.h
347 wx/unix/mimetype.h
348 wx/unix/pipe.h
349 wx/unix/private.h
350 wx/unix/stackwalk.h
351 wx/unix/stdpaths.h
352 wx/fs_inet.h
353 wx/gsocket.h
354 wx/protocol/file.h
355 wx/protocol/ftp.h
356 wx/protocol/http.h
357 wx/protocol/protocol.h
358 wx/sckaddr.h
359 wx/sckipc.h
360 wx/sckstrm.h
361 wx/socket.h
362 wx/url.h
363 wx/unix/gsockunx.h
364 wx/xml/xml.h
365 wx/xtixml.h
366 wx/db.h
367 wx/dbkeyg.h
368 wx/dbtable.h
369 EOF
370 # --- wxBase headers list ends here ---
371 cat <<EOF >wxbase-headers.paths
372 %{_includedir}/wx-%{ver2}/wx/afterstd.h
373 %{_includedir}/wx-%{ver2}/wx/app.h
374 %{_includedir}/wx-%{ver2}/wx/apptrait.h
375 %{_includedir}/wx-%{ver2}/wx/archive.h
376 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
377 %{_includedir}/wx-%{ver2}/wx/arrstr.h
378 %{_includedir}/wx-%{ver2}/wx/beforestd.h
379 %{_includedir}/wx-%{ver2}/wx/buffer.h
380 %{_includedir}/wx-%{ver2}/wx/build.h
381 %{_includedir}/wx-%{ver2}/wx/chkconf.h
382 %{_includedir}/wx-%{ver2}/wx/clntdata.h
383 %{_includedir}/wx-%{ver2}/wx/cmdline.h
384 %{_includedir}/wx-%{ver2}/wx/confbase.h
385 %{_includedir}/wx-%{ver2}/wx/config.h
386 %{_includedir}/wx-%{ver2}/wx/containr.h
387 %{_includedir}/wx-%{ver2}/wx/datetime.h
388 %{_includedir}/wx-%{ver2}/wx/datstrm.h
389 %{_includedir}/wx-%{ver2}/wx/dde.h
390 %{_includedir}/wx-%{ver2}/wx/debug.h
391 %{_includedir}/wx-%{ver2}/wx/defs.h
392 %{_includedir}/wx-%{ver2}/wx/dir.h
393 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
394 %{_includedir}/wx-%{ver2}/wx/dynarray.h
395 %{_includedir}/wx-%{ver2}/wx/dynlib.h
396 %{_includedir}/wx-%{ver2}/wx/dynload.h
397 %{_includedir}/wx-%{ver2}/wx/encconv.h
398 %{_includedir}/wx-%{ver2}/wx/event.h
399 %{_includedir}/wx-%{ver2}/wx/except.h
400 %{_includedir}/wx-%{ver2}/wx/features.h
401 %{_includedir}/wx-%{ver2}/wx/ffile.h
402 %{_includedir}/wx-%{ver2}/wx/file.h
403 %{_includedir}/wx-%{ver2}/wx/fileconf.h
404 %{_includedir}/wx-%{ver2}/wx/filefn.h
405 %{_includedir}/wx-%{ver2}/wx/filename.h
406 %{_includedir}/wx-%{ver2}/wx/filesys.h
407 %{_includedir}/wx-%{ver2}/wx/fontenc.h
408 %{_includedir}/wx-%{ver2}/wx/fontmap.h
409 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
410 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
411 %{_includedir}/wx-%{ver2}/wx/hash.h
412 %{_includedir}/wx-%{ver2}/wx/hashmap.h
413 %{_includedir}/wx-%{ver2}/wx/hashset.h
414 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
415 %{_includedir}/wx-%{ver2}/wx/iconloc.h
416 %{_includedir}/wx-%{ver2}/wx/init.h
417 %{_includedir}/wx-%{ver2}/wx/intl.h
418 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
419 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
420 %{_includedir}/wx-%{ver2}/wx/ipc.h
421 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
422 %{_includedir}/wx-%{ver2}/wx/isql.h
423 %{_includedir}/wx-%{ver2}/wx/isqlext.h
424 %{_includedir}/wx-%{ver2}/wx/list.h
425 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
426 %{_includedir}/wx-%{ver2}/wx/log.h
427 %{_includedir}/wx-%{ver2}/wx/longlong.h
428 %{_includedir}/wx-%{ver2}/wx/math.h
429 %{_includedir}/wx-%{ver2}/wx/memconf.h
430 %{_includedir}/wx-%{ver2}/wx/memory.h
431 %{_includedir}/wx-%{ver2}/wx/memtext.h
432 %{_includedir}/wx-%{ver2}/wx/mimetype.h
433 %{_includedir}/wx-%{ver2}/wx/module.h
434 %{_includedir}/wx-%{ver2}/wx/msgout.h
435 %{_includedir}/wx-%{ver2}/wx/mstream.h
436 %{_includedir}/wx-%{ver2}/wx/object.h
437 %{_includedir}/wx-%{ver2}/wx/platform.h
438 %{_includedir}/wx-%{ver2}/wx/process.h
439 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
440 %{_includedir}/wx-%{ver2}/wx/regex.h
441 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
442 %{_includedir}/wx-%{ver2}/wx/snglinst.h
443 %{_includedir}/wx-%{ver2}/wx/sstream.h
444 %{_includedir}/wx-%{ver2}/wx/stack.h
445 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
446 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
447 %{_includedir}/wx-%{ver2}/wx/stockitem.h
448 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
449 %{_includedir}/wx-%{ver2}/wx/strconv.h
450 %{_includedir}/wx-%{ver2}/wx/stream.h
451 %{_includedir}/wx-%{ver2}/wx/string.h
452 %{_includedir}/wx-%{ver2}/wx/sysopt.h
453 %{_includedir}/wx-%{ver2}/wx/textbuf.h
454 %{_includedir}/wx-%{ver2}/wx/textfile.h
455 %{_includedir}/wx-%{ver2}/wx/thread.h
456 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
457 %{_includedir}/wx-%{ver2}/wx/timer.h
458 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
459 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
460 %{_includedir}/wx-%{ver2}/wx/types.h
461 %{_includedir}/wx-%{ver2}/wx/uri.h
462 %{_includedir}/wx-%{ver2}/wx/utils.h
463 %{_includedir}/wx-%{ver2}/wx/variant.h
464 %{_includedir}/wx-%{ver2}/wx/vector.h
465 %{_includedir}/wx-%{ver2}/wx/version.h
466 %{_includedir}/wx-%{ver2}/wx/volume.h
467 %{_includedir}/wx-%{ver2}/wx/wfstream.h
468 %{_includedir}/wx-%{ver2}/wx/wx.h
469 %{_includedir}/wx-%{ver2}/wx/wxchar.h
470 %{_includedir}/wx-%{ver2}/wx/wxprec.h
471 %{_includedir}/wx-%{ver2}/wx/xti.h
472 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
473 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
474 %{_includedir}/wx-%{ver2}/wx/zstream.h
475 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
476 %{_includedir}/wx-%{ver2}/wx/gsocket.h
477 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
478 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
479 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
480 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
481 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
482 %{_includedir}/wx-%{ver2}/wx/sckipc.h
483 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
484 %{_includedir}/wx-%{ver2}/wx/socket.h
485 %{_includedir}/wx-%{ver2}/wx/url.h
486 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
487 %{_includedir}/wx-%{ver2}/wx/xtixml.h
488 %{_includedir}/wx-%{ver2}/wx/db.h
489 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
490 %{_includedir}/wx-%{ver2}/wx/dbtable.h
491 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
492 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
493 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
494 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
495 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
496 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
497 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
498 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
499 EOF
500 # --- wxBase headers list ends here ---
501
502 # temporarily remove base headers
503 mkdir $RPM_BUILD_ROOT/_save_dir
504 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
505 for f in `cat wxbase-headers.files` ; do
506 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
507 done
508 # list of all core headers:
509 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
510 # move base headers (actually all headers) back again
511 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
512 rm -rf $RPM_BUILD_ROOT/_save_dir
513
514 # contrib stuff:
515 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
516 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
517
518 %clean
519 rm -rf $RPM_BUILD_ROOT
520
521 %post
522 /sbin/ldconfig
523
524 %postun
525 /sbin/ldconfig
526
527 %post devel
528 # link wx-config when you install RPM.
529 %if %{unicode}
530 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
531 %endif
532 # link wx-config with explicit name.
533 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
534 /sbin/ldconfig
535
536 %postun devel
537 /sbin/ldconfig
538
539 %preun devel
540 %if %{unicode}
541 rm -f %{_bindir}/wx-config
542 %endif
543 rm -f %{_bindir}/%{wxconfiglink}
544
545 %post -n %{wxbasename}
546 /sbin/ldconfig
547
548 %postun -n %{wxbasename}
549 /sbin/ldconfig
550
551 %post -n %{wxbasename}-devel
552 # link wx-config with explicit name.
553 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
554 /sbin/ldconfig
555
556 %postun -n %{wxbasename}-devel
557 /sbin/ldconfig
558
559 %preun -n %{wxbasename}-devel
560 rm -f %{_bindir}/%{wxbaseconfiglink}
561
562 %post gl
563 /sbin/ldconfig
564
565 %postun gl
566 /sbin/ldconfig
567
568 %post contrib
569 /sbin/ldconfig
570
571 %postun contrib
572 /sbin/ldconfig
573
574 %post contrib-devel
575 /sbin/ldconfig
576
577 %postun contrib-devel
578 /sbin/ldconfig
579
580 %files
581 %defattr(-,root,root)
582 %doc COPYING.LIB *.txt
583 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
584 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
585 %if !%{unicode}
586 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
587 %endif
588 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
589 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
590 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
591 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
592
593 %files -n wx-i18n
594 %defattr(-,root,root)
595
596 %files devel -f core-headers.files
597 %defattr(-,root,root)
598 # shared libs
599 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
601 %if !%{unicode}
602 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
603 %endif
604 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
606 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
607 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
608 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
609 # static libs
610 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
611 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
612 %if !%{unicode}
613 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
614 %endif
615 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
617 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
618 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
619 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
620 %dir %{_libdir}/wx
621 %{_libdir}/wx/config/%{wxconfig}
622 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
623 %{_libdir}/wx/config/%{wxconfigstatic}
624 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
625 %{_bindir}/wxrc*
626
627 %files -n %{wxbasename}
628 %defattr(-,root,root)
629 %{_libdir}/libwx_base*-%{ver2}.so.*
630
631 %files -n %{wxbasename}-devel -f wxbase-headers.paths
632 %defattr (-,root,root)
633 %dir %{_includedir}/wx-%{ver2}
634 %{_libdir}/libwx_base*-%{ver2}.so
635 %{_libdir}/libwx_base*-%{ver2}.a
636 %if %{unicode}
637 %{_libdir}/libwxregexu-%{ver2}.a
638 %endif
639 %dir %{_libdir}/wx
640 %{_libdir}/wx/config/%{wxbaseconfig}
641 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
642 %{_libdir}/wx/config/%{wxbaseconfigstatic}
643 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
644 %{_datadir}/aclocal/*.m4
645
646 %files gl
647 %defattr(-,root,root)
648 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
649
650 %files contrib
651 %defattr(-,root,root)
652 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
653 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
655 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
661 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
662
663 %files contrib-devel
664 %defattr(-,root,root)
665 %dir %{_includedir}/wx-%{ver2}/wx/animate
666 %{_includedir}/wx-%{ver2}/wx/animate/*
667 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
668
669 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
670 %{_includedir}/wx-%{ver2}/wx/deprecated/*
671 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
672
673 %dir %{_includedir}/wx-%{ver2}/wx/fl
674 %{_includedir}/wx-%{ver2}/wx/fl/*
675 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
676
677 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
678 %{_includedir}/wx-%{ver2}/wx/gizmos/*
679 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
680 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
681
682 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
683 %{_includedir}/wx-%{ver2}/wx/mmedia/*
684 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
685
686 %dir %{_includedir}/wx-%{ver2}/wx/ogl
687 %{_includedir}/wx-%{ver2}/wx/ogl/*
688 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
689
690 %dir %{_includedir}/wx-%{ver2}/wx/plot
691 %{_includedir}/wx-%{ver2}/wx/plot/*
692 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
693
694 %dir %{_includedir}/wx-%{ver2}/wx/stc
695 %{_includedir}/wx-%{ver2}/wx/stc/*
696 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
697
698 %dir %{_includedir}/wx-%{ver2}/wx/svg
699 %{_includedir}/wx-%{ver2}/wx/svg/*
700 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so