Add wxArchiveFSHandler.
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 --with-odbc \
171 %endif
172 --with-opengl
173 $MAKE
174
175 cd contrib/src
176 $MAKE
177 cd ../../..
178
179 mkdir obj-static
180 cd obj-static
181 ../configure --prefix=%{_prefix} \
182 %if ! %{gtk2}
183 --with-gtk=1 \
184 %else
185 --with-gtk=2 \
186 %endif
187 --disable-shared \
188 %if %{unicode}
189 --enable-unicode \
190 %else
191 --disable-unicode \
192 --with-odbc \
193 %endif
194 --with-opengl
195 $MAKE
196
197 cd contrib/src
198 $MAKE
199 cd ../../..
200
201 make -C locale allmo
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208 # --- wxBase headers list begins here ---
209 cat <<EOF >wxbase-headers.files
210 wx/afterstd.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chkconf.h
220 wx/clntdata.h
221 wx/cmdline.h
222 wx/confbase.h
223 wx/config.h
224 wx/convauto.h
225 wx/containr.h
226 wx/cpp.h
227 wx/datetime.h
228 wx/datstrm.h
229 wx/dde.h
230 wx/debug.h
231 wx/defs.h
232 wx/dir.h
233 wx/dlimpexp.h
234 wx/dynarray.h
235 wx/dynlib.h
236 wx/dynload.h
237 wx/encconv.h
238 wx/event.h
239 wx/except.h
240 wx/features.h
241 wx/ffile.h
242 wx/file.h
243 wx/fileback.h
244 wx/fileconf.h
245 wx/filefn.h
246 wx/filename.h
247 wx/filesys.h
248 wx/fontenc.h
249 wx/fontmap.h
250 wx/fs_arc.h
251 wx/fs_filter.h
252 wx/fs_mem.h
253 wx/fs_zip.h
254 wx/hash.h
255 wx/hashmap.h
256 wx/hashset.h
257 wx/html/forcelnk.h
258 wx/iconloc.h
259 wx/init.h
260 wx/intl.h
261 wx/iosfwrap.h
262 wx/ioswrap.h
263 wx/ipc.h
264 wx/ipcbase.h
265 wx/isql.h
266 wx/isqlext.h
267 wx/link.h
268 wx/list.h
269 wx/listimpl.cpp
270 wx/log.h
271 wx/longlong.h
272 wx/math.h
273 wx/memconf.h
274 wx/memory.h
275 wx/memtext.h
276 wx/mimetype.h
277 wx/module.h
278 wx/msgout.h
279 wx/mstream.h
280 wx/object.h
281 wx/platform.h
282 wx/platinfo.h
283 wx/power.h
284 wx/process.h
285 wx/ptr_scpd.h
286 wx/recguard.h
287 wx/regex.h
288 wx/scopeguard.h
289 wx/snglinst.h
290 wx/sstream.h
291 wx/stack.h
292 wx/stackwalk.h
293 wx/stdpaths.h
294 wx/stockitem.h
295 wx/stopwatch.h
296 wx/strconv.h
297 wx/stream.h
298 wx/string.h
299 wx/sysopt.h
300 wx/tarstrm.h
301 wx/textbuf.h
302 wx/textfile.h
303 wx/thread.h
304 wx/thrimpl.cpp
305 wx/timer.h
306 wx/tokenzr.h
307 wx/txtstrm.h
308 wx/types.h
309 wx/uri.h
310 wx/utils.h
311 wx/variant.h
312 wx/vector.h
313 wx/version.h
314 wx/volume.h
315 wx/wfstream.h
316 wx/wx.h
317 wx/wxchar.h
318 wx/wxprec.h
319 wx/xti.h
320 wx/xtistrm.h
321 wx/zipstrm.h
322 wx/zstream.h
323 wx/unix/apptbase.h
324 wx/unix/apptrait.h
325 wx/unix/execute.h
326 wx/unix/mimetype.h
327 wx/unix/pipe.h
328 wx/unix/private.h
329 wx/unix/stackwalk.h
330 wx/unix/stdpaths.h
331 wx/fs_inet.h
332 wx/gsocket.h
333 wx/protocol/file.h
334 wx/protocol/ftp.h
335 wx/protocol/http.h
336 wx/protocol/protocol.h
337 wx/sckaddr.h
338 wx/sckipc.h
339 wx/sckstrm.h
340 wx/socket.h
341 wx/url.h
342 wx/unix/gsockunx.h
343 wx/xml/xml.h
344 wx/xtixml.h
345 wx/db.h
346 wx/dbkeyg.h
347 wx/dbtable.h
348 EOF
349 # --- wxBase headers list ends here ---
350 cat <<EOF >wxbase-headers.paths
351 %{_includedir}/wx-%{ver2}/wx/afterstd.h
352 %{_includedir}/wx-%{ver2}/wx/app.h
353 %{_includedir}/wx-%{ver2}/wx/apptrait.h
354 %{_includedir}/wx-%{ver2}/wx/archive.h
355 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
356 %{_includedir}/wx-%{ver2}/wx/arrstr.h
357 %{_includedir}/wx-%{ver2}/wx/beforestd.h
358 %{_includedir}/wx-%{ver2}/wx/buffer.h
359 %{_includedir}/wx-%{ver2}/wx/build.h
360 %{_includedir}/wx-%{ver2}/wx/chkconf.h
361 %{_includedir}/wx-%{ver2}/wx/clntdata.h
362 %{_includedir}/wx-%{ver2}/wx/cmdline.h
363 %{_includedir}/wx-%{ver2}/wx/confbase.h
364 %{_includedir}/wx-%{ver2}/wx/config.h
365 %{_includedir}/wx-%{ver2}/wx/containr.h
366 %{_includedir}/wx-%{ver2}/wx/convauto.h
367 %{_includedir}/wx-%{ver2}/wx/datetime.h
368 %{_includedir}/wx-%{ver2}/wx/datstrm.h
369 %{_includedir}/wx-%{ver2}/wx/dde.h
370 %{_includedir}/wx-%{ver2}/wx/debug.h
371 %{_includedir}/wx-%{ver2}/wx/defs.h
372 %{_includedir}/wx-%{ver2}/wx/dir.h
373 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
374 %{_includedir}/wx-%{ver2}/wx/dynarray.h
375 %{_includedir}/wx-%{ver2}/wx/dynlib.h
376 %{_includedir}/wx-%{ver2}/wx/dynload.h
377 %{_includedir}/wx-%{ver2}/wx/encconv.h
378 %{_includedir}/wx-%{ver2}/wx/event.h
379 %{_includedir}/wx-%{ver2}/wx/except.h
380 %{_includedir}/wx-%{ver2}/wx/features.h
381 %{_includedir}/wx-%{ver2}/wx/ffile.h
382 %{_includedir}/wx-%{ver2}/wx/file.h
383 %{_includedir}/wx-%{ver2}/wx/fileconf.h
384 %{_includedir}/wx-%{ver2}/wx/filefn.h
385 %{_includedir}/wx-%{ver2}/wx/filename.h
386 %{_includedir}/wx-%{ver2}/wx/filesys.h
387 %{_includedir}/wx-%{ver2}/wx/fontenc.h
388 %{_includedir}/wx-%{ver2}/wx/fontmap.h
389 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
390 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
391 %{_includedir}/wx-%{ver2}/wx/hash.h
392 %{_includedir}/wx-%{ver2}/wx/hashmap.h
393 %{_includedir}/wx-%{ver2}/wx/hashset.h
394 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
395 %{_includedir}/wx-%{ver2}/wx/iconloc.h
396 %{_includedir}/wx-%{ver2}/wx/init.h
397 %{_includedir}/wx-%{ver2}/wx/intl.h
398 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
399 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
400 %{_includedir}/wx-%{ver2}/wx/ipc.h
401 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
402 %{_includedir}/wx-%{ver2}/wx/isql.h
403 %{_includedir}/wx-%{ver2}/wx/isqlext.h
404 %{_includedir}/wx-%{ver2}/wx/link.h
405 %{_includedir}/wx-%{ver2}/wx/list.h
406 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
407 %{_includedir}/wx-%{ver2}/wx/log.h
408 %{_includedir}/wx-%{ver2}/wx/longlong.h
409 %{_includedir}/wx-%{ver2}/wx/math.h
410 %{_includedir}/wx-%{ver2}/wx/memconf.h
411 %{_includedir}/wx-%{ver2}/wx/memory.h
412 %{_includedir}/wx-%{ver2}/wx/memtext.h
413 %{_includedir}/wx-%{ver2}/wx/mimetype.h
414 %{_includedir}/wx-%{ver2}/wx/module.h
415 %{_includedir}/wx-%{ver2}/wx/msgout.h
416 %{_includedir}/wx-%{ver2}/wx/mstream.h
417 %{_includedir}/wx-%{ver2}/wx/object.h
418 %{_includedir}/wx-%{ver2}/wx/platform.h
419 %{_includedir}/wx-%{ver2}/wx/power.h
420 %{_includedir}/wx-%{ver2}/wx/process.h
421 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
422 %{_includedir}/wx-%{ver2}/wx/recguard.h
423 %{_includedir}/wx-%{ver2}/wx/regex.h
424 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
425 %{_includedir}/wx-%{ver2}/wx/snglinst.h
426 %{_includedir}/wx-%{ver2}/wx/sstream.h
427 %{_includedir}/wx-%{ver2}/wx/stack.h
428 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
429 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
430 %{_includedir}/wx-%{ver2}/wx/stockitem.h
431 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
432 %{_includedir}/wx-%{ver2}/wx/strconv.h
433 %{_includedir}/wx-%{ver2}/wx/stream.h
434 %{_includedir}/wx-%{ver2}/wx/string.h
435 %{_includedir}/wx-%{ver2}/wx/sysopt.h
436 %{_includedir}/wx-%{ver2}/wx/textbuf.h
437 %{_includedir}/wx-%{ver2}/wx/textfile.h
438 %{_includedir}/wx-%{ver2}/wx/thread.h
439 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
440 %{_includedir}/wx-%{ver2}/wx/timer.h
441 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
442 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
443 %{_includedir}/wx-%{ver2}/wx/types.h
444 %{_includedir}/wx-%{ver2}/wx/uri.h
445 %{_includedir}/wx-%{ver2}/wx/utils.h
446 %{_includedir}/wx-%{ver2}/wx/variant.h
447 %{_includedir}/wx-%{ver2}/wx/vector.h
448 %{_includedir}/wx-%{ver2}/wx/version.h
449 %{_includedir}/wx-%{ver2}/wx/volume.h
450 %{_includedir}/wx-%{ver2}/wx/wfstream.h
451 %{_includedir}/wx-%{ver2}/wx/wx.h
452 %{_includedir}/wx-%{ver2}/wx/wxchar.h
453 %{_includedir}/wx-%{ver2}/wx/wxprec.h
454 %{_includedir}/wx-%{ver2}/wx/xti.h
455 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
456 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
457 %{_includedir}/wx-%{ver2}/wx/zstream.h
458 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
459 %{_includedir}/wx-%{ver2}/wx/gsocket.h
460 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
461 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
462 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
463 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
464 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
465 %{_includedir}/wx-%{ver2}/wx/sckipc.h
466 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
467 %{_includedir}/wx-%{ver2}/wx/socket.h
468 %{_includedir}/wx-%{ver2}/wx/url.h
469 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
470 %{_includedir}/wx-%{ver2}/wx/xtixml.h
471 %{_includedir}/wx-%{ver2}/wx/db.h
472 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
473 %{_includedir}/wx-%{ver2}/wx/dbtable.h
474 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
475 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
476 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
477 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
478 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
479 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
480 %{_includedir}/wx-%{ver2}/wx/unix/private.h
481 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
482 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
483 EOF
484 # --- wxBase headers list ends here ---
485
486 # temporarily remove base headers
487 mkdir $RPM_BUILD_ROOT/_save_dir
488 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
489 for f in `cat wxbase-headers.files` ; do
490 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
491 done
492 # list of all core headers:
493 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
494 # move base headers (actually all headers) back again
495 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
496 rm -rf $RPM_BUILD_ROOT/_save_dir
497
498 # contrib stuff:
499 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
500 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
501
502 # utils:
503 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
504
505 # wx-config link is created during package installation, remove it for now
506 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
507
508 %clean
509 rm -rf $RPM_BUILD_ROOT
510
511 %post
512 /sbin/ldconfig
513
514 %postun
515 /sbin/ldconfig
516
517 %post devel
518 # link wx-config when you install RPM.
519 %if %{unicode}
520 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
521 %endif
522 # link wx-config with explicit name.
523 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
524 /sbin/ldconfig
525
526 %postun devel
527 /sbin/ldconfig
528
529 %preun devel
530 %if %{unicode}
531 rm -f %{_bindir}/wx-config
532 %endif
533 rm -f %{_bindir}/%{wxconfiglink}
534
535 %post -n %{wxbasename}
536 /sbin/ldconfig
537
538 %postun -n %{wxbasename}
539 /sbin/ldconfig
540
541 %post -n %{wxbasename}-devel
542 # link wx-config with explicit name.
543 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
544 /sbin/ldconfig
545
546 %postun -n %{wxbasename}-devel
547 /sbin/ldconfig
548
549 %preun -n %{wxbasename}-devel
550 rm -f %{_bindir}/%{wxbaseconfiglink}
551
552 %post gl
553 /sbin/ldconfig
554
555 %postun gl
556 /sbin/ldconfig
557
558 %post contrib
559 /sbin/ldconfig
560
561 %postun contrib
562 /sbin/ldconfig
563
564 %post contrib-devel
565 /sbin/ldconfig
566
567 %postun contrib-devel
568 /sbin/ldconfig
569
570 %files
571 %defattr(-,root,root)
572 %doc COPYING.LIB *.txt
573 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
574 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
575 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
576 %if !%{unicode}
577 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
578 %endif
579 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
580 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
581 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
582 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
583 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
584
585 %files -n wx-i18n
586 %defattr(-,root,root)
587 %{_datadir}/locale/*/LC_MESSAGES/*.mo
588
589 %files devel -f core-headers.files
590 %defattr(-,root,root)
591 # shared libs
592 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
593 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
594 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
595 %if !%{unicode}
596 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
597 %endif
598 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
599 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
601 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
602 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
603 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
604 # static libs
605 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
606 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
607 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
608 %if !%{unicode}
609 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
610 %endif
611 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
612 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
613 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
614 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
615 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
616 %dir %{_libdir}/wx
617 %{_libdir}/wx/config/%{wxconfig}
618 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
619 %{_libdir}/wx/config/%{wxconfigstatic}
620 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
621 %{_bindir}/wxrc*
622
623 %files -n %{wxbasename}
624 %defattr(-,root,root)
625 %{_libdir}/libwx_base*-%{ver2}.so.*
626
627 %files -n %{wxbasename}-devel -f wxbase-headers.paths
628 %defattr (-,root,root)
629 %dir %{_includedir}/wx-%{ver2}
630 %{_libdir}/libwx_base*-%{ver2}.so
631 %{_libdir}/libwx_base*-%{ver2}.a
632 %if %{unicode}
633 %{_libdir}/libwxregexu-%{ver2}.a
634 %endif
635 %dir %{_libdir}/wx
636 %{_datadir}/aclocal/*.m4
637 %{_datadir}/bakefile/presets/*
638
639 %files gl
640 %defattr(-,root,root)
641 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
642
643 %files contrib
644 %defattr(-,root,root)
645 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
646 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
647 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
648 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
649 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
650 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
651 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
653 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
655
656 # static libs
657 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
658 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
659 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
660 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
661 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
662 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
663 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
664 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
665 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
666 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
667
668 %files contrib-devel
669 %defattr(-,root,root)
670 %dir %{_includedir}/wx-%{ver2}/wx/animate
671 %{_includedir}/wx-%{ver2}/wx/animate/*
672 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
673
674 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
675 %{_includedir}/wx-%{ver2}/wx/deprecated/*
676 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
677
678 %dir %{_includedir}/wx-%{ver2}/wx/fl
679 %{_includedir}/wx-%{ver2}/wx/fl/*
680 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
681
682 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
683 %{_includedir}/wx-%{ver2}/wx/gizmos/*
684 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
685 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
686
687 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
688 %{_includedir}/wx-%{ver2}/wx/mmedia/*
689 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
690
691 %dir %{_includedir}/wx-%{ver2}/wx/ogl
692 %{_includedir}/wx-%{ver2}/wx/ogl/*
693 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
694
695 %dir %{_includedir}/wx-%{ver2}/wx/plot
696 %{_includedir}/wx-%{ver2}/wx/plot/*
697 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
698
699 %dir %{_includedir}/wx-%{ver2}/wx/stc
700 %{_includedir}/wx-%{ver2}/wx/stc/*
701 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
702
703 %dir %{_includedir}/wx-%{ver2}/wx/svg
704 %{_includedir}/wx-%{ver2}/wx/svg/*
705 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so