rebaked after adding new string-related headers
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers.files
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/beforestd.h
145 wx/buffer.h
146 wx/build.h
147 wx/chartype.h
148 wx/chkconf.h
149 wx/clntdata.h
150 wx/cmdline.h
151 wx/confbase.h
152 wx/config.h
153 wx/convauto.h
154 wx/containr.h
155 wx/cpp.h
156 wx/datetime.h
157 wx/datstrm.h
158 wx/dde.h
159 wx/debug.h
160 wx/defs.h
161 wx/dir.h
162 wx/dlimpexp.h
163 wx/dynarray.h
164 wx/dynlib.h
165 wx/dynload.h
166 wx/encconv.h
167 wx/event.h
168 wx/except.h
169 wx/features.h
170 wx/ffile.h
171 wx/file.h
172 wx/fileconf.h
173 wx/filefn.h
174 wx/filename.h
175 wx/filesys.h
176 wx/fontenc.h
177 wx/fontmap.h
178 wx/fs_arc.h
179 wx/fs_filter.h
180 wx/fs_mem.h
181 wx/fs_zip.h
182 wx/hash.h
183 wx/hashmap.h
184 wx/hashset.h
185 wx/html/forcelnk.h
186 wx/iconloc.h
187 wx/init.h
188 wx/intl.h
189 wx/iosfwrap.h
190 wx/ioswrap.h
191 wx/ipc.h
192 wx/ipcbase.h
193 wx/isql.h
194 wx/isqlext.h
195 wx/link.h
196 wx/list.h
197 wx/listimpl.cpp
198 wx/log.h
199 wx/longlong.h
200 wx/math.h
201 wx/memconf.h
202 wx/memory.h
203 wx/memtext.h
204 wx/mimetype.h
205 wx/module.h
206 wx/msgout.h
207 wx/mstream.h
208 wx/object.h
209 wx/platform.h
210 wx/platinfo.h
211 wx/power.h
212 wx/process.h
213 wx/ptr_scpd.h
214 wx/recguard.h
215 wx/regex.h
216 wx/scopeguard.h
217 wx/snglinst.h
218 wx/sstream.h
219 wx/stack.h
220 wx/stackwalk.h
221 wx/stdpaths.h
222 wx/stockitem.h
223 wx/stopwatch.h
224 wx/strconv.h
225 wx/stream.h
226 wx/string.h
227 wx/stringimpl.h
228 wx/strvararg.h
229 wx/sysopt.h
230 wx/tarstrm.h
231 wx/textbuf.h
232 wx/textfile.h
233 wx/thread.h
234 wx/thrimpl.cpp
235 wx/timer.h
236 wx/tokenzr.h
237 wx/txtstrm.h
238 wx/types.h
239 wx/unichar.h
240 wx/uri.h
241 wx/utils.h
242 wx/variant.h
243 wx/vector.h
244 wx/version.h
245 wx/volume.h
246 wx/wfstream.h
247 wx/wx.h
248 wx/wxchar.h
249 wx/wxcrt.h
250 wx/wxprec.h
251 wx/xti.h
252 wx/xtistrm.h
253 wx/zipstrm.h
254 wx/zstream.h
255 wx/unix/apptbase.h
256 wx/unix/apptrait.h
257 wx/unix/execute.h
258 wx/unix/mimetype.h
259 wx/unix/pipe.h
260 wx/unix/private.h
261 wx/unix/stackwalk.h
262 wx/unix/stdpaths.h
263 wx/fs_inet.h
264 wx/gsocket.h
265 wx/protocol/file.h
266 wx/protocol/ftp.h
267 wx/protocol/http.h
268 wx/protocol/protocol.h
269 wx/sckaddr.h
270 wx/sckipc.h
271 wx/sckstrm.h
272 wx/socket.h
273 wx/url.h
274 wx/unix/gsockunx.h
275 wx/xml/xml.h
276 wx/xtixml.h
277 wx/db.h
278 wx/dbkeyg.h
279 wx/dbtable.h
280 EOF
281 # --- wxBase headers list ends here ---
282 for f in `cat wxbase-headers-list` ; do
283 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
284 done
285
286 # list of all core headers:
287 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
288
289 # contrib stuff:
290 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
291 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
292
293 # remove wxBase files so that RPM doesn't complain about unpackaged files:
294 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
295 %if %{unicode}
296 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
297 %endif
298 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
299 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
300
301 %clean
302 rm -rf $RPM_BUILD_ROOT
303
304 %post
305 /sbin/ldconfig
306
307 %postun
308 /sbin/ldconfig
309
310 %post devel
311 # link wx-config when you install RPM.
312 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
313 # link wx-config with explicit name.
314 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
315 /sbin/ldconfig
316
317 %postun devel
318 /sbin/ldconfig
319
320 %preun devel
321 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
322 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
323 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
324 if test "x$SUM1" = "x$SUM2" ; then
325 rm -f %{_bindir}/wx-config
326 fi
327 fi
328 rm -f %{_bindir}/%{wxconfiglink}
329
330 %post gl
331 /sbin/ldconfig
332
333 %postun gl
334 /sbin/ldconfig
335
336 %post contrib
337 /sbin/ldconfig
338
339 %postun contrib
340 /sbin/ldconfig
341
342 %post contrib-devel
343 /sbin/ldconfig
344
345 %postun contrib-devel
346 /sbin/ldconfig
347
348 %files
349 %defattr(-,root,root)
350 %doc COPYING.LIB *.txt
351 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
352 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
353 %if !%{unicode}
354 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
355 %endif
356 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
357 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
358 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
359 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
360
361
362 %files devel -f core-headers.files
363 %defattr(-,root,root)
364 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
365 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
366 %if !%{unicode}
367 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
368 %endif
369 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
370 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
371 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
372 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
373 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
374 %dir %{_libdir}/wx
375 %{_libdir}/wx/*
376 %{_bindir}/wxrc*
377
378 %files gl
379 %defattr(-,root,root)
380 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
381
382 %files static
383 %defattr (-,root,root)
384 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
385
386 %files contrib
387 %defattr(-,root,root)
388 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
389 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
390 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
391 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
392 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
393 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
394 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
395 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
396 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
397
398 %files contrib-devel
399 %defattr(-,root,root)
400 %dir %{_includedir}/wx-%{ver2}/wx/animate
401 %{_includedir}/wx-%{ver2}/wx/animate/*
402 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
403
404 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
405 %{_includedir}/wx-%{ver2}/wx/deprecated/*
406 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
407
408 %dir %{_includedir}/wx-%{ver2}/wx/fl
409 %{_includedir}/wx-%{ver2}/wx/fl/*
410 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
411
412 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
413 %{_includedir}/wx-%{ver2}/wx/gizmos/*
414 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
415
416 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
417 %{_includedir}/wx-%{ver2}/wx/mmedia/*
418 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
419
420 %dir %{_includedir}/wx-%{ver2}/wx/ogl
421 %{_includedir}/wx-%{ver2}/wx/ogl/*
422 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
423
424 %dir %{_includedir}/wx-%{ver2}/wx/plot
425 %{_includedir}/wx-%{ver2}/wx/plot/*
426 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
427
428 %dir %{_includedir}/wx-%{ver2}/wx/stc
429 %{_includedir}/wx-%{ver2}/wx/stc/*
430 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
431
432 %dir %{_includedir}/wx-%{ver2}/wx/svg
433 %{_includedir}/wx-%{ver2}/wx/svg/*
434 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so