rebaked after adding new string-related headers
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-odbc --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-odbc --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/beforestd.h
120 wx/buffer.h
121 wx/build.h
122 wx/chartype.h
123 wx/chkconf.h
124 wx/clntdata.h
125 wx/cmdline.h
126 wx/confbase.h
127 wx/config.h
128 wx/convauto.h
129 wx/containr.h
130 wx/cpp.h
131 wx/datetime.h
132 wx/datstrm.h
133 wx/dde.h
134 wx/debug.h
135 wx/defs.h
136 wx/dir.h
137 wx/dlimpexp.h
138 wx/dynarray.h
139 wx/dynlib.h
140 wx/dynload.h
141 wx/encconv.h
142 wx/event.h
143 wx/except.h
144 wx/features.h
145 wx/ffile.h
146 wx/file.h
147 wx/fileconf.h
148 wx/filefn.h
149 wx/filename.h
150 wx/filesys.h
151 wx/fontenc.h
152 wx/fontmap.h
153 wx/fs_arc.h
154 wx/fs_filter.h
155 wx/fs_mem.h
156 wx/fs_zip.h
157 wx/hash.h
158 wx/hashmap.h
159 wx/hashset.h
160 wx/html/forcelnk.h
161 wx/iconloc.h
162 wx/init.h
163 wx/intl.h
164 wx/iosfwrap.h
165 wx/ioswrap.h
166 wx/ipc.h
167 wx/ipcbase.h
168 wx/isql.h
169 wx/isqlext.h
170 wx/link.h
171 wx/list.h
172 wx/listimpl.cpp
173 wx/log.h
174 wx/longlong.h
175 wx/math.h
176 wx/memconf.h
177 wx/memory.h
178 wx/memtext.h
179 wx/mimetype.h
180 wx/module.h
181 wx/msgout.h
182 wx/mstream.h
183 wx/object.h
184 wx/platform.h
185 wx/platinfo.h
186 wx/power.h
187 wx/process.h
188 wx/ptr_scpd.h
189 wx/recguard.h
190 wx/regex.h
191 wx/scopeguard.h
192 wx/snglinst.h
193 wx/sstream.h
194 wx/stack.h
195 wx/stackwalk.h
196 wx/stdpaths.h
197 wx/stockitem.h
198 wx/stopwatch.h
199 wx/strconv.h
200 wx/stream.h
201 wx/string.h
202 wx/stringimpl.h
203 wx/strvararg.h
204 wx/sysopt.h
205 wx/tarstrm.h
206 wx/textbuf.h
207 wx/textfile.h
208 wx/thread.h
209 wx/thrimpl.cpp
210 wx/timer.h
211 wx/tokenzr.h
212 wx/txtstrm.h
213 wx/types.h
214 wx/unichar.h
215 wx/uri.h
216 wx/utils.h
217 wx/variant.h
218 wx/vector.h
219 wx/version.h
220 wx/volume.h
221 wx/wfstream.h
222 wx/wx.h
223 wx/wxchar.h
224 wx/wxcrt.h
225 wx/wxprec.h
226 wx/xti.h
227 wx/xtistrm.h
228 wx/zipstrm.h
229 wx/zstream.h
230 wx/unix/apptbase.h
231 wx/unix/apptrait.h
232 wx/unix/execute.h
233 wx/unix/mimetype.h
234 wx/unix/pipe.h
235 wx/unix/private.h
236 wx/unix/stackwalk.h
237 wx/unix/stdpaths.h
238 wx/fs_inet.h
239 wx/gsocket.h
240 wx/protocol/file.h
241 wx/protocol/ftp.h
242 wx/protocol/http.h
243 wx/protocol/protocol.h
244 wx/sckaddr.h
245 wx/sckipc.h
246 wx/sckstrm.h
247 wx/socket.h
248 wx/url.h
249 wx/unix/gsockunx.h
250 wx/xml/xml.h
251 wx/xtixml.h
252 wx/db.h
253 wx/dbkeyg.h
254 wx/dbtable.h
255 EOF
256 # --- wxBase headers list ends here ---
257 for f in `cat wxbase-headers-list` ; do
258 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
259 done
260
261 # list of all core headers:
262 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
263
264 # contrib stuff:
265 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
266 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
267
268 # remove wxBase files so that RPM doesn't complain about unpackaged files:
269 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
270 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
271 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
272
273 %clean
274 rm -rf $RPM_BUILD_ROOT
275
276 %post
277 /sbin/ldconfig
278
279 %postun
280 /sbin/ldconfig
281
282 %post devel
283 # link wx-config when you install RPM.
284 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
285 # link wx-config with explicit name.
286 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
287 /sbin/ldconfig
288
289 %postun devel
290 /sbin/ldconfig
291
292 %preun devel
293 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
294 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
295 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
296 if test "x$SUM1" = "x$SUM2" ; then
297 rm -f %{_bindir}/wx-config
298 fi
299 fi
300 rm -f %{_bindir}/%{wxconfiglink}
301
302 %post gl
303 /sbin/ldconfig
304
305 %postun gl
306 /sbin/ldconfig
307
308 %post contrib
309 /sbin/ldconfig
310
311 %postun contrib
312 /sbin/ldconfig
313
314 %post contrib-devel
315 /sbin/ldconfig
316
317 %postun contrib-devel
318 /sbin/ldconfig
319
320 %files
321 %defattr(-,root,root)
322 %doc COPYING.LIB *.txt
323 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
324 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
325 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
326 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
327 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
328 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
329 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
330
331
332 %files devel -f core-headers.files
333 %defattr(-,root,root)
334 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
335 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
336 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
337 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
338 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
339 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
340 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
341 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
342 %dir %{_libdir}/wx
343 %{_libdir}/wx/*
344 %{_bindir}/wxrc*
345
346 %files gl
347 %defattr(-,root,root)
348 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
349
350 %files static
351 %defattr (-,root,root)
352 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
353
354 %files contrib
355 %defattr(-,root,root)
356 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
357 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
358 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
359 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
360 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
361 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
362 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
363 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
364 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
365
366 %files contrib-devel
367 %defattr(-,root,root)
368 %dir %{_includedir}/wx-%{ver2}/wx/animate
369 %{_includedir}/wx-%{ver2}/wx/animate/*
370 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
371
372 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
373 %{_includedir}/wx-%{ver2}/wx/deprecated/*
374 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
375
376 %dir %{_includedir}/wx-%{ver2}/wx/fl
377 %{_includedir}/wx-%{ver2}/wx/fl/*
378 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
379
380 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
381 %{_includedir}/wx-%{ver2}/wx/gizmos/*
382 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
383
384 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
385 %{_includedir}/wx-%{ver2}/wx/mmedia/*
386 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
387
388 %dir %{_includedir}/wx-%{ver2}/wx/ogl
389 %{_includedir}/wx-%{ver2}/wx/ogl/*
390 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
391
392 %dir %{_includedir}/wx-%{ver2}/wx/plot
393 %{_includedir}/wx-%{ver2}/wx/plot/*
394 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
395
396 %dir %{_includedir}/wx-%{ver2}/wx/stc
397 %{_includedir}/wx-%{ver2}/wx/stc/*
398 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
399
400 %dir %{_includedir}/wx-%{ver2}/wx/svg
401 %{_includedir}/wx-%{ver2}/wx/svg/*
402 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so