]> git.saurik.com Git - wxWidgets.git/blob - wxGTK_RR.spec
Committed by attempt of a spec file to CVS.
[wxWidgets.git] / wxGTK_RR.spec
1 %define pref /opt/gnome
2 %define ver 2.5.5
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 %if %{gtk2}
16 %define gtkver 2
17 %define portname gtk2
18 %else
19 %define gtkver 1.2
20 %define portname gtk
21 %endif
22
23 %if %{unicode}
24 %define name wx-%{portname}-unicode
25 %define wxconfig %{portname}-unicode-release-%{ver2}
26 %define wxconfiglink wx%{portname}u-%{ver2}-config
27 %else
28 %define wxbasename wx-base
29 %define name wx-%{portname}
30 %define wxconfig %{portname}-ansi-release-%{ver2}
31 %define wxconfiglink wx%{portname}-%{ver2}-config
32 %endif
33
34 %if %{unicode}
35 %define wxbasename wx-base-unicode
36 %define wxbaseconfig base-unicode-release-%{ver2}
37 %define wxbaseconfiglink wxbaseu-%{ver2}-config
38 %else
39 %define wxbasename wx-base-ansi
40 %define wxbaseconfig base-ansi-release-%{ver2}
41 %define wxbaseconfiglink wxbase-%{ver2}-config
42 %endif
43
44 Summary: The GTK+ %{gtkver} port of the wxWidgets library
45 Name: %{name}
46 Version: %{ver}
47 Release: %{rel}
48 License: wxWindows Licence
49 Group: X11/Libraries
50 Source: wxGTK-%{ver}.tar.gz
51 URL: http://www.wxwidgets.org
52 Packager: Vadim Zeitlin <vadim@wxwindows.org>
53 Prefix: %{pref}
54 BuildRoot: %{_tmppath}/%{name}-root
55 Requires: %{wxbasename} = %{ver}
56
57 # all packages providing an implementation of wxWidgets library (regardless of
58 # the toolkit used) should provide the (virtual) wxwin package, this makes it
59 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
60 Provides: wxwin
61 Provides: wxGTK
62
63 %description
64 wxWidgets is a free C++ library for cross-platform GUI development.
65 With wxWidgets, you can create applications for different GUIs (GTK+,
66 Motif, MS Windows, MacOS X) from the same source code.
67
68 %package devel
69 Summary: The GTK+ %{gtkver} port of the wxWidgets library
70 Group: X11/Libraries
71 Requires: %{name} = %{ver}
72 Requires: %{wxbasename}-devel = %{ver}
73 Provides: wxGTK-devel
74
75 %description devel
76 Header files for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
77
78 %package gl
79 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
80 Group: X11/Libraries
81 Requires: %{name} = %{ver}
82 Provides: wxGTK-gl
83
84 %description gl
85 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
86
87 %package -n %{wxbasename}
88 Summary: The base classes
89 Group: Development/Libraries
90 Provides: wxBase
91
92 %description -n %{wxbasename}
93 A collection of GUI independent classes
94
95 %package -n %{wxbasename}-devel
96 Summary: The base classes header files
97 Group: Development/Libraries
98 Provides: wxBase-devel
99
100 %description -n %{wxbasename}-devel
101 A collection of GUI independent classes. Header files.
102
103 %package contrib
104 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
105 Group: X11/Libraries
106 Requires: %{name} = %{ver}
107
108 %description contrib
109 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
110
111 %package contrib-devel
112 Summary: The GTK+ %{gtkver} port of the wxWidgets library
113 Group: X11/Libraries
114 Requires: %{name}-contrib = %{ver}
115 Requires: %{name}-devel = %{ver}
116
117 %description contrib-devel
118 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
119
120 %prep
121 %setup -q -n wxGTK-%{ver}
122
123 %build
124 if [ "$SMP" != "" ]; then
125 export MAKE="make -j$SMP"
126 else
127 export MAKE="make"
128 fi
129
130 mkdir obj-shared
131 cd obj-shared
132 ../configure --prefix=%{pref} \
133 %if ! %{gtk2}
134 --with-gtk1 \
135 %else
136 --with-gtk2 \
137 %endif
138 %if %{unicode}
139 --enable-unicode \
140 %endif
141 --disable-optimise \
142 --with-opengl
143 $MAKE
144
145 cd contrib/src
146 $MAKE
147 cd ../../..
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 (cd obj-shared; make prefix=$RPM_BUILD_ROOT/usr install)
152
153 # --- wxBase headers list begins here ---
154 cat <<EOF >wxbase-headers.files
155 wx/afterstd.h
156 wx/app.h
157 wx/apptrait.h
158 wx/archive.h
159 wx/arrimpl.cpp
160 wx/arrstr.h
161 wx/beforestd.h
162 wx/buffer.h
163 wx/build.h
164 wx/chkconf.h
165 wx/clntdata.h
166 wx/cmdline.h
167 wx/confbase.h
168 wx/config.h
169 wx/containr.h
170 wx/datetime.h
171 wx/datetime.inl
172 wx/datstrm.h
173 wx/dde.h
174 wx/debug.h
175 wx/defs.h
176 wx/dir.h
177 wx/dlimpexp.h
178 wx/dynarray.h
179 wx/dynlib.h
180 wx/dynload.h
181 wx/encconv.h
182 wx/event.h
183 wx/except.h
184 wx/features.h
185 wx/ffile.h
186 wx/file.h
187 wx/fileconf.h
188 wx/filefn.h
189 wx/filename.h
190 wx/filesys.h
191 wx/fontenc.h
192 wx/fontmap.h
193 wx/fs_mem.h
194 wx/fs_zip.h
195 wx/hash.h
196 wx/hashmap.h
197 wx/hashset.h
198 wx/html/forcelnk.h
199 wx/iconloc.h
200 wx/init.h
201 wx/intl.h
202 wx/iosfwrap.h
203 wx/ioswrap.h
204 wx/ipc.h
205 wx/ipcbase.h
206 wx/isql.h
207 wx/isqlext.h
208 wx/list.h
209 wx/listimpl.cpp
210 wx/log.h
211 wx/longlong.h
212 wx/math.h
213 wx/memconf.h
214 wx/memory.h
215 wx/memtext.h
216 wx/mimetype.h
217 wx/module.h
218 wx/msgout.h
219 wx/mstream.h
220 wx/object.h
221 wx/platform.h
222 wx/process.h
223 wx/ptr_scpd.h
224 wx/regex.h
225 wx/scopeguard.h
226 wx/snglinst.h
227 wx/sstream.h
228 wx/stack.h
229 wx/stackwalk.h
230 wx/stdpaths.h
231 wx/stockitem.h
232 wx/stopwatch.h
233 wx/strconv.h
234 wx/stream.h
235 wx/string.h
236 wx/sysopt.h
237 wx/textbuf.h
238 wx/textfile.h
239 wx/thread.h
240 wx/thrimpl.cpp
241 wx/timer.h
242 wx/tokenzr.h
243 wx/txtstrm.h
244 wx/types.h
245 wx/uri.h
246 wx/utils.h
247 wx/variant.h
248 wx/vector.h
249 wx/version.h
250 wx/volume.h
251 wx/wfstream.h
252 wx/wx.h
253 wx/wxchar.h
254 wx/wxprec.h
255 wx/xti.h
256 wx/xtistrm.h
257 wx/zipstrm.h
258 wx/zstream.h
259 wx/fs_inet.h
260 wx/gsocket.h
261 wx/protocol/file.h
262 wx/protocol/ftp.h
263 wx/protocol/http.h
264 wx/protocol/protocol.h
265 wx/sckaddr.h
266 wx/sckipc.h
267 wx/sckstrm.h
268 wx/socket.h
269 wx/url.h
270 wx/xml/xml.h
271 wx/xtixml.h
272 wx/db.h
273 wx/dbkeyg.h
274 wx/dbtable.h
275 EOF
276 # --- wxBase headers list ends here ---
277 cat <<EOF >wxbase-headers.paths
278 %{_includedir}/wx-%{ver2}/wx/afterstd.h
279 %{_includedir}/wx-%{ver2}/wx/app.h
280 %{_includedir}/wx-%{ver2}/wx/apptrait.h
281 %{_includedir}/wx-%{ver2}/wx/archive.h
282 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
283 %{_includedir}/wx-%{ver2}/wx/arrstr.h
284 %{_includedir}/wx-%{ver2}/wx/beforestd.h
285 %{_includedir}/wx-%{ver2}/wx/buffer.h
286 %{_includedir}/wx-%{ver2}/wx/build.h
287 %{_includedir}/wx-%{ver2}/wx/chkconf.h
288 %{_includedir}/wx-%{ver2}/wx/clntdata.h
289 %{_includedir}/wx-%{ver2}/wx/cmdline.h
290 %{_includedir}/wx-%{ver2}/wx/confbase.h
291 %{_includedir}/wx-%{ver2}/wx/config.h
292 %{_includedir}/wx-%{ver2}/wx/containr.h
293 %{_includedir}/wx-%{ver2}/wx/datetime.h
294 %{_includedir}/wx-%{ver2}/wx/datetime.inl
295 %{_includedir}/wx-%{ver2}/wx/datstrm.h
296 %{_includedir}/wx-%{ver2}/wx/dde.h
297 %{_includedir}/wx-%{ver2}/wx/debug.h
298 %{_includedir}/wx-%{ver2}/wx/defs.h
299 %{_includedir}/wx-%{ver2}/wx/dir.h
300 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
301 %{_includedir}/wx-%{ver2}/wx/dynarray.h
302 %{_includedir}/wx-%{ver2}/wx/dynlib.h
303 %{_includedir}/wx-%{ver2}/wx/dynload.h
304 %{_includedir}/wx-%{ver2}/wx/encconv.h
305 %{_includedir}/wx-%{ver2}/wx/event.h
306 %{_includedir}/wx-%{ver2}/wx/except.h
307 %{_includedir}/wx-%{ver2}/wx/features.h
308 %{_includedir}/wx-%{ver2}/wx/ffile.h
309 %{_includedir}/wx-%{ver2}/wx/file.h
310 %{_includedir}/wx-%{ver2}/wx/fileconf.h
311 %{_includedir}/wx-%{ver2}/wx/filefn.h
312 %{_includedir}/wx-%{ver2}/wx/filename.h
313 %{_includedir}/wx-%{ver2}/wx/filesys.h
314 %{_includedir}/wx-%{ver2}/wx/fontenc.h
315 %{_includedir}/wx-%{ver2}/wx/fontmap.h
316 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
317 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
318 %{_includedir}/wx-%{ver2}/wx/hash.h
319 %{_includedir}/wx-%{ver2}/wx/hashmap.h
320 %{_includedir}/wx-%{ver2}/wx/hashset.h
321 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
322 %{_includedir}/wx-%{ver2}/wx/iconloc.h
323 %{_includedir}/wx-%{ver2}/wx/init.h
324 %{_includedir}/wx-%{ver2}/wx/intl.h
325 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
326 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
327 %{_includedir}/wx-%{ver2}/wx/ipc.h
328 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
329 %{_includedir}/wx-%{ver2}/wx/isql.h
330 %{_includedir}/wx-%{ver2}/wx/isqlext.h
331 %{_includedir}/wx-%{ver2}/wx/list.h
332 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
333 %{_includedir}/wx-%{ver2}/wx/log.h
334 %{_includedir}/wx-%{ver2}/wx/longlong.h
335 %{_includedir}/wx-%{ver2}/wx/math.h
336 %{_includedir}/wx-%{ver2}/wx/memconf.h
337 %{_includedir}/wx-%{ver2}/wx/memory.h
338 %{_includedir}/wx-%{ver2}/wx/memtext.h
339 %{_includedir}/wx-%{ver2}/wx/mimetype.h
340 %{_includedir}/wx-%{ver2}/wx/module.h
341 %{_includedir}/wx-%{ver2}/wx/msgout.h
342 %{_includedir}/wx-%{ver2}/wx/mstream.h
343 %{_includedir}/wx-%{ver2}/wx/object.h
344 %{_includedir}/wx-%{ver2}/wx/platform.h
345 %{_includedir}/wx-%{ver2}/wx/process.h
346 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
347 %{_includedir}/wx-%{ver2}/wx/regex.h
348 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
349 %{_includedir}/wx-%{ver2}/wx/snglinst.h
350 %{_includedir}/wx-%{ver2}/wx/sstream.h
351 %{_includedir}/wx-%{ver2}/wx/stack.h
352 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
353 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
354 %{_includedir}/wx-%{ver2}/wx/stockitem.h
355 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
356 %{_includedir}/wx-%{ver2}/wx/strconv.h
357 %{_includedir}/wx-%{ver2}/wx/stream.h
358 %{_includedir}/wx-%{ver2}/wx/string.h
359 %{_includedir}/wx-%{ver2}/wx/sysopt.h
360 %{_includedir}/wx-%{ver2}/wx/textbuf.h
361 %{_includedir}/wx-%{ver2}/wx/textfile.h
362 %{_includedir}/wx-%{ver2}/wx/thread.h
363 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
364 %{_includedir}/wx-%{ver2}/wx/timer.h
365 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
366 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
367 %{_includedir}/wx-%{ver2}/wx/types.h
368 %{_includedir}/wx-%{ver2}/wx/uri.h
369 %{_includedir}/wx-%{ver2}/wx/utils.h
370 %{_includedir}/wx-%{ver2}/wx/variant.h
371 %{_includedir}/wx-%{ver2}/wx/vector.h
372 %{_includedir}/wx-%{ver2}/wx/version.h
373 %{_includedir}/wx-%{ver2}/wx/volume.h
374 %{_includedir}/wx-%{ver2}/wx/wfstream.h
375 %{_includedir}/wx-%{ver2}/wx/wx.h
376 %{_includedir}/wx-%{ver2}/wx/wxchar.h
377 %{_includedir}/wx-%{ver2}/wx/wxprec.h
378 %{_includedir}/wx-%{ver2}/wx/xti.h
379 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
380 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
381 %{_includedir}/wx-%{ver2}/wx/zstream.h
382 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
383 %{_includedir}/wx-%{ver2}/wx/gsocket.h
384 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
385 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
386 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
387 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
388 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
389 %{_includedir}/wx-%{ver2}/wx/sckipc.h
390 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
391 %{_includedir}/wx-%{ver2}/wx/socket.h
392 %{_includedir}/wx-%{ver2}/wx/url.h
393 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
394 %{_includedir}/wx-%{ver2}/wx/xtixml.h
395 %{_includedir}/wx-%{ver2}/wx/db.h
396 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
397 %{_includedir}/wx-%{ver2}/wx/dbtable.h
398 EOF
399 # --- wxBase headers list ends here ---
400
401 # temporarily remove base headers
402 mkdir $RPM_BUILD_ROOT/_save_dir
403 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
404 for f in `cat wxbase-headers.files` ; do
405 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
406 done
407 # list of all core headers:
408 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
409 # move base headers (actually all headers) back again
410 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
411 rm -rf $RPM_BUILD_ROOT/_save_dir
412
413 # contrib stuff:
414 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT/usr install)
415 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT/usr install)
416
417 %clean
418 rm -rf $RPM_BUILD_ROOT
419
420 %post
421 /sbin/ldconfig
422
423 %postun
424 /sbin/ldconfig
425
426 %post devel
427 # link wx-config when you install RPM.
428 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
429 # link wx-config with explicit name.
430 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
431 /sbin/ldconfig
432
433 %postun devel
434 /sbin/ldconfig
435
436 %preun devel
437 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
438 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
439 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
440 if test "x$SUM1" = "x$SUM2" ; then
441 rm -f %{_bindir}/wx-config
442 fi
443 fi
444 rm -f %{_bindir}/%{wxconfiglink}
445
446 %post -n %{wxbasename}
447 /sbin/ldconfig
448
449 %postun -n %{wxbasename}
450 /sbin/ldconfig
451
452 %post -n %{wxbasename}-devel
453 # link wx-config with explicit name.
454 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
455 /sbin/ldconfig
456
457 %postun -n %{wxbasename}-devel
458 /sbin/ldconfig
459
460 %preun -n %{wxbasename}-devel
461 rm -f %{_bindir}/%{wxbaseconfiglink}
462
463 %post gl
464 /sbin/ldconfig
465
466 %postun gl
467 /sbin/ldconfig
468
469 %post contrib
470 /sbin/ldconfig
471
472 %postun contrib
473 /sbin/ldconfig
474
475 %post contrib-devel
476 /sbin/ldconfig
477
478 %postun contrib-devel
479 /sbin/ldconfig
480
481 %files
482 %defattr(-,root,root)
483 %doc COPYING.LIB *.txt
484 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
485 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
486 %if !%{unicode}
487 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
488 %endif
489 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
490 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
491 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
492 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
493
494
495 %files devel -f core-headers.files
496 %defattr(-,root,root)
497 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
498 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
499 %if !%{unicode}
500 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
501 %endif
502 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
503 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
504 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
505 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
506 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
507 %dir %{_libdir}/wx
508 %{_libdir}/wx/config/%{wxconfig}
509 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
510 %{_bindir}/wxrc*
511
512 %files -n %{wxbasename}
513 %defattr(-,root,root)
514 %{_libdir}/libwx_base*-%{ver2}.so.*
515 #%{_datadir}/locale/*/*/*
516 # %if %{unicode}
517 # %{_libdir}/libwxregexu-%{ver2}.a
518 #%endif
519
520 %files -n %{wxbasename}-devel -f wxbase-headers.paths
521 %defattr (-,root,root)
522 %dir %{_includedir}/wx-%{ver2}
523 %{_libdir}/libwx_base*-%{ver2}.so
524 #%dir %{_libdir}/wx
525 #%{_libdir}/wx/config/%{wxbaseconfig}
526 #%{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
527 %{_datadir}/aclocal/*.m4
528
529 %files gl
530 %defattr(-,root,root)
531 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
532
533 %files contrib
534 %defattr(-,root,root)
535 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
536 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
537 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
538 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
539 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
540 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
541 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
542 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
543 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
544
545 %files contrib-devel
546 %defattr(-,root,root)
547 %dir %{_includedir}/wx-%{ver2}/wx/animate
548 %{_includedir}/wx-%{ver2}/wx/animate/*
549 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
550
551 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
552 %{_includedir}/wx-%{ver2}/wx/deprecated/*
553 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
554
555 %dir %{_includedir}/wx-%{ver2}/wx/fl
556 %{_includedir}/wx-%{ver2}/wx/fl/*
557 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
558
559 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
560 %{_includedir}/wx-%{ver2}/wx/gizmos/*
561 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
562
563 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
564 %{_includedir}/wx-%{ver2}/wx/mmedia/*
565 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
566
567 %dir %{_includedir}/wx-%{ver2}/wx/ogl
568 %{_includedir}/wx-%{ver2}/wx/ogl/*
569 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
570
571 %dir %{_includedir}/wx-%{ver2}/wx/plot
572 %{_includedir}/wx-%{ver2}/wx/plot/*
573 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
574
575 %dir %{_includedir}/wx-%{ver2}/wx/stc
576 %{_includedir}/wx-%{ver2}/wx/stc/*
577 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
578
579 %dir %{_includedir}/wx-%{ver2}/wx/svg
580 %{_includedir}/wx-%{ver2}/wx/svg/*
581 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so