Split intl.h into intl.h, language.h and translation.h.
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.1
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --disable-unicode \
109 %endif
110 $MAKE
111
112 cd contrib/src
113 $MAKE
114 cd ../../..
115
116 mkdir obj-static
117 cd obj-static
118 ../configure --prefix=%{pref} --with-x11 --disable-shared \
119 %if %{unicode}
120 --enable-unicode \
121 %else
122 --disable-unicode \
123 %endif
124 --with-opengl
125 $MAKE
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
131 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
132
133 # Remove headers that are part of wx-base-devel:
134
135 # --- wxBase headers list begins here ---
136 cat <<EOF >wxbase-headers.files
137 wx/afterstd.h
138 wx/any.h
139 wx/anystr.h
140 wx/app.h
141 wx/apptrait.h
142 wx/archive.h
143 wx/arrimpl.cpp
144 wx/arrstr.h
145 wx/atomic.h
146 wx/base64.h
147 wx/beforestd.h
148 wx/buffer.h
149 wx/build.h
150 wx/chartype.h
151 wx/checkeddelete.h
152 wx/chkconf.h
153 wx/clntdata.h
154 wx/cmdargs.h
155 wx/cmdline.h
156 wx/confbase.h
157 wx/config.h
158 wx/convauto.h
159 wx/containr.h
160 wx/cpp.h
161 wx/crt.h
162 wx/datetime.h
163 wx/datstrm.h
164 wx/dde.h
165 wx/debug.h
166 wx/defs.h
167 wx/dir.h
168 wx/dlimpexp.h
169 wx/dlist.h
170 wx/dynarray.h
171 wx/dynlib.h
172 wx/dynload.h
173 wx/encconv.h
174 wx/event.h
175 wx/evtloop.h
176 wx/except.h
177 wx/features.h
178 wx/flags.h
179 wx/ffile.h
180 wx/file.h
181 wx/fileconf.h
182 wx/filefn.h
183 wx/filename.h
184 wx/filesys.h
185 wx/fontenc.h
186 wx/fontmap.h
187 wx/fs_arc.h
188 wx/fs_filter.h
189 wx/fs_mem.h
190 wx/fs_zip.h
191 wx/hash.h
192 wx/hashmap.h
193 wx/hashset.h
194 wx/html/forcelnk.h
195 wx/iconloc.h
196 wx/init.h
197 wx/intl.h
198 wx/iosfwrap.h
199 wx/ioswrap.h
200 wx/ipc.h
201 wx/ipcbase.h
202 wx/kbdstate.h
203 wx/language.h
204 wx/link.h
205 wx/list.h
206 wx/listimpl.cpp
207 wx/log.h
208 wx/longlong.h
209 wx/math.h
210 wx/memconf.h
211 wx/memory.h
212 wx/memtext.h
213 wx/mimetype.h
214 wx/module.h
215 wx/mousestate.h
216 wx/msgout.h
217 wx/mstream.h
218 wx/object.h
219 wx/platform.h
220 wx/platinfo.h
221 wx/power.h
222 wx/process.h
223 wx/ptr_scpd.h
224 wx/ptr_shrd.h
225 wx/recguard.h
226 wx/regex.h
227 wx/scopedarray.h
228 wx/scopedptr.h
229 wx/scopeguard.h
230 wx/sharedptr.h
231 wx/snglinst.h
232 wx/sstream.h
233 wx/stack.h
234 wx/stackwalk.h
235 wx/stdpaths.h
236 wx/stdstream.h
237 wx/stockitem.h
238 wx/stopwatch.h
239 wx/strconv.h
240 wx/stream.h
241 wx/string.h
242 wx/stringimpl.h
243 wx/stringops.h
244 wx/strvararg.h
245 wx/sysopt.h
246 wx/tarstrm.h
247 wx/textbuf.h
248 wx/textfile.h
249 wx/thread.h
250 wx/thrimpl.cpp
251 wx/timer.h
252 wx/tls.h
253 wx/tokenzr.h
254 wx/tracker.h
255 wx/translation.h
256 wx/txtstrm.h
257 wx/typeinfo.h
258 wx/types.h
259 wx/unichar.h
260 wx/uri.h
261 wx/ustring.h
262 wx/utils.h
263 wx/variant.h
264 wx/vector.h
265 wx/version.h
266 wx/volume.h
267 wx/weakref.h
268 wx/wfstream.h
269 wx/wx.h
270 wx/wxchar.h
271 wx/wxcrt.h
272 wx/wxcrtbase.h
273 wx/wxcrtvararg.h
274 wx/wxprec.h
275 wx/xlocale.h
276 wx/xti.h
277 wx/xtistrm.h
278 wx/zipstrm.h
279 wx/zstream.h
280 wx/meta/convertible.h
281 wx/meta/if.h
282 wx/meta/int2type.h
283 wx/meta/movable.h
284 wx/fswatcher.h
285 wx/generic/fswatcher.h
286 wx/unix/app.h
287 wx/unix/apptbase.h
288 wx/unix/apptrait.h
289 wx/unix/chkconf.h
290 wx/unix/evtloop.h
291 wx/unix/evtloopsrc.h
292 wx/unix/pipe.h
293 wx/unix/stdpaths.h
294 wx/unix/stackwalk.h
295 wx/unix/tls.h
296 wx/unix/fswatcher_kqueue.h
297 wx/unix/execute.h
298 wx/unix/mimetype.h
299 wx/unix/fswatcher_inotify.h
300 wx/fs_inet.h
301 wx/protocol/file.h
302 wx/protocol/ftp.h
303 wx/protocol/http.h
304 wx/protocol/log.h
305 wx/protocol/protocol.h
306 wx/sckaddr.h
307 wx/sckipc.h
308 wx/sckstrm.h
309 wx/socket.h
310 wx/url.h
311 wx/xml/xml.h
312 wx/xtixml.h
313 EOF
314 # --- wxBase headers list ends here ---
315 for f in `cat wxbase-headers-list` ; do
316 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
317 done
318
319 # list of all core headers:
320 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
321
322 # contrib stuff:
323 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
324 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
325
326 # remove wxBase files so that RPM doesn't complain about unpackaged files:
327 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
328 %if %{unicode}
329 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
330 %endif
331 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
332 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
333
334 %clean
335 rm -rf $RPM_BUILD_ROOT
336
337 %post
338 /sbin/ldconfig
339
340 %postun
341 /sbin/ldconfig
342
343 %post devel
344 # link wx-config when you install RPM.
345 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
346 # link wx-config with explicit name.
347 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
348 /sbin/ldconfig
349
350 %postun devel
351 /sbin/ldconfig
352
353 %preun devel
354 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
355 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
356 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
357 if test "x$SUM1" = "x$SUM2" ; then
358 rm -f %{_bindir}/wx-config
359 fi
360 fi
361 rm -f %{_bindir}/%{wxconfiglink}
362
363 %post gl
364 /sbin/ldconfig
365
366 %postun gl
367 /sbin/ldconfig
368
369 %post contrib
370 /sbin/ldconfig
371
372 %postun contrib
373 /sbin/ldconfig
374
375 %post contrib-devel
376 /sbin/ldconfig
377
378 %postun contrib-devel
379 /sbin/ldconfig
380
381 %files
382 %defattr(-,root,root)
383 %doc COPYING.LIB *.txt
384 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
385 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
386 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
387 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
388 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
389 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
390
391
392 %files devel -f core-headers.files
393 %defattr(-,root,root)
394 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
395 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
396 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
397 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
398 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
399 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
400 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
401 %dir %{_libdir}/wx
402 %{_libdir}/wx/*
403 %{_bindir}/wxrc*
404
405 %files gl
406 %defattr(-,root,root)
407 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
408
409 %files static
410 %defattr (-,root,root)
411 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
412
413 %files contrib
414 %defattr(-,root,root)
415 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
416 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
417 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
418 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
419 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
420 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
421 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
422 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
423 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
424
425 %files contrib-devel
426 %defattr(-,root,root)
427 %dir %{_includedir}/wx-%{ver2}/wx/animate
428 %{_includedir}/wx-%{ver2}/wx/animate/*
429 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
430
431 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
432 %{_includedir}/wx-%{ver2}/wx/deprecated/*
433 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
434
435 %dir %{_includedir}/wx-%{ver2}/wx/fl
436 %{_includedir}/wx-%{ver2}/wx/fl/*
437 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
438
439 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
440 %{_includedir}/wx-%{ver2}/wx/gizmos/*
441 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
442
443 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
444 %{_includedir}/wx-%{ver2}/wx/mmedia/*
445 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
446
447 %dir %{_includedir}/wx-%{ver2}/wx/ogl
448 %{_includedir}/wx-%{ver2}/wx/ogl/*
449 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
450
451 %dir %{_includedir}/wx-%{ver2}/wx/plot
452 %{_includedir}/wx-%{ver2}/wx/plot/*
453 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
454
455 %dir %{_includedir}/wx-%{ver2}/wx/stc
456 %{_includedir}/wx-%{ver2}/wx/stc/*
457 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
458
459 %dir %{_includedir}/wx-%{ver2}/wx/svg
460 %{_includedir}/wx-%{ver2}/wx/svg/*
461 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so