Split intl.h into intl.h, language.h and translation.h.
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.1
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/any.h
115 wx/anystr.h
116 wx/app.h
117 wx/apptrait.h
118 wx/archive.h
119 wx/arrimpl.cpp
120 wx/arrstr.h
121 wx/atomic.h
122 wx/base64.h
123 wx/beforestd.h
124 wx/buffer.h
125 wx/build.h
126 wx/chartype.h
127 wx/checkeddelete.h
128 wx/chkconf.h
129 wx/clntdata.h
130 wx/cmdargs.h
131 wx/cmdline.h
132 wx/confbase.h
133 wx/config.h
134 wx/convauto.h
135 wx/containr.h
136 wx/cpp.h
137 wx/crt.h
138 wx/datetime.h
139 wx/datstrm.h
140 wx/dde.h
141 wx/debug.h
142 wx/defs.h
143 wx/dir.h
144 wx/dlimpexp.h
145 wx/dlist.h
146 wx/dynarray.h
147 wx/dynlib.h
148 wx/dynload.h
149 wx/encconv.h
150 wx/event.h
151 wx/evtloop.h
152 wx/except.h
153 wx/features.h
154 wx/flags.h
155 wx/ffile.h
156 wx/file.h
157 wx/fileconf.h
158 wx/filefn.h
159 wx/filename.h
160 wx/filesys.h
161 wx/fontenc.h
162 wx/fontmap.h
163 wx/fs_arc.h
164 wx/fs_filter.h
165 wx/fs_mem.h
166 wx/fs_zip.h
167 wx/hash.h
168 wx/hashmap.h
169 wx/hashset.h
170 wx/html/forcelnk.h
171 wx/iconloc.h
172 wx/init.h
173 wx/intl.h
174 wx/iosfwrap.h
175 wx/ioswrap.h
176 wx/ipc.h
177 wx/ipcbase.h
178 wx/kbdstate.h
179 wx/language.h
180 wx/link.h
181 wx/list.h
182 wx/listimpl.cpp
183 wx/log.h
184 wx/longlong.h
185 wx/math.h
186 wx/memconf.h
187 wx/memory.h
188 wx/memtext.h
189 wx/mimetype.h
190 wx/module.h
191 wx/mousestate.h
192 wx/msgout.h
193 wx/mstream.h
194 wx/object.h
195 wx/platform.h
196 wx/platinfo.h
197 wx/power.h
198 wx/process.h
199 wx/ptr_scpd.h
200 wx/ptr_shrd.h
201 wx/recguard.h
202 wx/regex.h
203 wx/scopedarray.h
204 wx/scopedptr.h
205 wx/scopeguard.h
206 wx/sharedptr.h
207 wx/snglinst.h
208 wx/sstream.h
209 wx/stack.h
210 wx/stackwalk.h
211 wx/stdpaths.h
212 wx/stdstream.h
213 wx/stockitem.h
214 wx/stopwatch.h
215 wx/strconv.h
216 wx/stream.h
217 wx/string.h
218 wx/stringimpl.h
219 wx/stringops.h
220 wx/strvararg.h
221 wx/sysopt.h
222 wx/tarstrm.h
223 wx/textbuf.h
224 wx/textfile.h
225 wx/thread.h
226 wx/thrimpl.cpp
227 wx/timer.h
228 wx/tls.h
229 wx/tokenzr.h
230 wx/tracker.h
231 wx/translation.h
232 wx/txtstrm.h
233 wx/typeinfo.h
234 wx/types.h
235 wx/unichar.h
236 wx/uri.h
237 wx/ustring.h
238 wx/utils.h
239 wx/variant.h
240 wx/vector.h
241 wx/version.h
242 wx/volume.h
243 wx/weakref.h
244 wx/wfstream.h
245 wx/wx.h
246 wx/wxchar.h
247 wx/wxcrt.h
248 wx/wxcrtbase.h
249 wx/wxcrtvararg.h
250 wx/wxprec.h
251 wx/xlocale.h
252 wx/xti.h
253 wx/xtistrm.h
254 wx/zipstrm.h
255 wx/zstream.h
256 wx/meta/convertible.h
257 wx/meta/if.h
258 wx/meta/int2type.h
259 wx/meta/movable.h
260 wx/fswatcher.h
261 wx/generic/fswatcher.h
262 wx/unix/app.h
263 wx/unix/apptbase.h
264 wx/unix/apptrait.h
265 wx/unix/chkconf.h
266 wx/unix/evtloop.h
267 wx/unix/evtloopsrc.h
268 wx/unix/pipe.h
269 wx/unix/stdpaths.h
270 wx/unix/stackwalk.h
271 wx/unix/tls.h
272 wx/unix/fswatcher_kqueue.h
273 wx/unix/execute.h
274 wx/unix/mimetype.h
275 wx/unix/fswatcher_inotify.h
276 wx/fs_inet.h
277 wx/protocol/file.h
278 wx/protocol/ftp.h
279 wx/protocol/http.h
280 wx/protocol/log.h
281 wx/protocol/protocol.h
282 wx/sckaddr.h
283 wx/sckipc.h
284 wx/sckstrm.h
285 wx/socket.h
286 wx/url.h
287 wx/xml/xml.h
288 wx/xtixml.h
289 EOF
290 # --- wxBase headers list ends here ---
291 for f in `cat wxbase-headers-list` ; do
292 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
293 done
294
295 # list of all core headers:
296 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
297
298 # contrib stuff:
299 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
300 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
301
302 # remove wxBase files so that RPM doesn't complain about unpackaged files:
303 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
304 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
305 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
306
307 %clean
308 rm -rf $RPM_BUILD_ROOT
309
310 %post
311 /sbin/ldconfig
312
313 %postun
314 /sbin/ldconfig
315
316 %post devel
317 # link wx-config when you install RPM.
318 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
319 # link wx-config with explicit name.
320 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
321 /sbin/ldconfig
322
323 %postun devel
324 /sbin/ldconfig
325
326 %preun devel
327 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
328 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
329 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
330 if test "x$SUM1" = "x$SUM2" ; then
331 rm -f %{_bindir}/wx-config
332 fi
333 fi
334 rm -f %{_bindir}/%{wxconfiglink}
335
336 %post gl
337 /sbin/ldconfig
338
339 %postun gl
340 /sbin/ldconfig
341
342 %post contrib
343 /sbin/ldconfig
344
345 %postun contrib
346 /sbin/ldconfig
347
348 %post contrib-devel
349 /sbin/ldconfig
350
351 %postun contrib-devel
352 /sbin/ldconfig
353
354 %files
355 %defattr(-,root,root)
356 %doc COPYING.LIB *.txt
357 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
358 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
359 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
360 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
361 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
362 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
363
364
365 %files devel -f core-headers.files
366 %defattr(-,root,root)
367 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
368 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
369 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
370 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
371 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
372 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
373 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
374 %dir %{_libdir}/wx
375 %{_libdir}/wx/*
376 %{_bindir}/wxrc*
377
378 %files gl
379 %defattr(-,root,root)
380 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
381
382 %files static
383 %defattr (-,root,root)
384 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
385
386 %files contrib
387 %defattr(-,root,root)
388 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
389 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
390 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
391 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
392 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
393 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
394 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
395 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
396 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
397
398 %files contrib-devel
399 %defattr(-,root,root)
400 %dir %{_includedir}/wx-%{ver2}/wx/animate
401 %{_includedir}/wx-%{ver2}/wx/animate/*
402 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
403
404 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
405 %{_includedir}/wx-%{ver2}/wx/deprecated/*
406 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
407
408 %dir %{_includedir}/wx-%{ver2}/wx/fl
409 %{_includedir}/wx-%{ver2}/wx/fl/*
410 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
411
412 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
413 %{_includedir}/wx-%{ver2}/wx/gizmos/*
414 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
415
416 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
417 %{_includedir}/wx-%{ver2}/wx/mmedia/*
418 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
419
420 %dir %{_includedir}/wx-%{ver2}/wx/ogl
421 %{_includedir}/wx-%{ver2}/wx/ogl/*
422 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
423
424 %dir %{_includedir}/wx-%{ver2}/wx/plot
425 %{_includedir}/wx-%{ver2}/wx/plot/*
426 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
427
428 %dir %{_includedir}/wx-%{ver2}/wx/stc
429 %{_includedir}/wx-%{ver2}/wx/stc/*
430 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
431
432 %dir %{_includedir}/wx-%{ver2}/wx/svg
433 %{_includedir}/wx-%{ver2}/wx/svg/*
434 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so