moved vararg CRT functions wrappers to a new wxcrtvararg.h header
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 --with-odbc \
171 %endif
172 --with-opengl
173 $MAKE
174
175 cd contrib/src
176 $MAKE
177 cd ../../..
178
179 mkdir obj-static
180 cd obj-static
181 ../configure --prefix=%{_prefix} \
182 %if ! %{gtk2}
183 --with-gtk=1 \
184 %else
185 --with-gtk=2 \
186 %endif
187 --disable-shared \
188 %if %{unicode}
189 --enable-unicode \
190 %else
191 --disable-unicode \
192 --with-odbc \
193 %endif
194 --with-opengl
195 $MAKE
196
197 cd contrib/src
198 $MAKE
199 cd ../../..
200
201 make -C locale allmo
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208 # --- wxBase headers list begins here ---
209 cat <<EOF >wxbase-headers.files
210 wx/afterstd.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/chkconf.h
221 wx/clntdata.h
222 wx/cmdline.h
223 wx/confbase.h
224 wx/config.h
225 wx/convauto.h
226 wx/containr.h
227 wx/cpp.h
228 wx/datetime.h
229 wx/datstrm.h
230 wx/dde.h
231 wx/debug.h
232 wx/defs.h
233 wx/dir.h
234 wx/dlimpexp.h
235 wx/dynarray.h
236 wx/dynlib.h
237 wx/dynload.h
238 wx/encconv.h
239 wx/event.h
240 wx/except.h
241 wx/features.h
242 wx/flags.h
243 wx/ffile.h
244 wx/file.h
245 wx/fileconf.h
246 wx/filefn.h
247 wx/filename.h
248 wx/filesys.h
249 wx/fontenc.h
250 wx/fontmap.h
251 wx/fs_arc.h
252 wx/fs_filter.h
253 wx/fs_mem.h
254 wx/fs_zip.h
255 wx/hash.h
256 wx/hashmap.h
257 wx/hashset.h
258 wx/html/forcelnk.h
259 wx/iconloc.h
260 wx/init.h
261 wx/intl.h
262 wx/iosfwrap.h
263 wx/ioswrap.h
264 wx/ipc.h
265 wx/ipcbase.h
266 wx/isql.h
267 wx/isqlext.h
268 wx/link.h
269 wx/list.h
270 wx/listimpl.cpp
271 wx/log.h
272 wx/longlong.h
273 wx/math.h
274 wx/memconf.h
275 wx/memory.h
276 wx/memtext.h
277 wx/mimetype.h
278 wx/module.h
279 wx/msgout.h
280 wx/mstream.h
281 wx/object.h
282 wx/platform.h
283 wx/platinfo.h
284 wx/power.h
285 wx/process.h
286 wx/ptr_scpd.h
287 wx/recguard.h
288 wx/regex.h
289 wx/scopeguard.h
290 wx/snglinst.h
291 wx/sstream.h
292 wx/stack.h
293 wx/stackwalk.h
294 wx/stdpaths.h
295 wx/stockitem.h
296 wx/stopwatch.h
297 wx/strconv.h
298 wx/stream.h
299 wx/string.h
300 wx/stringimpl.h
301 wx/strvararg.h
302 wx/sysopt.h
303 wx/tarstrm.h
304 wx/textbuf.h
305 wx/textfile.h
306 wx/thread.h
307 wx/thrimpl.cpp
308 wx/timer.h
309 wx/tokenzr.h
310 wx/txtstrm.h
311 wx/types.h
312 wx/unichar.h
313 wx/uri.h
314 wx/utils.h
315 wx/variant.h
316 wx/vector.h
317 wx/version.h
318 wx/volume.h
319 wx/wfstream.h
320 wx/wx.h
321 wx/wxchar.h
322 wx/wxcrt.h
323 wx/wxcrtvararg.h
324 wx/wxprec.h
325 wx/xti.h
326 wx/xtistrm.h
327 wx/zipstrm.h
328 wx/zstream.h
329 wx/unix/apptbase.h
330 wx/unix/apptrait.h
331 wx/unix/execute.h
332 wx/unix/mimetype.h
333 wx/unix/pipe.h
334 wx/unix/private.h
335 wx/unix/stackwalk.h
336 wx/unix/stdpaths.h
337 wx/fs_inet.h
338 wx/gsocket.h
339 wx/protocol/file.h
340 wx/protocol/ftp.h
341 wx/protocol/http.h
342 wx/protocol/protocol.h
343 wx/sckaddr.h
344 wx/sckipc.h
345 wx/sckstrm.h
346 wx/socket.h
347 wx/url.h
348 wx/unix/gsockunx.h
349 wx/xml/xml.h
350 wx/xtixml.h
351 wx/db.h
352 wx/dbkeyg.h
353 wx/dbtable.h
354 EOF
355 # --- wxBase headers list ends here ---
356 cat <<EOF >wxbase-headers.paths
357 %{_includedir}/wx-%{ver2}/wx/afterstd.h
358 %{_includedir}/wx-%{ver2}/wx/app.h
359 %{_includedir}/wx-%{ver2}/wx/apptrait.h
360 %{_includedir}/wx-%{ver2}/wx/archive.h
361 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
362 %{_includedir}/wx-%{ver2}/wx/arrstr.h
363 %{_includedir}/wx-%{ver2}/wx/beforestd.h
364 %{_includedir}/wx-%{ver2}/wx/buffer.h
365 %{_includedir}/wx-%{ver2}/wx/build.h
366 %{_includedir}/wx-%{ver2}/wx/chkconf.h
367 %{_includedir}/wx-%{ver2}/wx/clntdata.h
368 %{_includedir}/wx-%{ver2}/wx/cmdline.h
369 %{_includedir}/wx-%{ver2}/wx/confbase.h
370 %{_includedir}/wx-%{ver2}/wx/config.h
371 %{_includedir}/wx-%{ver2}/wx/containr.h
372 %{_includedir}/wx-%{ver2}/wx/convauto.h
373 %{_includedir}/wx-%{ver2}/wx/datetime.h
374 %{_includedir}/wx-%{ver2}/wx/datstrm.h
375 %{_includedir}/wx-%{ver2}/wx/dde.h
376 %{_includedir}/wx-%{ver2}/wx/debug.h
377 %{_includedir}/wx-%{ver2}/wx/defs.h
378 %{_includedir}/wx-%{ver2}/wx/dir.h
379 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
380 %{_includedir}/wx-%{ver2}/wx/dynarray.h
381 %{_includedir}/wx-%{ver2}/wx/dynlib.h
382 %{_includedir}/wx-%{ver2}/wx/dynload.h
383 %{_includedir}/wx-%{ver2}/wx/encconv.h
384 %{_includedir}/wx-%{ver2}/wx/event.h
385 %{_includedir}/wx-%{ver2}/wx/except.h
386 %{_includedir}/wx-%{ver2}/wx/features.h
387 %{_includedir}/wx-%{ver2}/wx/ffile.h
388 %{_includedir}/wx-%{ver2}/wx/file.h
389 %{_includedir}/wx-%{ver2}/wx/fileconf.h
390 %{_includedir}/wx-%{ver2}/wx/filefn.h
391 %{_includedir}/wx-%{ver2}/wx/filename.h
392 %{_includedir}/wx-%{ver2}/wx/filesys.h
393 %{_includedir}/wx-%{ver2}/wx/fontenc.h
394 %{_includedir}/wx-%{ver2}/wx/fontmap.h
395 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
396 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
397 %{_includedir}/wx-%{ver2}/wx/hash.h
398 %{_includedir}/wx-%{ver2}/wx/hashmap.h
399 %{_includedir}/wx-%{ver2}/wx/hashset.h
400 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
401 %{_includedir}/wx-%{ver2}/wx/iconloc.h
402 %{_includedir}/wx-%{ver2}/wx/init.h
403 %{_includedir}/wx-%{ver2}/wx/intl.h
404 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
405 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
406 %{_includedir}/wx-%{ver2}/wx/ipc.h
407 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
408 %{_includedir}/wx-%{ver2}/wx/isql.h
409 %{_includedir}/wx-%{ver2}/wx/isqlext.h
410 %{_includedir}/wx-%{ver2}/wx/link.h
411 %{_includedir}/wx-%{ver2}/wx/list.h
412 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
413 %{_includedir}/wx-%{ver2}/wx/log.h
414 %{_includedir}/wx-%{ver2}/wx/longlong.h
415 %{_includedir}/wx-%{ver2}/wx/math.h
416 %{_includedir}/wx-%{ver2}/wx/memconf.h
417 %{_includedir}/wx-%{ver2}/wx/memory.h
418 %{_includedir}/wx-%{ver2}/wx/memtext.h
419 %{_includedir}/wx-%{ver2}/wx/mimetype.h
420 %{_includedir}/wx-%{ver2}/wx/module.h
421 %{_includedir}/wx-%{ver2}/wx/msgout.h
422 %{_includedir}/wx-%{ver2}/wx/mstream.h
423 %{_includedir}/wx-%{ver2}/wx/object.h
424 %{_includedir}/wx-%{ver2}/wx/platform.h
425 %{_includedir}/wx-%{ver2}/wx/power.h
426 %{_includedir}/wx-%{ver2}/wx/process.h
427 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
428 %{_includedir}/wx-%{ver2}/wx/recguard.h
429 %{_includedir}/wx-%{ver2}/wx/regex.h
430 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
431 %{_includedir}/wx-%{ver2}/wx/snglinst.h
432 %{_includedir}/wx-%{ver2}/wx/sstream.h
433 %{_includedir}/wx-%{ver2}/wx/stack.h
434 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
435 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
436 %{_includedir}/wx-%{ver2}/wx/stockitem.h
437 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
438 %{_includedir}/wx-%{ver2}/wx/strconv.h
439 %{_includedir}/wx-%{ver2}/wx/stream.h
440 %{_includedir}/wx-%{ver2}/wx/string.h
441 %{_includedir}/wx-%{ver2}/wx/sysopt.h
442 %{_includedir}/wx-%{ver2}/wx/textbuf.h
443 %{_includedir}/wx-%{ver2}/wx/textfile.h
444 %{_includedir}/wx-%{ver2}/wx/thread.h
445 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
446 %{_includedir}/wx-%{ver2}/wx/timer.h
447 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
448 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
449 %{_includedir}/wx-%{ver2}/wx/types.h
450 %{_includedir}/wx-%{ver2}/wx/uri.h
451 %{_includedir}/wx-%{ver2}/wx/utils.h
452 %{_includedir}/wx-%{ver2}/wx/variant.h
453 %{_includedir}/wx-%{ver2}/wx/vector.h
454 %{_includedir}/wx-%{ver2}/wx/version.h
455 %{_includedir}/wx-%{ver2}/wx/volume.h
456 %{_includedir}/wx-%{ver2}/wx/wfstream.h
457 %{_includedir}/wx-%{ver2}/wx/wx.h
458 %{_includedir}/wx-%{ver2}/wx/wxchar.h
459 %{_includedir}/wx-%{ver2}/wx/wxprec.h
460 %{_includedir}/wx-%{ver2}/wx/xti.h
461 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
462 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
463 %{_includedir}/wx-%{ver2}/wx/zstream.h
464 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
465 %{_includedir}/wx-%{ver2}/wx/gsocket.h
466 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
467 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
468 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
469 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
470 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
471 %{_includedir}/wx-%{ver2}/wx/sckipc.h
472 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
473 %{_includedir}/wx-%{ver2}/wx/socket.h
474 %{_includedir}/wx-%{ver2}/wx/url.h
475 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
476 %{_includedir}/wx-%{ver2}/wx/xtixml.h
477 %{_includedir}/wx-%{ver2}/wx/db.h
478 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
479 %{_includedir}/wx-%{ver2}/wx/dbtable.h
480 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
481 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
482 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
483 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
484 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
485 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
486 %{_includedir}/wx-%{ver2}/wx/unix/private.h
487 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
488 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
489 EOF
490 # --- wxBase headers list ends here ---
491
492 # temporarily remove base headers
493 mkdir $RPM_BUILD_ROOT/_save_dir
494 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
495 for f in `cat wxbase-headers.files` ; do
496 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
497 done
498 # list of all core headers:
499 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
500 # move base headers (actually all headers) back again
501 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
502 rm -rf $RPM_BUILD_ROOT/_save_dir
503
504 # contrib stuff:
505 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
506 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
507
508 # utils:
509 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
510
511 # wx-config link is created during package installation, remove it for now
512 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
513
514 %clean
515 rm -rf $RPM_BUILD_ROOT
516
517 %post
518 /sbin/ldconfig
519
520 %postun
521 /sbin/ldconfig
522
523 %post devel
524 # link wx-config when you install RPM.
525 %if %{unicode}
526 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
527 %endif
528 # link wx-config with explicit name.
529 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
530 /sbin/ldconfig
531
532 %postun devel
533 /sbin/ldconfig
534
535 %preun devel
536 %if %{unicode}
537 rm -f %{_bindir}/wx-config
538 %endif
539 rm -f %{_bindir}/%{wxconfiglink}
540
541 %post -n %{wxbasename}
542 /sbin/ldconfig
543
544 %postun -n %{wxbasename}
545 /sbin/ldconfig
546
547 %post -n %{wxbasename}-devel
548 # link wx-config with explicit name.
549 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
550 /sbin/ldconfig
551
552 %postun -n %{wxbasename}-devel
553 /sbin/ldconfig
554
555 %preun -n %{wxbasename}-devel
556 rm -f %{_bindir}/%{wxbaseconfiglink}
557
558 %post gl
559 /sbin/ldconfig
560
561 %postun gl
562 /sbin/ldconfig
563
564 %post contrib
565 /sbin/ldconfig
566
567 %postun contrib
568 /sbin/ldconfig
569
570 %post contrib-devel
571 /sbin/ldconfig
572
573 %postun contrib-devel
574 /sbin/ldconfig
575
576 %files
577 %defattr(-,root,root)
578 %doc COPYING.LIB *.txt
579 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
580 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
581 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
582 %if !%{unicode}
583 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
584 %endif
585 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
586 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
587 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
588 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
589 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
590
591 %files -n wx-i18n
592 %defattr(-,root,root)
593 %{_datadir}/locale/*/LC_MESSAGES/*.mo
594
595 %files devel -f core-headers.files
596 %defattr(-,root,root)
597 # shared libs
598 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
599 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
601 %if !%{unicode}
602 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
603 %endif
604 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
606 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
607 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
608 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
610 # static libs
611 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
612 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
613 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
614 %if !%{unicode}
615 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
616 %endif
617 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
618 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
619 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
620 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
622 %dir %{_libdir}/wx
623 %{_libdir}/wx/config/%{wxconfig}
624 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
625 %{_libdir}/wx/config/%{wxconfigstatic}
626 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
627 %{_bindir}/wxrc*
628
629 %files -n %{wxbasename}
630 %defattr(-,root,root)
631 %{_libdir}/libwx_base*-%{ver2}.so.*
632
633 %files -n %{wxbasename}-devel -f wxbase-headers.paths
634 %defattr (-,root,root)
635 %dir %{_includedir}/wx-%{ver2}
636 %{_libdir}/libwx_base*-%{ver2}.so
637 %{_libdir}/libwx_base*-%{ver2}.a
638 %if %{unicode}
639 %{_libdir}/libwxregexu-%{ver2}.a
640 %endif
641 %dir %{_libdir}/wx
642 %{_datadir}/aclocal/*.m4
643 %{_datadir}/bakefile/presets/*
644
645 %files gl
646 %defattr(-,root,root)
647 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
648
649 %files contrib
650 %defattr(-,root,root)
651 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
653 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
655 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
661
662 # static libs
663 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
664 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
665 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
666 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
667 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
668 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
671 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
672 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
673
674 %files contrib-devel
675 %defattr(-,root,root)
676 %dir %{_includedir}/wx-%{ver2}/wx/animate
677 %{_includedir}/wx-%{ver2}/wx/animate/*
678 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
679
680 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
681 %{_includedir}/wx-%{ver2}/wx/deprecated/*
682 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
683
684 %dir %{_includedir}/wx-%{ver2}/wx/fl
685 %{_includedir}/wx-%{ver2}/wx/fl/*
686 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
687
688 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
689 %{_includedir}/wx-%{ver2}/wx/gizmos/*
690 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
691 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
692
693 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
694 %{_includedir}/wx-%{ver2}/wx/mmedia/*
695 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
696
697 %dir %{_includedir}/wx-%{ver2}/wx/ogl
698 %{_includedir}/wx-%{ver2}/wx/ogl/*
699 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
700
701 %dir %{_includedir}/wx-%{ver2}/wx/plot
702 %{_includedir}/wx-%{ver2}/wx/plot/*
703 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
704
705 %dir %{_includedir}/wx-%{ver2}/wx/stc
706 %{_includedir}/wx-%{ver2}/wx/stc/*
707 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
708
709 %dir %{_includedir}/wx-%{ver2}/wx/svg
710 %{_includedir}/wx-%{ver2}/wx/svg/*
711 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so