6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
15 # "buildname" needs to be e.g. gtk2ud for debug builds
20 %define buildname gtk2u
22 %define buildname gtk2
31 %define name wx
-%{portname}-unicode
32 %define wxconfig
%{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic
%{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx
%{portname}u-%{ver2}-config
36 %define name wx
-%{portname}-ansi
37 %define wxconfig
%{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic
%{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx
%{portname}-%{ver2}-config
43 %define wxbasename wx
-base
-unicode
44 %define wxbaseconfig base
-unicode
-release
-%{ver2}
45 %define wxbaseconfiglink wxbaseu
-%{ver2}-config
47 %define wxbasename wx
-base
-ansi
48 %define wxbaseconfig base
-ansi
-release
-%{ver2}
49 %define wxbaseconfiglink wxbase
-%{ver2}-config
52 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
56 License: wxWindows Licence
58 Source: wxGTK
-%{ver}.tar.bz2
59 URL: http
://www.wxwidgets.org
60 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires
: gtk
+-2.0-devel
67 BuildRequires
: gtk
+-devel
>= 1.2.0
70 BuildRequires
: zlib
-devel
, libjpeg
-devel
, libpng
-devel
, libtiff
-devel
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
79 wxWidgets is a free C
++ library
for cross
-platform GUI development.
80 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
81 Motif
, MS Windows
, MacOS X
, Windows CE
, GPE
) from the same
source code.
84 Summary: The translations
for the wxWidgets library.
87 %description -n wx
-i18n
88 The translations files
for the wxWidgets library.
91 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
98 The GTK
+ %{gtkver} port of the wxWidgets library
, header files.
101 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, OpenGL add
-on.
103 Requires: %{name} = %{ver}
107 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
109 %package -n
%{wxbasename}
110 Summary: wxBase library
- non
-GUI support classes of the wxWidgets toolkit
111 Group: Development
/Libraries
114 %description -n
%{wxbasename}
115 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
116 lists
, arrays
), portable wrappers around many OS
-specific funstions
(file
117 operations
, time/date manipulations
, threads
, processes
, sockets
, shared
118 library loading
) as well as other utility classes
(streams
, archive and
119 compression
). wxBase currently supports Win32
, most Unix variants
(Linux
,
120 FreeBSD
, Solaris
, HP
-UX
) and MacOS X
(Carbon and Mach
-0).
122 %package -n
%{wxbasename}-devel
123 Summary: wxBase library
, header files.
124 Group: Development
/Libraries
125 Provides: wxBase
-devel
127 %description -n
%{wxbasename}-devel
128 wxBase library
- non
-GUI support classes of the wxWidgets toolkit
,
132 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, contributed libraries.
134 Requires: %{name} = %{ver}
137 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
139 %package contrib
-devel
140 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
145 %description contrib
-devel
146 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
149 %setup -q
-n wxGTK
-%{ver}
152 if [ "$SMP"
!= ""
]; then
153 export MAKE
="
make -j$SMP"
160 ..
/configure
--prefix
=%{_prefix} \
181 ..
/configure
--prefix
=%{_prefix} \
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj
-static
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
206 (cd obj
-shared
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
208 # --- wxBase headers list begins here ---
209 cat
<<EOF
>wxbase
-headers.files
340 wx
/protocol
/protocol.h
353 # --- wxBase headers list ends here ---
354 cat
<<EOF
>wxbase
-headers.paths
355 %{_includedir}/wx-%{ver2}/wx
/afterstd.h
356 %{_includedir}/wx-%{ver2}/wx
/app.h
357 %{_includedir}/wx-%{ver2}/wx
/apptrait.h
358 %{_includedir}/wx-%{ver2}/wx
/archive.h
359 %{_includedir}/wx-%{ver2}/wx
/arrimpl.cpp
360 %{_includedir}/wx-%{ver2}/wx
/arrstr.h
361 %{_includedir}/wx-%{ver2}/wx
/beforestd.h
362 %{_includedir}/wx-%{ver2}/wx
/buffer.h
363 %{_includedir}/wx-%{ver2}/wx
/build.h
364 %{_includedir}/wx-%{ver2}/wx
/chkconf.h
365 %{_includedir}/wx-%{ver2}/wx
/clntdata.h
366 %{_includedir}/wx-%{ver2}/wx
/cmdline.h
367 %{_includedir}/wx-%{ver2}/wx
/confbase.h
368 %{_includedir}/wx-%{ver2}/wx
/config.h
369 %{_includedir}/wx-%{ver2}/wx
/containr.h
370 %{_includedir}/wx-%{ver2}/wx
/convauto.h
371 %{_includedir}/wx-%{ver2}/wx
/datetime.h
372 %{_includedir}/wx-%{ver2}/wx
/datstrm.h
373 %{_includedir}/wx-%{ver2}/wx
/dde.h
374 %{_includedir}/wx-%{ver2}/wx
/debug.h
375 %{_includedir}/wx-%{ver2}/wx
/defs.h
376 %{_includedir}/wx-%{ver2}/wx
/dir.h
377 %{_includedir}/wx-%{ver2}/wx
/dlimpexp.h
378 %{_includedir}/wx-%{ver2}/wx
/dynarray.h
379 %{_includedir}/wx-%{ver2}/wx
/dynlib.h
380 %{_includedir}/wx-%{ver2}/wx
/dynload.h
381 %{_includedir}/wx-%{ver2}/wx
/encconv.h
382 %{_includedir}/wx-%{ver2}/wx
/event.h
383 %{_includedir}/wx-%{ver2}/wx
/except.h
384 %{_includedir}/wx-%{ver2}/wx
/features.h
385 %{_includedir}/wx-%{ver2}/wx
/ffile.h
386 %{_includedir}/wx-%{ver2}/wx
/file.h
387 %{_includedir}/wx-%{ver2}/wx
/fileconf.h
388 %{_includedir}/wx-%{ver2}/wx
/filefn.h
389 %{_includedir}/wx-%{ver2}/wx
/filename.h
390 %{_includedir}/wx-%{ver2}/wx
/filesys.h
391 %{_includedir}/wx-%{ver2}/wx
/fontenc.h
392 %{_includedir}/wx-%{ver2}/wx
/fontmap.h
393 %{_includedir}/wx-%{ver2}/wx
/fs_mem.h
394 %{_includedir}/wx-%{ver2}/wx
/fs_zip.h
395 %{_includedir}/wx-%{ver2}/wx
/hash.h
396 %{_includedir}/wx-%{ver2}/wx
/hashmap.h
397 %{_includedir}/wx-%{ver2}/wx
/hashset.h
398 %{_includedir}/wx-%{ver2}/wx
/html
/forcelnk.h
399 %{_includedir}/wx-%{ver2}/wx
/iconloc.h
400 %{_includedir}/wx-%{ver2}/wx
/init.h
401 %{_includedir}/wx-%{ver2}/wx
/intl.h
402 %{_includedir}/wx-%{ver2}/wx
/iosfwrap.h
403 %{_includedir}/wx-%{ver2}/wx
/ioswrap.h
404 %{_includedir}/wx-%{ver2}/wx
/ipc.h
405 %{_includedir}/wx-%{ver2}/wx
/ipcbase.h
406 %{_includedir}/wx-%{ver2}/wx
/isql.h
407 %{_includedir}/wx-%{ver2}/wx
/isqlext.h
408 %{_includedir}/wx-%{ver2}/wx
/link.h
409 %{_includedir}/wx-%{ver2}/wx
/list.h
410 %{_includedir}/wx-%{ver2}/wx
/listimpl.cpp
411 %{_includedir}/wx-%{ver2}/wx
/log.h
412 %{_includedir}/wx-%{ver2}/wx
/longlong.h
413 %{_includedir}/wx-%{ver2}/wx
/math.h
414 %{_includedir}/wx-%{ver2}/wx
/memconf.h
415 %{_includedir}/wx-%{ver2}/wx
/memory.h
416 %{_includedir}/wx-%{ver2}/wx
/memtext.h
417 %{_includedir}/wx-%{ver2}/wx
/mimetype.h
418 %{_includedir}/wx-%{ver2}/wx
/module.h
419 %{_includedir}/wx-%{ver2}/wx
/msgout.h
420 %{_includedir}/wx-%{ver2}/wx
/mstream.h
421 %{_includedir}/wx-%{ver2}/wx
/object.h
422 %{_includedir}/wx-%{ver2}/wx
/platform.h
423 %{_includedir}/wx-%{ver2}/wx
/power.h
424 %{_includedir}/wx-%{ver2}/wx
/process.h
425 %{_includedir}/wx-%{ver2}/wx
/ptr_scpd.h
426 %{_includedir}/wx-%{ver2}/wx
/recguard.h
427 %{_includedir}/wx-%{ver2}/wx
/regex.h
428 %{_includedir}/wx-%{ver2}/wx
/scopeguard.h
429 %{_includedir}/wx-%{ver2}/wx
/snglinst.h
430 %{_includedir}/wx-%{ver2}/wx
/sstream.h
431 %{_includedir}/wx-%{ver2}/wx
/stack.h
432 %{_includedir}/wx-%{ver2}/wx
/stackwalk.h
433 %{_includedir}/wx-%{ver2}/wx
/stdpaths.h
434 %{_includedir}/wx-%{ver2}/wx
/stockitem.h
435 %{_includedir}/wx-%{ver2}/wx
/stopwatch.h
436 %{_includedir}/wx-%{ver2}/wx
/strconv.h
437 %{_includedir}/wx-%{ver2}/wx
/stream.h
438 %{_includedir}/wx-%{ver2}/wx
/string.h
439 %{_includedir}/wx-%{ver2}/wx
/sysopt.h
440 %{_includedir}/wx-%{ver2}/wx
/textbuf.h
441 %{_includedir}/wx-%{ver2}/wx
/textfile.h
442 %{_includedir}/wx-%{ver2}/wx
/thread.h
443 %{_includedir}/wx-%{ver2}/wx
/thrimpl.cpp
444 %{_includedir}/wx-%{ver2}/wx
/timer.h
445 %{_includedir}/wx-%{ver2}/wx
/tokenzr.h
446 %{_includedir}/wx-%{ver2}/wx
/txtstrm.h
447 %{_includedir}/wx-%{ver2}/wx
/types.h
448 %{_includedir}/wx-%{ver2}/wx
/uri.h
449 %{_includedir}/wx-%{ver2}/wx
/utils.h
450 %{_includedir}/wx-%{ver2}/wx
/variant.h
451 %{_includedir}/wx-%{ver2}/wx
/vector.h
452 %{_includedir}/wx-%{ver2}/wx
/version.h
453 %{_includedir}/wx-%{ver2}/wx
/volume.h
454 %{_includedir}/wx-%{ver2}/wx
/wfstream.h
455 %{_includedir}/wx-%{ver2}/wx
/wx.h
456 %{_includedir}/wx-%{ver2}/wx
/wxchar.h
457 %{_includedir}/wx-%{ver2}/wx
/wxprec.h
458 %{_includedir}/wx-%{ver2}/wx
/xti.h
459 %{_includedir}/wx-%{ver2}/wx
/xtistrm.h
460 %{_includedir}/wx-%{ver2}/wx
/zipstrm.h
461 %{_includedir}/wx-%{ver2}/wx
/zstream.h
462 %{_includedir}/wx-%{ver2}/wx
/fs_inet.h
463 %{_includedir}/wx-%{ver2}/wx
/gsocket.h
464 %{_includedir}/wx-%{ver2}/wx
/protocol
/file.h
465 %{_includedir}/wx-%{ver2}/wx
/protocol
/ftp.h
466 %{_includedir}/wx-%{ver2}/wx
/protocol
/http.h
467 %{_includedir}/wx-%{ver2}/wx
/protocol
/protocol.h
468 %{_includedir}/wx-%{ver2}/wx
/sckaddr.h
469 %{_includedir}/wx-%{ver2}/wx
/sckipc.h
470 %{_includedir}/wx-%{ver2}/wx
/sckstrm.h
471 %{_includedir}/wx-%{ver2}/wx
/socket.h
472 %{_includedir}/wx-%{ver2}/wx
/url.h
473 %{_includedir}/wx-%{ver2}/wx
/xml
/xml.h
474 %{_includedir}/wx-%{ver2}/wx
/xtixml.h
475 %{_includedir}/wx-%{ver2}/wx
/db.h
476 %{_includedir}/wx-%{ver2}/wx
/dbkeyg.h
477 %{_includedir}/wx-%{ver2}/wx
/dbtable.h
478 %{_includedir}/wx-%{ver2}/wx
/unix
/apptbase.h
479 %{_includedir}/wx-%{ver2}/wx
/unix
/apptrait.h
480 %{_includedir}/wx-%{ver2}/wx
/unix
/execute.h
481 %{_includedir}/wx-%{ver2}/wx
/unix
/gsockunx.h
482 %{_includedir}/wx-%{ver2}/wx
/unix
/mimetype.h
483 %{_includedir}/wx-%{ver2}/wx
/unix
/pipe.h
484 %{_includedir}/wx-%{ver2}/wx
/unix
/private.h
485 %{_includedir}/wx-%{ver2}/wx
/unix
/stackwalk.h
486 %{_includedir}/wx-%{ver2}/wx
/unix
/stdpaths.h
488 # --- wxBase headers list ends here ---
490 # temporarily remove base headers
491 mkdir $RPM_BUILD_ROOT
/_save_dir
492 cp
-r $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT
/_save_dir
493 for f
in `cat wxbase
-headers.files`
; do
494 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
496 # list of all core headers:
497 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
498 # move base headers (actually all headers) back again
499 cp
-f
-r $RPM_BUILD_ROOT
/_save_dir
/* $RPM_BUILD_ROOT
%{_includedir}
500 rm -rf $RPM_BUILD_ROOT
/_save_dir
503 (cd obj
-static
/contrib
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
504 (cd obj
-shared
/contrib
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
507 (cd obj
-shared
/utils
/wxrc
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
509 # wx-config link is created during package installation, remove it for now
510 rm -f $RPM_BUILD_ROOT
%{_bindir}/wx
-config
513 rm -rf $RPM_BUILD_ROOT
522 # link wx-config when you install RPM.
524 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
526 # link wx-config with explicit name.
527 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
535 rm -f
%{_bindir}/wx
-config
537 rm -f
%{_bindir}/%{wxconfiglink}
539 %post -n
%{wxbasename}
542 %postun -n
%{wxbasename}
545 %post -n
%{wxbasename}-devel
546 # link wx-config with explicit name.
547 ln
-sf
%{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
550 %postun -n
%{wxbasename}-devel
553 %preun -n
%{wxbasename}-devel
554 rm -f
%{_bindir}/%{wxbaseconfiglink}
571 %postun contrib
-devel
575 %defattr(-,root
,root
)
576 %doc COPYING.LIB
*.txt
577 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.
*
578 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.
*
579 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.
*
581 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.
*
583 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.
*
584 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
585 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.
*
586 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.
*
587 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.
*
590 %defattr(-,root
,root
)
591 %{_datadir}/locale
/*/LC_MESSAGES
/*.mo
593 %files devel
-f core
-headers.files
594 %defattr(-,root
,root
)
596 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
602 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
603 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
604 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
606 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
607 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
610 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
611 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
613 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
615 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
617 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
618 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
619 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
621 %{_libdir}/wx/config/%{wxconfig}
622 %{_libdir}/wx/include/%{wxconfig}/wx
/setup.h
623 %{_libdir}/wx/config/%{wxconfigstatic}
624 %{_libdir}/wx/include/%{wxconfigstatic}/wx
/setup.h
627 %files -n
%{wxbasename}
628 %defattr(-,root
,root
)
629 %{_libdir}/libwx_base*-%{ver2}.so.
*
631 %files -n
%{wxbasename}-devel
-f wxbase
-headers.paths
632 %defattr (-,root
,root
)
633 %dir %{_includedir}/wx-%{ver2}
634 %{_libdir}/libwx_base*-%{ver2}.so
635 %{_libdir}/libwx_base*-%{ver2}.a
637 %{_libdir}/libwxregexu-%{ver2}.a
640 %{_datadir}/aclocal
/*.m4
641 %{_datadir}/bakefile
/presets
/*
644 %defattr(-,root
,root
)
645 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.
*
648 %defattr(-,root
,root
)
649 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.
*
650 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.
*
651 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.
*
652 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.
*
653 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.
*
654 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
655 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.
*
656 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.
*
657 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.
*
658 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.
*
661 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
662 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
663 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
664 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
665 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
666 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
667 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
668 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
673 %defattr(-,root
,root
)
674 %dir %{_includedir}/wx-%{ver2}/wx
/animate
675 %{_includedir}/wx-%{ver2}/wx
/animate
/*
676 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
678 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
679 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
680 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
682 %dir %{_includedir}/wx-%{ver2}/wx
/fl
683 %{_includedir}/wx-%{ver2}/wx
/fl
/*
684 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
686 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
687 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
688 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
689 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
691 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
692 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
693 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
695 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
696 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
697 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
699 %dir %{_includedir}/wx-%{ver2}/wx
/plot
700 %{_includedir}/wx-%{ver2}/wx
/plot
/*
701 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
703 %dir %{_includedir}/wx-%{ver2}/wx
/stc
704 %{_includedir}/wx-%{ver2}/wx
/stc
/*
705 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
707 %dir %{_includedir}/wx-%{ver2}/wx
/svg
708 %{_includedir}/wx-%{ver2}/wx
/svg
/*
709 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so