5 Source: %{name}-%{version}-source.tar.bz2
8 Summary: Program to convert from LaTeX to RTF and HTML
9 Copyright: wxWindows Library
License
10 Group: Applications
/Editors
11 URL: http
://www.wxwindows.org
/tex2rtf
12 Packager: Vaclav Slavik
<vaclav.slavik@matfyz.cz
>
14 %define wxwin_version
2.3
15 BuildRequires
: wxBase
-devel
>= 2.3.2
16 BuildRequires
: wxBase
-static
>= 2.3.2
17 BuildRoot: /var
/tmp
/%{name}-%{version}-root
20 Tex2RTF is a program originally written by Julian Smart to convert
21 from a LaTeX subset to four other formats
:
23 * Linear RTF
, for importing into a wide range of word processors.
24 * Windows Help hypertext RTF
, for compilation with HC
(Help Compiler
).
25 * HTML
(Hypertext Markup Language
), with ordinary HTML mode and
26 Microsoft HTML Help
/wxWindows HTML Help mode.
27 * XLP wxHelp format
, the original wxWindows toolkit
help format.
28 This format is now obsolete.
30 Tex2RTF parses a 'reasonable' subset of LaTeX
, notable blind spots being
31 the tabbing environment and maths. However
, don't expect to translate
32 your LaTeX files immediately with no alteration of your
source files
, since
33 the objective is more to have a portable document
source language than to
34 convert old LaTeX files.
37 %setup -n
%{name}-%{version}-source
41 # build tex2rtf binary:
44 make -f makefile.unx \
45 "CXXFLAGS
=$RPM_OPT_FLAGS `wxbase
-%{wxwin_version}-config
--static
--cxxflags`
-DNO_GUI" \
46 "LDFLAGS
=`wxbase
-%{wxwin_version}-config
--static
--libs`"
49 # and use it to generate documentation:
51 src
/tex2rtf docs
/tex2rtf.tex html
/tex2rtf.html
-html
52 ln
-sf tex2rtf_contents.html html
/index.html
57 rm -rf $
{RPM_BUILD_ROOT
}
58 mkdir -p $
{RPM_BUILD_ROOT
}%{_bindir}
59 cp
-f src
/tex2rtf $
{RPM_BUILD_ROOT
}%{_bindir}
62 rm -Rf $
{RPM_BUILD_ROOT
}