6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
11 %define portname x11univ
14 %define wxbasename wx
-base
-unicode
15 %define name wx
-%{portname}-unicode
16 %define wxconfig
%{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx
%{portname}u-%{ver2}-config
19 %define wxbasename wx
-base
20 %define name wx
-%{portname}
21 %define wxconfig
%{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx
%{portname}-%{ver2}-config
25 Summary: The X11 port of the wxWidgets library
29 License: wxWindows Licence
31 Source: wxX11
-%{ver}.tar.bz2
32 URL: http
://www.wxwidgets.org
33 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
45 wxWidgets is a free C
++ library
for cross
-platform GUI development.
46 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
47 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
50 Summary: The X11 port of the wxWidgets library
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
56 Header files
for wxX11
, the X11 port of the wxWidgets library.
59 Summary: The X11 port of the wxWidgets library
, OpenGL add
-on.
61 Requires: %{name} = %{ver}
64 OpenGL add
-on library
for wxX11
, the X11 port of the wxWidgets library.
67 Summary: wxX11 static libraries
68 Group: Development
/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
73 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
76 Summary: Contrib libraries
for wxX11.
78 Requires: %{name} = %{ver}
81 Contributed libraries
for wxX11.
83 %package contrib
-devel
84 Summary: Contrib libraries
for wxX11.
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
89 %description contrib
-devel
90 Header files
for contributed libraries
for wxX11.
93 %setup -q
-n wxX11
-%{ver}
96 if [ "$SMP"
!= ""
]; then
97 export MAKE
="
make -j$SMP"
104 ..
/configure
--prefix
=%{pref} --with
-x11 \
119 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
132 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
134 # Remove headers that are part of wx-base-devel:
136 # --- wxBase headers list begins here ---
137 cat
<<EOF
>wxbase
-headers.files
273 wx
/mac
/corefoundation
/cfstring.h
274 wx
/mac
/corefoundation
/hid.h
275 wx
/mac
/corefoundation
/stdpaths.h
287 wx
/protocol
/protocol.h
297 wx
/mac
/carbon
/gsockmac.h
304 # --- wxBase headers list ends here ---
305 for f
in `cat wxbase
-headers
-list`
; do
306 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
309 # list of all core headers:
310 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
313 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
314 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
316 # remove wxBase files so that RPM doesn't complain about unpackaged files:
317 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
319 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwxregexu-%{ver2}.a
321 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
322 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
325 rm -rf $RPM_BUILD_ROOT
334 # link wx-config when you install RPM.
335 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
336 # link wx-config with explicit name.
337 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
344 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
345 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
346 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
347 if test "x$SUM1"
= "x$SUM2"
; then
348 rm -f
%{_bindir}/wx
-config
351 rm -f
%{_bindir}/%{wxconfiglink}
368 %postun contrib
-devel
372 %defattr(-,root
,root
)
373 %doc COPYING.LIB
*.txt
374 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
375 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
377 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.
*
379 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
380 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
381 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
382 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
385 %files devel
-f core
-headers.files
386 %defattr(-,root
,root
)
387 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
388 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
390 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
392 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
393 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
394 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
395 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
396 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
402 %defattr(-,root
,root
)
403 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
406 %defattr (-,root
,root
)
407 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
410 %defattr(-,root
,root
)
411 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.
*
412 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.
*
413 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.
*
414 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.
*
415 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.
*
416 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.
*
417 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.
*
418 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.
*
419 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.
*
422 %defattr(-,root
,root
)
423 %dir %{_includedir}/wx-%{ver2}/wx
/animate
424 %{_includedir}/wx-%{ver2}/wx
/animate
/*
425 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
427 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
428 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
429 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
431 %dir %{_includedir}/wx-%{ver2}/wx
/fl
432 %{_includedir}/wx-%{ver2}/wx
/fl
/*
433 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
435 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
436 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
437 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
439 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
440 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
441 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
443 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
444 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
445 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
447 %dir %{_includedir}/wx-%{ver2}/wx
/plot
448 %{_includedir}/wx-%{ver2}/wx
/plot
/*
449 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
451 %dir %{_includedir}/wx-%{ver2}/wx
/stc
452 %{_includedir}/wx-%{ver2}/wx
/stc
/*
453 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
455 %dir %{_includedir}/wx-%{ver2}/wx
/svg
456 %{_includedir}/wx-%{ver2}/wx
/svg
/*
457 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so