added AM_PATH_WXCONFIG macro and its installation
[wxWidgets.git] / wxBase.spec
1 %define pref /usr
2 %define ver 2.3.2
3 %define ver2 2.3
4 %define rel 1
5
6 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
7 Name: wxBase
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: Development/Libraries
12 Source: wxBase-%{ver}.tar.bz2
13 URL: http://www.wxwindows.org
14 Packager: Vadim Zeitlin <vadim@wxwindows.org>
15 Prefix: %{pref}
16 BuildRoot: /var/tmp/%{name}-root
17
18 %description
19 wxBase is a collection of C++ classes providing basic data structures (strings,
20 lists, arrays), powerful wxDateTime class for date manipulations, portable
21 wrappers around many OS-specific functions allowing to build the same program
22 under all supported folders, wxThread class for writing multithreaded programs
23 using either Win32 or POSIX threads and much more. wxBase currently supports
24 the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
25 ...) and BeOS.
26
27 %package devel
28 Summary: wxBase headers needed for developping with wxBase
29 Group: Development/Libraries
30 Requires: wxBase = %{ver}
31
32 %description devel
33 Header files for wxBase. You need them to develop programs using wxBase.
34
35 %package static
36 Summary: wxBase static libraries
37 Group: Development/Libraries
38
39 %description static
40 Static libraries for wxBase. You need them if you want to link statically against wxBase.
41
42 %prep
43 %setup -n wxBase-%{ver}
44
45 %build
46 if [ "$SMP" != "" ]; then
47 export MAKE="make -j$SMP"
48 else
49 export MAKE="make"
50 fi
51
52 (cd locale; make allmo)
53
54 mkdir obj-shared
55 cd obj-shared
56 ../configure --prefix=%{pref} --enable-soname --disable-gui --disable-std_iostreams
57 $MAKE
58 cd ..
59
60 mkdir obj-static
61 cd obj-static
62 ../configure --prefix=%{pref} --disable-shared --disable-gui --disable-std_iostreams
63 $MAKE
64 cd ..
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 (cd obj-static ; make prefix=$RPM_BUILD_ROOT%{pref} install)
69 (cd obj-shared ; make prefix=$RPM_BUILD_ROOT%{pref} install)
70
71 %find_lang wxstd
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 /sbin/ldconfig
78
79 %postun
80 /sbin/ldconfig
81
82 %post devel
83 # Install wx-config if there isn't any
84 if test ! -f %{_bindir}/wx-config ; then
85 ln -sf wxbase-%{ver2}-config %{_bindir}/wx-config
86 fi
87
88 %preun devel
89 # Remove wx-config if it points to this package
90 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
91 SUM1=`md5sum %{_bindir}/wxbase-%{ver2}-config | cut -c 0-32`
92 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
93 if test "x$SUM1" = "x$SUM2" ; then
94 rm -f %{_bindir}/wx-config
95 fi
96 fi
97
98 %files -f wxstd.lang
99 %defattr (-,root,root)
100 %doc COPYING.LIB *.txt
101 %{_libdir}/libwx_base*so.*
102
103 %files devel
104 %defattr (-,root,root)
105 %dir %{_includedir}/wx
106 %{_includedir}/wx/*
107 %{_libdir}/libwx_base*.so
108 %dir %{_libdir}/wx
109 %{_libdir}/wx/*
110 %{_bindir}/wxbase-%{ver2}-config
111 %{_datadir}/aclocal/*.m4
112
113 %files static
114 %defattr (-,root,root)
115 %{_libdir}/lib*.a