Comitting correct wxGTK.spec again.
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /opt/gnome
2 %define ver 2.6.1
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.gz
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 # BuildRequires: gtk+-2.0-devel
68 %else
69 # BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package -n wx-i18n
86 Summary: The translations for the wxWidgets library.
87 Group: X11/Libraries
88
89 %description -n wx-i18n
90 The translations files for the wxWidgets library.
91
92 %package devel
93 Summary: The GTK+ %{gtkver} port of the wxWidgets library
94 Group: X11/Libraries
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
97 Provides: wxGTK-devel
98
99 %description devel
100 The GTK+ %{gtkver} port of the wxWidgets library, header files.
101
102 %package gl
103 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
104 Group: X11/Libraries
105 Requires: %{name} = %{ver}
106 Provides: wxGTK-gl
107
108 %description gl
109 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
110
111 %package -n %{wxbasename}
112 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
113 Group: Development/Libraries
114 Provides: wxBase
115
116 %description -n %{wxbasename}
117 wxBase is a collection of C++ classes providing basic data structures (strings,
118 lists, arrays), portable wrappers around many OS-specific funstions (file
119 operations, time/date manipulations, threads, processes, sockets, shared
120 library loading) as well as other utility classes (streams, archive and
121 compression). wxBase currently supports Win32, most Unix variants (Linux,
122 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
123
124 %package -n %{wxbasename}-devel
125 Summary: wxBase library, header files.
126 Group: Development/Libraries
127 Provides: wxBase-devel
128
129 %description -n %{wxbasename}-devel
130 wxBase library - non-GUI support classes of the wxWidgets toolkit,
131 header files.
132
133 %package contrib
134 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
135 Group: X11/Libraries
136 Requires: %{name} = %{ver}
137
138 %description contrib
139 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
140
141 %package contrib-devel
142 Summary: The GTK+ %{gtkver} port of the wxWidgets library
143 Group: X11/Libraries
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
146
147 %description contrib-devel
148 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
149
150 %prep
151 %setup -q -n wxGTK-%{ver}
152
153 %build
154 if [ "$SMP" != "" ]; then
155 export MAKE="make -j$SMP"
156 else
157 export MAKE="make"
158 fi
159
160 mkdir obj-shared-no-gui
161 cd obj-shared-no-gui
162 ../configure --prefix=%{_prefix} \
163 --disable-gui \
164 %if %{unicode}
165 --enable-unicode
166 %else
167 --disable-unicode
168 %endif
169 $MAKE
170 cd ..
171
172 mkdir obj-shared
173 cd obj-shared
174 ../configure --prefix=%{_prefix} \
175 %if ! %{gtk2}
176 --with-gtk=1 \
177 %else
178 --with-gtk=2 \
179 %endif
180 %if %{unicode}
181 --enable-unicode \
182 %else
183 --disable-unicode \
184 --with-odbc \
185 %endif
186 --with-opengl
187 $MAKE
188
189 cd contrib/src
190 $MAKE
191 cd ../../..
192
193 mkdir obj-static-no-gui
194 cd obj-static-no-gui
195 ../configure --prefix=%{_prefix} \
196 --disable-gui \
197 --disable-shared \
198 %if %{unicode}
199 --enable-unicode
200 %else
201 --disable-unicode
202 %endif
203 $MAKE
204 cd ..
205
206 mkdir obj-static
207 cd obj-static
208 ../configure --prefix=%{_prefix} \
209 %if ! %{gtk2}
210 --with-gtk=1 \
211 %else
212 --with-gtk=2 \
213 %endif
214 --disable-shared \
215 %if %{unicode}
216 --enable-unicode \
217 %else
218 --disable-unicode \
219 --with-odbc \
220 %endif
221 --with-opengl
222 $MAKE
223
224 cd contrib/src
225 $MAKE
226 cd ../../..
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230 (cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
231 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
232 (cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
233 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
234
235 # --- wxBase headers list begins here ---
236 cat <<EOF >wxbase-headers.files
237 wx/afterstd.h
238 wx/app.h
239 wx/apptrait.h
240 wx/archive.h
241 wx/arrimpl.cpp
242 wx/arrstr.h
243 wx/beforestd.h
244 wx/buffer.h
245 wx/build.h
246 wx/chkconf.h
247 wx/clntdata.h
248 wx/cmdline.h
249 wx/confbase.h
250 wx/config.h
251 wx/containr.h
252 wx/datetime.h
253 wx/datstrm.h
254 wx/dde.h
255 wx/debug.h
256 wx/defs.h
257 wx/dir.h
258 wx/dlimpexp.h
259 wx/dynarray.h
260 wx/dynlib.h
261 wx/dynload.h
262 wx/encconv.h
263 wx/event.h
264 wx/except.h
265 wx/features.h
266 wx/ffile.h
267 wx/file.h
268 wx/fileconf.h
269 wx/filefn.h
270 wx/filename.h
271 wx/filesys.h
272 wx/fontenc.h
273 wx/fontmap.h
274 wx/fs_mem.h
275 wx/fs_zip.h
276 wx/hash.h
277 wx/hashmap.h
278 wx/hashset.h
279 wx/html/forcelnk.h
280 wx/iconloc.h
281 wx/init.h
282 wx/intl.h
283 wx/iosfwrap.h
284 wx/ioswrap.h
285 wx/ipc.h
286 wx/ipcbase.h
287 wx/isql.h
288 wx/isqlext.h
289 wx/list.h
290 wx/listimpl.cpp
291 wx/log.h
292 wx/longlong.h
293 wx/math.h
294 wx/memconf.h
295 wx/memory.h
296 wx/memtext.h
297 wx/mimetype.h
298 wx/module.h
299 wx/msgout.h
300 wx/mstream.h
301 wx/object.h
302 wx/platform.h
303 wx/process.h
304 wx/ptr_scpd.h
305 wx/regex.h
306 wx/scopeguard.h
307 wx/snglinst.h
308 wx/sstream.h
309 wx/stack.h
310 wx/stackwalk.h
311 wx/stdpaths.h
312 wx/stockitem.h
313 wx/stopwatch.h
314 wx/strconv.h
315 wx/stream.h
316 wx/string.h
317 wx/sysopt.h
318 wx/textbuf.h
319 wx/textfile.h
320 wx/thread.h
321 wx/thrimpl.cpp
322 wx/timer.h
323 wx/tokenzr.h
324 wx/txtstrm.h
325 wx/types.h
326 wx/uri.h
327 wx/utils.h
328 wx/variant.h
329 wx/vector.h
330 wx/version.h
331 wx/volume.h
332 wx/wfstream.h
333 wx/wx.h
334 wx/wxchar.h
335 wx/wxprec.h
336 wx/xti.h
337 wx/xtistrm.h
338 wx/zipstrm.h
339 wx/zstream.h
340 wx/fs_inet.h
341 wx/gsocket.h
342 wx/protocol/file.h
343 wx/protocol/ftp.h
344 wx/protocol/http.h
345 wx/protocol/protocol.h
346 wx/sckaddr.h
347 wx/sckipc.h
348 wx/sckstrm.h
349 wx/socket.h
350 wx/url.h
351 wx/xml/xml.h
352 wx/xtixml.h
353 wx/db.h
354 wx/dbkeyg.h
355 wx/dbtable.h
356 wx/unix/apptbase.h
357 wx/unix/apptrait.h
358 wx/unix/execute.h
359 wx/unix/gsockunx.h
360 wx/unix/mimetype.h
361 wx/unix/pipe.h
362 wx/unix/stackwalk.h
363 wx/unix/stdpaths.h
364 EOF
365 # --- wxBase headers list ends here ---
366 cat <<EOF >wxbase-headers.paths
367 %{_includedir}/wx-%{ver2}/wx/afterstd.h
368 %{_includedir}/wx-%{ver2}/wx/app.h
369 %{_includedir}/wx-%{ver2}/wx/apptrait.h
370 %{_includedir}/wx-%{ver2}/wx/archive.h
371 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
372 %{_includedir}/wx-%{ver2}/wx/arrstr.h
373 %{_includedir}/wx-%{ver2}/wx/beforestd.h
374 %{_includedir}/wx-%{ver2}/wx/buffer.h
375 %{_includedir}/wx-%{ver2}/wx/build.h
376 %{_includedir}/wx-%{ver2}/wx/chkconf.h
377 %{_includedir}/wx-%{ver2}/wx/clntdata.h
378 %{_includedir}/wx-%{ver2}/wx/cmdline.h
379 %{_includedir}/wx-%{ver2}/wx/confbase.h
380 %{_includedir}/wx-%{ver2}/wx/config.h
381 %{_includedir}/wx-%{ver2}/wx/containr.h
382 %{_includedir}/wx-%{ver2}/wx/datetime.h
383 %{_includedir}/wx-%{ver2}/wx/datetime.inl
384 %{_includedir}/wx-%{ver2}/wx/datstrm.h
385 %{_includedir}/wx-%{ver2}/wx/dde.h
386 %{_includedir}/wx-%{ver2}/wx/debug.h
387 %{_includedir}/wx-%{ver2}/wx/defs.h
388 %{_includedir}/wx-%{ver2}/wx/dir.h
389 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
390 %{_includedir}/wx-%{ver2}/wx/dynarray.h
391 %{_includedir}/wx-%{ver2}/wx/dynlib.h
392 %{_includedir}/wx-%{ver2}/wx/dynload.h
393 %{_includedir}/wx-%{ver2}/wx/encconv.h
394 %{_includedir}/wx-%{ver2}/wx/event.h
395 %{_includedir}/wx-%{ver2}/wx/except.h
396 %{_includedir}/wx-%{ver2}/wx/features.h
397 %{_includedir}/wx-%{ver2}/wx/ffile.h
398 %{_includedir}/wx-%{ver2}/wx/file.h
399 %{_includedir}/wx-%{ver2}/wx/fileconf.h
400 %{_includedir}/wx-%{ver2}/wx/filefn.h
401 %{_includedir}/wx-%{ver2}/wx/filename.h
402 %{_includedir}/wx-%{ver2}/wx/filesys.h
403 %{_includedir}/wx-%{ver2}/wx/fontenc.h
404 %{_includedir}/wx-%{ver2}/wx/fontmap.h
405 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
406 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
407 %{_includedir}/wx-%{ver2}/wx/hash.h
408 %{_includedir}/wx-%{ver2}/wx/hashmap.h
409 %{_includedir}/wx-%{ver2}/wx/hashset.h
410 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
411 %{_includedir}/wx-%{ver2}/wx/iconloc.h
412 %{_includedir}/wx-%{ver2}/wx/init.h
413 %{_includedir}/wx-%{ver2}/wx/intl.h
414 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
415 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
416 %{_includedir}/wx-%{ver2}/wx/ipc.h
417 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
418 %{_includedir}/wx-%{ver2}/wx/isql.h
419 %{_includedir}/wx-%{ver2}/wx/isqlext.h
420 %{_includedir}/wx-%{ver2}/wx/list.h
421 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
422 %{_includedir}/wx-%{ver2}/wx/log.h
423 %{_includedir}/wx-%{ver2}/wx/longlong.h
424 %{_includedir}/wx-%{ver2}/wx/math.h
425 %{_includedir}/wx-%{ver2}/wx/memconf.h
426 %{_includedir}/wx-%{ver2}/wx/memory.h
427 %{_includedir}/wx-%{ver2}/wx/memtext.h
428 %{_includedir}/wx-%{ver2}/wx/mimetype.h
429 %{_includedir}/wx-%{ver2}/wx/module.h
430 %{_includedir}/wx-%{ver2}/wx/msgout.h
431 %{_includedir}/wx-%{ver2}/wx/mstream.h
432 %{_includedir}/wx-%{ver2}/wx/object.h
433 %{_includedir}/wx-%{ver2}/wx/platform.h
434 %{_includedir}/wx-%{ver2}/wx/process.h
435 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
436 %{_includedir}/wx-%{ver2}/wx/regex.h
437 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
438 %{_includedir}/wx-%{ver2}/wx/snglinst.h
439 %{_includedir}/wx-%{ver2}/wx/sstream.h
440 %{_includedir}/wx-%{ver2}/wx/stack.h
441 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
442 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
443 %{_includedir}/wx-%{ver2}/wx/stockitem.h
444 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
445 %{_includedir}/wx-%{ver2}/wx/strconv.h
446 %{_includedir}/wx-%{ver2}/wx/stream.h
447 %{_includedir}/wx-%{ver2}/wx/string.h
448 %{_includedir}/wx-%{ver2}/wx/sysopt.h
449 %{_includedir}/wx-%{ver2}/wx/textbuf.h
450 %{_includedir}/wx-%{ver2}/wx/textfile.h
451 %{_includedir}/wx-%{ver2}/wx/thread.h
452 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
453 %{_includedir}/wx-%{ver2}/wx/timer.h
454 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
455 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
456 %{_includedir}/wx-%{ver2}/wx/types.h
457 %{_includedir}/wx-%{ver2}/wx/uri.h
458 %{_includedir}/wx-%{ver2}/wx/utils.h
459 %{_includedir}/wx-%{ver2}/wx/variant.h
460 %{_includedir}/wx-%{ver2}/wx/vector.h
461 %{_includedir}/wx-%{ver2}/wx/version.h
462 %{_includedir}/wx-%{ver2}/wx/volume.h
463 %{_includedir}/wx-%{ver2}/wx/wfstream.h
464 %{_includedir}/wx-%{ver2}/wx/wx.h
465 %{_includedir}/wx-%{ver2}/wx/wxchar.h
466 %{_includedir}/wx-%{ver2}/wx/wxprec.h
467 %{_includedir}/wx-%{ver2}/wx/xti.h
468 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
469 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
470 %{_includedir}/wx-%{ver2}/wx/zstream.h
471 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
472 %{_includedir}/wx-%{ver2}/wx/gsocket.h
473 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
474 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
475 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
476 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
477 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
478 %{_includedir}/wx-%{ver2}/wx/sckipc.h
479 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
480 %{_includedir}/wx-%{ver2}/wx/socket.h
481 %{_includedir}/wx-%{ver2}/wx/url.h
482 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
483 %{_includedir}/wx-%{ver2}/wx/xtixml.h
484 %{_includedir}/wx-%{ver2}/wx/db.h
485 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
486 %{_includedir}/wx-%{ver2}/wx/dbtable.h
487 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
488 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
489 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
490 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
491 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
492 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
493 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
494 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
495 EOF
496 # --- wxBase headers list ends here ---
497
498 # temporarily remove base headers
499 mkdir $RPM_BUILD_ROOT/_save_dir
500 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
501 for f in `cat wxbase-headers.files` ; do
502 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
503 done
504 # list of all core headers:
505 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
506 # move base headers (actually all headers) back again
507 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
508 rm -rf $RPM_BUILD_ROOT/_save_dir
509
510 # contrib stuff:
511 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
512 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
513
514 %clean
515 rm -rf $RPM_BUILD_ROOT
516
517 %post
518 /sbin/ldconfig
519
520 %postun
521 /sbin/ldconfig
522
523 %post devel
524 # link wx-config when you install RPM.
525 %if %{unicode}
526 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
527 %endif
528 # link wx-config with explicit name.
529 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
530 /sbin/ldconfig
531
532 %postun devel
533 /sbin/ldconfig
534
535 %preun devel
536 %if %{unicode}
537 rm -f %{_bindir}/wx-config
538 %endif
539 rm -f %{_bindir}/%{wxconfiglink}
540
541 %post -n %{wxbasename}
542 /sbin/ldconfig
543
544 %postun -n %{wxbasename}
545 /sbin/ldconfig
546
547 %post -n %{wxbasename}-devel
548 # link wx-config with explicit name.
549 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
550 /sbin/ldconfig
551
552 %postun -n %{wxbasename}-devel
553 /sbin/ldconfig
554
555 %preun -n %{wxbasename}-devel
556 rm -f %{_bindir}/%{wxbaseconfiglink}
557
558 %post gl
559 /sbin/ldconfig
560
561 %postun gl
562 /sbin/ldconfig
563
564 %post contrib
565 /sbin/ldconfig
566
567 %postun contrib
568 /sbin/ldconfig
569
570 %post contrib-devel
571 /sbin/ldconfig
572
573 %postun contrib-devel
574 /sbin/ldconfig
575
576 %files
577 %defattr(-,root,root)
578 %doc COPYING.LIB *.txt
579 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
580 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
581 %if !%{unicode}
582 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
583 %endif
584 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
585 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
586 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
587 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
588
589 %files -n wx-i18n
590 %defattr(-,root,root)
591 %{_datadir}/locale/*/*/*
592
593 %files devel -f core-headers.files
594 %defattr(-,root,root)
595 # shared libs
596 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
598 %if !%{unicode}
599 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
600 %endif
601 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
602 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
603 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
604 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
606 # static libs
607 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
608 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
609 %if !%{unicode}
610 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
611 %endif
612 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
613 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
614 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
615 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
617 %dir %{_libdir}/wx
618 %{_libdir}/wx/config/%{wxconfig}
619 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
620 %{_libdir}/wx/config/%{wxconfigstatic}
621 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
622 %{_bindir}/wxrc*
623
624 %files -n %{wxbasename}
625 %defattr(-,root,root)
626 %{_libdir}/libwx_base*-%{ver2}.so.*
627
628 %files -n %{wxbasename}-devel -f wxbase-headers.paths
629 %defattr (-,root,root)
630 %dir %{_includedir}/wx-%{ver2}
631 %{_libdir}/libwx_base*-%{ver2}.so
632 %{_libdir}/libwx_base*-%{ver2}.a
633 %if %{unicode}
634 %{_libdir}/libwxregexu-%{ver2}.a
635 %endif
636 %dir %{_libdir}/wx
637 %{_libdir}/wx/config/%{wxbaseconfig}
638 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
639 %{_libdir}/wx/config/%{wxbaseconfigstatic}
640 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
641 %{_datadir}/aclocal/*.m4
642
643 %files gl
644 %defattr(-,root,root)
645 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
646
647 %files contrib
648 %defattr(-,root,root)
649 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
650 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
651 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
653 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
655 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
659
660 %files contrib-devel
661 %defattr(-,root,root)
662 %dir %{_includedir}/wx-%{ver2}/wx/animate
663 %{_includedir}/wx-%{ver2}/wx/animate/*
664 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
665
666 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
667 %{_includedir}/wx-%{ver2}/wx/deprecated/*
668 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
669
670 %dir %{_includedir}/wx-%{ver2}/wx/fl
671 %{_includedir}/wx-%{ver2}/wx/fl/*
672 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
673
674 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
675 %{_includedir}/wx-%{ver2}/wx/gizmos/*
676 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
677 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
678
679 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
680 %{_includedir}/wx-%{ver2}/wx/mmedia/*
681 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
682
683 %dir %{_includedir}/wx-%{ver2}/wx/ogl
684 %{_includedir}/wx-%{ver2}/wx/ogl/*
685 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
686
687 %dir %{_includedir}/wx-%{ver2}/wx/plot
688 %{_includedir}/wx-%{ver2}/wx/plot/*
689 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
690
691 %dir %{_includedir}/wx-%{ver2}/wx/stc
692 %{_includedir}/wx-%{ver2}/wx/stc/*
693 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
694
695 %dir %{_includedir}/wx-%{ver2}/wx/svg
696 %{_includedir}/wx-%{ver2}/wx/svg/*
697 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so