7 %define name wx
-%{portname}
8 %define wxbasename wx
-base
9 %define wxconfigname wx
%{portname}-%{ver2}-config
11 Summary: The Motif
/Lesstif port of the wxWindows library
15 License: wxWindows Licence
17 Source: wxMOTIF
-%{ver}.tar.bz2
18 URL: http
://www.wxwidgets.org
19 Packager: wxWindows developers
<wx
-dev@lists.wxwidgets.org
>
20 BuildRoot: /tmp
/wxmotif_root
22 # all packages providing an implementation of wxWindows library (regardless of
23 # the toolkit used) should provide the (virtual) wxwin package, this makes it
24 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
29 Requires: %{wxbasename} = %{ver}
32 wxWindows is a free C
++ library
for cross
-platform GUI development.
33 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
34 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
37 Summary: The Motif
/Lesstif port of the wxWindows library
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
43 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
46 Summary: The Motif
/Lesstif port of the wxWindows library
, OpenGL add
-on.
48 Requires: %{name} = %{ver}
51 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
54 Summary: wxMotif static libraries
55 Group: Development
/Libraries
58 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
61 %setup -q
-n wxMOTIF
-%{ver}
64 if [ "$SMP"
!= ""
]; then
65 export MAKE
="
make -j$SMP"
72 ..
/configure
--prefix
=%{pref} --with
-odbc
--with
-opengl
--with
-motif
78 ..
/configure
--prefix
=%{pref} --disable
-shared
--with
-odbc
--with
-opengl
--with
-motif
83 rm -rf $RPM_BUILD_ROOT
84 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
85 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
87 # Remove headers that are part of wx-base-devel:
89 # --- wxBase headers list begins here ---
90 cat
<<EOF
>wxbase
-headers
-list
214 wx
/protocol
/protocol.h
227 # --- wxBase headers list ends here ---
228 for f
in `cat wxbase
-headers
-list`
; do
229 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx
-*/$f
232 # list of all core headers:
233 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
235 # remove wxBase files so that RPM doesn't complain about unpackaged files:
236 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
237 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
238 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
242 rm -rf $RPM_BUILD_ROOT
258 %defattr(-,root
,root
)
259 %doc COPYING.LIB
*.txt
260 %{_libdir}/libwx_%{portname}*_core
*.so.
*
261 %{_libdir}/libwx_%{portname}*_html
*.so.
*
262 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
263 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
265 %files devel
-f core
-headers.files
266 %defattr(-,root
,root
)
267 %{_libdir}/libwx_%{portname}*_core
*.so
268 %{_libdir}/libwx_%{portname}*_html
*.so
269 %{_libdir}/libwx_%{portname}*_adv
*.so
270 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
271 %{_libdir}/libwx_%{portname}*_gl
*.so
274 %{_bindir}/%{wxconfigname}
277 %defattr(-,root
,root
)
278 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
281 %defattr (-,root
,root
)
282 %{_libdir}/libwx_%{portname}*.a