wxURI. Move Convert/to/fromURI into uri.cpp so that it is compiled in base. Regener...
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.5.3
3 %define ver2 2.5
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9 %define wxconfigname wx%{portname}-%{ver2}-config
10
11 Summary: The Motif/Lesstif port of the wxWindows library
12 Name: %{name}
13 Version: %{ver}
14 Release: %{rel}
15 License: wxWindows Licence
16 Group: X11/Libraries
17 Source: wxMOTIF-%{ver}.tar.bz2
18 URL: http://www.wxwidgets.org
19 Packager: wxWindows developers <wx-dev@lists.wxwidgets.org>
20 BuildRoot: /tmp/wxmotif_root
21
22 # all packages providing an implementation of wxWindows library (regardless of
23 # the toolkit used) should provide the (virtual) wxwin package, this makes it
24 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
25 Provides: wxwin
26
27 Provides: wxMotif
28
29 Requires: %{wxbasename} = %{ver}
30
31 %description
32 wxWindows is a free C++ library for cross-platform GUI development.
33 With wxWindows, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWindows library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWindows library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56
57 %description static
58 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
59
60 %prep
61 %setup -q -n wxMOTIF-%{ver}
62
63 %build
64 if [ "$SMP" != "" ]; then
65 export MAKE="make -j$SMP"
66 else
67 export MAKE="make"
68 fi
69
70 mkdir obj-shared
71 cd obj-shared
72 ../configure --prefix=%{pref} --with-odbc --with-opengl --with-motif
73 $MAKE
74 cd ..
75
76 mkdir obj-static
77 cd obj-static
78 ../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl --with-motif
79 $MAKE
80 cd ..
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
85 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
86
87 # Remove headers that are part of wx-base-devel:
88
89 # --- wxBase headers list begins here ---
90 cat <<EOF >wxbase-headers-list
91 wx/afterstd.h
92 wx/app.h
93 wx/apptrait.h
94 wx/arrimpl.cpp
95 wx/arrstr.h
96 wx/beforestd.h
97 wx/buffer.h
98 wx/build.h
99 wx/chkconf.h
100 wx/clntdata.h
101 wx/cmdline.h
102 wx/confbase.h
103 wx/config.h
104 wx/containr.h
105 wx/datetime.h
106 wx/datetime.inl
107 wx/datstrm.h
108 wx/dde.h
109 wx/debug.h
110 wx/defs.h
111 wx/dir.h
112 wx/dlimpexp.h
113 wx/dynarray.h
114 wx/dynlib.h
115 wx/dynload.h
116 wx/encconv.h
117 wx/event.h
118 wx/except.h
119 wx/features.h
120 wx/ffile.h
121 wx/file.h
122 wx/fileconf.h
123 wx/filefn.h
124 wx/filename.h
125 wx/filesys.h
126 wx/fontenc.h
127 wx/fontmap.h
128 wx/fs_mem.h
129 wx/fs_zip.h
130 wx/hash.h
131 wx/hashmap.h
132 wx/hashset.h
133 wx/iconloc.h
134 wx/init.h
135 wx/intl.h
136 wx/iosfwrap.h
137 wx/ioswrap.h
138 wx/ipc.h
139 wx/ipcbase.h
140 wx/isql.h
141 wx/isqlext.h
142 wx/list.h
143 wx/listimpl.cpp
144 wx/log.h
145 wx/longlong.h
146 wx/math.h
147 wx/memconf.h
148 wx/memory.h
149 wx/memtext.h
150 wx/mimetype.h
151 wx/module.h
152 wx/msgout.h
153 wx/msgout.h
154 wx/mstream.h
155 wx/object.h
156 wx/platform.h
157 wx/process.h
158 wx/ptr_scpd.h
159 wx/regex.h
160 wx/scopeguard.h
161 wx/snglinst.h
162 wx/sstream.h
163 wx/stack.h
164 wx/stdpaths.h
165 wx/stockitem.h
166 wx/stopwatch.h
167 wx/strconv.h
168 wx/stream.h
169 wx/string.h
170 wx/sysopt.h
171 wx/textbuf.h
172 wx/textfile.h
173 wx/thread.h
174 wx/thrimpl.cpp
175 wx/timer.h
176 wx/tokenzr.h
177 wx/txtstrm.h
178 wx/types.h
179 wx/uri.h
180 wx/utils.h
181 wx/variant.h
182 wx/vector.h
183 wx/version.h
184 wx/volume.h
185 wx/wfstream.h
186 wx/wx.h
187 wx/wxchar.h
188 wx/wxprec.h
189 wx/xti.h
190 wx/xtistrm.h
191 wx/zipstrm.h
192 wx/zstream.h
193 wx/msw/apptrait.h
194 wx/msw/apptbase.h
195 wx/msw/chkconf.h
196 wx/msw/crashrpt.h
197 wx/msw/dde.h
198 wx/msw/gccpriv.h
199 wx/msw/mimetype.h
200 wx/msw/winundef.h
201 wx/msw/wrapcctl.h
202 wx/msw/wrapwin.h
203 wx/fs_inet.h
204 wx/gsocket.h
205 wx/protocol/file.h
206 wx/protocol/ftp.h
207 wx/protocol/http.h
208 wx/protocol/protocol.h
209 wx/sckaddr.h
210 wx/sckipc.h
211 wx/sckstrm.h
212 wx/socket.h
213 wx/url.h
214 wx/msw/gsockmsw.h
215 wx/xml/xml.h
216 wx/xtixml.h
217 wx/db.h
218 wx/dbkeyg.h
219 wx/dbtable.h
220 EOF
221 # --- wxBase headers list ends here ---
222 for f in `cat wxbase-headers-list` ; do
223 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
224 done
225
226 # list of all core headers:
227 find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
228
229 # remove wxBase files so that RPM doesn't complain about unpackaged files:
230 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
231 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
232 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
233
234
235 %clean
236 rm -rf $RPM_BUILD_ROOT
237
238 %post
239 /sbin/ldconfig
240
241 %postun
242 /sbin/ldconfig
243
244 %post gl
245 /sbin/ldconfig
246
247 %postun gl
248 /sbin/ldconfig
249
250
251 %files
252 %defattr(-,root,root)
253 %doc COPYING.LIB *.txt
254 %dir %{_datadir}/wx
255 %{_datadir}/wx/*
256 %{_libdir}/libwx_%{portname}*_core*.so.*
257 %{_libdir}/libwx_%{portname}*_html*.so.*
258 %{_libdir}/libwx_%{portname}*_adv*.so.*
259 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
260
261 %files devel -f core-headers.files
262 %defattr(-,root,root)
263 %{_libdir}/libwx_%{portname}*_core*.so
264 %{_libdir}/libwx_%{portname}*_html*.so
265 %{_libdir}/libwx_%{portname}*_adv*.so
266 %{_libdir}/libwx_%{portname}*_dbgrid*.so
267 %{_libdir}/libwx_%{portname}*_gl*.so
268 %dir %{_libdir}/wx
269 %{_libdir}/wx/*
270 %{_bindir}/%{wxconfigname}
271
272 %files gl
273 %defattr(-,root,root)
274 %{_libdir}/libwx_%{portname}*_gl*.so.*
275
276 %files static
277 %defattr (-,root,root)
278 %{_libdir}/libwx_%{portname}*.a
279