]> git.saurik.com Git - wxWidgets.git/blob - wxGTK_RR.spec
Removed very out of date files in docs/msw
[wxWidgets.git] / wxGTK_RR.spec
1 %define pref /opt/gnome
2 %define ver 2.5.5
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 %if %{gtk2}
16 %define gtkver 2
17 %define portname gtk2
18 %else
19 %define gtkver 1.2
20 %define portname gtk
21 %endif
22
23 %if %{unicode}
24 %define name wx-%{portname}-unicode
25 %define wxconfig %{portname}-unicode-release-%{ver2}
26 %define wxconfiglink wx%{portname}u-%{ver2}-config
27 %else
28 %define wxbasename wx-base
29 %define name wx-%{portname}
30 %define wxconfig %{portname}-ansi-release-%{ver2}
31 %define wxconfiglink wx%{portname}-%{ver2}-config
32 %endif
33
34 %if %{unicode}
35 %define wxbasename wx-base-unicode
36 %define wxbaseconfig base-unicode-release-%{ver2}
37 %define wxbaseconfiglink wxbaseu-%{ver2}-config
38 %else
39 %define wxbasename wx-base-ansi
40 %define wxbaseconfig base-ansi-release-%{ver2}
41 %define wxbaseconfiglink wxbase-%{ver2}-config
42 %endif
43
44 Summary: The GTK+ %{gtkver} port of the wxWidgets library
45 Name: %{name}
46 Version: %{ver}
47 Release: %{rel}
48 License: wxWindows Licence
49 Group: X11/Libraries
50 Source: wxGTK-%{ver}.tar.gz
51 URL: http://www.wxwidgets.org
52 Packager: Vadim Zeitlin <vadim@wxwindows.org>
53 Prefix: %{pref}
54 BuildRoot: %{_tmppath}/%{name}-root
55 Requires: %{wxbasename} = %{ver}
56 %if %{portname} == gtk2
57 # BuildRequires: gtk+-2.0-devel
58 %else
59 # BuildRequires: gtk+-devel >= 1.2.0
60 %endif
61
62 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
63
64 # all packages providing an implementation of wxWidgets library (regardless of
65 # the toolkit used) should provide the (virtual) wxwin package, this makes it
66 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
67 Provides: wxwin
68 Provides: wxGTK
69
70 %description
71 wxWidgets is a free C++ library for cross-platform GUI development.
72 With wxWidgets, you can create applications for different GUIs (GTK+,
73 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
74
75 %package devel
76 Summary: The GTK+ %{gtkver} port of the wxWidgets library
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79 Requires: %{wxbasename}-devel = %{ver}
80 Provides: wxGTK-devel
81
82 %description devel
83 The GTK+ %{gtkver} port of the wxWidgets library, header files.
84
85 %package gl
86 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
87 Group: X11/Libraries
88 Requires: %{name} = %{ver}
89 Provides: wxGTK-gl
90
91 %description gl
92 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
93
94 %package -n %{wxbasename}
95 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
96 Group: Development/Libraries
97 Provides: wxBase
98
99 %description -n %{wxbasename}
100 wxBase is a collection of C++ classes providing basic data structures (strings,
101 lists, arrays), portable wrappers around many OS-specific funstions (file
102 operations, time/date manipulations, threads, processes, sockets, shared
103 library loading) as well as other utility classes (streams, archive and
104 compression). wxBase currently supports Win32, most Unix variants (Linux,
105 FreeBSD, Solaris, HP-UX) and MacOS X 10.3.
106
107 %package -n %{wxbasename}-devel
108 Summary: wxBase library, header files.
109 Group: Development/Libraries
110 Provides: wxBase-devel
111
112 %description -n %{wxbasename}-devel
113 wxBase library - non-GUI support classes of the wxWidgets toolkit,
114 header files.
115
116 %package contrib
117 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
118 Group: X11/Libraries
119 Requires: %{name} = %{ver}
120
121 %description contrib
122 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
123
124 %package contrib-devel
125 Summary: The GTK+ %{gtkver} port of the wxWidgets library
126 Group: X11/Libraries
127 Requires: %{name}-contrib = %{ver}
128 Requires: %{name}-devel = %{ver}
129
130 %description contrib-devel
131 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
132
133 %prep
134 %setup -q -n wxGTK-%{ver}
135
136 %build
137 if [ "$SMP" != "" ]; then
138 export MAKE="make -j$SMP"
139 else
140 export MAKE="make"
141 fi
142
143 mkdir obj-shared-no-gui
144 cd obj-shared-no-gui
145 ../configure --prefix=%{pref} \
146 --disable-gui \
147 %if %{unicode}
148 --enable-unicode \
149 %endif
150 --disable-optimise
151 $MAKE
152 cd ..
153
154 mkdir obj-shared
155 cd obj-shared
156 ../configure --prefix=%{pref} \
157 %if ! %{gtk2}
158 --with-gtk1 \
159 %else
160 --with-gtk2 \
161 %endif
162 %if %{unicode}
163 --enable-unicode \
164 %endif
165 --disable-optimise \
166 --with-opengl
167 $MAKE
168
169 cd contrib/src
170 $MAKE
171 cd ../../..
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175 (cd obj-shared-no-gui; make prefix=$RPM_BUILD_ROOT/usr install)
176 (cd obj-shared; make prefix=$RPM_BUILD_ROOT/usr install)
177
178 # --- wxBase headers list begins here ---
179 cat <<EOF >wxbase-headers.files
180 wx/afterstd.h
181 wx/app.h
182 wx/apptrait.h
183 wx/archive.h
184 wx/arrimpl.cpp
185 wx/arrstr.h
186 wx/beforestd.h
187 wx/buffer.h
188 wx/build.h
189 wx/chkconf.h
190 wx/clntdata.h
191 wx/cmdline.h
192 wx/confbase.h
193 wx/config.h
194 wx/containr.h
195 wx/datetime.h
196 wx/datetime.inl
197 wx/datstrm.h
198 wx/dde.h
199 wx/debug.h
200 wx/defs.h
201 wx/dir.h
202 wx/dlimpexp.h
203 wx/dynarray.h
204 wx/dynlib.h
205 wx/dynload.h
206 wx/encconv.h
207 wx/event.h
208 wx/except.h
209 wx/features.h
210 wx/ffile.h
211 wx/file.h
212 wx/fileconf.h
213 wx/filefn.h
214 wx/filename.h
215 wx/filesys.h
216 wx/fontenc.h
217 wx/fontmap.h
218 wx/fs_mem.h
219 wx/fs_zip.h
220 wx/hash.h
221 wx/hashmap.h
222 wx/hashset.h
223 wx/html/forcelnk.h
224 wx/iconloc.h
225 wx/init.h
226 wx/intl.h
227 wx/iosfwrap.h
228 wx/ioswrap.h
229 wx/ipc.h
230 wx/ipcbase.h
231 wx/isql.h
232 wx/isqlext.h
233 wx/list.h
234 wx/listimpl.cpp
235 wx/log.h
236 wx/longlong.h
237 wx/math.h
238 wx/memconf.h
239 wx/memory.h
240 wx/memtext.h
241 wx/mimetype.h
242 wx/module.h
243 wx/msgout.h
244 wx/mstream.h
245 wx/object.h
246 wx/platform.h
247 wx/process.h
248 wx/ptr_scpd.h
249 wx/regex.h
250 wx/scopeguard.h
251 wx/snglinst.h
252 wx/sstream.h
253 wx/stack.h
254 wx/stackwalk.h
255 wx/stdpaths.h
256 wx/stockitem.h
257 wx/stopwatch.h
258 wx/strconv.h
259 wx/stream.h
260 wx/string.h
261 wx/sysopt.h
262 wx/textbuf.h
263 wx/textfile.h
264 wx/thread.h
265 wx/thrimpl.cpp
266 wx/timer.h
267 wx/tokenzr.h
268 wx/txtstrm.h
269 wx/types.h
270 wx/uri.h
271 wx/utils.h
272 wx/variant.h
273 wx/vector.h
274 wx/version.h
275 wx/volume.h
276 wx/wfstream.h
277 wx/wx.h
278 wx/wxchar.h
279 wx/wxprec.h
280 wx/xti.h
281 wx/xtistrm.h
282 wx/zipstrm.h
283 wx/zstream.h
284 wx/fs_inet.h
285 wx/gsocket.h
286 wx/protocol/file.h
287 wx/protocol/ftp.h
288 wx/protocol/http.h
289 wx/protocol/protocol.h
290 wx/sckaddr.h
291 wx/sckipc.h
292 wx/sckstrm.h
293 wx/socket.h
294 wx/url.h
295 wx/xml/xml.h
296 wx/xtixml.h
297 wx/db.h
298 wx/dbkeyg.h
299 wx/dbtable.h
300 EOF
301 # --- wxBase headers list ends here ---
302 cat <<EOF >wxbase-headers.paths
303 %{_includedir}/wx-%{ver2}/wx/afterstd.h
304 %{_includedir}/wx-%{ver2}/wx/app.h
305 %{_includedir}/wx-%{ver2}/wx/apptrait.h
306 %{_includedir}/wx-%{ver2}/wx/archive.h
307 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
308 %{_includedir}/wx-%{ver2}/wx/arrstr.h
309 %{_includedir}/wx-%{ver2}/wx/beforestd.h
310 %{_includedir}/wx-%{ver2}/wx/buffer.h
311 %{_includedir}/wx-%{ver2}/wx/build.h
312 %{_includedir}/wx-%{ver2}/wx/chkconf.h
313 %{_includedir}/wx-%{ver2}/wx/clntdata.h
314 %{_includedir}/wx-%{ver2}/wx/cmdline.h
315 %{_includedir}/wx-%{ver2}/wx/confbase.h
316 %{_includedir}/wx-%{ver2}/wx/config.h
317 %{_includedir}/wx-%{ver2}/wx/containr.h
318 %{_includedir}/wx-%{ver2}/wx/datetime.h
319 %{_includedir}/wx-%{ver2}/wx/datetime.inl
320 %{_includedir}/wx-%{ver2}/wx/datstrm.h
321 %{_includedir}/wx-%{ver2}/wx/dde.h
322 %{_includedir}/wx-%{ver2}/wx/debug.h
323 %{_includedir}/wx-%{ver2}/wx/defs.h
324 %{_includedir}/wx-%{ver2}/wx/dir.h
325 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
326 %{_includedir}/wx-%{ver2}/wx/dynarray.h
327 %{_includedir}/wx-%{ver2}/wx/dynlib.h
328 %{_includedir}/wx-%{ver2}/wx/dynload.h
329 %{_includedir}/wx-%{ver2}/wx/encconv.h
330 %{_includedir}/wx-%{ver2}/wx/event.h
331 %{_includedir}/wx-%{ver2}/wx/except.h
332 %{_includedir}/wx-%{ver2}/wx/features.h
333 %{_includedir}/wx-%{ver2}/wx/ffile.h
334 %{_includedir}/wx-%{ver2}/wx/file.h
335 %{_includedir}/wx-%{ver2}/wx/fileconf.h
336 %{_includedir}/wx-%{ver2}/wx/filefn.h
337 %{_includedir}/wx-%{ver2}/wx/filename.h
338 %{_includedir}/wx-%{ver2}/wx/filesys.h
339 %{_includedir}/wx-%{ver2}/wx/fontenc.h
340 %{_includedir}/wx-%{ver2}/wx/fontmap.h
341 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
342 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
343 %{_includedir}/wx-%{ver2}/wx/hash.h
344 %{_includedir}/wx-%{ver2}/wx/hashmap.h
345 %{_includedir}/wx-%{ver2}/wx/hashset.h
346 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
347 %{_includedir}/wx-%{ver2}/wx/iconloc.h
348 %{_includedir}/wx-%{ver2}/wx/init.h
349 %{_includedir}/wx-%{ver2}/wx/intl.h
350 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
351 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
352 %{_includedir}/wx-%{ver2}/wx/ipc.h
353 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
354 %{_includedir}/wx-%{ver2}/wx/isql.h
355 %{_includedir}/wx-%{ver2}/wx/isqlext.h
356 %{_includedir}/wx-%{ver2}/wx/list.h
357 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
358 %{_includedir}/wx-%{ver2}/wx/log.h
359 %{_includedir}/wx-%{ver2}/wx/longlong.h
360 %{_includedir}/wx-%{ver2}/wx/math.h
361 %{_includedir}/wx-%{ver2}/wx/memconf.h
362 %{_includedir}/wx-%{ver2}/wx/memory.h
363 %{_includedir}/wx-%{ver2}/wx/memtext.h
364 %{_includedir}/wx-%{ver2}/wx/mimetype.h
365 %{_includedir}/wx-%{ver2}/wx/module.h
366 %{_includedir}/wx-%{ver2}/wx/msgout.h
367 %{_includedir}/wx-%{ver2}/wx/mstream.h
368 %{_includedir}/wx-%{ver2}/wx/object.h
369 %{_includedir}/wx-%{ver2}/wx/platform.h
370 %{_includedir}/wx-%{ver2}/wx/process.h
371 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
372 %{_includedir}/wx-%{ver2}/wx/regex.h
373 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
374 %{_includedir}/wx-%{ver2}/wx/snglinst.h
375 %{_includedir}/wx-%{ver2}/wx/sstream.h
376 %{_includedir}/wx-%{ver2}/wx/stack.h
377 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
378 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
379 %{_includedir}/wx-%{ver2}/wx/stockitem.h
380 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
381 %{_includedir}/wx-%{ver2}/wx/strconv.h
382 %{_includedir}/wx-%{ver2}/wx/stream.h
383 %{_includedir}/wx-%{ver2}/wx/string.h
384 %{_includedir}/wx-%{ver2}/wx/sysopt.h
385 %{_includedir}/wx-%{ver2}/wx/textbuf.h
386 %{_includedir}/wx-%{ver2}/wx/textfile.h
387 %{_includedir}/wx-%{ver2}/wx/thread.h
388 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
389 %{_includedir}/wx-%{ver2}/wx/timer.h
390 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
391 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
392 %{_includedir}/wx-%{ver2}/wx/types.h
393 %{_includedir}/wx-%{ver2}/wx/uri.h
394 %{_includedir}/wx-%{ver2}/wx/utils.h
395 %{_includedir}/wx-%{ver2}/wx/variant.h
396 %{_includedir}/wx-%{ver2}/wx/vector.h
397 %{_includedir}/wx-%{ver2}/wx/version.h
398 %{_includedir}/wx-%{ver2}/wx/volume.h
399 %{_includedir}/wx-%{ver2}/wx/wfstream.h
400 %{_includedir}/wx-%{ver2}/wx/wx.h
401 %{_includedir}/wx-%{ver2}/wx/wxchar.h
402 %{_includedir}/wx-%{ver2}/wx/wxprec.h
403 %{_includedir}/wx-%{ver2}/wx/xti.h
404 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
405 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
406 %{_includedir}/wx-%{ver2}/wx/zstream.h
407 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
408 %{_includedir}/wx-%{ver2}/wx/gsocket.h
409 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
410 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
411 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
412 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
413 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
414 %{_includedir}/wx-%{ver2}/wx/sckipc.h
415 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
416 %{_includedir}/wx-%{ver2}/wx/socket.h
417 %{_includedir}/wx-%{ver2}/wx/url.h
418 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
419 %{_includedir}/wx-%{ver2}/wx/xtixml.h
420 %{_includedir}/wx-%{ver2}/wx/db.h
421 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
422 %{_includedir}/wx-%{ver2}/wx/dbtable.h
423 EOF
424 # --- wxBase headers list ends here ---
425
426 # temporarily remove base headers
427 mkdir $RPM_BUILD_ROOT/_save_dir
428 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
429 for f in `cat wxbase-headers.files` ; do
430 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
431 done
432 # list of all core headers:
433 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
434 # move base headers (actually all headers) back again
435 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
436 rm -rf $RPM_BUILD_ROOT/_save_dir
437
438 # contrib stuff:
439 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT/usr install)
440 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT/usr install)
441
442 %clean
443 rm -rf $RPM_BUILD_ROOT
444
445 %post
446 /sbin/ldconfig
447
448 %postun
449 /sbin/ldconfig
450
451 %post devel
452 # link wx-config when you install RPM.
453 %if %{unicode}
454 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
455 %endif
456 # link wx-config with explicit name.
457 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
458 /sbin/ldconfig
459
460 %postun devel
461 /sbin/ldconfig
462
463 %preun devel
464 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
465 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
466 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
467 if test "x$SUM1" = "x$SUM2" ; then
468 rm -f %{_bindir}/wx-config
469 fi
470 fi
471 rm -f %{_bindir}/%{wxconfiglink}
472
473 %post -n %{wxbasename}
474 /sbin/ldconfig
475
476 %postun -n %{wxbasename}
477 /sbin/ldconfig
478
479 %post -n %{wxbasename}-devel
480 # link wx-config with explicit name.
481 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
482 /sbin/ldconfig
483
484 %postun -n %{wxbasename}-devel
485 /sbin/ldconfig
486
487 %preun -n %{wxbasename}-devel
488 rm -f %{_bindir}/%{wxbaseconfiglink}
489
490 %post gl
491 /sbin/ldconfig
492
493 %postun gl
494 /sbin/ldconfig
495
496 %post contrib
497 /sbin/ldconfig
498
499 %postun contrib
500 /sbin/ldconfig
501
502 %post contrib-devel
503 /sbin/ldconfig
504
505 %postun contrib-devel
506 /sbin/ldconfig
507
508 %files
509 %defattr(-,root,root)
510 %doc COPYING.LIB *.txt
511 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
512 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
513 %if !%{unicode}
514 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
515 %endif
516 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
517 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
518 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
519 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
520
521
522 %files devel -f core-headers.files
523 %defattr(-,root,root)
524 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
525 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
526 %if !%{unicode}
527 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
528 %endif
529 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
530 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
531 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
532 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
533 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
534 %dir %{_libdir}/wx
535 %{_libdir}/wx/config/%{wxconfig}
536 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
537 %{_bindir}/wxrc*
538
539 %files -n %{wxbasename}
540 %defattr(-,root,root)
541 %{_libdir}/libwx_base*-%{ver2}.so.*
542 #%{_datadir}/locale/*/*/*
543 # %if %{unicode}
544 # %{_libdir}/libwxregexu-%{ver2}.a
545 #%endif
546
547 %files -n %{wxbasename}-devel -f wxbase-headers.paths
548 %defattr (-,root,root)
549 %dir %{_includedir}/wx-%{ver2}
550 %{_libdir}/libwx_base*-%{ver2}.so
551 %dir %{_libdir}/wx
552 %{_libdir}/wx/config/%{wxbaseconfig}
553 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
554 %{_datadir}/aclocal/*.m4
555
556 %files gl
557 %defattr(-,root,root)
558 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
559
560 %files contrib
561 %defattr(-,root,root)
562 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
563 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
564 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
565 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
566 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
567 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
568 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
569 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
570 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
571
572 %files contrib-devel
573 %defattr(-,root,root)
574 %dir %{_includedir}/wx-%{ver2}/wx/animate
575 %{_includedir}/wx-%{ver2}/wx/animate/*
576 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
577
578 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
579 %{_includedir}/wx-%{ver2}/wx/deprecated/*
580 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
581
582 %dir %{_includedir}/wx-%{ver2}/wx/fl
583 %{_includedir}/wx-%{ver2}/wx/fl/*
584 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
585
586 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
587 %{_includedir}/wx-%{ver2}/wx/gizmos/*
588 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
589
590 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
591 %{_includedir}/wx-%{ver2}/wx/mmedia/*
592 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
593
594 %dir %{_includedir}/wx-%{ver2}/wx/ogl
595 %{_includedir}/wx-%{ver2}/wx/ogl/*
596 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
597
598 %dir %{_includedir}/wx-%{ver2}/wx/plot
599 %{_includedir}/wx-%{ver2}/wx/plot/*
600 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
601
602 %dir %{_includedir}/wx-%{ver2}/wx/stc
603 %{_includedir}/wx-%{ver2}/wx/stc/*
604 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
605
606 %dir %{_includedir}/wx-%{ver2}/wx/svg
607 %{_includedir}/wx-%{ver2}/wx/svg/*
608 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so