]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
Some Motif fixes; makefile fixes; added wxTransferStreamToFile/FileToStream for wxWin
[wxWidgets.git] / wxGTK.spec
1 # Note that this is NOT a relocatable package
2 %define pref /usr
3 %define ver 2.1.14
4 %define rel 0
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: wxGTK-%{ver}.tar.gz
13 URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
14 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
15 BuildRoot: /tmp/wxgtk_root
16
17 # all packages providing an implementation of wxWindows library (regardless of
18 # the toolkit used) should provide the (virtual) wxwin package, this makes it
19 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
20 Provides: wxwin
21
22 %description
23 wxWindows is a free C++ library for cross-platform GUI development.
24 With wxWindows, you can create applications for different GUIs (GTK+,
25 Motif/LessTif, MS Windows, Mac) from the same source code.
26
27 %package devel
28 Summary: The GTK+ 1.2 port of the wxWindows library
29 Group: X11/Libraries
30 Requires: wxGTK
31
32 %description devel
33 Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
34
35 %prep
36 %setup -n wxGTK
37 ./configure --prefix=%{pref} --enable-burnt_name --with-odbc
38
39 %build
40 if [ "$SMP" != "" ]; then
41 export MAKE="make -j$SMP"
42 else
43 export MAKE="make"
44 fi
45 $MAKE
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 make prefix=$RPM_BUILD_ROOT%{pref} install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /sbin/ldconfig
56
57 %postun
58 /sbin/ldconfig
59
60 %files
61 %defattr (644, root, root, 755)
62 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
63 %dir %{pref}/share/wx
64 %{pref}/share/wx/*
65 %attr(755, -, -) %{pref}/lib/libwx_gtk*
66
67 %files devel
68 %defattr (644, root, root, 755)
69 %dir %{pref}/include/wx
70 %{pref}/include/wx/*
71 %dir %{pref}/lib/wx
72 %{pref}/lib/wx/*
73 %attr(755, -, -) %{pref}/bin/wx-config
74