Removed the SaveBG hack. The real incompatibility is that the MemoryDC
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.5.1
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 0
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 %if %{gtk2}
16 %define gtkver 2
17 %define portname gtk2
18 %else
19 %define gtkver 1.2
20 %define portname gtk
21 %endif
22
23 %if %{unicode}
24 %define name wx-%{portname}-unicode
25 %define wxbasename wx-base-unicode
26 %else
27 %define name wx-%{portname}
28 %define wxbasename wx-base
29 %endif
30
31 %if %{unicode}
32 %define wxconfigname wx%{portname}u-%{ver2}-config
33 %else
34 %define wxconfigname wx%{portname}-%{ver2}-config
35 %endif
36
37 Name: %{name}
38 Summary: The GTK+ %{gtkver} port of the wxWindows library
39 Version: %{ver}
40 Release: %{rel}
41 License: wxWindows Licence
42 Group: X11/Libraries
43 Source: wxGTK-%{ver}.tar.bz2
44 URL: http://www.wxwindows.org
45 Packager: Vadim Zeitlin <vadim@wxwindows.org>
46 Prefix: %{pref}
47 BuildRoot: /var/tmp/%{name}-root
48
49 # all packages providing an implementation of wxWindows library (regardless of
50 # the toolkit used) should provide the (virtual) wxwin package, this makes it
51 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
52 Provides: wxwin
53 Provides: wxGTK
54
55 # in addition, we should provide libwx_gtk as automatic generator only notices
56 # libwx_gtk-%{ver}-%{rel}
57 Provides: libwx_gtk.so
58 Provides: libwx_gtk-%{ver2}.so
59
60 Requires: %{wxbasename} = %{ver}
61
62 %description
63 wxWindows is a free C++ library for cross-platform GUI development.
64 With wxWindows, you can create applications for different GUIs (GTK+,
65 Motif/LessTif, MS Windows, Mac) from the same source code.
66
67 %package devel
68 Summary: The GTK+ %{gtkver} port of the wxWindows library
69 Group: X11/Libraries
70 Requires: %{name} = %{ver}
71 Requires: %{wxbasename}-devel = %{ver}
72 Provides: wxGTK-devel
73
74 %description devel
75 Header files for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
76
77 %package gl
78 Summary: The GTK+ %{gtkver} port of the wxWindows library, OpenGL add-on.
79 Group: X11/Libraries
80 Requires: %{name} = %{ver}
81
82 %description gl
83 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
84
85 %package static
86 Summary: wxGTK static libraries
87 Group: Development/Libraries
88 Requires: %{wxbasename}-static
89
90 %description static
91 Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
92
93 %package contrib
94 Summary: The GTK+ %{gtkver} port of the wxWindows library, contributed libraries.
95 Group: X11/Libraries
96 Requires: %{name} = %{ver}
97
98 %description contrib
99 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
100
101 %package contrib-devel
102 Summary: The GTK+ %{gtkver} port of the wxWindows library
103 Group: X11/Libraries
104 Requires: %{name}-contrib = %{ver}
105 Requires: %{name}-devel = %{ver}
106
107 %description contrib-devel
108 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
109
110 %prep
111 %setup -q -n wxGTK-%{ver}
112
113 %build
114 if [ "$SMP" != "" ]; then
115 export MAKE="make -j$SMP"
116 else
117 export MAKE="make"
118 fi
119
120 mkdir obj-shared
121 cd obj-shared
122 ../configure --prefix=%{pref} \
123 %if %{unicode}
124 --enable-unicode \
125 %else
126 --with-odbc \
127 %endif
128 %if %{gtk2}
129 --enable-gtk2 \
130 %endif
131 --with-opengl
132 $MAKE
133 cd contrib/src
134 $MAKE
135 cd ../../..
136
137 mkdir obj-static
138 cd obj-static
139 ../configure --prefix=%{pref} --disable-shared \
140 %if %{unicode}
141 --enable-unicode \
142 %else
143 --with-odbc \
144 %endif
145 %if %{gtk2}
146 --enable-gtk2 \
147 %endif
148 --with-opengl
149 $MAKE
150 cd ..
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
155 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
156
157 # Remove headers that are part of wx-base-devel:
158
159 # --- wxBase headers list begins here ---
160 cat <<EOF >wxbase-headers-list
161 wx/afterstd.h
162 wx/app.h
163 wx/apptrait.h
164 wx/arrimpl.cpp
165 wx/arrstr.h
166 wx/beforestd.h
167 wx/buffer.h
168 wx/build.h
169 wx/chkconf.h
170 wx/cmdline.h
171 wx/confbase.h
172 wx/config.h
173 wx/containr.h
174 wx/datetime.h
175 wx/datetime.inl
176 wx/datstrm.h
177 wx/dde.h
178 wx/debug.h
179 wx/defs.h
180 wx/dir.h
181 wx/dlimpexp.h
182 wx/dynarray.h
183 wx/dynlib.h
184 wx/dynload.h
185 wx/encconv.h
186 wx/event.h
187 wx/except.h
188 wx/features.h
189 wx/ffile.h
190 wx/file.h
191 wx/fileconf.h
192 wx/filefn.h
193 wx/filename.h
194 wx/filesys.h
195 wx/fontenc.h
196 wx/fontmap.h
197 wx/fs_mem.h
198 wx/fs_zip.h
199 wx/gzstream.h
200 wx/hash.h
201 wx/hashmap.h
202 wx/hashset.h
203 wx/iconloc.h
204 wx/init.h
205 wx/intl.h
206 wx/iosfwrap.h
207 wx/ioswrap.h
208 wx/ipc.h
209 wx/ipcbase.h
210 wx/isql.h
211 wx/isqlext.h
212 wx/list.h
213 wx/listimpl.cpp
214 wx/log.h
215 wx/longlong.h
216 wx/math.h
217 wx/memconf.h
218 wx/memory.h
219 wx/memtext.h
220 wx/mimetype.h
221 wx/module.h
222 wx/msgout.h
223 wx/msgout.h
224 wx/mstream.h
225 wx/object.h
226 wx/platform.h
227 wx/process.h
228 wx/ptr_scpd.h
229 wx/regex.h
230 wx/scopeguard.h
231 wx/snglinst.h
232 wx/stack.h
233 wx/stopwatch.h
234 wx/strconv.h
235 wx/stream.h
236 wx/string.h
237 wx/sysopt.h
238 wx/textbuf.h
239 wx/textfile.h
240 wx/thread.h
241 wx/thrimpl.cpp
242 wx/timer.h
243 wx/tokenzr.h
244 wx/txtstrm.h
245 wx/types.h
246 wx/utils.h
247 wx/variant.h
248 wx/vector.h
249 wx/version.h
250 wx/volume.h
251 wx/wfstream.h
252 wx/wx.h
253 wx/wxchar.h
254 wx/wxprec.h
255 wx/xti.h
256 wx/xtistrm.h
257 wx/zipstrm.h
258 wx/zstream.h
259 wx/msw/apptrait.h
260 wx/msw/apptbase.h
261 wx/msw/chkconf.h
262 wx/msw/crashrpt.h
263 wx/msw/dde.h
264 wx/msw/gccpriv.h
265 wx/msw/mimetype.h
266 wx/msw/winundef.h
267 wx/msw/wrapcctl.h
268 wx/msw/wrapwin.h
269 wx/fs_inet.h
270 wx/gsocket.h
271 wx/protocol/file.h
272 wx/protocol/ftp.h
273 wx/protocol/http.h
274 wx/protocol/protocol.h
275 wx/sckaddr.h
276 wx/sckipc.h
277 wx/sckstrm.h
278 wx/socket.h
279 wx/url.h
280 wx/msw/gsockmsw.h
281 wx/xml/xml.h
282 wx/xtixml.h
283 wx/db.h
284 wx/dbkeyg.h
285 wx/dbtable.h
286 EOF
287 # --- wxBase headers list ends here ---
288 for f in `cat wxbase-headers-list` ; do
289 rm -f $RPM_BUILD_ROOT%{_includedir}/$f
290 done
291
292 # list of all core headers:
293 find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
294
295 # contrib stuff:
296 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
297 (cd obj-shared/contrib/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
298
299 # remove wxBase files so that RPM doesn't complain about unpackaged files:
300 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
301 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
302 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
303
304 %clean
305 rm -rf $RPM_BUILD_ROOT
306
307 %post
308 /sbin/ldconfig
309
310 %postun
311 /sbin/ldconfig
312
313 %post gl
314 /sbin/ldconfig
315
316 %postun gl
317 /sbin/ldconfig
318
319 %post devel
320 # Install wx-config if there isn't any
321 if test ! -f %{_bindir}/wx-config ; then
322 ln -sf %{wxconfigname} %{_bindir}/wx-config
323 fi
324
325 %preun devel
326 # Remove wx-config if it points to this package
327 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
328 SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
329 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
330 if test "x$SUM1" = "x$SUM2" ; then
331 rm -f %{_bindir}/wx-config
332 fi
333 fi
334
335
336 %files
337 %defattr(-,root,root)
338 %doc COPYING.LIB *.txt
339 %dir %{_datadir}/wx
340 %{_datadir}/wx/*
341 %{_libdir}/libwx_%{portname}*_core*.so.*
342 %{_libdir}/libwx_%{portname}*_html*.so.*
343 %{_libdir}/libwx_%{portname}*_adv*.so.*
344 %if !%{unicode}
345 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
346 %endif
347
348 %files devel -f core-headers.files
349 %defattr(-,root,root)
350 %{_libdir}/libwx_%{portname}*_core*.so
351 %{_libdir}/libwx_%{portname}*_html*.so
352 %{_libdir}/libwx_%{portname}*_adv*.so
353 %if !%{unicode}
354 %{_libdir}/libwx_%{portname}*_dbgrid*.so
355 %endif
356 %{_libdir}/libwx_%{portname}*_gl*.so
357 %dir %{_libdir}/wx
358 %{_libdir}/wx/*
359 %{_bindir}/%{wxconfigname}
360
361 %files gl
362 %defattr(-,root,root)
363 %{_libdir}/libwx_%{portname}*_gl*.so.*
364
365 %files static
366 %defattr (-,root,root)
367 %{_libdir}/libwx_gtk*.a
368
369 %files contrib
370 %defattr(-,root,root)
371 %{_libdir}/libwx_%{portname}*_animate*.so.*
372 %{_libdir}/libwx_%{portname}*_deprecated*.so.*
373 %{_libdir}/libwx_%{portname}*_fl*.so.*
374 %{_libdir}/libwx_%{portname}*_gizmos*.so.*
375 %{_libdir}/libwx_%{portname}*_mmedia*.so.*
376 %{_libdir}/libwx_%{portname}*_ogl*.so.*
377 %{_libdir}/libwx_%{portname}*_plot*.so.*
378 %{_libdir}/libwx_%{portname}*_stc*.so.*
379 %{_libdir}/libwx_%{portname}*_svg*.so.*
380 %{_libdir}/libwx_%{portname}*_xrc*.so.*
381
382 %files contrib-devel
383 %defattr(-,root,root)
384 %{_bindir}/wxrc
385 %dir %{_includedir}/wx/animate
386 %{_includedir}/wx/animate/*
387 %{_libdir}/libwx_%{portname}*_animate*.so
388
389 %dir %{_includedir}/wx/deprecated
390 %{_includedir}/wx/deprecated/*
391 %{_libdir}/libwx_%{portname}*_deprecated*.so
392
393 %dir %{_includedir}/wx/fl
394 %{_includedir}/wx/fl/*
395 %{_libdir}/libwx_%{portname}*_fl*.so
396
397 %dir %{_includedir}/wx/gizmos
398 %{_includedir}/wx/gizmos/*
399 %{_libdir}/libwx_%{portname}*_gizmos*.so
400
401 %dir %{_includedir}/wx/mmedia
402 %{_includedir}/wx/mmedia/*
403 %{_libdir}/libwx_%{portname}*_mmedia*.so
404
405 %dir %{_includedir}/wx/ogl
406 %{_includedir}/wx/ogl/*
407 %{_libdir}/libwx_%{portname}*_ogl*.so
408
409 %dir %{_includedir}/wx/plot
410 %{_includedir}/wx/plot/*
411 %{_libdir}/libwx_%{portname}*_plot*.so
412
413 %dir %{_includedir}/wx/stc
414 %{_includedir}/wx/stc/*
415 %{_libdir}/libwx_%{portname}*_stc*.so
416
417 %dir %{_includedir}/wx/svg
418 %{_includedir}/wx/svg/*
419 %{_libdir}/libwx_%{portname}*_svg*.so
420
421 %dir %{_includedir}/wx/xrc
422 %{_includedir}/wx/xrc/*
423 %{_libdir}/libwx_%{portname}*_xrc*.so