added AC_CXX_DYNAMIC_CAST
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.5.4
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 %if %{gtk2}
16 %define gtkver 2
17 %define portname gtk2
18 %else
19 %define gtkver 1.2
20 %define portname gtk
21 %endif
22
23 %if %{unicode}
24 %define name wx-%{portname}-unicode
25 %define wxbasename wx-base-unicode
26 %else
27 %define name wx-%{portname}
28 %define wxbasename wx-base
29 %endif
30
31 %if %{unicode}
32 %define wxconfigname %{portname}-unicode-release-%{ver2}
33 %define wxconfiglinkname wx%{portname}u-%{ver2}-config
34 %else
35 %define wxconfigname %{portname}-ansi-release-%{ver2}
36 %define wxconfiglinkname wx%{portname}-%{ver2}-config
37 %endif
38
39 Name: %{name}
40 Summary: The GTK+ %{gtkver} port of the wxWindows library
41 Version: %{ver}
42 Release: %{rel}
43 License: wxWindows Licence
44 Group: X11/Libraries
45 Source: wxGTK-%{ver}.tar.bz2
46 URL: http://www.wxwindows.org
47 Packager: Vadim Zeitlin <vadim@wxwindows.org>
48 Prefix: %{pref}
49 BuildRoot: /var/tmp/%{name}-root
50
51 # all packages providing an implementation of wxWindows library (regardless of
52 # the toolkit used) should provide the (virtual) wxwin package, this makes it
53 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
54 Provides: wxwin
55 Provides: wxGTK
56
57 # in addition, we should provide libwx_gtk as automatic generator only notices
58 # libwx_gtk-%{ver}-%{rel}
59 Provides: libwx_gtk.so
60 Provides: libwx_gtk-%{ver2}.so
61
62 Requires: %{wxbasename} = %{ver}
63
64 %description
65 wxWindows is a free C++ library for cross-platform GUI development.
66 With wxWindows, you can create applications for different GUIs (GTK+,
67 Motif/LessTif, MS Windows, Mac) from the same source code.
68
69 %package devel
70 Summary: The GTK+ %{gtkver} port of the wxWindows library
71 Group: X11/Libraries
72 Requires: %{name} = %{ver}
73 Requires: %{wxbasename}-devel = %{ver}
74 Provides: wxGTK-devel
75
76 %description devel
77 Header files for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
78
79 %package gl
80 Summary: The GTK+ %{gtkver} port of the wxWindows library, OpenGL add-on.
81 Group: X11/Libraries
82 Requires: %{name} = %{ver}
83
84 %description gl
85 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
86
87 %package static
88 Summary: wxGTK static libraries
89 Group: Development/Libraries
90 Requires: %{wxbasename}-static
91
92 %description static
93 Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
94
95 %package contrib
96 Summary: The GTK+ %{gtkver} port of the wxWindows library, contributed libraries.
97 Group: X11/Libraries
98 Requires: %{name} = %{ver}
99
100 %description contrib
101 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
102
103 %package contrib-devel
104 Summary: The GTK+ %{gtkver} port of the wxWindows library
105 Group: X11/Libraries
106 Requires: %{name}-contrib = %{ver}
107 Requires: %{name}-devel = %{ver}
108
109 %description contrib-devel
110 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
111
112 %prep
113 %setup -q -n wxGTK-%{ver}
114
115 %build
116 if [ "$SMP" != "" ]; then
117 export MAKE="make -j$SMP"
118 else
119 export MAKE="make"
120 fi
121
122 mkdir obj-shared
123 cd obj-shared
124 ../configure --prefix=%{pref} \
125 %if %{unicode}
126 --enable-unicode \
127 %else
128 --with-odbc \
129 %endif
130 %if ! %{gtk2}
131 --disable-gtk2 \
132 %endif
133 --with-opengl
134 $MAKE
135 cd contrib/src
136 $MAKE
137 cd ../../..
138
139 mkdir obj-static
140 cd obj-static
141 ../configure --prefix=%{pref} --disable-shared \
142 %if %{unicode}
143 --enable-unicode \
144 %else
145 --with-odbc \
146 %endif
147 %if ! %{gtk2}
148 --disable-gtk2 \
149 %endif
150 --with-opengl
151 $MAKE
152 cd ..
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
157 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
158
159 # Remove headers that are part of wx-base-devel:
160
161 # --- wxBase headers list begins here ---
162 cat <<EOF >wxbase-headers-list
163 wx/afterstd.h
164 wx/app.h
165 wx/apptrait.h
166 wx/archive.h
167 wx/arrimpl.cpp
168 wx/arrstr.h
169 wx/beforestd.h
170 wx/buffer.h
171 wx/build.h
172 wx/chkconf.h
173 wx/clntdata.h
174 wx/cmdline.h
175 wx/confbase.h
176 wx/config.h
177 wx/containr.h
178 wx/datetime.h
179 wx/datetime.inl
180 wx/datstrm.h
181 wx/dde.h
182 wx/debug.h
183 wx/defs.h
184 wx/dir.h
185 wx/dlimpexp.h
186 wx/dynarray.h
187 wx/dynlib.h
188 wx/dynload.h
189 wx/encconv.h
190 wx/event.h
191 wx/except.h
192 wx/features.h
193 wx/ffile.h
194 wx/file.h
195 wx/fileconf.h
196 wx/filefn.h
197 wx/filename.h
198 wx/filesys.h
199 wx/fontenc.h
200 wx/fontmap.h
201 wx/fs_mem.h
202 wx/fs_zip.h
203 wx/hash.h
204 wx/hashmap.h
205 wx/hashset.h
206 wx/iconloc.h
207 wx/init.h
208 wx/intl.h
209 wx/iosfwrap.h
210 wx/ioswrap.h
211 wx/ipc.h
212 wx/ipcbase.h
213 wx/isql.h
214 wx/isqlext.h
215 wx/list.h
216 wx/listimpl.cpp
217 wx/log.h
218 wx/longlong.h
219 wx/math.h
220 wx/memconf.h
221 wx/memory.h
222 wx/memtext.h
223 wx/mimetype.h
224 wx/module.h
225 wx/msgout.h
226 wx/msgout.h
227 wx/mstream.h
228 wx/object.h
229 wx/platform.h
230 wx/process.h
231 wx/ptr_scpd.h
232 wx/regex.h
233 wx/scopeguard.h
234 wx/snglinst.h
235 wx/sstream.h
236 wx/stack.h
237 wx/stackwalk.h
238 wx/stdpaths.h
239 wx/stockitem.h
240 wx/stopwatch.h
241 wx/strconv.h
242 wx/stream.h
243 wx/string.h
244 wx/sysopt.h
245 wx/textbuf.h
246 wx/textfile.h
247 wx/thread.h
248 wx/thrimpl.cpp
249 wx/timer.h
250 wx/tokenzr.h
251 wx/txtstrm.h
252 wx/types.h
253 wx/uri.h
254 wx/utils.h
255 wx/variant.h
256 wx/vector.h
257 wx/version.h
258 wx/volume.h
259 wx/wfstream.h
260 wx/wx.h
261 wx/wxchar.h
262 wx/wxprec.h
263 wx/xti.h
264 wx/xtistrm.h
265 wx/zipstrm.h
266 wx/zstream.h
267 wx/msw/apptrait.h
268 wx/msw/apptbase.h
269 wx/msw/chkconf.h
270 wx/msw/crashrpt.h
271 wx/msw/dde.h
272 wx/msw/debughlp.h
273 wx/msw/gccpriv.h
274 wx/msw/mimetype.h
275 wx/msw/stackwalk.h
276 wx/msw/winundef.h
277 wx/msw/wrapcctl.h
278 wx/msw/wrapwin.h
279 wx/fs_inet.h
280 wx/gsocket.h
281 wx/protocol/file.h
282 wx/protocol/ftp.h
283 wx/protocol/http.h
284 wx/protocol/protocol.h
285 wx/sckaddr.h
286 wx/sckipc.h
287 wx/sckstrm.h
288 wx/socket.h
289 wx/url.h
290 wx/msw/gsockmsw.h
291 wx/xml/xml.h
292 wx/xtixml.h
293 wx/db.h
294 wx/dbkeyg.h
295 wx/dbtable.h
296 EOF
297 # --- wxBase headers list ends here ---
298 for f in `cat wxbase-headers-list` ; do
299 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
300 done
301
302 # list of all core headers:
303 find $RPM_BUILD_ROOT/usr/include/wx-* -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
304
305 # contrib stuff:
306 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
307 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
308
309 # remove wxBase files so that RPM doesn't complain about unpackaged files:
310 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
311 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
312 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
313 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
314
315 %clean
316 rm -rf $RPM_BUILD_ROOT
317
318 %post
319 /sbin/ldconfig
320
321 %postun
322 /sbin/ldconfig
323
324 %post gl
325 /sbin/ldconfig
326
327 %postun gl
328 /sbin/ldconfig
329
330 %post devel
331 # link wx-config when you install RPM.
332 ln -sf %{_libdir}/wx/config/%{wxconfigname} %{_bindir}/wx-config
333 # link wx-config with explicit name.
334 ln -sf %{_libdir}/wx/config/%{wxconfigname} %{_bindir}/%{wxconfiglinkname}
335
336 %preun devel
337 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
338 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfigname} | cut -c 0-32`
339 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
340 if test "x$SUM1" = "x$SUM2" ; then
341 rm -f %{_bindir}/wx-config
342 fi
343 fi
344
345 rm -f %{_bindir}/%{wxconfiglinkname}
346
347 %files
348 %defattr(-,root,root)
349 %doc COPYING.LIB *.txt
350 %{_libdir}/libwx_%{portname}*_core*.so.*
351 %{_libdir}/libwx_%{portname}*_html*.so.*
352 %{_libdir}/libwx_%{portname}*_adv*.so.*
353 %{_libdir}/libwx_%{portname}*_media*.so.*
354 %if !%{unicode}
355 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
356 %endif
357
358 %files devel -f core-headers.files
359 %defattr(-,root,root)
360 %{_libdir}/libwx_%{portname}*_core*.so
361 %{_libdir}/libwx_%{portname}*_html*.so
362 %{_libdir}/libwx_%{portname}*_adv*.so
363 %{_libdir}/libwx_%{portname}*_media*.so
364 %if !%{unicode}
365 %{_libdir}/libwx_%{portname}*_dbgrid*.so
366 %endif
367 %{_libdir}/libwx_%{portname}*_gl*.so
368 %dir %{_libdir}/wx
369 %{_libdir}/wx/*
370
371 %files gl
372 %defattr(-,root,root)
373 %{_libdir}/libwx_%{portname}*_gl*.so.*
374
375 %files static
376 %defattr (-,root,root)
377 %{_libdir}/libwx_gtk*.a
378
379 %files contrib
380 %defattr(-,root,root)
381 %{_libdir}/libwx_%{portname}*_animate*.so.*
382 %{_libdir}/libwx_%{portname}*_deprecated*.so.*
383 %{_libdir}/libwx_%{portname}*_fl*.so.*
384 %{_libdir}/libwx_%{portname}*_gizmos*.so.*
385 %{_libdir}/libwx_%{portname}*_mmedia*.so.*
386 %{_libdir}/libwx_%{portname}*_ogl*.so.*
387 %{_libdir}/libwx_%{portname}*_plot*.so.*
388 %{_libdir}/libwx_%{portname}*_stc*.so.*
389 %{_libdir}/libwx_%{portname}*_svg*.so.*
390 %{_libdir}/libwx_%{portname}*_xrc*.so.*
391
392 %files contrib-devel
393 %defattr(-,root,root)
394 %{_bindir}/wxrc*
395 %dir %{_includedir}/wx-*/wx/animate
396 %{_includedir}/wx-*/wx/animate/*
397 %{_libdir}/libwx_%{portname}*_animate*.so
398
399 %dir %{_includedir}/wx-*/wx/deprecated
400 %{_includedir}/wx-*/wx/deprecated/*
401 %{_libdir}/libwx_%{portname}*_deprecated*.so
402
403 %dir %{_includedir}/wx-*/wx/fl
404 %{_includedir}/wx-*/wx/fl/*
405 %{_libdir}/libwx_%{portname}*_fl*.so
406
407 %dir %{_includedir}/wx-*/wx/gizmos
408 %{_includedir}/wx-*/wx/gizmos/*
409 %{_libdir}/libwx_%{portname}*_gizmos*.so
410
411 %dir %{_includedir}/wx-*/wx/mmedia
412 %{_includedir}/wx-*/wx/mmedia/*
413 %{_libdir}/libwx_%{portname}*_mmedia*.so
414
415 %dir %{_includedir}/wx-*/wx/ogl
416 %{_includedir}/wx-*/wx/ogl/*
417 %{_libdir}/libwx_%{portname}*_ogl*.so
418
419 %dir %{_includedir}/wx-*/wx/plot
420 %{_includedir}/wx-*/wx/plot/*
421 %{_libdir}/libwx_%{portname}*_plot*.so
422
423 %dir %{_includedir}/wx-*/wx/stc
424 %{_includedir}/wx-*/wx/stc/*
425 %{_libdir}/libwx_%{portname}*_stc*.so
426
427 %dir %{_includedir}/wx-*/wx/svg
428 %{_includedir}/wx-*/wx/svg/*
429 %{_libdir}/libwx_%{portname}*_svg*.so
430
431 %dir %{_includedir}/wx-*/wx/xrc
432 %{_includedir}/wx-*/wx/xrc/*
433 %{_libdir}/libwx_%{portname}*_xrc*.so