6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
15 # "buildname" needs to be e.g. gtk2ud for debug builds
20 %define buildname gtk2u
22 %define buildname gtk2
31 %define name wx
-%{portname}-unicode
32 %define wxconfig
%{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic
%{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx
%{portname}u-%{ver2}-config
36 %define name wx
-%{portname}-ansi
37 %define wxconfig
%{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic
%{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx
%{portname}-%{ver2}-config
43 %define wxbasename wx
-base
-unicode
44 %define wxbaseconfig base
-unicode
-release
-%{ver2}
45 %define wxbaseconfiglink wxbaseu
-%{ver2}-config
47 %define wxbasename wx
-base
-ansi
48 %define wxbaseconfig base
-ansi
-release
-%{ver2}
49 %define wxbaseconfiglink wxbase
-%{ver2}-config
52 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
56 License: wxWindows Licence
58 Source: wxGTK
-%{ver}.tar.bz2
59 URL: http
://www.wxwidgets.org
60 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires
: gtk
+-2.0-devel
67 BuildRequires
: gtk
+-devel
>= 1.2.0
70 BuildRequires
: zlib
-devel
, libjpeg
-devel
, libpng
-devel
, libtiff
-devel
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
79 wxWidgets is a free C
++ library
for cross
-platform GUI development.
80 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
81 Motif
, MS Windows
, MacOS X
, Windows CE
, GPE
) from the same
source code.
84 Summary: The translations
for the wxWidgets library.
87 %description -n wx
-i18n
88 The translations files
for the wxWidgets library.
91 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
98 The GTK
+ %{gtkver} port of the wxWidgets library
, header files.
101 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, OpenGL add
-on.
103 Requires: %{name} = %{ver}
107 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
109 %package -n
%{wxbasename}
110 Summary: wxBase library
- non
-GUI support classes of the wxWidgets toolkit
111 Group: Development
/Libraries
114 %description -n
%{wxbasename}
115 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
116 lists
, arrays
), portable wrappers around many OS
-specific funstions
(file
117 operations
, time/date manipulations
, threads
, processes
, sockets
, shared
118 library loading
) as well as other utility classes
(streams
, archive and
119 compression
). wxBase currently supports Win32
, most Unix variants
(Linux
,
120 FreeBSD
, Solaris
, HP
-UX
) and MacOS X
(Carbon and Mach
-0).
122 %package -n
%{wxbasename}-devel
123 Summary: wxBase library
, header files.
124 Group: Development
/Libraries
125 Provides: wxBase
-devel
127 %description -n
%{wxbasename}-devel
128 wxBase library
- non
-GUI support classes of the wxWidgets toolkit
,
132 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, contributed libraries.
134 Requires: %{name} = %{ver}
137 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
139 %package contrib
-devel
140 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
145 %description contrib
-devel
146 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
149 %setup -q
-n wxGTK
-%{ver}
152 if [ "$SMP"
!= ""
]; then
153 export MAKE
="
make -j$SMP"
160 ..
/configure
--prefix
=%{_prefix} \
180 ..
/configure
--prefix
=%{_prefix} \
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj
-static
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
204 (cd obj
-shared
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
206 # --- wxBase headers list begins here ---
207 cat
<<EOF
>wxbase
-headers.files
349 wx
/meta
/convertible.h
354 wx
/generic
/fswatcher.h
365 wx
/unix
/fswatcher_kqueue.h
368 wx
/unix
/fswatcher_inotify.h
374 wx
/protocol
/protocol.h
383 # --- wxBase headers list ends here ---
384 cat
<<EOF
>wxbase
-headers.paths
385 %{_includedir}/wx-%{ver2}/wx
/afterstd.h
386 %{_includedir}/wx-%{ver2}/wx
/app.h
387 %{_includedir}/wx-%{ver2}/wx
/apptrait.h
388 %{_includedir}/wx-%{ver2}/wx
/archive.h
389 %{_includedir}/wx-%{ver2}/wx
/arrimpl.cpp
390 %{_includedir}/wx-%{ver2}/wx
/arrstr.h
391 %{_includedir}/wx-%{ver2}/wx
/beforestd.h
392 %{_includedir}/wx-%{ver2}/wx
/buffer.h
393 %{_includedir}/wx-%{ver2}/wx
/build.h
394 %{_includedir}/wx-%{ver2}/wx
/chkconf.h
395 %{_includedir}/wx-%{ver2}/wx
/clntdata.h
396 %{_includedir}/wx-%{ver2}/wx
/cmdline.h
397 %{_includedir}/wx-%{ver2}/wx
/confbase.h
398 %{_includedir}/wx-%{ver2}/wx
/config.h
399 %{_includedir}/wx-%{ver2}/wx
/containr.h
400 %{_includedir}/wx-%{ver2}/wx
/convauto.h
401 %{_includedir}/wx-%{ver2}/wx
/datetime.h
402 %{_includedir}/wx-%{ver2}/wx
/datstrm.h
403 %{_includedir}/wx-%{ver2}/wx
/dde.h
404 %{_includedir}/wx-%{ver2}/wx
/debug.h
405 %{_includedir}/wx-%{ver2}/wx
/defs.h
406 %{_includedir}/wx-%{ver2}/wx
/dir.h
407 %{_includedir}/wx-%{ver2}/wx
/dlimpexp.h
408 %{_includedir}/wx-%{ver2}/wx
/dynarray.h
409 %{_includedir}/wx-%{ver2}/wx
/dynlib.h
410 %{_includedir}/wx-%{ver2}/wx
/dynload.h
411 %{_includedir}/wx-%{ver2}/wx
/encconv.h
412 %{_includedir}/wx-%{ver2}/wx
/event.h
413 %{_includedir}/wx-%{ver2}/wx
/except.h
414 %{_includedir}/wx-%{ver2}/wx
/features.h
415 %{_includedir}/wx-%{ver2}/wx
/ffile.h
416 %{_includedir}/wx-%{ver2}/wx
/file.h
417 %{_includedir}/wx-%{ver2}/wx
/fileconf.h
418 %{_includedir}/wx-%{ver2}/wx
/filefn.h
419 %{_includedir}/wx-%{ver2}/wx
/filename.h
420 %{_includedir}/wx-%{ver2}/wx
/filesys.h
421 %{_includedir}/wx-%{ver2}/wx
/fontenc.h
422 %{_includedir}/wx-%{ver2}/wx
/fontmap.h
423 %{_includedir}/wx-%{ver2}/wx
/fs_mem.h
424 %{_includedir}/wx-%{ver2}/wx
/fs_zip.h
425 %{_includedir}/wx-%{ver2}/wx
/hash.h
426 %{_includedir}/wx-%{ver2}/wx
/hashmap.h
427 %{_includedir}/wx-%{ver2}/wx
/hashset.h
428 %{_includedir}/wx-%{ver2}/wx
/html
/forcelnk.h
429 %{_includedir}/wx-%{ver2}/wx
/iconloc.h
430 %{_includedir}/wx-%{ver2}/wx
/init.h
431 %{_includedir}/wx-%{ver2}/wx
/intl.h
432 %{_includedir}/wx-%{ver2}/wx
/iosfwrap.h
433 %{_includedir}/wx-%{ver2}/wx
/ioswrap.h
434 %{_includedir}/wx-%{ver2}/wx
/ipc.h
435 %{_includedir}/wx-%{ver2}/wx
/ipcbase.h
436 %{_includedir}/wx-%{ver2}/wx
/isql.h
437 %{_includedir}/wx-%{ver2}/wx
/isqlext.h
438 %{_includedir}/wx-%{ver2}/wx
/link.h
439 %{_includedir}/wx-%{ver2}/wx
/list.h
440 %{_includedir}/wx-%{ver2}/wx
/listimpl.cpp
441 %{_includedir}/wx-%{ver2}/wx
/log.h
442 %{_includedir}/wx-%{ver2}/wx
/longlong.h
443 %{_includedir}/wx-%{ver2}/wx
/math.h
444 %{_includedir}/wx-%{ver2}/wx
/memconf.h
445 %{_includedir}/wx-%{ver2}/wx
/memory.h
446 %{_includedir}/wx-%{ver2}/wx
/memtext.h
447 %{_includedir}/wx-%{ver2}/wx
/mimetype.h
448 %{_includedir}/wx-%{ver2}/wx
/module.h
449 %{_includedir}/wx-%{ver2}/wx
/msgout.h
450 %{_includedir}/wx-%{ver2}/wx
/mstream.h
451 %{_includedir}/wx-%{ver2}/wx
/object.h
452 %{_includedir}/wx-%{ver2}/wx
/platform.h
453 %{_includedir}/wx-%{ver2}/wx
/power.h
454 %{_includedir}/wx-%{ver2}/wx
/process.h
455 %{_includedir}/wx-%{ver2}/wx
/ptr_scpd.h
456 %{_includedir}/wx-%{ver2}/wx
/recguard.h
457 %{_includedir}/wx-%{ver2}/wx
/regex.h
458 %{_includedir}/wx-%{ver2}/wx
/scopeguard.h
459 %{_includedir}/wx-%{ver2}/wx
/snglinst.h
460 %{_includedir}/wx-%{ver2}/wx
/sstream.h
461 %{_includedir}/wx-%{ver2}/wx
/stack.h
462 %{_includedir}/wx-%{ver2}/wx
/stackwalk.h
463 %{_includedir}/wx-%{ver2}/wx
/stdpaths.h
464 %{_includedir}/wx-%{ver2}/wx
/stockitem.h
465 %{_includedir}/wx-%{ver2}/wx
/stopwatch.h
466 %{_includedir}/wx-%{ver2}/wx
/strconv.h
467 %{_includedir}/wx-%{ver2}/wx
/stream.h
468 %{_includedir}/wx-%{ver2}/wx
/string.h
469 %{_includedir}/wx-%{ver2}/wx
/sysopt.h
470 %{_includedir}/wx-%{ver2}/wx
/textbuf.h
471 %{_includedir}/wx-%{ver2}/wx
/textfile.h
472 %{_includedir}/wx-%{ver2}/wx
/thread.h
473 %{_includedir}/wx-%{ver2}/wx
/thrimpl.cpp
474 %{_includedir}/wx-%{ver2}/wx
/timer.h
475 %{_includedir}/wx-%{ver2}/wx
/tokenzr.h
476 %{_includedir}/wx-%{ver2}/wx
/txtstrm.h
477 %{_includedir}/wx-%{ver2}/wx
/types.h
478 %{_includedir}/wx-%{ver2}/wx
/uri.h
479 %{_includedir}/wx-%{ver2}/wx
/utils.h
480 %{_includedir}/wx-%{ver2}/wx
/variant.h
481 %{_includedir}/wx-%{ver2}/wx
/vector.h
482 %{_includedir}/wx-%{ver2}/wx
/version.h
483 %{_includedir}/wx-%{ver2}/wx
/volume.h
484 %{_includedir}/wx-%{ver2}/wx
/wfstream.h
485 %{_includedir}/wx-%{ver2}/wx
/wx.h
486 %{_includedir}/wx-%{ver2}/wx
/wxchar.h
487 %{_includedir}/wx-%{ver2}/wx
/wxprec.h
488 %{_includedir}/wx-%{ver2}/wx
/xti.h
489 %{_includedir}/wx-%{ver2}/wx
/xtistrm.h
490 %{_includedir}/wx-%{ver2}/wx
/zipstrm.h
491 %{_includedir}/wx-%{ver2}/wx
/zstream.h
492 %{_includedir}/wx-%{ver2}/wx
/fs_inet.h
493 %{_includedir}/wx-%{ver2}/wx
/gsocket.h
494 %{_includedir}/wx-%{ver2}/wx
/protocol
/file.h
495 %{_includedir}/wx-%{ver2}/wx
/protocol
/ftp.h
496 %{_includedir}/wx-%{ver2}/wx
/protocol
/http.h
497 %{_includedir}/wx-%{ver2}/wx
/protocol
/protocol.h
498 %{_includedir}/wx-%{ver2}/wx
/sckaddr.h
499 %{_includedir}/wx-%{ver2}/wx
/sckipc.h
500 %{_includedir}/wx-%{ver2}/wx
/sckstrm.h
501 %{_includedir}/wx-%{ver2}/wx
/socket.h
502 %{_includedir}/wx-%{ver2}/wx
/url.h
503 %{_includedir}/wx-%{ver2}/wx
/xml
/xml.h
504 %{_includedir}/wx-%{ver2}/wx
/xtixml.h
505 %{_includedir}/wx-%{ver2}/wx
/unix
/apptbase.h
506 %{_includedir}/wx-%{ver2}/wx
/unix
/apptrait.h
507 %{_includedir}/wx-%{ver2}/wx
/unix
/execute.h
508 %{_includedir}/wx-%{ver2}/wx
/unix
/gsockunx.h
509 %{_includedir}/wx-%{ver2}/wx
/unix
/mimetype.h
510 %{_includedir}/wx-%{ver2}/wx
/unix
/pipe.h
511 %{_includedir}/wx-%{ver2}/wx
/unix
/private.h
512 %{_includedir}/wx-%{ver2}/wx
/unix
/stackwalk.h
513 %{_includedir}/wx-%{ver2}/wx
/unix
/stdpaths.h
515 # --- wxBase headers list ends here ---
517 # temporarily remove base headers
518 mkdir $RPM_BUILD_ROOT
/_save_dir
519 cp
-r $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT
/_save_dir
520 for f
in `cat wxbase
-headers.files`
; do
521 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
523 # list of all core headers:
524 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
525 # move base headers (actually all headers) back again
526 cp
-f
-r $RPM_BUILD_ROOT
/_save_dir
/* $RPM_BUILD_ROOT
%{_includedir}
527 rm -rf $RPM_BUILD_ROOT
/_save_dir
530 (cd obj
-static
/contrib
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
531 (cd obj
-shared
/contrib
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
534 (cd obj
-shared
/utils
/wxrc
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
536 # wx-config link is created during package installation, remove it for now
537 rm -f $RPM_BUILD_ROOT
%{_bindir}/wx
-config
540 rm -rf $RPM_BUILD_ROOT
549 # link wx-config when you install RPM.
551 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
553 # link wx-config with explicit name.
554 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
562 rm -f
%{_bindir}/wx
-config
564 rm -f
%{_bindir}/%{wxconfiglink}
566 %post -n
%{wxbasename}
569 %postun -n
%{wxbasename}
572 %post -n
%{wxbasename}-devel
573 # link wx-config with explicit name.
574 ln
-sf
%{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
577 %postun -n
%{wxbasename}-devel
580 %preun -n
%{wxbasename}-devel
581 rm -f
%{_bindir}/%{wxbaseconfiglink}
598 %postun contrib
-devel
602 %defattr(-,root
,root
)
603 %doc COPYING.LIB
*.txt
604 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.
*
605 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.
*
606 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.
*
607 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.
*
608 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
609 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.
*
610 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.
*
611 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.
*
614 %defattr(-,root
,root
)
615 %{_datadir}/locale
/*/LC_MESSAGES
/*.mo
617 %files devel
-f core
-headers.files
618 %defattr(-,root
,root
)
620 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
621 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
622 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
623 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
624 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
625 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
626 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
627 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
628 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
630 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
631 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
632 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
633 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
634 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
635 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
636 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
637 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
639 %{_libdir}/wx/config/%{wxconfig}
640 %{_libdir}/wx/include/%{wxconfig}/wx
/setup.h
641 %{_libdir}/wx/config/%{wxconfigstatic}
642 %{_libdir}/wx/include/%{wxconfigstatic}/wx
/setup.h
645 %files -n
%{wxbasename}
646 %defattr(-,root
,root
)
647 %{_libdir}/libwx_base*-%{ver2}.so.
*
649 %files -n
%{wxbasename}-devel
-f wxbase
-headers.paths
650 %defattr (-,root
,root
)
651 %dir %{_includedir}/wx-%{ver2}
652 %{_libdir}/libwx_base*-%{ver2}.so
653 %{_libdir}/libwx_base*-%{ver2}.a
655 %{_libdir}/libwxregexu-%{ver2}.a
658 %{_datadir}/aclocal
/*.m4
659 %{_datadir}/bakefile
/presets
/*
662 %defattr(-,root
,root
)
663 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.
*
666 %defattr(-,root
,root
)
667 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.
*
668 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.
*
669 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.
*
670 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.
*
671 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.
*
672 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
673 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.
*
674 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.
*
675 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.
*
676 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.
*
679 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
680 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
681 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
682 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
683 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
684 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
685 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
686 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
687 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
688 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
691 %defattr(-,root
,root
)
692 %dir %{_includedir}/wx-%{ver2}/wx
/animate
693 %{_includedir}/wx-%{ver2}/wx
/animate
/*
694 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
696 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
697 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
698 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
700 %dir %{_includedir}/wx-%{ver2}/wx
/fl
701 %{_includedir}/wx-%{ver2}/wx
/fl
/*
702 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
704 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
705 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
706 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
707 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
709 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
710 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
711 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
713 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
714 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
715 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
717 %dir %{_includedir}/wx-%{ver2}/wx
/plot
718 %{_includedir}/wx-%{ver2}/wx
/plot
/*
719 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
721 %dir %{_includedir}/wx-%{ver2}/wx
/stc
722 %{_includedir}/wx-%{ver2}/wx
/stc
/*
723 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
725 %dir %{_includedir}/wx-%{ver2}/wx
/svg
726 %{_includedir}/wx-%{ver2}/wx
/svg
/*
727 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so