6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
24 %define name wx
-%{portname}-unicode
25 %define wxbasename wx
-base
-unicode
27 %define name wx
-%{portname}
28 %define wxbasename wx
-base
32 %define wxconfigname
%{portname}-unicode-release-%{ver2}
33 %define wxconfiglinkname wx
%{portname}u-%{ver2}-config
35 %define wxconfigname
%{portname}-ansi-release-%{ver2}
36 %define wxconfiglinkname wx
%{portname}-%{ver2}-config
40 Summary: The GTK
+ %{gtkver} port of the wxWindows library
43 License: wxWindows Licence
45 Source: wxGTK
-%{ver}.tar.bz2
46 URL: http
://www.wxwindows.org
47 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
49 BuildRoot: /var
/tmp
/%{name}-root
51 # all packages providing an implementation of wxWindows library (regardless of
52 # the toolkit used) should provide the (virtual) wxwin package, this makes it
53 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
57 # in addition, we should provide libwx_gtk as automatic generator only notices
58 # libwx_gtk-%{ver}-%{rel}
59 Provides: libwx_gtk.so
60 Provides: libwx_gtk
-%{ver2}.so
62 Requires: %{wxbasename} = %{ver}
65 wxWindows is a free C
++ library
for cross
-platform GUI development.
66 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
67 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
70 Summary: The GTK
+ %{gtkver} port of the wxWindows library
72 Requires: %{name} = %{ver}
73 Requires: %{wxbasename}-devel = %{ver}
77 Header files
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
80 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, OpenGL add
-on.
82 Requires: %{name} = %{ver}
85 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
88 Summary: wxGTK static libraries
89 Group: Development
/Libraries
90 Requires: %{wxbasename}-static
93 Static libraries
for wxGTK. You need them
if you want to link statically against wxGTK.
96 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, contributed libraries.
98 Requires: %{name} = %{ver}
101 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
103 %package contrib
-devel
104 Summary: The GTK
+ %{gtkver} port of the wxWindows library
106 Requires: %{name}-contrib = %{ver}
107 Requires: %{name}-devel = %{ver}
109 %description contrib
-devel
110 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
113 %setup -q
-n wxGTK
-%{ver}
116 if [ "$SMP"
!= ""
]; then
117 export MAKE
="
make -j$SMP"
124 ..
/configure
--prefix
=%{pref} \
141 ..
/configure
--prefix
=%{pref} --disable
-shared \
155 rm -rf $RPM_BUILD_ROOT
156 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
157 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
159 # Remove headers that are part of wx-base-devel:
161 # --- wxBase headers list begins here ---
162 cat
<<EOF
>wxbase
-headers
-list
286 wx
/protocol
/protocol.h
299 # --- wxBase headers list ends here ---
300 for f
in `cat wxbase
-headers
-list`
; do
301 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx
-*/$f
304 # list of all core headers:
305 find $RPM_BUILD_ROOT
/usr
/include
/wx
-* -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
308 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
309 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
311 # remove wxBase files so that RPM doesn't complain about unpackaged files:
312 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
313 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwxregexu-%{ver2}.a
314 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
315 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
318 rm -rf $RPM_BUILD_ROOT
333 # link wx-config when you install RPM.
334 ln
-sf
%{_libdir}/wx/config/%{wxconfigname} %{_bindir}/wx
-config
335 # link wx-config with explicit name.
336 ln
-sf
%{_libdir}/wx/config/%{wxconfigname} %{_bindir}/%{wxconfiglinkname}
339 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
340 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfigname} | cut
-c
0-32`
341 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
342 if test "x$SUM1"
= "x$SUM2"
; then
343 rm -f
%{_bindir}/wx
-config
347 rm -f
%{_bindir}/%{wxconfiglinkname}
350 %defattr(-,root
,root
)
351 %doc COPYING.LIB
*.txt
352 %{_libdir}/libwx_%{portname}*_core
*.so.
*
353 %{_libdir}/libwx_%{portname}*_html
*.so.
*
354 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
355 %{_libdir}/libwx_%{portname}*_media
*.so.
*
357 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
360 %files devel
-f core
-headers.files
361 %defattr(-,root
,root
)
362 %{_libdir}/libwx_%{portname}*_core
*.so
363 %{_libdir}/libwx_%{portname}*_html
*.so
364 %{_libdir}/libwx_%{portname}*_adv
*.so
365 %{_libdir}/libwx_%{portname}*_media
*.so
367 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
369 %{_libdir}/libwx_%{portname}*_gl
*.so
374 %defattr(-,root
,root
)
375 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
378 %defattr (-,root
,root
)
379 %{_libdir}/libwx_gtk
*.a
382 %defattr(-,root
,root
)
383 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
384 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
385 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
386 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
387 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
388 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
389 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
390 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
391 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
392 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
395 %defattr(-,root
,root
)
397 %dir %{_includedir}/wx
-*/wx
/animate
398 %{_includedir}/wx
-*/wx
/animate
/*
399 %{_libdir}/libwx_%{portname}*_animate
*.so
401 %dir %{_includedir}/wx
-*/wx
/deprecated
402 %{_includedir}/wx
-*/wx
/deprecated
/*
403 %{_libdir}/libwx_%{portname}*_deprecated
*.so
405 %dir %{_includedir}/wx
-*/wx
/fl
406 %{_includedir}/wx
-*/wx
/fl
/*
407 %{_libdir}/libwx_%{portname}*_fl
*.so
409 %dir %{_includedir}/wx
-*/wx
/gizmos
410 %{_includedir}/wx
-*/wx
/gizmos
/*
411 %{_libdir}/libwx_%{portname}*_gizmos
*.so
413 %dir %{_includedir}/wx
-*/wx
/mmedia
414 %{_includedir}/wx
-*/wx
/mmedia
/*
415 %{_libdir}/libwx_%{portname}*_mmedia
*.so
417 %dir %{_includedir}/wx
-*/wx
/ogl
418 %{_includedir}/wx
-*/wx
/ogl
/*
419 %{_libdir}/libwx_%{portname}*_ogl
*.so
421 %dir %{_includedir}/wx
-*/wx
/plot
422 %{_includedir}/wx
-*/wx
/plot
/*
423 %{_libdir}/libwx_%{portname}*_plot
*.so
425 %dir %{_includedir}/wx
-*/wx
/stc
426 %{_includedir}/wx
-*/wx
/stc
/*
427 %{_libdir}/libwx_%{portname}*_stc
*.so
429 %dir %{_includedir}/wx
-*/wx
/svg
430 %{_includedir}/wx
-*/wx
/svg
/*
431 %{_libdir}/libwx_%{portname}*_svg
*.so
433 %dir %{_includedir}/wx
-*/wx
/xrc
434 %{_includedir}/wx
-*/wx
/xrc
/*
435 %{_libdir}/libwx_%{portname}*_xrc
*.so