Regenerated makefiles for 2.5.2
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.5.2
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11
12 %if %{unicode}
13 %define name wx-%{portname}-unicode
14 %define wxbasename wx-base-unicode
15 %else
16 %define name wx-%{portname}
17 %define wxbasename wx-base
18 %endif
19
20 %if %{unicode}
21 %define wxconfigname wx%{portname}univu-%{ver2}-config
22 %else
23 %define wxconfigname wx%{portname}univ-%{ver2}-config
24 %endif
25
26 Summary: The X11 port of the wxWindows library
27 Name: %{name}
28 Version: %{ver}
29 Release: %{rel}
30 License: wxWindows Licence
31 Group: X11/Libraries
32 Source: wxX11-%{ver}.tar.bz2
33 URL: http://www.wxwindows.org
34 Packager: Vadim Zeitlin <vadim@wxwindows.org>
35 Prefix: %{pref}
36 BuildRoot: /var/tmp/%{name}-root
37
38 # all packages providing an implementation of wxWindows library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42
43 # in addition, we should provide libwx_gtk as automatic generator only notices
44 # libwx_gtk-%{ver}-%{rel}
45 Provides: libwx_x11.so
46 Provides: libwx_x11-%{ver2}.so
47 Provides: wxX11
48
49 Requires: %{wxbasename} = %{ver}
50
51 %description
52 wxWindows is a free C++ library for cross-platform GUI development.
53 With wxWindows, you can create applications for different GUIs (GTK+,
54 Motif/LessTif, MS Windows, Mac) from the same source code.
55
56 %package devel
57 Summary: The X11 port of the wxWindows library
58 Group: X11/Libraries
59 Requires: %{name} = %{ver}
60 Requires: %{wxbasename}-devel = %{ver}
61
62 %description devel
63 Header files for wxX11, the X11 port of the wxWindows library.
64
65 %package gl
66 Summary: The X11 port of the wxWindows library, OpenGL add-on.
67 Group: X11/Libraries
68 Requires: %{name} = %{ver}
69
70 %description gl
71 OpenGL add-on library for wxX11, the X11 port of the wxWindows library.
72
73 %package static
74 Summary: wxX11 static libraries
75 Group: Development/Libraries
76
77 %description static
78 Static libraries for wxX11. You need them if you want to link statically against wxX11.
79
80 %package contrib
81 Summary: Contrib libraries for wxX11.
82 Group: X11/Libraries
83 Requires: %{name} = %{ver}
84
85 %description contrib
86 Contributed libraries for wxX11.
87
88 %package contrib-devel
89 Summary: Contrib libraries for wxX11.
90 Group: X11/Libraries
91 Requires: %{name}-contrib = %{ver}
92 Requires: %{name}-devel = %{ver}
93
94 %description contrib-devel
95 Header files for contributed libraries for wxX11.
96
97 %prep
98 %setup -q -n wxX11-%{ver}
99
100 %build
101 if [ "$SMP" != "" ]; then
102 export MAKE="make -j$SMP"
103 else
104 export MAKE="make"
105 fi
106
107 mkdir obj-shared
108 cd obj-shared
109 ../configure --prefix=%{pref} --with-x11 \
110 %if %{unicode}
111 --enable-unicode \
112 %else
113 --with-odbc \
114 %endif
115 --with-opengl
116 $MAKE
117 cd contrib/src
118 $MAKE
119 cd ../../..
120
121 mkdir obj-static
122 cd obj-static
123 ../configure --prefix=%{pref} --with-x11 --disable-shared \
124 %if %{unicode}
125 --enable-unicode \
126 %else
127 --with-odbc \
128 %endif
129 --with-opengl
130 $MAKE
131 cd ..
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
136 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
137
138 # Remove headers that are part of wx-base-devel:
139
140 # --- wxBase headers list begins here ---
141 cat <<EOF >wxbase-headers-list
142 wx/afterstd.h
143 wx/app.h
144 wx/apptrait.h
145 wx/arrimpl.cpp
146 wx/arrstr.h
147 wx/beforestd.h
148 wx/buffer.h
149 wx/build.h
150 wx/chkconf.h
151 wx/cmdline.h
152 wx/confbase.h
153 wx/config.h
154 wx/containr.h
155 wx/datetime.h
156 wx/datetime.inl
157 wx/datstrm.h
158 wx/dde.h
159 wx/debug.h
160 wx/defs.h
161 wx/dir.h
162 wx/dlimpexp.h
163 wx/dynarray.h
164 wx/dynlib.h
165 wx/dynload.h
166 wx/encconv.h
167 wx/event.h
168 wx/except.h
169 wx/features.h
170 wx/ffile.h
171 wx/file.h
172 wx/fileconf.h
173 wx/filefn.h
174 wx/filename.h
175 wx/filesys.h
176 wx/fontenc.h
177 wx/fontmap.h
178 wx/fs_mem.h
179 wx/fs_zip.h
180 wx/hash.h
181 wx/hashmap.h
182 wx/hashset.h
183 wx/iconloc.h
184 wx/init.h
185 wx/intl.h
186 wx/iosfwrap.h
187 wx/ioswrap.h
188 wx/ipc.h
189 wx/ipcbase.h
190 wx/isql.h
191 wx/isqlext.h
192 wx/list.h
193 wx/listimpl.cpp
194 wx/log.h
195 wx/longlong.h
196 wx/math.h
197 wx/memconf.h
198 wx/memory.h
199 wx/memtext.h
200 wx/mimetype.h
201 wx/module.h
202 wx/msgout.h
203 wx/msgout.h
204 wx/mstream.h
205 wx/object.h
206 wx/platform.h
207 wx/process.h
208 wx/ptr_scpd.h
209 wx/regex.h
210 wx/scopeguard.h
211 wx/snglinst.h
212 wx/stack.h
213 wx/stopwatch.h
214 wx/strconv.h
215 wx/stream.h
216 wx/string.h
217 wx/sysopt.h
218 wx/textbuf.h
219 wx/textfile.h
220 wx/thread.h
221 wx/thrimpl.cpp
222 wx/timer.h
223 wx/tokenzr.h
224 wx/txtstrm.h
225 wx/types.h
226 wx/utils.h
227 wx/variant.h
228 wx/vector.h
229 wx/version.h
230 wx/volume.h
231 wx/wfstream.h
232 wx/wx.h
233 wx/wxchar.h
234 wx/wxprec.h
235 wx/xti.h
236 wx/xtistrm.h
237 wx/zipstrm.h
238 wx/zstream.h
239 wx/msw/apptrait.h
240 wx/msw/apptbase.h
241 wx/msw/chkconf.h
242 wx/msw/crashrpt.h
243 wx/msw/dde.h
244 wx/msw/gccpriv.h
245 wx/msw/mimetype.h
246 wx/msw/winundef.h
247 wx/msw/wrapcctl.h
248 wx/msw/wrapwin.h
249 wx/fs_inet.h
250 wx/gsocket.h
251 wx/protocol/file.h
252 wx/protocol/ftp.h
253 wx/protocol/http.h
254 wx/protocol/protocol.h
255 wx/sckaddr.h
256 wx/sckipc.h
257 wx/sckstrm.h
258 wx/socket.h
259 wx/url.h
260 wx/msw/gsockmsw.h
261 wx/xml/xml.h
262 wx/xtixml.h
263 wx/db.h
264 wx/dbkeyg.h
265 wx/dbtable.h
266 EOF
267 # --- wxBase headers list ends here ---
268 for f in `cat wxbase-headers-list` ; do
269 rm -f $RPM_BUILD_ROOT%{_includedir}/$f
270 done
271
272 # list of all core headers:
273 find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
274
275 # contrib stuff:
276 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
277 (cd obj-shared/contrib/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
278
279 # remove wxBase files so that RPM doesn't complain about unpackaged files:
280 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
281 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
282 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
283
284 %clean
285 rm -rf $RPM_BUILD_ROOT
286
287 %post
288 /sbin/ldconfig
289
290 %postun
291 /sbin/ldconfig
292
293 %post gl
294 /sbin/ldconfig
295
296 %postun gl
297 /sbin/ldconfig
298
299 %post devel
300 # Install wx-config if there isn't any
301 if test ! -f %{_bindir}/wx-config ; then
302 ln -sf %{wxconfigname} %{_bindir}/wx-config
303 fi
304
305 %preun devel
306 # Remove wx-config if it points to this package
307 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
308 SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
309 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
310 if test "x$SUM1" = "x$SUM2" ; then
311 rm -f %{_bindir}/wx-config
312 fi
313 fi
314
315
316 %files
317 %defattr(-,root,root)
318 %doc COPYING.LIB *.txt
319 %dir %{_datadir}/wx
320 %{_datadir}/wx/*
321 %{_libdir}/libwx_%{portname}*_core*.so.*
322 %{_libdir}/libwx_%{portname}*_html*.so.*
323 %{_libdir}/libwx_%{portname}*_adv*.so.*
324 %if !%{unicode}
325 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
326 %endif
327
328 %files devel -f core-headers.files
329 %defattr(-,root,root)
330 %{_libdir}/libwx_%{portname}*_core*.so
331 %{_libdir}/libwx_%{portname}*_html*.so
332 %{_libdir}/libwx_%{portname}*_adv*.so
333 %if !%{unicode}
334 %{_libdir}/libwx_%{portname}*_dbgrid*.so
335 %endif
336 %{_libdir}/libwx_%{portname}*_gl*.so
337 %dir %{_libdir}/wx
338 %{_libdir}/wx/*
339 %{_bindir}/%{wxconfigname}
340
341 %files gl
342 %defattr(-,root,root)
343 %{_libdir}/libwx_%{portname}*_gl*.so.*
344
345 %files static
346 %defattr (-,root,root)
347 %{_libdir}/libwx_%{portname}*.a
348
349 %files contrib
350 %defattr(-,root,root)
351 %{_libdir}/libwx_%{portname}*_animate*.so.*
352 %{_libdir}/libwx_%{portname}*_deprecated*.so.*
353 %{_libdir}/libwx_%{portname}*_fl*.so.*
354 %{_libdir}/libwx_%{portname}*_gizmos*.so.*
355 %{_libdir}/libwx_%{portname}*_mmedia*.so.*
356 %{_libdir}/libwx_%{portname}*_ogl*.so.*
357 %{_libdir}/libwx_%{portname}*_plot*.so.*
358 %{_libdir}/libwx_%{portname}*_stc*.so.*
359 %{_libdir}/libwx_%{portname}*_svg*.so.*
360 %{_libdir}/libwx_%{portname}*_xrc*.so.*
361
362 %files contrib-devel
363 %defattr(-,root,root)
364 %{_bindir}/wxrc
365 %dir %{_includedir}/wx/animate
366 %{_includedir}/wx/animate/*
367 %{_libdir}/libwx_%{portname}*_animate*.so
368
369 %dir %{_includedir}/wx/deprecated
370 %{_includedir}/wx/deprecated/*
371 %{_libdir}/libwx_%{portname}*_deprecated*.so
372
373 %dir %{_includedir}/wx/fl
374 %{_includedir}/wx/fl/*
375 %{_libdir}/libwx_%{portname}*_fl*.so
376
377 %dir %{_includedir}/wx/gizmos
378 %{_includedir}/wx/gizmos/*
379 %{_libdir}/libwx_%{portname}*_gizmos*.so
380
381 %dir %{_includedir}/wx/mmedia
382 %{_includedir}/wx/mmedia/*
383 %{_libdir}/libwx_%{portname}*_mmedia*.so
384
385 %dir %{_includedir}/wx/ogl
386 %{_includedir}/wx/ogl/*
387 %{_libdir}/libwx_%{portname}*_ogl*.so
388
389 %dir %{_includedir}/wx/plot
390 %{_includedir}/wx/plot/*
391 %{_libdir}/libwx_%{portname}*_plot*.so
392
393 %dir %{_includedir}/wx/stc
394 %{_includedir}/wx/stc/*
395 %{_libdir}/libwx_%{portname}*_stc*.so
396
397 %dir %{_includedir}/wx/svg
398 %{_includedir}/wx/svg/*
399 %{_libdir}/libwx_%{portname}*_svg*.so
400
401 %dir %{_includedir}/wx/xrc
402 %{_includedir}/wx/xrc/*
403 %{_libdir}/libwx_%{portname}*_xrc*.so