uncommented Build-Requires (accidentally checked in)
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 --with-odbc \
171 %endif
172 --with-opengl
173 $MAKE
174
175 cd contrib/src
176 $MAKE
177 cd ../../..
178
179 mkdir obj-static
180 cd obj-static
181 ../configure --prefix=%{_prefix} \
182 %if ! %{gtk2}
183 --with-gtk=1 \
184 %else
185 --with-gtk=2 \
186 %endif
187 --disable-shared \
188 %if %{unicode}
189 --enable-unicode \
190 %else
191 --disable-unicode \
192 --with-odbc \
193 %endif
194 --with-opengl
195 $MAKE
196
197 cd contrib/src
198 $MAKE
199 cd ../../..
200
201 make -C locale allmo
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208 # --- wxBase headers list begins here ---
209 cat <<EOF >wxbase-headers.files
210 wx/afterstd.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chkconf.h
220 wx/clntdata.h
221 wx/cmdline.h
222 wx/confbase.h
223 wx/config.h
224 wx/convauto.h
225 wx/containr.h
226 wx/datetime.h
227 wx/datstrm.h
228 wx/dde.h
229 wx/debug.h
230 wx/defs.h
231 wx/dir.h
232 wx/dlimpexp.h
233 wx/dynarray.h
234 wx/dynlib.h
235 wx/dynload.h
236 wx/encconv.h
237 wx/event.h
238 wx/except.h
239 wx/features.h
240 wx/ffile.h
241 wx/file.h
242 wx/fileconf.h
243 wx/filefn.h
244 wx/filename.h
245 wx/filesys.h
246 wx/fontenc.h
247 wx/fontmap.h
248 wx/fs_mem.h
249 wx/fs_zip.h
250 wx/hash.h
251 wx/hashmap.h
252 wx/hashset.h
253 wx/html/forcelnk.h
254 wx/iconloc.h
255 wx/init.h
256 wx/intl.h
257 wx/iosfwrap.h
258 wx/ioswrap.h
259 wx/ipc.h
260 wx/ipcbase.h
261 wx/isql.h
262 wx/isqlext.h
263 wx/link.h
264 wx/list.h
265 wx/listimpl.cpp
266 wx/log.h
267 wx/longlong.h
268 wx/math.h
269 wx/memconf.h
270 wx/memory.h
271 wx/memtext.h
272 wx/mimetype.h
273 wx/module.h
274 wx/msgout.h
275 wx/mstream.h
276 wx/object.h
277 wx/platform.h
278 wx/power.h
279 wx/process.h
280 wx/ptr_scpd.h
281 wx/recguard.h
282 wx/regex.h
283 wx/scopeguard.h
284 wx/snglinst.h
285 wx/sstream.h
286 wx/stack.h
287 wx/stackwalk.h
288 wx/stdpaths.h
289 wx/stockitem.h
290 wx/stopwatch.h
291 wx/strconv.h
292 wx/stream.h
293 wx/string.h
294 wx/sysopt.h
295 wx/textbuf.h
296 wx/textfile.h
297 wx/thread.h
298 wx/thrimpl.cpp
299 wx/timer.h
300 wx/tokenzr.h
301 wx/txtstrm.h
302 wx/types.h
303 wx/uri.h
304 wx/utils.h
305 wx/variant.h
306 wx/vector.h
307 wx/version.h
308 wx/volume.h
309 wx/wfstream.h
310 wx/wx.h
311 wx/wxchar.h
312 wx/wxprec.h
313 wx/xti.h
314 wx/xtistrm.h
315 wx/zipstrm.h
316 wx/zstream.h
317 wx/unix/apptbase.h
318 wx/unix/apptrait.h
319 wx/unix/execute.h
320 wx/unix/mimetype.h
321 wx/unix/pipe.h
322 wx/unix/private.h
323 wx/unix/stackwalk.h
324 wx/unix/stdpaths.h
325 wx/fs_inet.h
326 wx/gsocket.h
327 wx/protocol/file.h
328 wx/protocol/ftp.h
329 wx/protocol/http.h
330 wx/protocol/protocol.h
331 wx/sckaddr.h
332 wx/sckipc.h
333 wx/sckstrm.h
334 wx/socket.h
335 wx/url.h
336 wx/unix/gsockunx.h
337 wx/xml/xml.h
338 wx/xtixml.h
339 wx/db.h
340 wx/dbkeyg.h
341 wx/dbtable.h
342 EOF
343 # --- wxBase headers list ends here ---
344 cat <<EOF >wxbase-headers.paths
345 %{_includedir}/wx-%{ver2}/wx/afterstd.h
346 %{_includedir}/wx-%{ver2}/wx/app.h
347 %{_includedir}/wx-%{ver2}/wx/apptrait.h
348 %{_includedir}/wx-%{ver2}/wx/archive.h
349 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
350 %{_includedir}/wx-%{ver2}/wx/arrstr.h
351 %{_includedir}/wx-%{ver2}/wx/beforestd.h
352 %{_includedir}/wx-%{ver2}/wx/buffer.h
353 %{_includedir}/wx-%{ver2}/wx/build.h
354 %{_includedir}/wx-%{ver2}/wx/chkconf.h
355 %{_includedir}/wx-%{ver2}/wx/clntdata.h
356 %{_includedir}/wx-%{ver2}/wx/cmdline.h
357 %{_includedir}/wx-%{ver2}/wx/confbase.h
358 %{_includedir}/wx-%{ver2}/wx/config.h
359 %{_includedir}/wx-%{ver2}/wx/containr.h
360 %{_includedir}/wx-%{ver2}/wx/convauto.h
361 %{_includedir}/wx-%{ver2}/wx/datetime.h
362 %{_includedir}/wx-%{ver2}/wx/datstrm.h
363 %{_includedir}/wx-%{ver2}/wx/dde.h
364 %{_includedir}/wx-%{ver2}/wx/debug.h
365 %{_includedir}/wx-%{ver2}/wx/defs.h
366 %{_includedir}/wx-%{ver2}/wx/dir.h
367 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
368 %{_includedir}/wx-%{ver2}/wx/dynarray.h
369 %{_includedir}/wx-%{ver2}/wx/dynlib.h
370 %{_includedir}/wx-%{ver2}/wx/dynload.h
371 %{_includedir}/wx-%{ver2}/wx/encconv.h
372 %{_includedir}/wx-%{ver2}/wx/event.h
373 %{_includedir}/wx-%{ver2}/wx/except.h
374 %{_includedir}/wx-%{ver2}/wx/features.h
375 %{_includedir}/wx-%{ver2}/wx/ffile.h
376 %{_includedir}/wx-%{ver2}/wx/file.h
377 %{_includedir}/wx-%{ver2}/wx/fileconf.h
378 %{_includedir}/wx-%{ver2}/wx/filefn.h
379 %{_includedir}/wx-%{ver2}/wx/filename.h
380 %{_includedir}/wx-%{ver2}/wx/filesys.h
381 %{_includedir}/wx-%{ver2}/wx/fontenc.h
382 %{_includedir}/wx-%{ver2}/wx/fontmap.h
383 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
384 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
385 %{_includedir}/wx-%{ver2}/wx/hash.h
386 %{_includedir}/wx-%{ver2}/wx/hashmap.h
387 %{_includedir}/wx-%{ver2}/wx/hashset.h
388 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
389 %{_includedir}/wx-%{ver2}/wx/iconloc.h
390 %{_includedir}/wx-%{ver2}/wx/init.h
391 %{_includedir}/wx-%{ver2}/wx/intl.h
392 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
393 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
394 %{_includedir}/wx-%{ver2}/wx/ipc.h
395 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
396 %{_includedir}/wx-%{ver2}/wx/isql.h
397 %{_includedir}/wx-%{ver2}/wx/isqlext.h
398 %{_includedir}/wx-%{ver2}/wx/link.h
399 %{_includedir}/wx-%{ver2}/wx/list.h
400 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
401 %{_includedir}/wx-%{ver2}/wx/log.h
402 %{_includedir}/wx-%{ver2}/wx/longlong.h
403 %{_includedir}/wx-%{ver2}/wx/math.h
404 %{_includedir}/wx-%{ver2}/wx/memconf.h
405 %{_includedir}/wx-%{ver2}/wx/memory.h
406 %{_includedir}/wx-%{ver2}/wx/memtext.h
407 %{_includedir}/wx-%{ver2}/wx/mimetype.h
408 %{_includedir}/wx-%{ver2}/wx/module.h
409 %{_includedir}/wx-%{ver2}/wx/msgout.h
410 %{_includedir}/wx-%{ver2}/wx/mstream.h
411 %{_includedir}/wx-%{ver2}/wx/object.h
412 %{_includedir}/wx-%{ver2}/wx/platform.h
413 %{_includedir}/wx-%{ver2}/wx/power.h
414 %{_includedir}/wx-%{ver2}/wx/process.h
415 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
416 %{_includedir}/wx-%{ver2}/wx/recguard.h
417 %{_includedir}/wx-%{ver2}/wx/regex.h
418 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
419 %{_includedir}/wx-%{ver2}/wx/snglinst.h
420 %{_includedir}/wx-%{ver2}/wx/sstream.h
421 %{_includedir}/wx-%{ver2}/wx/stack.h
422 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
423 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
424 %{_includedir}/wx-%{ver2}/wx/stockitem.h
425 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
426 %{_includedir}/wx-%{ver2}/wx/strconv.h
427 %{_includedir}/wx-%{ver2}/wx/stream.h
428 %{_includedir}/wx-%{ver2}/wx/string.h
429 %{_includedir}/wx-%{ver2}/wx/sysopt.h
430 %{_includedir}/wx-%{ver2}/wx/textbuf.h
431 %{_includedir}/wx-%{ver2}/wx/textfile.h
432 %{_includedir}/wx-%{ver2}/wx/thread.h
433 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
434 %{_includedir}/wx-%{ver2}/wx/timer.h
435 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
436 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
437 %{_includedir}/wx-%{ver2}/wx/types.h
438 %{_includedir}/wx-%{ver2}/wx/uri.h
439 %{_includedir}/wx-%{ver2}/wx/utils.h
440 %{_includedir}/wx-%{ver2}/wx/variant.h
441 %{_includedir}/wx-%{ver2}/wx/vector.h
442 %{_includedir}/wx-%{ver2}/wx/version.h
443 %{_includedir}/wx-%{ver2}/wx/volume.h
444 %{_includedir}/wx-%{ver2}/wx/wfstream.h
445 %{_includedir}/wx-%{ver2}/wx/wx.h
446 %{_includedir}/wx-%{ver2}/wx/wxchar.h
447 %{_includedir}/wx-%{ver2}/wx/wxprec.h
448 %{_includedir}/wx-%{ver2}/wx/xti.h
449 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
450 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
451 %{_includedir}/wx-%{ver2}/wx/zstream.h
452 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
453 %{_includedir}/wx-%{ver2}/wx/gsocket.h
454 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
455 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
456 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
457 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
458 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
459 %{_includedir}/wx-%{ver2}/wx/sckipc.h
460 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
461 %{_includedir}/wx-%{ver2}/wx/socket.h
462 %{_includedir}/wx-%{ver2}/wx/url.h
463 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
464 %{_includedir}/wx-%{ver2}/wx/xtixml.h
465 %{_includedir}/wx-%{ver2}/wx/db.h
466 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
467 %{_includedir}/wx-%{ver2}/wx/dbtable.h
468 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
469 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
470 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
471 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
472 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
473 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
474 %{_includedir}/wx-%{ver2}/wx/unix/private.h
475 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
476 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
477 EOF
478 # --- wxBase headers list ends here ---
479
480 # temporarily remove base headers
481 mkdir $RPM_BUILD_ROOT/_save_dir
482 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
483 for f in `cat wxbase-headers.files` ; do
484 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
485 done
486 # list of all core headers:
487 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
488 # move base headers (actually all headers) back again
489 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
490 rm -rf $RPM_BUILD_ROOT/_save_dir
491
492 # contrib stuff:
493 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
494 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
495
496 # utils:
497 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
498
499 # wx-config link is created during package installation, remove it for now
500 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
501
502 %clean
503 rm -rf $RPM_BUILD_ROOT
504
505 %post
506 /sbin/ldconfig
507
508 %postun
509 /sbin/ldconfig
510
511 %post devel
512 # link wx-config when you install RPM.
513 %if %{unicode}
514 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
515 %endif
516 # link wx-config with explicit name.
517 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
518 /sbin/ldconfig
519
520 %postun devel
521 /sbin/ldconfig
522
523 %preun devel
524 %if %{unicode}
525 rm -f %{_bindir}/wx-config
526 %endif
527 rm -f %{_bindir}/%{wxconfiglink}
528
529 %post -n %{wxbasename}
530 /sbin/ldconfig
531
532 %postun -n %{wxbasename}
533 /sbin/ldconfig
534
535 %post -n %{wxbasename}-devel
536 # link wx-config with explicit name.
537 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
538 /sbin/ldconfig
539
540 %postun -n %{wxbasename}-devel
541 /sbin/ldconfig
542
543 %preun -n %{wxbasename}-devel
544 rm -f %{_bindir}/%{wxbaseconfiglink}
545
546 %post gl
547 /sbin/ldconfig
548
549 %postun gl
550 /sbin/ldconfig
551
552 %post contrib
553 /sbin/ldconfig
554
555 %postun contrib
556 /sbin/ldconfig
557
558 %post contrib-devel
559 /sbin/ldconfig
560
561 %postun contrib-devel
562 /sbin/ldconfig
563
564 %files
565 %defattr(-,root,root)
566 %doc COPYING.LIB *.txt
567 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
568 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
569 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
570 %if !%{unicode}
571 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
572 %endif
573 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
574 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
575 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
576 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
577 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
578
579 %files -n wx-i18n
580 %defattr(-,root,root)
581 %{_datadir}/locale/*/LC_MESSAGES/*.mo
582
583 %files devel -f core-headers.files
584 %defattr(-,root,root)
585 # shared libs
586 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
587 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
588 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
589 %if !%{unicode}
590 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
591 %endif
592 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
593 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
594 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
595 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
596 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
598 # static libs
599 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
600 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
601 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
602 %if !%{unicode}
603 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
604 %endif
605 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
606 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
607 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
608 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
609 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
610 %dir %{_libdir}/wx
611 %{_libdir}/wx/config/%{wxconfig}
612 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
613 %{_libdir}/wx/config/%{wxconfigstatic}
614 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
615 %{_bindir}/wxrc*
616
617 %files -n %{wxbasename}
618 %defattr(-,root,root)
619 %{_libdir}/libwx_base*-%{ver2}.so.*
620
621 %files -n %{wxbasename}-devel -f wxbase-headers.paths
622 %defattr (-,root,root)
623 %dir %{_includedir}/wx-%{ver2}
624 %{_libdir}/libwx_base*-%{ver2}.so
625 %{_libdir}/libwx_base*-%{ver2}.a
626 %if %{unicode}
627 %{_libdir}/libwxregexu-%{ver2}.a
628 %endif
629 %dir %{_libdir}/wx
630 %{_datadir}/aclocal/*.m4
631 %{_datadir}/bakefile/presets/*
632
633 %files gl
634 %defattr(-,root,root)
635 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
636
637 %files contrib
638 %defattr(-,root,root)
639 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
640 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
641 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
642 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
643 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
644 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
645 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
646 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
647 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
648 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
649
650 # static libs
651 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
652 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
653 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
654 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
655 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
656 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
657 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
658 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
659 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
660 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
661
662 %files contrib-devel
663 %defattr(-,root,root)
664 %dir %{_includedir}/wx-%{ver2}/wx/animate
665 %{_includedir}/wx-%{ver2}/wx/animate/*
666 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
667
668 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
669 %{_includedir}/wx-%{ver2}/wx/deprecated/*
670 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
671
672 %dir %{_includedir}/wx-%{ver2}/wx/fl
673 %{_includedir}/wx-%{ver2}/wx/fl/*
674 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
675
676 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
677 %{_includedir}/wx-%{ver2}/wx/gizmos/*
678 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
679 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
680
681 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
682 %{_includedir}/wx-%{ver2}/wx/mmedia/*
683 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
684
685 %dir %{_includedir}/wx-%{ver2}/wx/ogl
686 %{_includedir}/wx-%{ver2}/wx/ogl/*
687 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
688
689 %dir %{_includedir}/wx-%{ver2}/wx/plot
690 %{_includedir}/wx-%{ver2}/wx/plot/*
691 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
692
693 %dir %{_includedir}/wx-%{ver2}/wx/stc
694 %{_includedir}/wx-%{ver2}/wx/stc/*
695 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
696
697 %dir %{_includedir}/wx-%{ver2}/wx/svg
698 %{_includedir}/wx-%{ver2}/wx/svg/*
699 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so