6 Summary: wxBase library
- non
-GUI support classes of wxWindows toolkit
10 Copyright: wxWindows Licence
11 Group: Development
/Libraries
12 Source: wxBase
-%{ver}.tar.bz2
13 URL: http
://www.wxwindows.org
14 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
16 BuildRoot: /var
/tmp
/%{name}-root
19 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
20 lists
, arrays
), powerful wxDateTime class
for date manipulations
, portable
21 wrappers around many OS
-specific functions allowing to build the same program
22 under all supported folders
, wxThread class
for writing multithreaded programs
23 using either Win32 or POSIX threads and much more. wxBase currently supports
24 the following platforms
: Win32
, generic Unix
(Linux
, FreeBSD
, Solaris
, HP
-UX
,
28 Summary: wxBase headers needed
for developping with wxBase
29 Group: Development
/Libraries
30 Requires: wxBase
= %{ver}
33 Header files
for wxBase. You need them to develop programs using wxBase.
36 Summary: wxBase static libraries
37 Group: Development
/Libraries
40 Static libraries
for wxBase. You need them
if you want to link statically against wxBase.
43 %setup -n wxBase
-%{ver}
46 if [ "$SMP"
!= ""
]; then
47 export MAKE
="
make -j$SMP"
54 ..
/configure
--prefix
=%{pref} --enable-soname
--disable
-gui
--disable
-std_iostreams
60 ..
/configure
--prefix
=%{pref} --disable
-shared
--disable
-gui
--disable
-std_iostreams
65 rm -rf $RPM_BUILD_ROOT
66 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
67 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
72 rm -rf $RPM_BUILD_ROOT
81 # Install wx-config if there isn't any
82 if test ! -f
%{_bindir}/wx
-config
; then
83 ln
-sf wxbase
-%{ver2}-config %{_bindir}/wx
-config
87 # Remove wx-config if it points to this package
88 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
89 SUM1
=`md5sum
%{_bindir}/wxbase-%{ver2}-config | cut
-c
0-32`
90 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
91 if test "x$SUM1"
= "x$SUM2"
; then
92 rm -f
%{_bindir}/wx
-config
97 %defattr (-,root
,root
)
98 %doc COPYING.LIB
*.txt
99 %{_libdir}/libwx_base
*so.
*
102 %defattr (-,root
,root
)
103 %dir %{_includedir}/wx
105 %{_libdir}/libwx_base
*.so
108 %{_bindir}/wxbase-%{ver2}-config
109 %{_datadir}/aclocal
/*.m4
112 %defattr (-,root
,root
)