Added mono bitmap to image conversion.
[wxWidgets.git] / wxGTK.spec
1 # Note that this is NOT a relocatable package
2 %define pref /usr
3 %define ver 2.1.12
4 %define rel 0
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.12.tgz
13 URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
14 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
15 BuildRoot: /tmp/wxgtk_root
16
17 # all packages providing an implementation of wxWindows library (regardless of
18 # the toolkit used) should provide the (virtual) wxwin package, this makes it
19 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
20 Provides: wxwin
21
22 %description
23 wxWindows is a free C++ library for cross-platform GUI development.
24 With wxWindows, you can create applications for different GUIs (GTK+,
25 Motif/LessTif, MS Windows, Mac) from the same source code.
26
27 %package devel
28 Summary: The GTK+ 1.2 port of the wxWindows library
29 Group: X11/Libraries
30 Requires: wxGTK
31
32 %description devel
33 Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
34
35 %prep
36 %setup -n wxGTK
37 ./configure --prefix=%{pref} --enable-threads --disable-std_iostreams --disable-newgrid
38
39 %build
40 make
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 make prefix=$RPM_BUILD_ROOT%{pref} install
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 /sbin/ldconfig
51
52 %postun
53 /sbin/ldconfig
54
55 %files
56 %defattr (644, root, root, 755)
57 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
58 %dir %{pref}/share/wx
59 %{pref}/share/wx/*
60 %attr(755, -, -) %{pref}/lib/libwx_gtk*
61
62 %files devel
63 %defattr (644, root, root, 755)
64 %dir %{pref}/include/wx
65 %{pref}/include/wx/*
66 %dir %{pref}/lib/wx
67 %{pref}/lib/wx/*
68 %attr(755, -, -) %{pref}/bin/wx-config
69