1. use tar.bz2 as sources, not tar.gz
[wxWidgets.git] / wxMotif.spec
1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
3
4 # Note that this is NOT a relocatable package
5 %define pref /usr
6 %define ver 2.3.1
7 %define rel 1
8
9 Summary: The Motif/Lesstif port of the wxWindows library
10 Name: wxMotif
11 Version: %{ver}
12 Release: %{rel}
13 Copyright: wxWindows Licence
14 Group: X11/Libraries
15 Source: wxMotif-%{ver}.tgz
16 URL: http://www.wxwindows.org
17 Packager: Robert Fendt <rfendt@myokay.net>
18 BuildRoot: /tmp/wxmotif_root
19
20 # all packages providing an implementation of wxWindows library (regardless of
21 # the toolkit used) should provide the (virtual) wxwin package, this makes it
22 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
23 Provides: wxwin
24
25 %description
26 wxWindows is a free C++ library for cross-platform GUI development.
27 With wxWindows, you can create applications for different GUIs (GTK+,
28 Motif/LessTif, MS Windows, Mac) from the same source code.
29
30 %package devel
31 Summary: The Motif/Lesstif port of the wxWindows library
32 Group: X11/Libraries
33 Requires: wxMotif
34
35 %description devel
36 Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
37
38 %package gl
39 Summary: The Motif/Lesstif port of the wxWindows library, OpenGl add-on.
40 Group: X11/Libraries
41 Requires: wxMotif
42
43 %description gl
44 OpenGl add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
45
46 %prep
47 %setup -n wxMotif
48 ./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl --with-motif
49
50 %build
51 if [ "$SMP" != "" ]; then
52 export MAKE="make -j$SMP"
53 else
54 export MAKE="make"
55 fi
56 $MAKE
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 make prefix=$RPM_BUILD_ROOT%{pref} install
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 /sbin/ldconfig
67
68 %postun
69 /sbin/ldconfig
70
71 %files
72 %defattr (644, root, root, 755)
73 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
74 %dir %{pref}/share/wx
75 %{pref}/share/wx/*
76 %attr(755, -, -) %{pref}/lib/libwx_motif.*
77 %attr(755, -, -) %{pref}/lib/libwx_motif-2.1.*
78
79 %files devel
80 %defattr (644, root, root, 755)
81 %dir %{pref}/include/wx
82 %{pref}/include/wx/*
83 %dir %{pref}/lib/wx
84 %{pref}/lib/wx/*
85 %attr(755, -, -) %{pref}/bin/wxmotif-config
86 %attr(755, -, -) %{pref}/bin/wx-config
87
88 %files gl
89 %attr(755, -, -) %{pref}/lib/libwx_motif_gl*