Add wx/msgqueue.h to the list of wxBase headers and rebake.
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.1
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 %endif
171 --with-opengl
172 $MAKE
173
174 cd contrib/src
175 $MAKE
176 cd ../../..
177
178 mkdir obj-static
179 cd obj-static
180 ../configure --prefix=%{_prefix} \
181 %if ! %{gtk2}
182 --with-gtk=1 \
183 %else
184 --with-gtk=2 \
185 %endif
186 --disable-shared \
187 %if %{unicode}
188 --enable-unicode \
189 %else
190 --disable-unicode \
191 %endif
192 --with-opengl
193 $MAKE
194
195 cd contrib/src
196 $MAKE
197 cd ../../..
198
199 make -C locale allmo
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
204 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
205
206 # --- wxBase headers list begins here ---
207 cat <<EOF >wxbase-headers.files
208 wx/afterstd.h
209 wx/any.h
210 wx/anystr.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/atomic.h
217 wx/base64.h
218 wx/beforestd.h
219 wx/buffer.h
220 wx/build.h
221 wx/chartype.h
222 wx/checkeddelete.h
223 wx/chkconf.h
224 wx/clntdata.h
225 wx/cmdargs.h
226 wx/cmdline.h
227 wx/confbase.h
228 wx/config.h
229 wx/convauto.h
230 wx/containr.h
231 wx/cpp.h
232 wx/crt.h
233 wx/datetime.h
234 wx/datstrm.h
235 wx/dde.h
236 wx/debug.h
237 wx/defs.h
238 wx/dir.h
239 wx/dlimpexp.h
240 wx/dlist.h
241 wx/dynarray.h
242 wx/dynlib.h
243 wx/dynload.h
244 wx/encconv.h
245 wx/event.h
246 wx/evtloop.h
247 wx/except.h
248 wx/features.h
249 wx/flags.h
250 wx/ffile.h
251 wx/file.h
252 wx/fileconf.h
253 wx/filefn.h
254 wx/filename.h
255 wx/filesys.h
256 wx/fontenc.h
257 wx/fontmap.h
258 wx/fs_arc.h
259 wx/fs_filter.h
260 wx/fs_mem.h
261 wx/fs_zip.h
262 wx/hash.h
263 wx/hashmap.h
264 wx/hashset.h
265 wx/html/forcelnk.h
266 wx/iconloc.h
267 wx/init.h
268 wx/intl.h
269 wx/iosfwrap.h
270 wx/ioswrap.h
271 wx/ipc.h
272 wx/ipcbase.h
273 wx/kbdstate.h
274 wx/language.h
275 wx/link.h
276 wx/list.h
277 wx/listimpl.cpp
278 wx/log.h
279 wx/longlong.h
280 wx/math.h
281 wx/memconf.h
282 wx/memory.h
283 wx/memtext.h
284 wx/mimetype.h
285 wx/module.h
286 wx/mousestate.h
287 wx/msgout.h
288 wx/msgqueue.h
289 wx/mstream.h
290 wx/object.h
291 wx/platform.h
292 wx/platinfo.h
293 wx/power.h
294 wx/process.h
295 wx/ptr_scpd.h
296 wx/ptr_shrd.h
297 wx/recguard.h
298 wx/regex.h
299 wx/scopedarray.h
300 wx/scopedptr.h
301 wx/scopeguard.h
302 wx/sharedptr.h
303 wx/snglinst.h
304 wx/sstream.h
305 wx/stack.h
306 wx/stackwalk.h
307 wx/stdpaths.h
308 wx/stdstream.h
309 wx/stockitem.h
310 wx/stopwatch.h
311 wx/strconv.h
312 wx/stream.h
313 wx/string.h
314 wx/stringimpl.h
315 wx/stringops.h
316 wx/strvararg.h
317 wx/sysopt.h
318 wx/tarstrm.h
319 wx/textbuf.h
320 wx/textfile.h
321 wx/thread.h
322 wx/thrimpl.cpp
323 wx/timer.h
324 wx/tls.h
325 wx/tokenzr.h
326 wx/tracker.h
327 wx/translation.h
328 wx/txtstrm.h
329 wx/typeinfo.h
330 wx/types.h
331 wx/unichar.h
332 wx/uri.h
333 wx/ustring.h
334 wx/utils.h
335 wx/variant.h
336 wx/vector.h
337 wx/version.h
338 wx/volume.h
339 wx/weakref.h
340 wx/wfstream.h
341 wx/wx.h
342 wx/wxchar.h
343 wx/wxcrt.h
344 wx/wxcrtbase.h
345 wx/wxcrtvararg.h
346 wx/wxprec.h
347 wx/xlocale.h
348 wx/xti.h
349 wx/xtistrm.h
350 wx/zipstrm.h
351 wx/zstream.h
352 wx/meta/convertible.h
353 wx/meta/if.h
354 wx/meta/int2type.h
355 wx/meta/movable.h
356 wx/fswatcher.h
357 wx/generic/fswatcher.h
358 wx/unix/app.h
359 wx/unix/apptbase.h
360 wx/unix/apptrait.h
361 wx/unix/chkconf.h
362 wx/unix/evtloop.h
363 wx/unix/evtloopsrc.h
364 wx/unix/pipe.h
365 wx/unix/stdpaths.h
366 wx/unix/stackwalk.h
367 wx/unix/tls.h
368 wx/unix/fswatcher_kqueue.h
369 wx/unix/execute.h
370 wx/unix/mimetype.h
371 wx/unix/fswatcher_inotify.h
372 wx/fs_inet.h
373 wx/protocol/file.h
374 wx/protocol/ftp.h
375 wx/protocol/http.h
376 wx/protocol/log.h
377 wx/protocol/protocol.h
378 wx/sckaddr.h
379 wx/sckipc.h
380 wx/sckstrm.h
381 wx/socket.h
382 wx/url.h
383 wx/xml/xml.h
384 wx/xtixml.h
385 EOF
386 # --- wxBase headers list ends here ---
387 cat <<EOF >wxbase-headers.paths
388 %{_includedir}/wx-%{ver2}/wx/afterstd.h
389 %{_includedir}/wx-%{ver2}/wx/app.h
390 %{_includedir}/wx-%{ver2}/wx/apptrait.h
391 %{_includedir}/wx-%{ver2}/wx/archive.h
392 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
393 %{_includedir}/wx-%{ver2}/wx/arrstr.h
394 %{_includedir}/wx-%{ver2}/wx/beforestd.h
395 %{_includedir}/wx-%{ver2}/wx/buffer.h
396 %{_includedir}/wx-%{ver2}/wx/build.h
397 %{_includedir}/wx-%{ver2}/wx/chkconf.h
398 %{_includedir}/wx-%{ver2}/wx/clntdata.h
399 %{_includedir}/wx-%{ver2}/wx/cmdline.h
400 %{_includedir}/wx-%{ver2}/wx/confbase.h
401 %{_includedir}/wx-%{ver2}/wx/config.h
402 %{_includedir}/wx-%{ver2}/wx/containr.h
403 %{_includedir}/wx-%{ver2}/wx/convauto.h
404 %{_includedir}/wx-%{ver2}/wx/datetime.h
405 %{_includedir}/wx-%{ver2}/wx/datstrm.h
406 %{_includedir}/wx-%{ver2}/wx/dde.h
407 %{_includedir}/wx-%{ver2}/wx/debug.h
408 %{_includedir}/wx-%{ver2}/wx/defs.h
409 %{_includedir}/wx-%{ver2}/wx/dir.h
410 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
411 %{_includedir}/wx-%{ver2}/wx/dynarray.h
412 %{_includedir}/wx-%{ver2}/wx/dynlib.h
413 %{_includedir}/wx-%{ver2}/wx/dynload.h
414 %{_includedir}/wx-%{ver2}/wx/encconv.h
415 %{_includedir}/wx-%{ver2}/wx/event.h
416 %{_includedir}/wx-%{ver2}/wx/except.h
417 %{_includedir}/wx-%{ver2}/wx/features.h
418 %{_includedir}/wx-%{ver2}/wx/ffile.h
419 %{_includedir}/wx-%{ver2}/wx/file.h
420 %{_includedir}/wx-%{ver2}/wx/fileconf.h
421 %{_includedir}/wx-%{ver2}/wx/filefn.h
422 %{_includedir}/wx-%{ver2}/wx/filename.h
423 %{_includedir}/wx-%{ver2}/wx/filesys.h
424 %{_includedir}/wx-%{ver2}/wx/fontenc.h
425 %{_includedir}/wx-%{ver2}/wx/fontmap.h
426 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
427 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
428 %{_includedir}/wx-%{ver2}/wx/hash.h
429 %{_includedir}/wx-%{ver2}/wx/hashmap.h
430 %{_includedir}/wx-%{ver2}/wx/hashset.h
431 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
432 %{_includedir}/wx-%{ver2}/wx/iconloc.h
433 %{_includedir}/wx-%{ver2}/wx/init.h
434 %{_includedir}/wx-%{ver2}/wx/intl.h
435 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
436 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
437 %{_includedir}/wx-%{ver2}/wx/ipc.h
438 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
439 %{_includedir}/wx-%{ver2}/wx/isql.h
440 %{_includedir}/wx-%{ver2}/wx/isqlext.h
441 %{_includedir}/wx-%{ver2}/wx/link.h
442 %{_includedir}/wx-%{ver2}/wx/list.h
443 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
444 %{_includedir}/wx-%{ver2}/wx/log.h
445 %{_includedir}/wx-%{ver2}/wx/longlong.h
446 %{_includedir}/wx-%{ver2}/wx/math.h
447 %{_includedir}/wx-%{ver2}/wx/memconf.h
448 %{_includedir}/wx-%{ver2}/wx/memory.h
449 %{_includedir}/wx-%{ver2}/wx/memtext.h
450 %{_includedir}/wx-%{ver2}/wx/mimetype.h
451 %{_includedir}/wx-%{ver2}/wx/module.h
452 %{_includedir}/wx-%{ver2}/wx/msgout.h
453 %{_includedir}/wx-%{ver2}/wx/mstream.h
454 %{_includedir}/wx-%{ver2}/wx/object.h
455 %{_includedir}/wx-%{ver2}/wx/platform.h
456 %{_includedir}/wx-%{ver2}/wx/power.h
457 %{_includedir}/wx-%{ver2}/wx/process.h
458 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
459 %{_includedir}/wx-%{ver2}/wx/recguard.h
460 %{_includedir}/wx-%{ver2}/wx/regex.h
461 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
462 %{_includedir}/wx-%{ver2}/wx/snglinst.h
463 %{_includedir}/wx-%{ver2}/wx/sstream.h
464 %{_includedir}/wx-%{ver2}/wx/stack.h
465 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
466 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
467 %{_includedir}/wx-%{ver2}/wx/stockitem.h
468 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
469 %{_includedir}/wx-%{ver2}/wx/strconv.h
470 %{_includedir}/wx-%{ver2}/wx/stream.h
471 %{_includedir}/wx-%{ver2}/wx/string.h
472 %{_includedir}/wx-%{ver2}/wx/sysopt.h
473 %{_includedir}/wx-%{ver2}/wx/textbuf.h
474 %{_includedir}/wx-%{ver2}/wx/textfile.h
475 %{_includedir}/wx-%{ver2}/wx/thread.h
476 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
477 %{_includedir}/wx-%{ver2}/wx/timer.h
478 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
479 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
480 %{_includedir}/wx-%{ver2}/wx/types.h
481 %{_includedir}/wx-%{ver2}/wx/uri.h
482 %{_includedir}/wx-%{ver2}/wx/utils.h
483 %{_includedir}/wx-%{ver2}/wx/variant.h
484 %{_includedir}/wx-%{ver2}/wx/vector.h
485 %{_includedir}/wx-%{ver2}/wx/version.h
486 %{_includedir}/wx-%{ver2}/wx/volume.h
487 %{_includedir}/wx-%{ver2}/wx/wfstream.h
488 %{_includedir}/wx-%{ver2}/wx/wx.h
489 %{_includedir}/wx-%{ver2}/wx/wxchar.h
490 %{_includedir}/wx-%{ver2}/wx/wxprec.h
491 %{_includedir}/wx-%{ver2}/wx/xti.h
492 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
493 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
494 %{_includedir}/wx-%{ver2}/wx/zstream.h
495 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
496 %{_includedir}/wx-%{ver2}/wx/gsocket.h
497 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
498 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
499 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
500 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
501 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
502 %{_includedir}/wx-%{ver2}/wx/sckipc.h
503 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
504 %{_includedir}/wx-%{ver2}/wx/socket.h
505 %{_includedir}/wx-%{ver2}/wx/url.h
506 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
507 %{_includedir}/wx-%{ver2}/wx/xtixml.h
508 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
509 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
510 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
511 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
512 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
513 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
514 %{_includedir}/wx-%{ver2}/wx/unix/private.h
515 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
516 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
517 EOF
518 # --- wxBase headers list ends here ---
519
520 # temporarily remove base headers
521 mkdir $RPM_BUILD_ROOT/_save_dir
522 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
523 for f in `cat wxbase-headers.files` ; do
524 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
525 done
526 # list of all core headers:
527 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
528 # move base headers (actually all headers) back again
529 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
530 rm -rf $RPM_BUILD_ROOT/_save_dir
531
532 # contrib stuff:
533 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
534 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
535
536 # utils:
537 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
538
539 # wx-config link is created during package installation, remove it for now
540 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
541
542 %clean
543 rm -rf $RPM_BUILD_ROOT
544
545 %post
546 /sbin/ldconfig
547
548 %postun
549 /sbin/ldconfig
550
551 %post devel
552 # link wx-config when you install RPM.
553 %if %{unicode}
554 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
555 %endif
556 # link wx-config with explicit name.
557 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
558 /sbin/ldconfig
559
560 %postun devel
561 /sbin/ldconfig
562
563 %preun devel
564 %if %{unicode}
565 rm -f %{_bindir}/wx-config
566 %endif
567 rm -f %{_bindir}/%{wxconfiglink}
568
569 %post -n %{wxbasename}
570 /sbin/ldconfig
571
572 %postun -n %{wxbasename}
573 /sbin/ldconfig
574
575 %post -n %{wxbasename}-devel
576 # link wx-config with explicit name.
577 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
578 /sbin/ldconfig
579
580 %postun -n %{wxbasename}-devel
581 /sbin/ldconfig
582
583 %preun -n %{wxbasename}-devel
584 rm -f %{_bindir}/%{wxbaseconfiglink}
585
586 %post gl
587 /sbin/ldconfig
588
589 %postun gl
590 /sbin/ldconfig
591
592 %post contrib
593 /sbin/ldconfig
594
595 %postun contrib
596 /sbin/ldconfig
597
598 %post contrib-devel
599 /sbin/ldconfig
600
601 %postun contrib-devel
602 /sbin/ldconfig
603
604 %files
605 %defattr(-,root,root)
606 %doc COPYING.LIB *.txt
607 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
608 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
609 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
610 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
611 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
612 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
613 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
614 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
615
616 %files -n wx-i18n
617 %defattr(-,root,root)
618 %{_datadir}/locale/*/LC_MESSAGES/*.mo
619
620 %files devel -f core-headers.files
621 %defattr(-,root,root)
622 # shared libs
623 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
624 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
625 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
626 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
627 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
628 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
629 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
630 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
631 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
632 # static libs
633 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
634 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
635 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
636 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
637 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
638 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
639 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
640 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
641 %dir %{_libdir}/wx
642 %{_libdir}/wx/config/%{wxconfig}
643 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
644 %{_libdir}/wx/config/%{wxconfigstatic}
645 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
646 %{_bindir}/wxrc*
647
648 %files -n %{wxbasename}
649 %defattr(-,root,root)
650 %{_libdir}/libwx_base*-%{ver2}.so.*
651
652 %files -n %{wxbasename}-devel -f wxbase-headers.paths
653 %defattr (-,root,root)
654 %dir %{_includedir}/wx-%{ver2}
655 %{_libdir}/libwx_base*-%{ver2}.so
656 %{_libdir}/libwx_base*-%{ver2}.a
657 %if %{unicode}
658 %{_libdir}/libwxregexu-%{ver2}.a
659 %endif
660 %dir %{_libdir}/wx
661 %{_datadir}/aclocal/*.m4
662 %{_datadir}/bakefile/presets/*
663
664 %files gl
665 %defattr(-,root,root)
666 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
667
668 %files contrib
669 %defattr(-,root,root)
670 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
671 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
672 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
673 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
674 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
675 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
676 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
677 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
678 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
679 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
680
681 # static libs
682 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
683 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
684 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
685 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
686 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
687 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
688 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
689 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
690 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
691 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
692
693 %files contrib-devel
694 %defattr(-,root,root)
695 %dir %{_includedir}/wx-%{ver2}/wx/animate
696 %{_includedir}/wx-%{ver2}/wx/animate/*
697 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
698
699 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
700 %{_includedir}/wx-%{ver2}/wx/deprecated/*
701 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
702
703 %dir %{_includedir}/wx-%{ver2}/wx/fl
704 %{_includedir}/wx-%{ver2}/wx/fl/*
705 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
706
707 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
708 %{_includedir}/wx-%{ver2}/wx/gizmos/*
709 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
710 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
711
712 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
713 %{_includedir}/wx-%{ver2}/wx/mmedia/*
714 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
715
716 %dir %{_includedir}/wx-%{ver2}/wx/ogl
717 %{_includedir}/wx-%{ver2}/wx/ogl/*
718 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
719
720 %dir %{_includedir}/wx-%{ver2}/wx/plot
721 %{_includedir}/wx-%{ver2}/wx/plot/*
722 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
723
724 %dir %{_includedir}/wx-%{ver2}/wx/stc
725 %{_includedir}/wx-%{ver2}/wx/stc/*
726 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
727
728 %dir %{_includedir}/wx-%{ver2}/wx/svg
729 %{_includedir}/wx-%{ver2}/wx/svg/*
730 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so