implement event loop for console applications (heavily modified patch 1715735)
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers.files
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/beforestd.h
145 wx/buffer.h
146 wx/build.h
147 wx/chartype.h
148 wx/chkconf.h
149 wx/clntdata.h
150 wx/cmdline.h
151 wx/confbase.h
152 wx/config.h
153 wx/convauto.h
154 wx/containr.h
155 wx/cpp.h
156 wx/datetime.h
157 wx/datstrm.h
158 wx/dde.h
159 wx/debug.h
160 wx/defs.h
161 wx/dir.h
162 wx/dlimpexp.h
163 wx/dynarray.h
164 wx/dynlib.h
165 wx/dynload.h
166 wx/encconv.h
167 wx/event.h
168 wx/except.h
169 wx/features.h
170 wx/flags.h
171 wx/ffile.h
172 wx/file.h
173 wx/fileconf.h
174 wx/filefn.h
175 wx/filename.h
176 wx/filesys.h
177 wx/fontenc.h
178 wx/fontmap.h
179 wx/fs_arc.h
180 wx/fs_filter.h
181 wx/fs_mem.h
182 wx/fs_zip.h
183 wx/hash.h
184 wx/hashmap.h
185 wx/hashset.h
186 wx/html/forcelnk.h
187 wx/iconloc.h
188 wx/init.h
189 wx/intl.h
190 wx/iosfwrap.h
191 wx/ioswrap.h
192 wx/ipc.h
193 wx/ipcbase.h
194 wx/isql.h
195 wx/isqlext.h
196 wx/link.h
197 wx/list.h
198 wx/listimpl.cpp
199 wx/log.h
200 wx/longlong.h
201 wx/math.h
202 wx/memconf.h
203 wx/memory.h
204 wx/memtext.h
205 wx/mimetype.h
206 wx/module.h
207 wx/msgout.h
208 wx/mstream.h
209 wx/object.h
210 wx/platform.h
211 wx/platinfo.h
212 wx/power.h
213 wx/process.h
214 wx/ptr_scpd.h
215 wx/recguard.h
216 wx/regex.h
217 wx/scopeguard.h
218 wx/snglinst.h
219 wx/sstream.h
220 wx/stack.h
221 wx/stackwalk.h
222 wx/stdpaths.h
223 wx/stockitem.h
224 wx/stopwatch.h
225 wx/strconv.h
226 wx/stream.h
227 wx/string.h
228 wx/stringimpl.h
229 wx/stringops.h
230 wx/strvararg.h
231 wx/sysopt.h
232 wx/tarstrm.h
233 wx/textbuf.h
234 wx/textfile.h
235 wx/thread.h
236 wx/thrimpl.cpp
237 wx/timer.h
238 wx/tokenzr.h
239 wx/txtstrm.h
240 wx/types.h
241 wx/unichar.h
242 wx/uri.h
243 wx/utils.h
244 wx/variant.h
245 wx/vector.h
246 wx/version.h
247 wx/volume.h
248 wx/wfstream.h
249 wx/wx.h
250 wx/wxchar.h
251 wx/wxcrt.h
252 wx/wxcrtvararg.h
253 wx/wxprec.h
254 wx/xti.h
255 wx/xtistrm.h
256 wx/zipstrm.h
257 wx/zstream.h
258 wx/unix/app.h
259 wx/unix/apptbase.h
260 wx/unix/apptrait.h
261 wx/unix/execute.h
262 wx/unix/evtloop.h
263 wx/unix/mimetype.h
264 wx/unix/pipe.h
265 wx/unix/private.h
266 wx/unix/stackwalk.h
267 wx/unix/stdpaths.h
268 wx/fs_inet.h
269 wx/gsocket.h
270 wx/protocol/file.h
271 wx/protocol/ftp.h
272 wx/protocol/http.h
273 wx/protocol/protocol.h
274 wx/sckaddr.h
275 wx/sckipc.h
276 wx/sckstrm.h
277 wx/socket.h
278 wx/url.h
279 wx/unix/gsockunx.h
280 wx/xml/xml.h
281 wx/xtixml.h
282 wx/db.h
283 wx/dbkeyg.h
284 wx/dbtable.h
285 EOF
286 # --- wxBase headers list ends here ---
287 for f in `cat wxbase-headers-list` ; do
288 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
289 done
290
291 # list of all core headers:
292 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
293
294 # contrib stuff:
295 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
296 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
297
298 # remove wxBase files so that RPM doesn't complain about unpackaged files:
299 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
300 %if %{unicode}
301 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
302 %endif
303 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
304 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
305
306 %clean
307 rm -rf $RPM_BUILD_ROOT
308
309 %post
310 /sbin/ldconfig
311
312 %postun
313 /sbin/ldconfig
314
315 %post devel
316 # link wx-config when you install RPM.
317 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
318 # link wx-config with explicit name.
319 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
320 /sbin/ldconfig
321
322 %postun devel
323 /sbin/ldconfig
324
325 %preun devel
326 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
327 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
328 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
329 if test "x$SUM1" = "x$SUM2" ; then
330 rm -f %{_bindir}/wx-config
331 fi
332 fi
333 rm -f %{_bindir}/%{wxconfiglink}
334
335 %post gl
336 /sbin/ldconfig
337
338 %postun gl
339 /sbin/ldconfig
340
341 %post contrib
342 /sbin/ldconfig
343
344 %postun contrib
345 /sbin/ldconfig
346
347 %post contrib-devel
348 /sbin/ldconfig
349
350 %postun contrib-devel
351 /sbin/ldconfig
352
353 %files
354 %defattr(-,root,root)
355 %doc COPYING.LIB *.txt
356 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
357 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
358 %if !%{unicode}
359 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
360 %endif
361 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
362 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
363 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
364 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
365
366
367 %files devel -f core-headers.files
368 %defattr(-,root,root)
369 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
370 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
371 %if !%{unicode}
372 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
373 %endif
374 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
375 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
376 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
377 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
378 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
379 %dir %{_libdir}/wx
380 %{_libdir}/wx/*
381 %{_bindir}/wxrc*
382
383 %files gl
384 %defattr(-,root,root)
385 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
386
387 %files static
388 %defattr (-,root,root)
389 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
390
391 %files contrib
392 %defattr(-,root,root)
393 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
394 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
395 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
396 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
397 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
398 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
399 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
400 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
401 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
402
403 %files contrib-devel
404 %defattr(-,root,root)
405 %dir %{_includedir}/wx-%{ver2}/wx/animate
406 %{_includedir}/wx-%{ver2}/wx/animate/*
407 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
408
409 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
410 %{_includedir}/wx-%{ver2}/wx/deprecated/*
411 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
412
413 %dir %{_includedir}/wx-%{ver2}/wx/fl
414 %{_includedir}/wx-%{ver2}/wx/fl/*
415 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
416
417 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
418 %{_includedir}/wx-%{ver2}/wx/gizmos/*
419 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
420
421 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
422 %{_includedir}/wx-%{ver2}/wx/mmedia/*
423 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
424
425 %dir %{_includedir}/wx-%{ver2}/wx/ogl
426 %{_includedir}/wx-%{ver2}/wx/ogl/*
427 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
428
429 %dir %{_includedir}/wx-%{ver2}/wx/plot
430 %{_includedir}/wx-%{ver2}/wx/plot/*
431 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
432
433 %dir %{_includedir}/wx-%{ver2}/wx/stc
434 %{_includedir}/wx-%{ver2}/wx/stc/*
435 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
436
437 %dir %{_includedir}/wx-%{ver2}/wx/svg
438 %{_includedir}/wx-%{ver2}/wx/svg/*
439 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so